MPSizector .NET Programmer's Manual: Mega Phase Sizector 3D Camera .NET SDK

MPSizector .NET Programmer's Manual V2.717
  • Main Page
  • Classes
Mega Phase Sizector 3D Camera .NET SDK

Intro

MPSizectorS .NET provides class library based on .NET Framework. It offers managed and unmanaged data interface. With managed data, some util functions like 3D model display, 3D post-process, data conversion are provided.

You can achieve following function by using MPSizectorS .NET

    ●Generation of device instance
    ●Enumeration and connection
    ●Device parameter setting
    ●Device snap control and data acquisition
    ●Device IO port control
    ●Display of 3D data
    ●Post-process of 3D data
    ●Data conversion and file operation

We've written some C# demo, showing how to use this library.

We also have written some article, illustrating more details about the SDK. We strongly suggest you read these articles before you start coding, as it will help you to understand the SDK quickly. You can view these articles in Related Pages . (Only in Chinese)

Files

MPSizectorS .NET includes following files:

    ●MPSizectorS_DotNet.dll - MPSizectorS .NET Dynamic Link Library
    ●MPSizectorS_DotNetUI.dll - User Interface Dynamic Link Library
    ●MPMeasure.dll - Open Source Meaurement Tools Dynamic Link Library
    ●MathNet.Numerics.dll - MPMeasure.dll Dependent Math Tools Dynamic Link Library
    ●EPPlus.dll - MPMeasure.dll Dependent Table Tools Dynamic Link Library
    ●MPSizectorS_API.dll - MPSizectorS API Dynamic Link Library
    ●OpenTK.dll - 3D Display Dynamic Link Library
    ●OpenTK.GLControl.dll - 3D Display Dynamic Link Library

Plase copy these files to the exe directory, and add ●MPSizectorS_DotNet.dll to reference.

Environment

Windows 7 or above version x64 operation system. The application must be written for x64 target machine.

Visual C++ Redistributable for Visual Studio 2012 Update 4 (This pack is automatically installed when installing SDK, but when you distribute, you should concern about this)

.NET Framework 4.0(This pack is automatically installed when installing SDK, but when you distribute, you should concern about this)

Must install the driver of 3D camera

Copyright

Copyright © 2014 - 2018 Mega Phase Industrial Inspection(Shanghai) Co., Ltd. All Rights Reserved.

Generated by doxygen 1.10.0


MPSizector .NET Programmer's Manual: Package Members

  • All
  • Enumerations
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • AntiLampFlickerModeType : MPSizectorS_DotNet
  • Auxiliary2DType : MPSizectorS_DotNet
  • BayerTransferType : MPSizectorS_DotNet
  • DataFormatType : MPSizectorS_DotNet
  • DataOutModeType : MPSizectorS_DotNet
  • DeviceStateType : MPSizectorS_DotNet
  • DumpContentType : MPSizectorS_DotNet
  • ExposureModeType : MPSizectorS_DotNet
  • ExpROIPropertyType : MPSizectorS_DotNet
  • ExpROIShapeType : MPSizectorS_DotNet
  • InterfaceType : MPSizectorS_DotNet
  • LogMediaType : MPSizectorS_DotNet
  • MPSizectorS_HardwarePreprocessModeType : MPSizectorS_DotNet
  • MultiHeadConfigType : MPSizectorS_DotNet
  • OutputPinModeType : MPSizectorS_DotNet
  • SoftwarePostProcessType : MPSizectorS_DotNet
  • TemperatureFeedBackStateType : MPSizectorS_DotNet
  • TriggerSourceType : MPSizectorS_DotNet
  • TSNSourceType : MPSizectorS_DotNet
  • ValidMaskType : MPSizectorS_DotNet
  • WorkingModeType : MPSizectorS_DotNet


MPSizector .NET Programmer's Manual: Package Members

  • All
  • Enumerations
Here is a list of all documented namespace enums with links to the namespaces they belong to:
  • AntiLampFlickerModeType : MPSizectorS_DotNet
  • Auxiliary2DType : MPSizectorS_DotNet
  • BayerTransferType : MPSizectorS_DotNet
  • DataFormatType : MPSizectorS_DotNet
  • DataOutModeType : MPSizectorS_DotNet
  • DeviceStateType : MPSizectorS_DotNet
  • DumpContentType : MPSizectorS_DotNet
  • ExposureModeType : MPSizectorS_DotNet
  • ExpROIPropertyType : MPSizectorS_DotNet
  • ExpROIShapeType : MPSizectorS_DotNet
  • InterfaceType : MPSizectorS_DotNet
  • LogMediaType : MPSizectorS_DotNet
  • MPSizectorS_HardwarePreprocessModeType : MPSizectorS_DotNet
  • MultiHeadConfigType : MPSizectorS_DotNet
  • OutputPinModeType : MPSizectorS_DotNet
  • SoftwarePostProcessType : MPSizectorS_DotNet
  • TemperatureFeedBackStateType : MPSizectorS_DotNet
  • TriggerSourceType : MPSizectorS_DotNet
  • TSNSourceType : MPSizectorS_DotNet
  • ValidMaskType : MPSizectorS_DotNet
  • WorkingModeType : MPSizectorS_DotNet


MPSizector .NET Programmer's Manual: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123]
▼N MPSizectorS_DotNet
C AutoHDRResultStructType | Structure of Auto HDR calculation result. This structure is generated by device and sent to user through head pack
C BasicSettingsStructType | Structure of basic setting
C CalibParamStructType | Structure of calib param
C ColorDepthRangeStruct | Structure of color depth range setting
C CompensationStructType | Structure of compensation
C CorrectDistortionParamStructType
C DataPointFix3DStruct | Structure of 3D data point in fixed point format. The data scale information is saved in the FrameInfo of data frame
C DataPointFixZMapStruct | Structure of 3D data point in fixed point z map format. The data scale information is saved in the FrameInfo of data frame
C DataPointFloat3DStruct | Structure of 3D data point in float format
C DebugInfoStruct | Debug register array information structure, reserved for vendor debug purpose
C DeviceInfoStructType | Device info structure
C ExpertSettingsStructType | Structure of expert settings
C ExposureBasicSettingStructType | Structure of exposure basic setting
C ExposureSettingsStructType | Structure of exposure setting
C ExpROIStructType | Structure of exposure roi region
C Extension
C ExternalExposureSettingsStructType | Structure of exposure setting for external light
C FlipEnableStructType | Flip Params
C GeneralSettingsStructType | Structure of general setting
C HardwarePreprocessModeListStructType | Structure of hardware preprocess mode list
C HardwareTimeStampsStructType | Structure of hardware timestamp
C HeadDebugInfoStructType | Debug info structure generated by device and sent to PC through head pack. This is a compact version of StatesStructType
C HeadPackDataInfoStructType | Data info structure, used in head pack
C HeadPackStructType | Structure of head pack. It is regularly sent from device to PC, and also included in every data frame
C HWTriggerSettingStructType | Structure of hardware trigger setting
C IOSettingsStructType | Structure of IO settings
C LinearTemperatureDriftCompensationStructType | Structure of linear temperature drift compensation
C ManagedDataFrame2DStruct | Structure of managed 2D data frame
C ManagedDataFrameFix3DStruct | Structure of managed 3D data frame in fix point format
C ManagedDataFrameFixZMapSimpleStruct | Structure of managed 3D data frame in simplified fixed point z map format
C ManagedDataFrameFixZMapStruct | Structure of managed 3D data frame in fixed point z map format
C ManagedDataFrameFloat3DStruct | Structure of managed 3D data frame in float point format
C MonitorPositionStructType | Monitor Positions
C MonitorZStructType | Monitor Z
C MPDisplayer2D | 2D image display control
▼C MPDisplayer3D | 3D model display control
C ViewMatrixStruct | The matrix structure of view and object pose
C MPSizectorS
C MPSizectorS_AutoHDRAdvanceSettingsStructType | Structure of auto hdr advance settings
C MPSizectorS_ExpICoefSettingsStructType | Exposure intensity coef settings
C MultiHeadSettingsStructType | Structure of reconstruction setting for multiple projecting
C OutputPinSettingStructType | Structure of output pin setting (for one pin)
C PartialFactorySettingsStructType | Partial factory settings struct type
C PointScaleSettingStructType Structure of point scale setting. Used to convert between float point cloud and fixed point cloud format.
e.g., relationship between float and fixed point X value: XFloat = XIncrement * XFixedPoint + X0Pos
C PostProcessSettingsStructType | Structure of post-process setting
▼C Process
C RotatedRectangle
C RangeCheckSettingStructType | Structure of user defined range check setting. Contains the valid range value of X, Y, Z
C RangeImageManaged Managed range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C RangeImageUnmanaged Unmanaged range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C ReconstructionSettingsStructType | Structure of reconstruction setting
C RTMatrixStructType | Structure of RT matrix
C SettingsStructType | Structure of all the settings
C SoftwarePostProcessSetting | Structure of software post process
▼C SoftwarePreprocessListRegisters | Structure of software preprocess list
C PreprocessStructType
▼C SoftwarePreprocessPresetParamListStructType | Structure of software preprocess preset param list
C PreprocessPresetFiltrateStructType
C PreprocessPresetMedianFilterStructType
C PreprocessPresetMendStructType
C PreprocessPresetRemoveBurrsStructType
C PreprocessPresetStructType
C StatesStructType | Structure of full device state information
C SuppressExpParamsEnableStructType | Suppress Exposure Params
C TemperatureFeedbackStructType | Structure of temperature feed back information
C TSNStructType | TSN structure. Indicates the ID of a valid trigger signal: source of trigger, SN of trigger
C UnmanagedDataFrame2DStruct | Structure of unmanaged 2D data frame
C UnmanagedDataFrameFix3DStruct | Structure of unmanaged 3D data frame in fix point format
C UnmanagedDataFrameFixZMapSimpleStruct | Structure of unmanaged 3D data frame in simplified fixed point z map format
C UnmanagedDataFrameFixZMapStruct | Structure of unmanaged 3D data frame in fixed point z map format
C UnmanagedDataFrameFloat3DStruct | Structure of unmanaged 3D data frame in float point format
C UnmanagedDataFrameUndefinedStruct | Structure of unmanaged undefined format data. This is the only data type delievered from callback. It is an intermediate data format to avoid using different callback functions to deliever different format of data
C Utils


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet Namespace Reference

Classes | Enumerations
MPSizectorS_DotNet Namespace Reference

Classes

struct | AutoHDRResultStructType
Structure of Auto HDR calculation result. This structure is generated by device and sent to user through head pack. More...
struct | BasicSettingsStructType
Structure of basic setting. More...
struct | CalibParamStructType
Structure of calib param. More...
struct | ColorDepthRangeStruct
Structure of color depth range setting. More...
struct | CompensationStructType
Structure of compensation. More...
struct | CorrectDistortionParamStructType
struct | DataPointFix3DStruct
Structure of 3D data point in fixed point format. The data scale information is saved in the FrameInfo of data frame. More...
struct | DataPointFixZMapStruct
Structure of 3D data point in fixed point z map format. The data scale information is saved in the FrameInfo of data frame. More...
struct | DataPointFloat3DStruct
Structure of 3D data point in float format. More...
struct | DebugInfoStruct
Debug register array information structure, reserved for vendor debug purpose. More...
struct | DeviceInfoStructType
Device info structure. More...
struct | ExpertSettingsStructType
Structure of expert settings. More...
struct | ExposureBasicSettingStructType
Structure of exposure basic setting. More...
struct | ExposureSettingsStructType
Structure of exposure setting. More...
struct | ExpROIStructType
Structure of exposure roi region. More...
class | Extension
struct | ExternalExposureSettingsStructType
Structure of exposure setting for external light. More...
struct | FlipEnableStructType
Flip Params. More...
struct | GeneralSettingsStructType
Structure of general setting. More...
struct | HardwarePreprocessModeListStructType
Structure of hardware preprocess mode list. More...
struct | HardwareTimeStampsStructType
Structure of hardware timestamp. More...
struct | HeadDebugInfoStructType
Debug info structure generated by device and sent to PC through head pack. This is a compact version of StatesStructType. More...
struct | HeadPackDataInfoStructType
Data info structure, used in head pack. More...
struct | HeadPackStructType
Structure of head pack. It is regularly sent from device to PC, and also included in every data frame. More...
struct | HWTriggerSettingStructType
Structure of hardware trigger setting. More...
struct | InternalCalibParam
使用Mat3和Point3表示RT矩阵的标定参数，方便计算；仅内部使用
struct | IOSettingsStructType
Structure of IO settings. More...
struct | LinearTemperatureDriftCompensationStructType
Structure of linear temperature drift compensation. More...
struct | ManagedDataFrame2DStruct
Structure of managed 2D data frame. More...
struct | ManagedDataFrameFix3DStruct
Structure of managed 3D data frame in fix point format. More...
struct | ManagedDataFrameFixZMapSimpleStruct
Structure of managed 3D data frame in simplified fixed point z map format. More...
struct | ManagedDataFrameFixZMapStruct
Structure of managed 3D data frame in fixed point z map format. More...
struct | ManagedDataFrameFloat3DStruct
Structure of managed 3D data frame in float point format. More...
class | Mat3
3x3 matrix class
struct | MonitorPositionStructType
Monitor Positions. More...
struct | MonitorZStructType
Monitor Z. More...
class | MPDisplayer2D
2D image display control. More...
class | MPDisplayer3D
3D model display control More...
class | MPSizectorS
struct | MPSizectorS_AutoHDRAdvanceSettingsStructType
Structure of auto hdr advance settings. More...
struct | MPSizectorS_ExpICoefSettingsStructType
Exposure intensity coef settings. More...
struct | MultiHeadSettingsStructType
Structure of reconstruction setting for multiple projecting. More...
struct | OutputPinSettingStructType
Structure of output pin setting (for one pin). More...
struct | PartialFactorySettingsStructType
Partial factory settings struct type. More...
class | Point3
3D point class
struct | PointScaleSettingStructType
Structure of point scale setting. Used to convert between float point cloud and fixed point cloud format.
e.g., relationship between float and fixed point X value: XFloat = XIncrement * XFixedPoint + X0Pos. More...
struct | PostProcessSettingsStructType
Structure of post-process setting. More...
class | Process
struct | RangeCheckSettingStructType
Structure of user defined range check setting. Contains the valid range value of X, Y, Z. More...
struct | RangeImageManaged
Managed range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]. More...
struct | RangeImageUnmanaged
Unmanaged range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]. More...
struct | ReconstructionSettingsStructType
Structure of reconstruction setting. More...
struct | RTMatrixStructType
Structure of RT matrix. More...
struct | SettingsStructType
Structure of all the settings. More...
struct | SoftwarePostProcessSetting
Structure of software post process. More...
struct | SoftwarePreprocessListRegisters
Structure of software preprocess list. More...
struct | SoftwarePreprocessPresetParamListStructType
Structure of software preprocess preset param list. More...
struct | StatesStructType
Structure of full device state information. More...
struct | SuppressExpParamsEnableStructType
Suppress Exposure Params. More...
struct | TemperatureFeedbackStructType
Structure of temperature feed back information. More...
struct | TSNStructType
TSN structure. Indicates the ID of a valid trigger signal: source of trigger, SN of trigger. More...
struct | UnmanagedDataFrame2DStruct
Structure of unmanaged 2D data frame. More...
struct | UnmanagedDataFrameFix3DStruct
Structure of unmanaged 3D data frame in fix point format. More...
struct | UnmanagedDataFrameFixZMapSimpleStruct
Structure of unmanaged 3D data frame in simplified fixed point z map format. More...
struct | UnmanagedDataFrameFixZMapStruct
Structure of unmanaged 3D data frame in fixed point z map format. More...
struct | UnmanagedDataFrameFloat3DStruct
Structure of unmanaged 3D data frame in float point format. More...
struct | UnmanagedDataFrameUndefinedStruct
Structure of unmanaged undefined format data. This is the only data type delievered from callback. It is an intermediate data format to avoid using different callback functions to deliever different format of data. More...
class | Utils

Enumerations

enum | LogMediaType { Off = 0 , Console = 1 , File = 2 , CallBack = 3 }
Enumeration of log output media. Used as parameter when constructing the device class. More...
enum DeviceStateType {
Disconnected = 0 , UnderInit = 1 , StandBy = 2 , UnderExposure = 3 ,
UnderTransfer = 4
}
Enumeration of device states. More...
enum | MultiHeadConfigType { SingleHead = 0 , TwoHead = 1 , FourHead = 2 }
Enumeration of multiple head configuration. More...
enum | InterfaceType { NULL = 0 , U2 = 1 , U3 = 2 }
Enumeration of connection interface type. More...
enum DataFormatType {
FloatPointCloud = 0 , FixPointCloud = 1 , FixZMap = 3 , FixZMapSimple = 5 ,
Image2D = 8
}
Enumeration of data format. More...
enum | TSNSourceType { Soft = 0 , Auto = 1 , Hard = 2 }
Enumeration of Trigger Serial Number (TSN) source. More...
enum WorkingModeType {
Fast3D = 0 , Standard3D = 1 , Precise3D = 2 , SuperPrecise3D = 3 ,
White2D = 4 , Black2D = 5 , Grid2D = 6 , ExposurePrediction2D = 7 ,
SuperFast3D = 8 , FastPrecision3D = 9 , SuperDynamic3D = 10
}
Enumeration of device working mode. More...
enum | TriggerSourceType { SoftTriggerOnly = 0 , KeepRunning = 1 , HardTriggerI0 = 2 , HardTriggerI1 = 3 }
Enumeration of trigger source. More...
enum | ExposureModeType { Manual = 0 , ManualRepeat = 1 , AutoNHDR = 2 , AutoPHDR = 3 }
Enumeration of exposure mode. More...
enum | DataOutModeType { FloatPointCloud = 0 , FixPointCloud = 1 , FixZMap = 3 , FixZMapSimple = 5 }
Enumeration of 3D data output mode. More...
enum OutputPinModeType {
UserControlled = 0 , InitDone = 1 , UnderExposure = 2 , Busy = 3 ,
TriggerExternalExposure = 4
}
Enumeration of output pin mode. More...
enum | TemperatureFeedBackStateType { InRange = 0 , TooHigh = 1 , TooLow = 2 }
Enumeration of temperature feed back states. More...
enum | ExpROIShapeType { Rect = 0 , Circle = 1 }
Enumeration of exposure region shape.
enum | ExpROIPropertyType { Negative = 0 , Positive = 1 }
Enumeration of exposure region polarity.
enum | AntiLampFlickerModeType { Off = 0 , Hz50 = 1 , Hz60 = 2 }
Enumeration of anti lamp flicker mode.
enum SoftwarePostProcessType {
RangeCheck , RemoveBurrs , Mend , Filtrate ,
Spi , SpiChannel3 , PlaneCorrection , MendByFeature ,
SegmentMedianFilter , MendByRegion
}
Enumeration of post process type.
enum ValidMaskType {
OK = 0 , OverExposure = 1 , ReconFail = 2 , OverOfRange = 3 ,
Overflow = 4 , MaximumVal = 5
}
Enumeration of data valid mask. More...
enum Auxiliary2DType {
Gray = 0 , W = 1 , R = 2 , G = 3 ,
B = 4 , RGB = 5
}
Enumeration of auxiliary 2D image. More...
enum | MPSizectorS_HardwarePreprocessModeType { MPSizectorS_HardwarePreprocessModeType_Weak = 0 , MPSizectorS_HardwarePreprocessModeType_Normal = 1 , MPSizectorS_HardwarePreprocessModeType_Strong = 2 , MPSizectorS_HardwarePreprocessModeType_Custom = 3 }
Enumeration of hardware preprocess type.
enum | DumpContentType { Basic = 0 , Normal = 1 , Expert = 2 }
Enumeration of dump content type.
enum | BayerTransferType { RGGB = 0 , GBRG = 1 }
Bayer transfer type.

Enumeration Type Documentation

◆ Auxiliary2DType

enum MPSizectorS_DotNet.Auxiliary2DType

Enumeration of auxiliary 2D image.

Enumerator
Gray | Gray.
W | White.
R | Red.
G | Green.
B | Blue.
RGB | RGB.

◆ DataFormatType

enum MPSizectorS_DotNet.DataFormatType

Enumeration of data format.

Enumerator
FloatPointCloud | Float point cloud, 16 bytes per point.
FixPointCloud | Fixed point cloud, 8 bytes per point.
FixZMap | Fixed point Z map image data mode, No X and Y, Z is represented by a 16-bit unsigned short.
FixZMapSimple | Simplified fixed point Z map image data mode, No X, Y, gray and mask information , Z is represented by a 16-bit unsigned short.
Image2D | Image 2D, 1 byte per pixel.

◆ DataOutModeType

enum MPSizectorS_DotNet.DataOutModeType

Enumeration of 3D data output mode.

Enumerator
FloatPointCloud | Float point cloud 3D data mode. X, Y, Z is represented by a 32-bit float respectively.
FixPointCloud | Fixed point cloud 3D data mode, X, Y, Z is represented by a 16-bit unsigned short respectively.
FixZMap | Fixed point Z map image data mode, No X and Y, Z is represented by a 16-bit unsigned short.
FixZMapSimple | Simplified fixed point Z map image data mode, No X, Y, gray and mask information , Z is represented by a 16-bit unsigned short.

◆ DeviceStateType

enum MPSizectorS_DotNet.DeviceStateType

Enumeration of device states.

Enumerator
Disconnected | Device is disconnected.
UnderInit | Device is during the process of initialization.
StandBy | Device is stand by, ready to begin a new capture.
UnderExposure | Device is under the process of exposure.
UnderTransfer | Device is under the process of data transfer.

◆ ExposureModeType

enum MPSizectorS_DotNet.ExposureModeType

Enumeration of exposure mode.

Enumerator
Manual | Manual exposure mode. Using fixed exposure number and fixed exposure intensity values. For 3D working modes, when exposure number is set to be more than 1, 3D result is HDR result.
ManualRepeat | Manual repeat exposure mode. Using the 1st 3D exposure intensity value to repeat fixed number of exposures. The final 3D result is the averaged value of multiple exposures. Not valid for 2D working mode.
AutoNHDR | Auto NHDR exposure mode. Exposure intensity values are decided by device automatically according to the configured exposure number. Not valid for 2D working mode.
AutoPHDR | Auto PHDR exposure mode. Exposure number and exposure intensity values are decided by device automatically according to the configured 3D quality threshold. Not valid for 2D working mode.

◆ InterfaceType

enum MPSizectorS_DotNet.InterfaceType

Enumeration of connection interface type.

Enumerator
NULL | Null type, used when interface not connected or not decided.
U2 | Interface type is USB2.0.
U3 | Interface type is USB3.0.

◆ LogMediaType

enum MPSizectorS_DotNet.LogMediaType

Enumeration of log output media. Used as parameter when constructing the device class.

Enumerator
Off | No log output.
Console | Log output by print on console, Only used when running a console application.
File | Log output to a log file under the exe path.
CallBack | Log output handled by user call back function.

◆ MultiHeadConfigType

enum MPSizectorS_DotNet.MultiHeadConfigType

Enumeration of multiple head configuration.

Enumerator
SingleHead | Single Head.
TwoHead | Two Head.
FourHead | Four Head.

◆ OutputPinModeType

enum MPSizectorS_DotNet.OutputPinModeType

Enumeration of output pin mode.

Enumerator
UserControlled | Controlled by user. Output value is user-controlled register value.
InitDone | The output signal indicates init state. For positive polarity, 1 indicates for init done.
UnderExposure | The output signal indicates exposure state. For positive polarity, 1 indicates for device during exposure.
Busy | The output signal indicates busy state. For positive polarity, 1 indicates for busy. Different to the under exposure signal, busy signal is 1 also when device is during data transfer.
TriggerExternalExposure | Output external trigger signals. Depends on settings of external exposure enable: if white is enabled, then output 1 trigger signal; if RGB is enabled, then output 3 trigger signals, if both white and RGB are enabled, then output 4 trigger signals; if none external exposure is enabled, then no output.

◆ TemperatureFeedBackStateType

enum MPSizectorS_DotNet.TemperatureFeedBackStateType

Enumeration of temperature feed back states.

Enumerator
InRange | Temperature is in range.
TooHigh | Temperature is too high.
TooLow | Temperature is too low.

◆ TriggerSourceType

enum MPSizectorS_DotNet.TriggerSourceType

Enumeration of trigger source.

Enumerator
SoftTriggerOnly | Only triggered by software trigger.
KeepRunning | Keep running, automatically start next snap when one capture is finished.
HardTriggerI0 | Triggered by hardware pin I0 and software trigger.
HardTriggerI1 | Triggered by hardware pin I1 and software trigger.

◆ TSNSourceType

enum MPSizectorS_DotNet.TSNSourceType

Enumeration of Trigger Serial Number (TSN) source.

Enumerator
Soft | Triggered by software trigger.
Auto | Triggered by auto trigger(keep running mode).
Hard | Triggered by external hardware pin signal.

◆ ValidMaskType

enum MPSizectorS_DotNet.ValidMaskType

Enumeration of data valid mask.

Enumerator
OK | Valid point.
OverExposure | Over exposure.
ReconFail | Reconstruction failed. Possible situations: multiple reflection, too dark surface, no object in depth of view.
OverOfRange | Judged to be out of range by the range check function.
Overflow | When output mode is fix point cloud, the fix point value is out of 0~65535 range.
MaximumVal | The data value is out of the physical detection range limit of the device. The data could be wrong data.

◆ WorkingModeType

enum MPSizectorS_DotNet.WorkingModeType

Enumeration of device working mode.

Enumerator
Fast3D | Fast 3D mode.
Standard3D | Standard 3D mode.
Precise3D | Precise 3D mode.
SuperPrecise3D | Super precise 3D mode.
White2D | 2D mode with full white illumination.
Black2D | 2D mode with no illumination.
Grid2D | 2D mode with grid pattern projection.
ExposurePrediction2D | 2D mode of exposure prediction.
SuperDynamic3D | Super dynamic 3D mode.


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.AutoHDRResultStructType Struct Reference

  • Class Members
  • MPSizectorS_DotNet
  • AutoHDRResultStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.AutoHDRResultStructType Struct Reference

Structure of Auto HDR calculation result. This structure is generated by device and sent to user through head pack. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | IsUsingAutoHDRResult
Is the Auto HDR result applied fo capture or not.
byte | ExposureNum
Number of exposures. Indicating the valid state of following 1st, 2nd, 3rd exposure intensity. It is calculated result under Auto PHDR mode。
float | AutoHDR_ExposureIntensity3D_1st
1st exposure intensity calculated by Auto HDR. Valid value is [0, 100].
float | AutoHDR_ExposureIntensity3D_2nd
2nd exposure intensity calculated by Auto HDR. Valid value is [0, 100].
float | AutoHDR_ExposureIntensity3D_3rd
3rd exposure intensity calculated by Auto HDR. Valid value is [0, 100].
byte | Score
Estimated score of the exposure configuration given by Auto HDR. Valid value is [0, 100].

Properties

byte | _IsUsingAutoHDRResult [get]
byte | _ExposureNum [get]
float | _AutoHDR_ExposureIntensity3D_1st [get]
float | _AutoHDR_ExposureIntensity3D_2nd [get]
float | _AutoHDR_ExposureIntensity3D_3rd [get]
byte | _Score [get]

Detailed Description

Structure of Auto HDR calculation result. This structure is generated by device and sent to user through head pack.


MPSizector .NET Programmer's Manual: Member List

  • AutoHDRResultStructType
MPSizectorS_DotNet.AutoHDRResultStructType Member List

This is the complete list of members for MPSizectorS_DotNet.AutoHDRResultStructType, including all inherited members.

_AutoHDR_ExposureIntensity3D_1st (defined in MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_AutoHDR_ExposureIntensity3D_2nd (defined in MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_AutoHDR_ExposureIntensity3D_3rd (defined in MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_ExposureNum (defined in MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_IsUsingAutoHDRResult (defined in MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_Score (defined in MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
AutoHDR_ExposureIntensity3D_1st | MPSizectorS_DotNet.AutoHDRResultStructType
AutoHDR_ExposureIntensity3D_2nd | MPSizectorS_DotNet.AutoHDRResultStructType
AutoHDR_ExposureIntensity3D_3rd | MPSizectorS_DotNet.AutoHDRResultStructType
ExposureNum | MPSizectorS_DotNet.AutoHDRResultStructType
IsUsingAutoHDRResult | MPSizectorS_DotNet.AutoHDRResultStructType
Score | MPSizectorS_DotNet.AutoHDRResultStructType
ToString() (defined in MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.BasicSettingsStructType Struct Reference

  • BasicSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.BasicSettingsStructType Struct Reference

Structure of basic setting. More...

Public Member Functions

override string ToString ()

Public Attributes

WorkingModeType | WorkingMode
Working mode.
byte | HoldState
Hold state. When hold state is true, device will not start a new capture (ignore all kinds of trigger).
byte | BinningState
Binning state. If binning state = 1, device will work under low resolution mode (if it is available).
byte | ROIX0Ratio
ROI X start point. Set the positon of ROI X start compare to horizontal pixeles, valid value range is [0, 255], 0 is minimum pixel, 2555 is maximum pixel.
byte | ROIY0Ratio
ROI Y start point. Set the positon of ROI Y start compare to vertical pixeles, valid value range is [0, 255], 0 is minimum pixel, 2555 is maximum pixel.
byte | ROIWidthRatio
ROI width. Set the width of ROI compare to horizontal pixeles, valid value range is [0, 255], 0 is minimum pixeles, 2555 is all pixeles.
byte | ROIHeightRatio
ROI width. Set the height of ROI compare to vertical pixeles, valid value range is [0, 255], 0 is minimum pixeles, 2555 is all pixeles.
TriggerSourceType | TriggerSource
Trigger source.

Properties

WorkingModeType | _WorkingMode [get]
byte | _HoldState [get]
byte | _BinningState [get]
byte | _ROIX0Ratio [get]
byte | _ROIY0Ratio [get]
byte | _ROIWidthRatio [get]
byte | _ROIHeightRatio [get]
TriggerSourceType | _TriggerSource [get]

Detailed Description

Structure of basic setting.


MPSizector .NET Programmer's Manual: Member List

  • BasicSettingsStructType
MPSizectorS_DotNet.BasicSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.BasicSettingsStructType, including all inherited members.

_BinningState (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_HoldState (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIHeightRatio (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIWidthRatio (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIX0Ratio (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIY0Ratio (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_TriggerSource (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_WorkingMode (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
BinningState | MPSizectorS_DotNet.BasicSettingsStructType
HoldState | MPSizectorS_DotNet.BasicSettingsStructType
ROIHeightRatio | MPSizectorS_DotNet.BasicSettingsStructType
ROIWidthRatio | MPSizectorS_DotNet.BasicSettingsStructType
ROIX0Ratio | MPSizectorS_DotNet.BasicSettingsStructType
ROIY0Ratio | MPSizectorS_DotNet.BasicSettingsStructType
ToString() (defined in MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
TriggerSource | MPSizectorS_DotNet.BasicSettingsStructType
WorkingMode | MPSizectorS_DotNet.BasicSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.CalibParamStructType Struct Reference

  • CalibParamStructType
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.CalibParamStructType Struct Reference

Structure of calib param. More...

Public Attributes

uint | CalibDate
Calibration date.
float | CF1
Camera principal distance.
float | CF2
Camera principal distance.
float | CC1
Camera column coordinate of the principal point in the image.
float | CC2
Camera row coordinate of the principal point in the image.
float | CSx
Camera horizontal distance between two neighboring cells on the sensor.
float | CSy
Camera vertical distance between two neighboring cells on the sensor.
float | CKappa
Camera distortion coefficient to model the radial lens distortions.
float | CR00
Camera rotation matrix param.
float | CR01
Camera rotation matrix param.
float | CR02
Camera rotation matrix param.
float | CR10
Camera rotation matrix param.
float | CR11
Camera rotation matrix param.
float | CR12
Camera rotation matrix param.
float | CR20
Camera rotation matrix param.
float | CR21
Camera rotation matrix param.
float | CR22
Camera rotation matrix param.
float | CT0
Camera x-direction offset vector.
float | CT1
Camera y-direction offset vector.
float | CT2
Camera z-direction offset vector.
float[] | PF1
Camera principal distance.
float[] | PF2
Projection principal distance.
float[] | PC1
Projection column coordinate of the principal point in the image.
float[] | PC2
Projection row coordinate of the principal point in the image.
float[] | PSx
Projection horizontal distance between two neighboring cells on the sensor.
float[] | PSy
Projection vertical distance between two neighboring cells on the sensor.
float[] | PKappa
Projection distortion coefficient to model the radial lens distortions.
float[] | PR00
Projection rotation matrix param.
float[] | PR01
Projection rotation matrix param.
float[] | PR02
Projection rotation matrix param.
float[] | PR10
Projection rotation matrix param.
float[] | PR11
Projection rotation matrix param.
float[] | PR12
Projection rotation matrix param.
float[] | PR20
Projection rotation matrix param.
float[] | PR21
Projection rotation matrix param.
float[] | PR22
Projection rotation matrix param.
float[] | PT0
Projection x-direction offset vector.
float[] | PT1
Projection y-direction offset vector.
float[] | PT2
Projection z-direction offset vector.

Properties

uint | _CalibDate [get, set]
float | _CF1 [get, set]
float | _CF2 [get, set]
float | _CC1 [get, set]
float | _CC2 [get, set]
float | _CSx [get, set]
float | _CSy [get, set]
float | _CKappa [get, set]
float | _CR00 [get, set]
float | _CR01 [get, set]
float | _CR02 [get, set]
float | _CR10 [get, set]
float | _CR11 [get, set]
float | _CR12 [get, set]
float | _CR20 [get, set]
float | _CR21 [get, set]
float | _CR22 [get, set]
float | _CT0 [get, set]
float | _CT1 [get, set]
float | _CT2 [get, set]
float[] | _PF1 [get, set]
float[] | _PF2 [get, set]
float[] | _PC1 [get, set]
float[] | _PC2 [get, set]
float[] | _PSx [get, set]
float[] | _PSy [get, set]
float[] | _PKappa [get, set]
float[] | _PR00 [get, set]
float[] | _PR01 [get, set]
float[] | _PR02 [get, set]
float[] | _PR10 [get, set]
float[] | _PR11 [get, set]
float[] | _PR12 [get, set]
float[] | _PR20 [get, set]
float[] | _PR21 [get, set]
float[] | _PR22 [get, set]
float[] | _PT0 [get, set]
float[] | _PT1 [get, set]
float[] | _PT2 [get, set]

Detailed Description

Structure of calib param.


MPSizector .NET Programmer's Manual: Member List

  • CalibParamStructType
MPSizectorS_DotNet.CalibParamStructType Member List

This is the complete list of members for MPSizectorS_DotNet.CalibParamStructType, including all inherited members.

_CalibDate (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CC1 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CC2 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CF1 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CF2 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CKappa (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR00 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR01 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR02 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR10 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR11 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR12 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR20 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR21 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR22 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CSx (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CSy (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CT0 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CT1 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CT2 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PC1 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PC2 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PF1 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PF2 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PKappa (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR00 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR01 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR02 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR10 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR11 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR12 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR20 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR21 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR22 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PSx (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PSy (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PT0 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PT1 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PT2 (defined in MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
CalibDate | MPSizectorS_DotNet.CalibParamStructType
CC1 | MPSizectorS_DotNet.CalibParamStructType
CC2 | MPSizectorS_DotNet.CalibParamStructType
CF1 | MPSizectorS_DotNet.CalibParamStructType
CF2 | MPSizectorS_DotNet.CalibParamStructType
CKappa | MPSizectorS_DotNet.CalibParamStructType
CR00 | MPSizectorS_DotNet.CalibParamStructType
CR01 | MPSizectorS_DotNet.CalibParamStructType
CR02 | MPSizectorS_DotNet.CalibParamStructType
CR10 | MPSizectorS_DotNet.CalibParamStructType
CR11 | MPSizectorS_DotNet.CalibParamStructType
CR12 | MPSizectorS_DotNet.CalibParamStructType
CR20 | MPSizectorS_DotNet.CalibParamStructType
CR21 | MPSizectorS_DotNet.CalibParamStructType
CR22 | MPSizectorS_DotNet.CalibParamStructType
CSx | MPSizectorS_DotNet.CalibParamStructType
CSy | MPSizectorS_DotNet.CalibParamStructType
CT0 | MPSizectorS_DotNet.CalibParamStructType
CT1 | MPSizectorS_DotNet.CalibParamStructType
CT2 | MPSizectorS_DotNet.CalibParamStructType
PC1 | MPSizectorS_DotNet.CalibParamStructType
PC2 | MPSizectorS_DotNet.CalibParamStructType
PF1 | MPSizectorS_DotNet.CalibParamStructType
PF2 | MPSizectorS_DotNet.CalibParamStructType
PKappa | MPSizectorS_DotNet.CalibParamStructType
PR00 | MPSizectorS_DotNet.CalibParamStructType
PR01 | MPSizectorS_DotNet.CalibParamStructType
PR02 | MPSizectorS_DotNet.CalibParamStructType
PR10 | MPSizectorS_DotNet.CalibParamStructType
PR11 | MPSizectorS_DotNet.CalibParamStructType
PR12 | MPSizectorS_DotNet.CalibParamStructType
PR20 | MPSizectorS_DotNet.CalibParamStructType
PR21 | MPSizectorS_DotNet.CalibParamStructType
PR22 | MPSizectorS_DotNet.CalibParamStructType
PSx | MPSizectorS_DotNet.CalibParamStructType
PSy | MPSizectorS_DotNet.CalibParamStructType
PT0 | MPSizectorS_DotNet.CalibParamStructType
PT1 | MPSizectorS_DotNet.CalibParamStructType
PT2 | MPSizectorS_DotNet.CalibParamStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ColorDepthRangeStruct Struct Reference

  • ColorDepthRangeStruct
Public Attributes | List of all members
MPSizectorS_DotNet.ColorDepthRangeStruct Struct Reference

Structure of color depth range setting. More...

Public Attributes

float | Min
Min value of the color depth range.
float | Max
Max value of the color depth range.

Detailed Description

Structure of color depth range setting.


MPSizector .NET Programmer's Manual: Member List

  • ColorDepthRangeStruct
MPSizectorS_DotNet.ColorDepthRangeStruct Member List

This is the complete list of members for MPSizectorS_DotNet.ColorDepthRangeStruct, including all inherited members.

Max | MPSizectorS_DotNet.ColorDepthRangeStruct
Min | MPSizectorS_DotNet.ColorDepthRangeStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.CompensationStructType Struct Reference

  • CompensationStructType
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.CompensationStructType Struct Reference

Structure of compensation. More...

Public Attributes

LinearTemperatureDriftCompensationStructType LinearTemperatureDriftCompensationParam
Linear temperature drift compensation.

Properties

LinearTemperatureDriftCompensationStructType _LinearTemperatureDriftCompensationParam [get]

Detailed Description

Structure of compensation.


MPSizector .NET Programmer's Manual: Member List

  • CompensationStructType
MPSizectorS_DotNet.CompensationStructType Member List

This is the complete list of members for MPSizectorS_DotNet.CompensationStructType, including all inherited members.

_LinearTemperatureDriftCompensationParam (defined in MPSizectorS_DotNet.CompensationStructType) | MPSizectorS_DotNet.CompensationStructType
LinearTemperatureDriftCompensationParam | MPSizectorS_DotNet.CompensationStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.CorrectDistortionParamStructType Struct Reference

  • CorrectDistortionParamStructType
Public Attributes | List of all members
MPSizectorS_DotNet.CorrectDistortionParamStructType Struct Reference

Public Attributes

double | p0
double | p1
double | p2
double | p3
double | p4
double | p5
double | p6
double | p7
double | p8
double | p9


MPSizector .NET Programmer's Manual: Member List

  • CorrectDistortionParamStructType
MPSizectorS_DotNet.CorrectDistortionParamStructType Member List

This is the complete list of members for MPSizectorS_DotNet.CorrectDistortionParamStructType, including all inherited members.

p0 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p1 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p2 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p3 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p4 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p5 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p6 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p7 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p8 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p9 (defined in MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.DataPointFix3DStruct Struct Reference

  • DataPointFix3DStruct
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.DataPointFix3DStruct Struct Reference

Structure of 3D data point in fixed point format. The data scale information is saved in the FrameInfo of data frame. More...

Public Attributes

byte | Gray
Gray scale value of the point.
byte | Mask
Mask value of the point.
Notice! The definition of mask has been changed compared to Sizector-H/HD! Using Mask == 0 to judge valid point will cause error!
bit 0 to bit 2: valid mask. 0x00 for valid point, 0x01 for over-exposure. 0x02 for reconstruction failed. 0x03 for out of user range(points that filtered by range check function). 0x04 for data overflow (caused by converting to fixed-point data, and value is out of 0~65535).
bit 3 to bit 4: HDR mask, exposure index of valid point. For example, when 3 exposures are taken for HDR fusion, and finally the value of exposure 2 is taken as the result, the exposure index of valid point is 2.
bit 5 to bit 7: HDR mask, valid state of each exposure.
ushort | X
Rescaled X value.
ushort | Y
Rescaled Y value.
ushort | Z
Rescaled Z value.

Properties

bool IsValid [get]
Judge whether current data point is a valid point or not.

Detailed Description

Structure of 3D data point in fixed point format. The data scale information is saved in the FrameInfo of data frame.


MPSizector .NET Programmer's Manual: Member List

  • DataPointFix3DStruct
MPSizectorS_DotNet.DataPointFix3DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.DataPointFix3DStruct, including all inherited members.

Gray | MPSizectorS_DotNet.DataPointFix3DStruct
IsValid | MPSizectorS_DotNet.DataPointFix3DStruct
Mask | MPSizectorS_DotNet.DataPointFix3DStruct
X | MPSizectorS_DotNet.DataPointFix3DStruct
Y | MPSizectorS_DotNet.DataPointFix3DStruct
Z | MPSizectorS_DotNet.DataPointFix3DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.DataPointFixZMapStruct Struct Reference

  • DataPointFixZMapStruct
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.DataPointFixZMapStruct Struct Reference

Structure of 3D data point in fixed point z map format. The data scale information is saved in the FrameInfo of data frame. More...

Public Attributes

byte | Gray
Gray scale value of the point.
byte | Mask
Mask value of the point.

Notice! The definition of mask has been changed compared to Sizector-H/HD! Using Mask == 0 to judge valid point will cause error!

bit 0 to bit 2: valid mask. 0x00 for valid point, 0x01 for over-exposure. 0x02 for reconstruction failed. 0x03 for out of user range(points that filtered by range check function). 0x04 for data overflow (caused by converting to fixed-point data, and value is out of 0~65535).

bit 3 to bit 4: HDR mask, exposure index of valid point. For example, when 3 exposures are taken for HDR fusion, and finally the value of exposure 2 is taken as the result, the exposure index of valid point is 2.

bit 5 to bit 7: HDR mask, valid state of each exposure. When multiple projecting is used, bit 3 to bit 7 have different meaning: bit 3 is reserved, bit 4 to bit 7 separately indicate whether projecting 0 to projecting 3 is used in construnct this point.
ushort | Z
Rescaled Z value.

Properties

bool IsValid [get]
Judge whether current data point is a valid point or not.

Detailed Description

Structure of 3D data point in fixed point z map format. The data scale information is saved in the FrameInfo of data frame.


MPSizector .NET Programmer's Manual: Member List

  • DataPointFixZMapStruct
MPSizectorS_DotNet.DataPointFixZMapStruct Member List

This is the complete list of members for MPSizectorS_DotNet.DataPointFixZMapStruct, including all inherited members.

Gray | MPSizectorS_DotNet.DataPointFixZMapStruct
IsValid | MPSizectorS_DotNet.DataPointFixZMapStruct
Mask | MPSizectorS_DotNet.DataPointFixZMapStruct
Z | MPSizectorS_DotNet.DataPointFixZMapStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.DataPointFloat3DStruct Struct Reference

  • DataPointFloat3DStruct
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.DataPointFloat3DStruct Struct Reference

Structure of 3D data point in float format. More...

Public Attributes

byte | Gray
Gray scale value of the point.
byte | Mask
Mask value of the point.
Notice! The definition of mask has been changed compared to Sizector-H/HD! Using Mask == 0 to judge valid point will cause error!
bit 0 to bit 2: valid mask. 0x00 for valid point, 0x01 for over-exposure. 0x02 for reconstruction failed. 0x03 for out of user range(points that filtered by range check function). 0x04 for data overflow (caused by converting to fixed-point data, and value is out of 0~65535).
bit 3 to bit 4: HDR mask, exposure index of valid point. For example, when 3 exposures are taken for HDR fusion, and finally the value of exposure 2 is taken as the result, the exposure index of valid point is 2.
bit 5 to bit 7: HDR mask, valid state of each exposure.
float | X
X coordinate in mm.
float | Y
Y coordinate in mm.
float | Z
Z coordinate in mm.

Properties

bool IsValid [get]
Judge whether current data point is a valid point or not.

Detailed Description

Structure of 3D data point in float format.


MPSizector .NET Programmer's Manual: Member List

  • DataPointFloat3DStruct
MPSizectorS_DotNet.DataPointFloat3DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.DataPointFloat3DStruct, including all inherited members.

Gray | MPSizectorS_DotNet.DataPointFloat3DStruct
IsValid | MPSizectorS_DotNet.DataPointFloat3DStruct
Mask | MPSizectorS_DotNet.DataPointFloat3DStruct
X | MPSizectorS_DotNet.DataPointFloat3DStruct
Y | MPSizectorS_DotNet.DataPointFloat3DStruct
Z | MPSizectorS_DotNet.DataPointFloat3DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.DebugInfoStruct Struct Reference

  • DebugInfoStruct
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.DebugInfoStruct Struct Reference

Debug register array information structure, reserved for vendor debug purpose. More...

Public Member Functions

override string ToString ()

Public Attributes

uint | D0
uint | D1
uint | D2
uint | D3
uint | D4
uint | D5
uint | D6
uint | D7
uint | D8
uint | D9
uint | D10
uint | D11
uint | D12
uint | D13
uint | D14
uint | D15
uint | D16
uint | D17
uint | D18
uint | D19
uint | D20
uint | D21
uint | D22
uint | D23
uint | D24
uint | D25
uint | D26
uint | D27
uint | D28
uint | D29
uint | D30
uint | D31

Properties

uint | _D0 [get]
uint | _D1 [get]
uint | _D2 [get]
uint | _D3 [get]
uint | _D4 [get]
uint | _D5 [get]
uint | _D6 [get]
uint | _D7 [get]
uint | _D8 [get]
uint | _D9 [get]
uint | _D10 [get]
uint | _D11 [get]
uint | _D12 [get]
uint | _D13 [get]
uint | _D14 [get]
uint | _D15 [get]
uint | _D16 [get]
uint | _D17 [get]
uint | _D18 [get]
uint | _D19 [get]
uint | _D20 [get]
uint | _D21 [get]
uint | _D22 [get]
uint | _D23 [get]
uint | _D24 [get]
uint | _D25 [get]
uint | _D26 [get]
uint | _D27 [get]
uint | _D28 [get]
uint | _D29 [get]
uint | _D30 [get]
uint | _D31 [get]

Detailed Description

Debug register array information structure, reserved for vendor debug purpose.


MPSizector .NET Programmer's Manual: Member List

  • DebugInfoStruct
MPSizectorS_DotNet.DebugInfoStruct Member List

This is the complete list of members for MPSizectorS_DotNet.DebugInfoStruct, including all inherited members.

_D0 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D1 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D10 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D11 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D12 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D13 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D14 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D15 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D16 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D17 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D18 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D19 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D2 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D20 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D21 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D22 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D23 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D24 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D25 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D26 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D27 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D28 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D29 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D3 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D30 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D31 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D4 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D5 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D6 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D7 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D8 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D9 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D0 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D1 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D10 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D11 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D12 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D13 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D14 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D15 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D16 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D17 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D18 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D19 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D2 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D20 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D21 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D22 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D23 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D24 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D25 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D26 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D27 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D28 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D29 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D3 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D30 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D31 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D4 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D5 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D6 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D7 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D8 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D9 (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
ToString() (defined in MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.DeviceInfoStructType Struct Reference

  • DeviceInfoStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.DeviceInfoStructType Struct Reference

Device info structure. More...

Public Member Functions

override string ToString ()

Public Attributes

string | DeviceName
Device name.
string | DeviceSerialNumber
Unique serial number for the device.
byte | IsActivated
Activation state of device.
float | HWVersion
Version of device firmware.
float | FWVersion
Version of device hardware.
float | MinimumSDKVersion
The minimum version required by device.
uint | SensorWidth
The pixel resolution of X direction.
uint | SensorHeight
The pixel resolution of Y direction.
uint | SensorResolution
The pixel resolution of device.
byte | BinningPossibility
Whether the device support low resolution mode.
byte | ExternalExposurePossibility
Whether the device support capture 2D of external light exposure.
MultiHeadConfigType | MultiHeadConfig
Device configuration of projecting.
uint | SensorBinningWidth
The pixel resolution of X direction (Low resolution mode)
uint | SensorBinningHeight
The pixel resolution of Y direction(Low resolution mode)
uint | SensorBinningResolution
The pixel resolution of device(Low resolution mode)
float | XMax
The maximum X coordinate value of device, in mm.
float | YMax
The maximum Y coordinate value of device, in mm.
float | ZMax
The maximum Z coordinate value of device, in mm.
InterfaceType | InterfaceType
Device interface type.

Properties

string | _DeviceName [get]
string | _DeviceSerialNumber [get]
byte | _IsActivated [get]
float | _HWVersion [get]
float | _FWVersion [get]
float | _MinimumSDKVersion [get]
uint | _SensorWidth [get]
uint | _SensorHeight [get]
uint | _SensorResolution [get]
byte | _BinningPossibility [get]
byte | _ExternalExposurePossibility [get]
MultiHeadConfigType | _MultiHeadConfig [get]
uint | _SensorBinningWidth [get]
uint | _SensorBinningHeight [get]
uint | _SensorBinningResolution [get]
float | _XMax [get]
float | _YMax [get]
float | _ZMax [get]
InterfaceType | _InterfaceType [get]

Detailed Description

Device info structure.

Device Info Structure


MPSizector .NET Programmer's Manual: Member List

  • DeviceInfoStructType
MPSizectorS_DotNet.DeviceInfoStructType Member List

This is the complete list of members for MPSizectorS_DotNet.DeviceInfoStructType, including all inherited members.

_BinningPossibility (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_DeviceName (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_DeviceSerialNumber (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_ExternalExposurePossibility (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_FWVersion (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_HWVersion (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_InterfaceType (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_IsActivated (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_MinimumSDKVersion (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_MultiHeadConfig (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorBinningHeight (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorBinningResolution (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorBinningWidth (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorHeight (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorResolution (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorWidth (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_XMax (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_YMax (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_ZMax (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
BinningPossibility | MPSizectorS_DotNet.DeviceInfoStructType
DeviceName | MPSizectorS_DotNet.DeviceInfoStructType
DeviceSerialNumber | MPSizectorS_DotNet.DeviceInfoStructType
ExternalExposurePossibility | MPSizectorS_DotNet.DeviceInfoStructType
FWVersion | MPSizectorS_DotNet.DeviceInfoStructType
HWVersion | MPSizectorS_DotNet.DeviceInfoStructType
InterfaceType | MPSizectorS_DotNet.DeviceInfoStructType
IsActivated | MPSizectorS_DotNet.DeviceInfoStructType
MinimumSDKVersion | MPSizectorS_DotNet.DeviceInfoStructType
MultiHeadConfig | MPSizectorS_DotNet.DeviceInfoStructType
SensorBinningHeight | MPSizectorS_DotNet.DeviceInfoStructType
SensorBinningResolution | MPSizectorS_DotNet.DeviceInfoStructType
SensorBinningWidth | MPSizectorS_DotNet.DeviceInfoStructType
SensorHeight | MPSizectorS_DotNet.DeviceInfoStructType
SensorResolution | MPSizectorS_DotNet.DeviceInfoStructType
SensorWidth | MPSizectorS_DotNet.DeviceInfoStructType
ToString() (defined in MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
XMax | MPSizectorS_DotNet.DeviceInfoStructType
YMax | MPSizectorS_DotNet.DeviceInfoStructType
ZMax | MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ExpertSettingsStructType Struct Reference

  • ExpertSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.ExpertSettingsStructType Struct Reference

Structure of expert settings. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | ExpROINum
Exposure ROI Num.
ExpROIStructType[] | ExpROIs
Exposure ROI Regions.
byte | Reserved
Reserved.
SuppressExpParamsEnableStructType | SuppressExpParamsEnable
Suppress Exposure Params.
FlipEnableStructType | FlipEnable
Flip Params.
AntiLampFlickerModeType | AntiLampFlickerMode
Anti-Lamp Flicker Mode.
MonitorPositionStructType[] | MonitorPositions
Monitor Positions.
MonitorZStructType[] | MonitorZArr
Monitor Z Arr.

Properties

byte | _ExpROINum [get]
ExpROIStructType | _ExpROI0 [get]
SuppressExpParamsEnableStructType | _SuppressExpParamsEnable [get]
FlipEnableStructType | _FlipEnable [get]
AntiLampFlickerModeType | _AntiLampFlickerMode [get]
MonitorPositionStructType | _MonitorPosition0 [get]
MonitorZStructType | _MonitorZArr0 [get]

Detailed Description

Structure of expert settings.


MPSizector .NET Programmer's Manual: Member List

  • ExpertSettingsStructType
MPSizectorS_DotNet.ExpertSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.ExpertSettingsStructType, including all inherited members.

_AntiLampFlickerMode (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_ExpROI0 (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_ExpROINum (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_FlipEnable (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_MonitorPosition0 (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_MonitorZArr0 (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_SuppressExpParamsEnable (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
AntiLampFlickerMode | MPSizectorS_DotNet.ExpertSettingsStructType
ExpROINum | MPSizectorS_DotNet.ExpertSettingsStructType
ExpROIs | MPSizectorS_DotNet.ExpertSettingsStructType
FlipEnable | MPSizectorS_DotNet.ExpertSettingsStructType
MonitorPositions | MPSizectorS_DotNet.ExpertSettingsStructType
MonitorZArr | MPSizectorS_DotNet.ExpertSettingsStructType
Reserved | MPSizectorS_DotNet.ExpertSettingsStructType
SuppressExpParamsEnable | MPSizectorS_DotNet.ExpertSettingsStructType
ToString() (defined in MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ExposureBasicSettingStructType Struct Reference

  • ExposureBasicSettingStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.ExposureBasicSettingStructType Struct Reference

Structure of exposure basic setting. More...

Public Member Functions

override string ToString ()

Public Attributes

ExposureModeType | ExposureMode
Exposure mode, select between Manual/Auto HDR and repeat.
byte | ExposureNumber
Exposure number. Valid value is 1, 2, 3.
byte | AutoHDRPriority
Auto HDR priority. Valid value range is [0, 7]. 0 for highest priority for completeness, 7 for highest priority for repeatability.
byte | AutoPHDRQuality
Auto PHDR quality. Valid value range is [0, 100]. 0 for lowest quality threshold, 100 for highest quality threshold.

Properties

ExposureModeType | _ExposureMode [get]
byte | _ExposureNumber [get]
byte | _AutoHDRPriority [get]
byte | _AutoPHDRQuality [get]

Detailed Description

Structure of exposure basic setting.


MPSizector .NET Programmer's Manual: Member List

  • ExposureBasicSettingStructType
MPSizectorS_DotNet.ExposureBasicSettingStructType Member List

This is the complete list of members for MPSizectorS_DotNet.ExposureBasicSettingStructType, including all inherited members.

_AutoHDRPriority (defined in MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
_AutoPHDRQuality (defined in MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
_ExposureMode (defined in MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
_ExposureNumber (defined in MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
AutoHDRPriority | MPSizectorS_DotNet.ExposureBasicSettingStructType
AutoPHDRQuality | MPSizectorS_DotNet.ExposureBasicSettingStructType
ExposureMode | MPSizectorS_DotNet.ExposureBasicSettingStructType
ExposureNumber | MPSizectorS_DotNet.ExposureBasicSettingStructType
ToString() (defined in MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ExposureSettingsStructType Struct Reference

  • ExposureSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.ExposureSettingsStructType Struct Reference

Structure of exposure setting. More...

Public Member Functions

override string ToString ()

Public Attributes

ExposureBasicSettingStructType | ExposureBasicSetting
Basic exposure setting.
byte | UserGain
User gain (only for 3D mode). Valid value range is [0, 3]. Higher gain value will result shorter exposure time, but worse repeatability.
float | ExposureIntensity3D_1st
1st exposure intensity for 3D mode. Valid value range is [0.1, 100].
float | ExposureIntensity3D_2nd
2nd exposure intensity for 3D mode. Valid value range is [0.1, 100].
float | ExposureIntensity3D_3rd
3rd exposure intensity for 3D mode. Valid value range is [0.1, 100].
float | ExposureIntensity2D
Exposure intensity for 2D mode (except exposure prediction) and 3D mode gray image.
byte | MultiHeadExpoVarMode
Multi head exposure variance mode for 3D mode. Valid value range is [0.1, 100].
byte | MultiHeadExpoVarRatio
Multi head exposure variance ratio for 3D mode. Valid value range is [0, 15].

Properties

ExposureBasicSettingStructType | _ExposureBasicSetting [get]
byte | _UserGain [get]
float | _ExposureIntensity3D_1st [get]
float | _ExposureIntensity3D_2nd [get]
float | _ExposureIntensity3D_3rd [get]
float | _ExposureIntensity2D [get]
byte | _MultiHeadExpoVarMode [get]
byte | _MultiHeadExpoVarRatio [get]

Detailed Description

Structure of exposure setting.


MPSizector .NET Programmer's Manual: Member List

  • ExposureSettingsStructType
MPSizectorS_DotNet.ExposureSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.ExposureSettingsStructType, including all inherited members.

_ExposureBasicSetting (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity2D (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity3D_1st (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity3D_2nd (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity3D_3rd (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_MultiHeadExpoVarMode (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_MultiHeadExpoVarRatio (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_UserGain (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureBasicSetting | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity2D | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity3D_1st | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity3D_2nd | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity3D_3rd | MPSizectorS_DotNet.ExposureSettingsStructType
MultiHeadExpoVarMode | MPSizectorS_DotNet.ExposureSettingsStructType
MultiHeadExpoVarRatio | MPSizectorS_DotNet.ExposureSettingsStructType
ToString() (defined in MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
UserGain | MPSizectorS_DotNet.ExposureSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ExpROIStructType Struct Reference

  • ExpROIStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.ExpROIStructType Struct Reference

Structure of exposure roi region. More...

Public Member Functions

override string ToString ()

Public Attributes

ushort | ExpROIXCenter
Exposure ROI StartX.
ushort | ExpROIYCenter
Exposure ROI StartY.
ushort | ExpROIWidth
Exposure ROI Width.
ushort | ExpROIHeight
Exposure ROI Height.
ExpROIShapeType | shapeType
Exposure ROI Shape.
byte | IsBase
Whether the exposure ROI is the base region.
ExpROIPropertyType | Polarity
Exposire ROI polarity.

Properties

ushort | _ExpROIXCenter [get]
ushort | _ExpROIYCenter [get]
ushort | _ExpROIWidth [get]
ushort | _ExpROIHeight [get]
ExpROIShapeType | _shapeType [get]
byte | _IsBase [get]
ExpROIPropertyType | _Polarity [get]

Detailed Description

Structure of exposure roi region.


MPSizector .NET Programmer's Manual: Member List

  • ExpROIStructType
MPSizectorS_DotNet.ExpROIStructType Member List

This is the complete list of members for MPSizectorS_DotNet.ExpROIStructType, including all inherited members.

_ExpROIHeight (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_ExpROIWidth (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_ExpROIXCenter (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_ExpROIYCenter (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_IsBase (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_Polarity (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_shapeType (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
ExpROIHeight | MPSizectorS_DotNet.ExpROIStructType
ExpROIWidth | MPSizectorS_DotNet.ExpROIStructType
ExpROIXCenter | MPSizectorS_DotNet.ExpROIStructType
ExpROIYCenter | MPSizectorS_DotNet.ExpROIStructType
IsBase | MPSizectorS_DotNet.ExpROIStructType
Polarity | MPSizectorS_DotNet.ExpROIStructType
shapeType | MPSizectorS_DotNet.ExpROIStructType
ToString() (defined in MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.Extension Class Reference

  • Extension
Public Member Functions | Static Public Member Functions | List of all members
MPSizectorS_DotNet.Extension Class Reference

Public Member Functions

unsafe delegate void | CustomStreamReadImpl (byte *Dest, uint Len)
static bool | LoadSettingFromXML (string Filepath, ref SettingsStructType Setings)
Load the XML configuration file locally into the SettingsStructType struct.
static bool | SaveSettingToXML (string Filepath, SettingsStructType Setings)
Save to the local path from the SettingsStructType struct.

Static Public Member Functions

static unsafe bool LoadUnmanagedDataFrameUndefined_FileStream (FileStream fs, out UnmanagedDataFrameUndefinedStruct DataFrame, out int Size, out float ColorDepthMin, out float ColorDepthMax, bool NeedCheckDataLength=true)
Load dataframe by filestream。

Member Function Documentation

◆ LoadUnmanagedDataFrameUndefined_FileStream()

static unsafe bool MPSizectorS_DotNet.Extension.LoadUnmanagedDataFrameUndefined_FileStream | ( | FileStream | fs,
 |  | out UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | out int | Size,
 |  | out float | ColorDepthMin,
 |  | out float | ColorDepthMax,
 |  | bool | NeedCheckDataLength = true )
 static

Load dataframe by filestream。

Parameters
fs | File stream.
DataFrame | Data.
Size | Data size.
ColorDepthMin | Min ColorDepth.
ColorDepthMax | Max ColorDepth.
needCheckDataLength | If need check data length。
Returns
If load success.


MPSizector .NET Programmer's Manual: Member List

  • Extension
MPSizectorS_DotNet.Extension Member List

This is the complete list of members for MPSizectorS_DotNet.Extension, including all inherited members.

CustomStreamReadImpl(byte *Dest, uint Len) (defined in MPSizectorS_DotNet.Extension) | MPSizectorS_DotNet.Extension |
LoadSettingFromXML(string Filepath, ref SettingsStructType Setings) | MPSizectorS_DotNet.Extension |
LoadUnmanagedDataFrameUndefined_FileStream(FileStream fs, out UnmanagedDataFrameUndefinedStruct DataFrame, out int Size, out float ColorDepthMin, out float ColorDepthMax, bool NeedCheckDataLength=true) | MPSizectorS_DotNet.Extension | static
SaveSettingToXML(string Filepath, SettingsStructType Setings) | MPSizectorS_DotNet.Extension |


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ExternalExposureSettingsStructType Struct Reference

  • ExternalExposureSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.ExternalExposureSettingsStructType Struct Reference

Structure of exposure setting for external light. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | ExternalExposureEnable
Enable of external light exposure. Bit 0 for white enable; Bit 1 for RGB enable; 1 : on, 0 : off.
ushort | ExternalExposureGain
Gain of external light exposure. Bit 0 ~ Bit 3 for white gain; Bit 4 ~ Bit 7 for red gain; Bit 8 ~ Bit 11 for green gain ;Bit 12 ~ Bit 15 for blue gain. Valid value range [0, 4].
ushort | ExternalExposureTimeWhite_us
Exposure time of external white light, unit is us.
ushort | ExternalExposureTimeRed_us
Exposure time of external red light, unit is us.
ushort | ExternalExposureTimeGreen_us
Exposure time of external green light, unit is us.
ushort | ExternalExposureTimeBlue_us
Exposure time of external blue light, unit is us.

Properties

byte | _ExternalExposureEnable [get]
float | _ExternalExposureGain [get]
float | _ExternalExposureTimeWhite_us [get]
float | _ExternalExposureTimeRed_us [get]
float | _ExternalExposureTimeGreen_us [get]
float | _ExternalExposureTimeBlue_us [get]

Detailed Description

Structure of exposure setting for external light.


MPSizector .NET Programmer's Manual: Member List

  • ExternalExposureSettingsStructType
MPSizectorS_DotNet.ExternalExposureSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.ExternalExposureSettingsStructType, including all inherited members.

_ExternalExposureEnable (defined in MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureGain (defined in MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeBlue_us (defined in MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeGreen_us (defined in MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeRed_us (defined in MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeWhite_us (defined in MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureEnable | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureGain | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeBlue_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeGreen_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeRed_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeWhite_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ToString() (defined in MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.FlipEnableStructType Struct Reference

  • FlipEnableStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.FlipEnableStructType Struct Reference

Flip Params. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | FlipXEnable
Enable Flip X.
byte | FlipYEnable
Enable Flip Y.

Properties

byte | _FlipXEnable [get]
byte | _FlipYEnable [get]

Detailed Description

Flip Params.


MPSizector .NET Programmer's Manual: Member List

  • FlipEnableStructType
MPSizectorS_DotNet.FlipEnableStructType Member List

This is the complete list of members for MPSizectorS_DotNet.FlipEnableStructType, including all inherited members.

_FlipXEnable (defined in MPSizectorS_DotNet.FlipEnableStructType) | MPSizectorS_DotNet.FlipEnableStructType
_FlipYEnable (defined in MPSizectorS_DotNet.FlipEnableStructType) | MPSizectorS_DotNet.FlipEnableStructType
FlipXEnable | MPSizectorS_DotNet.FlipEnableStructType
FlipYEnable | MPSizectorS_DotNet.FlipEnableStructType
ToString() (defined in MPSizectorS_DotNet.FlipEnableStructType) | MPSizectorS_DotNet.FlipEnableStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.GeneralSettingsStructType Struct Reference

  • GeneralSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.GeneralSettingsStructType Struct Reference

Structure of general setting. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | AutoSleepEnableState
Enable state of auto-sleep function. When true, the device will enter sleep mode after a certain idle time, and automatically wake-up when a trigger signal is comming.
ushort | AutoSleepDelayMS
Time period threshold for entering sleep mode, in ms.

Properties

byte | _AutoSleepEnableState [get]
ushort | _AutoSleepDelayMS [get]

Detailed Description

Structure of general setting.


MPSizector .NET Programmer's Manual: Member List

  • GeneralSettingsStructType
MPSizectorS_DotNet.GeneralSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.GeneralSettingsStructType, including all inherited members.

_AutoSleepDelayMS (defined in MPSizectorS_DotNet.GeneralSettingsStructType) | MPSizectorS_DotNet.GeneralSettingsStructType
_AutoSleepEnableState (defined in MPSizectorS_DotNet.GeneralSettingsStructType) | MPSizectorS_DotNet.GeneralSettingsStructType
AutoSleepDelayMS | MPSizectorS_DotNet.GeneralSettingsStructType
AutoSleepEnableState | MPSizectorS_DotNet.GeneralSettingsStructType
ToString() (defined in MPSizectorS_DotNet.GeneralSettingsStructType) | MPSizectorS_DotNet.GeneralSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.HardwarePreprocessModeListStructType Struct Reference

  • HardwarePreprocessModeListStructType
Public Attributes | List of all members
MPSizectorS_DotNet.HardwarePreprocessModeListStructType Struct Reference

Structure of hardware preprocess mode list. More...

Public Attributes

MPSizectorS_HardwarePreprocessModeType | PreProcess_PresetMode
MPSizectorS_HardwarePreprocessModeType | BurrFilter_PresetMode
MPSizectorS_HardwarePreprocessModeType | ValidPointThreshold_PresetMode

Detailed Description

Structure of hardware preprocess mode list.


MPSizector .NET Programmer's Manual: Member List

  • HardwarePreprocessModeListStructType
MPSizectorS_DotNet.HardwarePreprocessModeListStructType Member List

This is the complete list of members for MPSizectorS_DotNet.HardwarePreprocessModeListStructType, including all inherited members.

BurrFilter_PresetMode (defined in MPSizectorS_DotNet.HardwarePreprocessModeListStructType) | MPSizectorS_DotNet.HardwarePreprocessModeListStructType
PreProcess_PresetMode (defined in MPSizectorS_DotNet.HardwarePreprocessModeListStructType) | MPSizectorS_DotNet.HardwarePreprocessModeListStructType
ValidPointThreshold_PresetMode (defined in MPSizectorS_DotNet.HardwarePreprocessModeListStructType) | MPSizectorS_DotNet.HardwarePreprocessModeListStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.HardwareTimeStampsStructType Struct Reference

  • HardwareTimeStampsStructType
Public Attributes | List of all members
MPSizectorS_DotNet.HardwareTimeStampsStructType Struct Reference

Structure of hardware timestamp. More...

Public Attributes

uint | TriggerTimeMs
uint | ExpStartTimeMs
uint | ExpEndTimeMs
uint | TransEndTimeMs

Detailed Description

Structure of hardware timestamp.


MPSizector .NET Programmer's Manual: Member List

  • HardwareTimeStampsStructType
MPSizectorS_DotNet.HardwareTimeStampsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.HardwareTimeStampsStructType, including all inherited members.

ExpEndTimeMs (defined in MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType
ExpStartTimeMs (defined in MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType
TransEndTimeMs (defined in MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType
TriggerTimeMs (defined in MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.HeadDebugInfoStructType Struct Reference

  • HeadDebugInfoStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.HeadDebugInfoStructType Struct Reference

Debug info structure generated by device and sent to PC through head pack. This is a compact version of StatesStructType. More...

Public Member Functions

override string ToString ()

Public Attributes

uint | ConnectionTimeMS
Device connected time in ms.
uint | SnapCnt
Device snap counter (include 2D and 3D).
ushort | TotalTransferRetryNum
Total transfer retry counter.
ushort | CurrentTransferRetryNum
Current frame transfer retry counter.
ushort | TotalCaptureRetryNum
Total capture retry number.
TemperatureFeedbackStructType | TempCore
Core temperature sensor feedback structure.
TemperatureFeedbackStructType | Temp0
Temprature sensor 0 feedback structure.
TemperatureFeedbackStructType | Temp1
Temprature sensor 1 feedback structure.
TemperatureFeedbackStructType | Temp2
Temprature sensor 2 feedback structure.
uint | InitStates
Init state register.
byte 0: 0x00 for under init. 0x01 for init done and not in sleep mode. 0x02 for in sleep mode.
other bytes: reserved for vender diagostics purpose.
byte | EXTIOInput
Hardware input pin state. As the head pack is sent from device to PC regularly, user can refresh the hardware input pin value by reading it from head pack instead of reading register.
byte | SettingValidation
Validation indication for current device settings. 0 : invalid, others : valid. When setting is invalid, capture can't be triggered.

Properties

uint | _ConnectionTimeMS [get]
uint | _SnapCnt [get]
ushort | _TotalTransferRetryNum [get]
ushort | _CurrentTransferRetryNum [get]
ushort | _TotalCaptureRetryNum [get]
TemperatureFeedbackStructType | _TempCore [get]
TemperatureFeedbackStructType | _Temp0 [get]
uint | _InitStates [get]
byte | _EXTIOInput [get]
byte | _SettingValidation [get]

Detailed Description

Debug info structure generated by device and sent to PC through head pack. This is a compact version of StatesStructType.


MPSizector .NET Programmer's Manual: Member List

  • HeadDebugInfoStructType
MPSizectorS_DotNet.HeadDebugInfoStructType Member List

This is the complete list of members for MPSizectorS_DotNet.HeadDebugInfoStructType, including all inherited members.

_ConnectionTimeMS (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_CurrentTransferRetryNum (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_EXTIOInput (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_InitStates (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_SettingValidation (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_SnapCnt (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_Temp0 (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_TempCore (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_TotalCaptureRetryNum (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_TotalTransferRetryNum (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
ConnectionTimeMS | MPSizectorS_DotNet.HeadDebugInfoStructType
CurrentTransferRetryNum | MPSizectorS_DotNet.HeadDebugInfoStructType
EXTIOInput | MPSizectorS_DotNet.HeadDebugInfoStructType
InitStates | MPSizectorS_DotNet.HeadDebugInfoStructType
SettingValidation | MPSizectorS_DotNet.HeadDebugInfoStructType
SnapCnt | MPSizectorS_DotNet.HeadDebugInfoStructType
Temp0 | MPSizectorS_DotNet.HeadDebugInfoStructType
Temp1 | MPSizectorS_DotNet.HeadDebugInfoStructType
Temp2 | MPSizectorS_DotNet.HeadDebugInfoStructType
TempCore | MPSizectorS_DotNet.HeadDebugInfoStructType
ToString() (defined in MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
TotalCaptureRetryNum | MPSizectorS_DotNet.HeadDebugInfoStructType
TotalTransferRetryNum | MPSizectorS_DotNet.HeadDebugInfoStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.HeadPackDataInfoStructType Struct Reference

  • HeadPackDataInfoStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.HeadPackDataInfoStructType Struct Reference

Data info structure, used in head pack. More...

Public Member Functions

override string ToString ()

Public Attributes

DataFormatType | DataFormat
Format of data.
byte | DataNumber
Data number included in this frame. For 3D frame, 0 means 1.
ushort | DataTag
Data tag. This variable is set by user to mark frame captured for different purpose, and identify them at callback.
ushort | XPixResolution
X direction pixel resolution.
ushort | YPixResolution
Y direction pixel resolution.
uint | DeviceTimeStamp
Time stemp at the moment trigger signal is recieved. Time counted in device start-up time.
UInt64 | PCTimeStamp
The moment PC recieved the complete frame.
TSNStructType | TSN
TSN of current data.

Properties

DataFormatType | _DataFormat [get]
byte | _DataNumber [get]
ushort | _DataTag [get]
ushort | _XPixResolution [get]
ushort | _YPixResolution [get]
uint | _DeviceTimeStamp [get]
string | _PCTimeStamp [get]
TSNStructType | _TSN [get]

Detailed Description

Data info structure, used in head pack.

Head Pack Structures


MPSizector .NET Programmer's Manual: Member List

  • HeadPackDataInfoStructType
MPSizectorS_DotNet.HeadPackDataInfoStructType Member List

This is the complete list of members for MPSizectorS_DotNet.HeadPackDataInfoStructType, including all inherited members.

_DataFormat (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_DataNumber (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_DataTag (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_DeviceTimeStamp (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_PCTimeStamp (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_TSN (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_XPixResolution (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_YPixResolution (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
DataFormat | MPSizectorS_DotNet.HeadPackDataInfoStructType
DataNumber | MPSizectorS_DotNet.HeadPackDataInfoStructType
DataTag | MPSizectorS_DotNet.HeadPackDataInfoStructType
DeviceTimeStamp | MPSizectorS_DotNet.HeadPackDataInfoStructType
PCTimeStamp | MPSizectorS_DotNet.HeadPackDataInfoStructType
ToString() (defined in MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
TSN | MPSizectorS_DotNet.HeadPackDataInfoStructType
XPixResolution | MPSizectorS_DotNet.HeadPackDataInfoStructType
YPixResolution | MPSizectorS_DotNet.HeadPackDataInfoStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.HeadPackStructType Struct Reference

  • HeadPackStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.HeadPackStructType Struct Reference

Structure of head pack. It is regularly sent from device to PC, and also included in every data frame. More...

Public Member Functions

override string ToString ()

Public Attributes

DeviceInfoStructType | DeviceInfo
Device Info.
HeadPackDataInfoStructType | DataInfo
Data Info.
BasicSettingsStructType | BasicSetings
Basic Settings.
ExposureSettingsStructType | ExposureSettings
Exposure Settings.
ExternalExposureSettingsStructType | ExternalExposureSettings
Exposure settings for external light.
AutoHDRResultStructType | AutoHDRResult
Auto HDR Result.
ReconstructionSettingsStructType | ReconstructionSettings
Recon Settings.
MultiHeadSettingsStructType | MultiHeadSettings
Reconstruction settings for multiple projecting.
PostProcessSettingsStructType | PostProcessSettings
Post Process Settings.
GeneralSettingsStructType | GeneralSettings
General Settings.
HeadDebugInfoStructType | DebugInfo
Debug Info.
ExpertSettingsStructType | ExpertSettings
Expert Info.
IOSettingsStructType | IOSettings
IO settings.
MPSizectorS_AutoHDRAdvanceSettingsStructType | AutoHDRAdvanceSettings
Auto hdr advance settings.
MPSizectorS_ExpICoefSettingsStructType | ExpICoefSettings
Exposure intensity coef settings.
byte | CorrectDistortionEnable
Correct distortion enable state.
byte[] | Reserved1
float | SettingsVersion
Settings version.
CalibParamStructType | CalibParam
Calib param.
SoftwarePreprocessListRegisters | SoftwarePreprocessList
Software preprocess list.
HardwarePreprocessModeListStructType | HardwarePreprocessModeList
Software preprocess list.
SoftwarePreprocessPresetParamListStructType | SoftwarePreprocessPresetParamList
Software preprocess preset param list.
CompensationStructType | CompensationParams
Temperature compensation params.
byte[] | Reserved2
PartialFactorySettingsStructType | PartialFactorySettings
Temperature compensation params.

Properties

DeviceInfoStructType | _DeviceInfo [get]
HeadPackDataInfoStructType | _DataInfo [get]
BasicSettingsStructType | _BasicSettings [get]
ExposureSettingsStructType | _ExposureSettings [get]
ExternalExposureSettingsStructType | _ExternalExposureSettings [get]
AutoHDRResultStructType | _AutoHDRResult [get]
ReconstructionSettingsStructType | _ReconstructionSettings [get]
MultiHeadSettingsStructType | _MultiHeadSettings [get]
PostProcessSettingsStructType | _PostProcessSettings [get]
GeneralSettingsStructType | _GeneralSettings [get]
HeadDebugInfoStructType | _DebugInfo [get]
ExpertSettingsStructType | _ExpertSettings [get]
float | _SettingsVersion [get]
CalibParamStructType | _CalibParam [get]
MPSizectorS_AutoHDRAdvanceSettingsStructType | _AutoHDRAdvanceSettings [get]
MPSizectorS_ExpICoefSettingsStructType | _ExpICoefSettings [get]
byte | _CorrectDistortionEnable [get]
byte | _SoftwarePreprocessEnable [get]
uint | _SoftwarePreprocessCnt [get]
CompensationStructType | _CompensationParams [get]
PartialFactorySettingsStructType | _PartialFactorySettings [get]
bool | HasAuxiliaryWhiteImage [get]
Whether enaled external white exposure light.
bool | HasAuxiliaryRGBImage [get]
Whether enaled external RGB exposure light.

Detailed Description

Structure of head pack. It is regularly sent from device to PC, and also included in every data frame.


MPSizector .NET Programmer's Manual: Member List

  • HeadPackStructType
MPSizectorS_DotNet.HeadPackStructType Member List

This is the complete list of members for MPSizectorS_DotNet.HeadPackStructType, including all inherited members.

_AutoHDRAdvanceSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_AutoHDRResult (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_BasicSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_CalibParam (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_CompensationParams (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_CorrectDistortionEnable (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_DataInfo (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_DebugInfo (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_DeviceInfo (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExpertSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExpICoefSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExposureSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExternalExposureSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_GeneralSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_MultiHeadSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_PartialFactorySettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_PostProcessSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ReconstructionSettings (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_SettingsVersion (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_SoftwarePreprocessCnt (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_SoftwarePreprocessEnable (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
AutoHDRAdvanceSettings | MPSizectorS_DotNet.HeadPackStructType
AutoHDRResult | MPSizectorS_DotNet.HeadPackStructType
BasicSetings | MPSizectorS_DotNet.HeadPackStructType
CalibParam | MPSizectorS_DotNet.HeadPackStructType
CompensationParams | MPSizectorS_DotNet.HeadPackStructType
CorrectDistortionEnable | MPSizectorS_DotNet.HeadPackStructType
DataInfo | MPSizectorS_DotNet.HeadPackStructType
DebugInfo | MPSizectorS_DotNet.HeadPackStructType
DeviceInfo | MPSizectorS_DotNet.HeadPackStructType
ExpertSettings | MPSizectorS_DotNet.HeadPackStructType
ExpICoefSettings | MPSizectorS_DotNet.HeadPackStructType
ExposureSettings | MPSizectorS_DotNet.HeadPackStructType
ExternalExposureSettings | MPSizectorS_DotNet.HeadPackStructType
GeneralSettings | MPSizectorS_DotNet.HeadPackStructType
HardwarePreprocessModeList | MPSizectorS_DotNet.HeadPackStructType
HasAuxiliaryRGBImage | MPSizectorS_DotNet.HeadPackStructType
HasAuxiliaryWhiteImage | MPSizectorS_DotNet.HeadPackStructType
IOSettings | MPSizectorS_DotNet.HeadPackStructType
MultiHeadSettings | MPSizectorS_DotNet.HeadPackStructType
PartialFactorySettings | MPSizectorS_DotNet.HeadPackStructType
PostProcessSettings | MPSizectorS_DotNet.HeadPackStructType
ReconstructionSettings | MPSizectorS_DotNet.HeadPackStructType
Reserved1 (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
Reserved2 (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
SettingsVersion | MPSizectorS_DotNet.HeadPackStructType
SoftwarePreprocessList | MPSizectorS_DotNet.HeadPackStructType
SoftwarePreprocessPresetParamList | MPSizectorS_DotNet.HeadPackStructType
ToString() (defined in MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.HWTriggerSettingStructType Struct Reference

  • HWTriggerSettingStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.HWTriggerSettingStructType Struct Reference

Structure of hardware trigger setting. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | IsReversed
Polarity of HW trigger. false for triggered as rising edge. true for trigger as dropping edge.
ushort | DelayIn100us
Delay for trigger in unit of 100us.

Properties

byte | _IsReversed [get]
ushort | _DelayIn100us [get]

Detailed Description

Structure of hardware trigger setting.


MPSizector .NET Programmer's Manual: Member List

  • HWTriggerSettingStructType
MPSizectorS_DotNet.HWTriggerSettingStructType Member List

This is the complete list of members for MPSizectorS_DotNet.HWTriggerSettingStructType, including all inherited members.

_DelayIn100us (defined in MPSizectorS_DotNet.HWTriggerSettingStructType) | MPSizectorS_DotNet.HWTriggerSettingStructType
_IsReversed (defined in MPSizectorS_DotNet.HWTriggerSettingStructType) | MPSizectorS_DotNet.HWTriggerSettingStructType
DelayIn100us | MPSizectorS_DotNet.HWTriggerSettingStructType
IsReversed | MPSizectorS_DotNet.HWTriggerSettingStructType
ToString() (defined in MPSizectorS_DotNet.HWTriggerSettingStructType) | MPSizectorS_DotNet.HWTriggerSettingStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.IOSettingsStructType Struct Reference

  • IOSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.IOSettingsStructType Struct Reference

Structure of IO settings. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | EXTIOOutput
Value register of output pin. Bitwise represented.
OutputPinSettingStructType | EXTIOO0Setting
Output pin setting for pin 0.
OutputPinSettingStructType | EXTIOO1Setting
Output pin setting for pin 1.
HWTriggerSettingStructType | HWTriggerSeting
Hardware trigger setting.

Properties

byte | _EXTIOOutput [get]
OutputPinSettingStructType | _EXTIOO0Setting [get]
OutputPinSettingStructType | _EXTIOO1Setting [get]
HWTriggerSettingStructType | _HWTriggerSeting [get]

Detailed Description

Structure of IO settings.


MPSizector .NET Programmer's Manual: Member List

  • IOSettingsStructType
MPSizectorS_DotNet.IOSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.IOSettingsStructType, including all inherited members.

_EXTIOO0Setting (defined in MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
_EXTIOO1Setting (defined in MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
_EXTIOOutput (defined in MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
_HWTriggerSeting (defined in MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
EXTIOO0Setting | MPSizectorS_DotNet.IOSettingsStructType
EXTIOO1Setting | MPSizectorS_DotNet.IOSettingsStructType
EXTIOOutput | MPSizectorS_DotNet.IOSettingsStructType
HWTriggerSeting | MPSizectorS_DotNet.IOSettingsStructType
ToString() (defined in MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType Struct Reference

  • LinearTemperatureDriftCompensationStructType
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType Struct Reference

Structure of linear temperature drift compensation. More...

Public Attributes

byte | Enable
Enable State.
float | K
Compensation ratio.

Properties

byte | _Enable [get]
float | _K [get]

Detailed Description

Structure of linear temperature drift compensation.


MPSizector .NET Programmer's Manual: Member List

  • LinearTemperatureDriftCompensationStructType
MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType Member List

This is the complete list of members for MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType, including all inherited members.

_Enable (defined in MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType) | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
_K (defined in MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType) | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
Enable | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
K | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ManagedDataFrame2DStruct Struct Reference

  • ManagedDataFrame2DStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.ManagedDataFrame2DStruct Struct Reference

Structure of managed 2D data frame. More...

Public Member Functions

Bitmap | GetGrayBitmap (byte PicIndex=0)
Get bitmap of gray.
Bitmap | GetExposurePredictionBitmap ()
Get bitmap of exposure prediction image.
unsafe bool | SaveDataFrame (string FileName)
Save data frame to file.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
byte[] | Data
Managed 2D image data.

Detailed Description

Structure of managed 2D data frame.

Member Function Documentation

◆ GetExposurePredictionBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrame2DStruct.GetExposurePredictionBitmap ( )

Get bitmap of exposure prediction image.

Returns
Bitmap of exposure prediction image.

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrame2DStruct.GetGrayBitmap ( byte PicIndex = 0 )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrame2DStruct.SaveDataFrame ( string FileName )

Save data frame to file.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.


MPSizector .NET Programmer's Manual: Member List

  • ManagedDataFrame2DStruct
MPSizectorS_DotNet.ManagedDataFrame2DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.ManagedDataFrame2DStruct, including all inherited members.

Data | MPSizectorS_DotNet.ManagedDataFrame2DStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrame2DStruct
GetExposurePredictionBitmap() | MPSizectorS_DotNet.ManagedDataFrame2DStruct
GetGrayBitmap(byte PicIndex=0) | MPSizectorS_DotNet.ManagedDataFrame2DStruct
SaveDataFrame(string FileName) | MPSizectorS_DotNet.ManagedDataFrame2DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ManagedDataFrameFix3DStruct Struct Reference

  • ManagedDataFrameFix3DStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.ManagedDataFrameFix3DStruct Struct Reference

Structure of managed 3D data frame in fix point format. More...

Public Member Functions

unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
Convert current data frame to managed float 3D data format.
unsafe UnmanagedDataFrameFix3DStruct | ToUnmanagedFix3D ()
Convert current data frame to Unmanaged fix 3D data format.
Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
Bitmap | GetHDRMaskBitmap ()
Get bitmap of HDR mask.
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
DataPointFix3DStruct[] | Data
Point cloud data in managed fix point format.
byte[] | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte[] | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of managed 3D data frame in fix point format.

Member Function Documentation

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetHDRMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetHDRMaskBitmap ( )

Get bitmap of HDR mask.

Returns
Bitmap of HDR mask.

◆ GetValidMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.ToManagedFloat3D ( )

Convert current data frame to managed float 3D data format.

Returns
Data frame after conversion.

◆ ToUnmanagedFix3D()

unsafe UnmanagedDataFrameFix3DStruct MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.ToUnmanagedFix3D ( )

Convert current data frame to Unmanaged fix 3D data format.

Returns
Data frame after conversion.


MPSizector .NET Programmer's Manual: Member List

  • ManagedDataFrameFix3DStruct
MPSizectorS_DotNet.ManagedDataFrameFix3DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
Data | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
ToManagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
ToUnmanagedFix3D() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct Struct Reference

  • ManagedDataFrameFixZMapSimpleStruct
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct Struct Reference

Structure of managed 3D data frame in simplified fixed point z map format. More...

Public Member Functions

unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
Convert current data frame to managed float 3D data format.
unsafe UnmanagedDataFrameFixZMapSimpleStruct | ToUnmanagedFixZMapSimple ()
Convert current data frame to Unmanaged FixZMapSimple 3D data format.
Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Static Public Member Functions

static bool | IsValid (ushort point)
Judge whether a fixed point Z data point is valid.
static byte | GetMaskValue (ushort point)
Get mask of a fixed point Z data point.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
byte[] | Data
Array that contains all data.
ushort[] | Z
Rescaled Z value.0 and 65535 mean invalid data.
byte[] | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte[] | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of managed 3D data frame in simplified fixed point z map format.

Member Function Documentation

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetMaskValue()

static byte MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetMaskValue ( ushort point )
static

Get mask of a fixed point Z data point.

Parameters
point Fixed point Z data。
Returns
Mask.

◆ GetValidMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ IsValid()

static bool MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.IsValid ( ushort point )
static

Judge whether a fixed point Z data point is valid.

Parameters
point Fixed point Z data。
Returns
Return true if valid.

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.ToManagedFloat3D ( )

Convert current data frame to managed float 3D data format.

Returns
Data frame after conversion.

◆ ToUnmanagedFixZMapSimple()

unsafe UnmanagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.ToUnmanagedFixZMapSimple ( )

Convert current data frame to Unmanaged FixZMapSimple 3D data format.

Returns
Data frame after conversion.


MPSizector .NET Programmer's Manual: Member List

  • ManagedDataFrameFixZMapSimpleStruct
MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct Member List

This is the complete list of members for MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
Data | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetMaskValue(ushort point) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct | static
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
IsValid(ushort point) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct | static
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
ToManagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
ToUnmanagedFixZMapSimple() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
Z | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct Struct Reference

  • ManagedDataFrameFixZMapStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct Struct Reference

Structure of managed 3D data frame in fixed point z map format. More...

Public Member Functions

unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
Convert current data frame to managed float 3D data format.
unsafe UnmanagedDataFrameFixZMapStruct | ToUnmanagedFixZMap ()
Convert current data frame to Unmanaged FixZMap 3D data format.
Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
Bitmap | GetHDRMaskBitmap ()
Get bitmap of HDR mask.
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
DataPointFixZMapStruct[] | Data
Z map data in fixed point format.
byte[] | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte[] | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of managed 3D data frame in fixed point z map format.

Member Function Documentation

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetHDRMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetHDRMaskBitmap ( )

Get bitmap of HDR mask.

Returns
Bitmap of HDR mask.

◆ GetValidMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.ToManagedFloat3D ( )

Convert current data frame to managed float 3D data format.

Returns
Data frame after conversion.

◆ ToUnmanagedFixZMap()

unsafe UnmanagedDataFrameFixZMapStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.ToUnmanagedFixZMap ( )

Convert current data frame to Unmanaged FixZMap 3D data format.

Returns
Data frame after conversion.


MPSizector .NET Programmer's Manual: Member List

  • ManagedDataFrameFixZMapStruct
MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct Member List

This is the complete list of members for MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
Data | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
ToManagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
ToUnmanagedFixZMap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct Struct Reference

  • ManagedDataFrameFloat3DStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct Struct Reference

Structure of managed 3D data frame in float point format. More...

Public Member Functions

ManagedDataFrameFix3DStruct ToManagedFix3D ()
Convert current data frame to managed fixed 3D data format.
unsafe UnmanagedDataFrameFloat3DStruct | ToUnmanagedFloat3D ()
Convert current data frame to Unmanaged float 3D data format.
unsafe Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
unsafe Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
unsafe Bitmap | GetHDRMaskBitmap ()
Get bitmap of HDR mask.
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
DataPointFloat3DStruct[] | Data
Point cloud data in managed float point format.
byte[] | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte[] | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of managed 3D data frame in float point format.

Member Function Documentation

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetHDRMaskBitmap ( )

Get bitmap of HDR mask.

Returns
Bitmap of HDR mask.

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.

◆ ToManagedFix3D()

ManagedDataFrameFix3DStruct MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.ToManagedFix3D ( )

Convert current data frame to managed fixed 3D data format.

Returns
Data frame after conversion.

◆ ToUnmanagedFloat3D()

unsafe UnmanagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.ToUnmanagedFloat3D ( )

Convert current data frame to Unmanaged float 3D data format.

Returns
Data frame after conversion.


MPSizector .NET Programmer's Manual: Member List

  • ManagedDataFrameFloat3DStruct
MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
Data | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
ToManagedFix3D() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
ToUnmanagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MonitorPositionStructType Struct Reference

  • MonitorPositionStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.MonitorPositionStructType Struct Reference

Monitor Positions. More...

Public Member Functions

override string ToString ()

Public Attributes

ushort | MonitorPositionX
Monitor Position X.
ushort | MonitorPositionY
Monitor Position Y.

Properties

ushort | _MonitorPositionX [get]
ushort | _MonitorPositionY [get]

Detailed Description

Monitor Positions.


MPSizector .NET Programmer's Manual: Member List

  • MonitorPositionStructType
MPSizectorS_DotNet.MonitorPositionStructType Member List

This is the complete list of members for MPSizectorS_DotNet.MonitorPositionStructType, including all inherited members.

_MonitorPositionX (defined in MPSizectorS_DotNet.MonitorPositionStructType) | MPSizectorS_DotNet.MonitorPositionStructType
_MonitorPositionY (defined in MPSizectorS_DotNet.MonitorPositionStructType) | MPSizectorS_DotNet.MonitorPositionStructType
MonitorPositionX | MPSizectorS_DotNet.MonitorPositionStructType
MonitorPositionY | MPSizectorS_DotNet.MonitorPositionStructType
ToString() (defined in MPSizectorS_DotNet.MonitorPositionStructType) | MPSizectorS_DotNet.MonitorPositionStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MonitorZStructType Struct Reference

  • MonitorZStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.MonitorZStructType Struct Reference

Monitor Z. More...

Public Member Functions

override string ToString ()

Public Attributes

float | Z0
Monitor Z0.
float | Z1
Monitor Z1.
float | Z2
Monitor Z2.
float | Z3
Monitor Z3.

Properties

float | _Z0 [get]
float | _Z1 [get]
float | _Z2 [get]
float | _Z3 [get]

Detailed Description

Monitor Z.


MPSizector .NET Programmer's Manual: Member List

  • MonitorZStructType
MPSizectorS_DotNet.MonitorZStructType Member List

This is the complete list of members for MPSizectorS_DotNet.MonitorZStructType, including all inherited members.

_Z0 (defined in MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
_Z1 (defined in MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
_Z2 (defined in MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
_Z3 (defined in MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
ToString() (defined in MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
Z0 | MPSizectorS_DotNet.MonitorZStructType
Z1 | MPSizectorS_DotNet.MonitorZStructType
Z2 | MPSizectorS_DotNet.MonitorZStructType
Z3 | MPSizectorS_DotNet.MonitorZStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MPDisplayer2D Class Reference

  • MPDisplayer2D
Public Member Functions | Public Attributes | Protected Member Functions | Properties | Events | List of all members
MPSizectorS_DotNet.MPDisplayer2D Class Reference

2D image display control. More...

Inherits UserControl.

Public Member Functions

MPDisplayer2D ()
ctor, no parameter.

Public Attributes

bool InPainting = false

Protected Member Functions

override void Dispose (bool disposing)
清理所有正在使用的资源。

Properties

float | Zoom [get, set]
Gets or sets the zooming ratio.
Point | ImageOrigin [get, set]
Gets or sets the image origin position.
Bitmap | Bitmap [get, set]
Gets or sets the bitmap displayed.
bool | Binning [get, set]
Gets or sets the binning state of source image.
Point | CurPixelCord [get]
Get the pixel coordinate that mouse is currently pointed.

Events

EventHandler PixelCordChange
The event of mouse pointed pixel coordinate changing.

Detailed Description

2D image display control.

Member Function Documentation

◆ Dispose()

override void MPSizectorS_DotNet.MPDisplayer2D.Dispose ( bool disposing )
protected

清理所有正在使用的资源。

Parameters
disposing 如果应释放托管资源，为 true；否则为 false。


MPSizector .NET Programmer's Manual: Member List

  • MPDisplayer2D
MPSizectorS_DotNet.MPDisplayer2D Member List

This is the complete list of members for MPSizectorS_DotNet.MPDisplayer2D, including all inherited members.

Binning | MPSizectorS_DotNet.MPDisplayer2D |
Bitmap | MPSizectorS_DotNet.MPDisplayer2D |
CurPixelCord | MPSizectorS_DotNet.MPDisplayer2D |
Dispose(bool disposing) | MPSizectorS_DotNet.MPDisplayer2D | protected
ImageOrigin | MPSizectorS_DotNet.MPDisplayer2D |
InPainting (defined in MPSizectorS_DotNet.MPDisplayer2D) | MPSizectorS_DotNet.MPDisplayer2D |
MPDisplayer2D() | MPSizectorS_DotNet.MPDisplayer2D |
PixelCordChange | MPSizectorS_DotNet.MPDisplayer2D |
Zoom | MPSizectorS_DotNet.MPDisplayer2D |


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MPDisplayer3D Class Reference

  • MPDisplayer3D
Classes | Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Properties | List of all members
MPSizectorS_DotNet.MPDisplayer3D Class Reference

3D model display control More...

Inherits UserControl.

Classes

struct ViewMatrixStruct
The matrix structure of view and object pose. More...

Public Types

enum | MPModelPolygonType { Point = 0 , Line = 1 , Fill = 2 }
Enumeration of methods of drawing polygon. More...
enum | MPModelTextureType { GrayImage = 0 , ColorDepthImage = 1 , GrayAndColorDepthMixed = 2 }
Enumeration of texture mode of 3D display. More...
enum | RotateModeEnumType { Disabled = 0 , Swing = 1 , RoundZ = 2 }
Auto rotate mode enum type. More...

Public Member Functions

delegate void | SelPointChangedCallBackType (Point point)
MPDisplayer3D ()
Construct function.
void | Display (ManagedDataFrameFloat3DStruct DataFrame)
Display managed Float3D data frame.
void | Display (ManagedDataFrameFix3DStruct DataFrame)
Display managed Fix3D data frame.
void | Display (ManagedDataFrameFixZMapStruct DataFrame)
void | Display (ManagedDataFrameFixZMapSimpleStruct DataFrame)
void | Display (UnmanagedDataFrameFloat3DStruct DataFrame)
Display unmanaged Float3D data frame.
void | Display (UnmanagedDataFrameFix3DStruct DataFrame)
Display unmanaged Fix3D data frame.
void | Display (UnmanagedDataFrameFixZMapStruct DataFrame)
void | Display (UnmanagedDataFrameFixZMapSimpleStruct DataFrame)
new void | Refresh ()
void | SetDrawLines (Vector3[] LinePoints, Color4[] LineColors, uint[] PointOrder)
Set param of lines to display.
void | SetLanguage (string lan)

Public Attributes

SelPointChangedCallBackType | SelPointChangedCallBack
Vector3[] | m_NormCloud

Protected Member Functions

override void Dispose (bool disposing)
清理所有正在使用的资源。

Properties

bool | DrawLineEnable [get, set]
bool | IsLoaded [get]
Gets the loaded state of current control.
bool | SettingVisible [get, set]
Color | BackgroundColor [get, set]
MPModelPolygonType | ModelPolygon [get, set]
Methods of drawing polygon.
MPModelTextureType | ModelTexture [get, set]
Texture mode of 3D display.
Auxiliary2DType | TextureImageChannel [get, set]
bool | UseNormVector [get, set]
Enable state of norm vector.
bool | SpecularReflection [get, set]
Enable state of specular reflection.
bool | TransparentBackGroundSnapshot [get, set]
Enable state of transparent background for snapshot.
bool | EnableDisplayFilter [get, set]
Enable state of display filter.
float | ColorDepthImageMin [get, set]
Min of color depth image range.
float | ColorDepthImageMax [get, set]
Max of color depth image range.
float | PointLineSize [get, set]
Bitmap | Screenshot [get]
Get screen shot of current 3D display.
ViewMatrixStruct | ViewMatrix [get, set]
Gets or sets the structure of camera view and object pose matrix.
RotateModeEnumType | RotateMode [get, set]
Gets or sets Auto rotate mode.
int | RotateSpeed [get, set]
Speed of rotation.
int | RotateAmplitude [get, set]
Amplitude of rotation.
float | RotatePhase [get, set]
Phase of rotation.

Detailed Description

3D model display control

Member Enumeration Documentation

◆ MPModelPolygonType

enum MPSizectorS_DotNet.MPDisplayer3D.MPModelPolygonType

Enumeration of methods of drawing polygon.

Enumerator
Point | Draw points.
Line | Draw Lines.
Fill | Draw fills.

◆ MPModelTextureType

enum MPSizectorS_DotNet.MPDisplayer3D.MPModelTextureType

Enumeration of texture mode of 3D display.

Enumerator
GrayImage | Use gray image for texture.
ColorDepthImage | Use color depth image for texture.
GrayAndColorDepthMixed | Use the mixture of gray image and color depth image for texture.

◆ RotateModeEnumType

enum MPSizectorS_DotNet.MPDisplayer3D.RotateModeEnumType

Auto rotate mode enum type.

Enumerator
Disabled | Disabled.
Swing | Rotate by swinging object.
RoundZ | Rotate object around Z axis.

Member Function Documentation

◆ Display() [1/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( ManagedDataFrameFix3DStruct DataFrame )

Display managed Fix3D data frame.

Parameters
DataFrame Data frame to be displayed.

◆ Display() [2/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( ManagedDataFrameFloat3DStruct DataFrame )

Display managed Float3D data frame.

Parameters
DataFrame Data frame to be displayed.

◆ Display() [3/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( UnmanagedDataFrameFix3DStruct DataFrame )

Display unmanaged Fix3D data frame.

Parameters
DataFrame Data frame to be displayed.

◆ Display() [4/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( UnmanagedDataFrameFloat3DStruct DataFrame )

Display unmanaged Float3D data frame.

Parameters
DataFrame Data frame to be displayed.

◆ Dispose()

override void MPSizectorS_DotNet.MPDisplayer3D.Dispose ( bool disposing )
protected

清理所有正在使用的资源。

Parameters
disposing 如果应释放托管资源，为 true；否则为 false。

◆ SetDrawLines()

void MPSizectorS_DotNet.MPDisplayer3D.SetDrawLines | ( | Vector3[] | LinePoints,
 |  | Color4[] | LineColors,
 |  | uint[] | PointOrder )

Set param of lines to display.

Parameters
LinePoints | Data of line points.
LineColors | Data of line colors.
PointOrder | The order of points making up lines.


MPSizector .NET Programmer's Manual: Member List

  • MPDisplayer3D
MPSizectorS_DotNet.MPDisplayer3D Member List

This is the complete list of members for MPSizectorS_DotNet.MPDisplayer3D, including all inherited members.

BackgroundColor (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
ColorDepthImageMax | MPSizectorS_DotNet.MPDisplayer3D |
ColorDepthImageMin | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFloat3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFix3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFixZMapStruct DataFrame) (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFixZMapSimpleStruct DataFrame) (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFloat3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFix3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFixZMapStruct DataFrame) (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFixZMapSimpleStruct DataFrame) (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Dispose(bool disposing) | MPSizectorS_DotNet.MPDisplayer3D | protected
DrawLineEnable (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
EnableDisplayFilter | MPSizectorS_DotNet.MPDisplayer3D |
IsLoaded | MPSizectorS_DotNet.MPDisplayer3D |
m_NormCloud (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
ModelPolygon | MPSizectorS_DotNet.MPDisplayer3D |
ModelTexture | MPSizectorS_DotNet.MPDisplayer3D |
MPDisplayer3D() | MPSizectorS_DotNet.MPDisplayer3D |
MPModelPolygonType enum name | MPSizectorS_DotNet.MPDisplayer3D |
MPModelTextureType enum name | MPSizectorS_DotNet.MPDisplayer3D |
PointLineSize (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Refresh() (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
RotateAmplitude | MPSizectorS_DotNet.MPDisplayer3D |
RotateMode | MPSizectorS_DotNet.MPDisplayer3D |
RotateModeEnumType enum name | MPSizectorS_DotNet.MPDisplayer3D |
RotatePhase | MPSizectorS_DotNet.MPDisplayer3D |
RotateSpeed | MPSizectorS_DotNet.MPDisplayer3D |
Screenshot | MPSizectorS_DotNet.MPDisplayer3D |
SelPointChangedCallBack (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SelPointChangedCallBackType(Point point) (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SetDrawLines(Vector3[] LinePoints, Color4[] LineColors, uint[] PointOrder) | MPSizectorS_DotNet.MPDisplayer3D |
SetLanguage(string lan) (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SettingVisible (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SpecularReflection | MPSizectorS_DotNet.MPDisplayer3D |
TextureImageChannel (defined in MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
TransparentBackGroundSnapshot | MPSizectorS_DotNet.MPDisplayer3D |
UseNormVector | MPSizectorS_DotNet.MPDisplayer3D |
ViewMatrix | MPSizectorS_DotNet.MPDisplayer3D |


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct Struct Reference

  • MPDisplayer3D
  • ViewMatrixStruct
Public Attributes | List of all members
MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct Struct Reference

The matrix structure of view and object pose. More...

Public Attributes

float | XTrans
float | YTrans
float | Zoom
float | EyeXRotDeg
float | EyeYRotDeg
float | EyeZRotDeg
float | ObjXRotDeg
float | ObjYRotDeg
float | ObjZRotDeg

Detailed Description

The matrix structure of view and object pose.


MPSizector .NET Programmer's Manual: Member List

  • MPDisplayer3D
  • ViewMatrixStruct
MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct Member List

This is the complete list of members for MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct, including all inherited members.

EyeXRotDeg (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
EyeYRotDeg (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
EyeZRotDeg (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
ObjXRotDeg (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
ObjYRotDeg (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
ObjZRotDeg (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
XTrans (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
YTrans (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
Zoom (defined in MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MPSizectorS Class Reference

  • MPSizectorS
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.MPSizectorS Class Reference

Public Member Functions

MPSizectorS (LogMediaType LogMedia=LogMediaType.Off, int BufferRate=1, bool EnableDependencyCheck=true)
Constructor.
bool | UpdateDeviceList ()
Refresh the device list.
int | GetDeviceCount ()
Get total device number in the device list.
DeviceInfoStructType | GetDeviceInfo (int Index)
Get the device info of device with specified index in the device list.
bool | Open (DeviceInfoStructType DeviceInfo)
Open device.
bool | Reconnect ()
Reconnect the device. When auto-reconnect function is disabled, use this function to reconnect the device once the connection is lost.
void | Close ()
Close current connection.
void | SetAutoReconnect (bool AutoReconnect)
Set the enable state of auto-reconnect function. The auto-reconnect function is enabled in default.
bool | FireSoftwareTrigger ()
Fire software trigger.
bool | SnapUnmanaged (bool SoftwareTrigger, out DataFormatType DataFormat, out UnmanagedDataFrameUndefinedStruct Data, uint TimeOutMS)
Synchronized snap frame. Function returns after captured valid data frame, or time out.
delegate void | DeviceStateChangeCallBackType (DeviceStateType DeviceState)
Callback delegate of device state change.
delegate void | LogCallBackType (string Log)
Callback delegate of log.
delegate void | DataCallBackType (DataFormatType DataFormat, UnmanagedDataFrameUndefinedStruct DataFrame)
Callback delegate of data.
delegate void | HeadPackCallBackType (HeadPackStructType HeadPack)
Callback delegate of head pack.
void | SetLogCallBack (LogCallBackType CallBackFn)
Register log callback function.
void | SetDeviceStateChangeCallBack (DeviceStateChangeCallBackType CallBackFn)
Register device state change callback function.
void | SetDataCallBack (DataCallBackType CallBackFn)
Register data callback function.
void | SetHeadPackCallBack (HeadPackCallBackType CallBackFn)
Register head pack callback function.
bool | SaveSettingsAsDefault ()
Save current setting to FlashROM. It will be applied when device power up.
bool | LoadDefaultSettings ()
Apply the setting in FlashROM.
unsafe byte | GetHardwareTimeStamps (out HardwareTimeStampsStructType HardwareTimeStamps)
Gets or sets hardware time stamp.
bool | GetMonitorPosition (byte Position, out ushort X, out ushort Y)
Get position of multihead monitor.
bool | SetMonitorPosition (byte Position, ushort X, ushort Y)
Set position of multihead monitor.
float | GetLastZAt (byte Position, byte Head)
Get z value of multihead monitor.
bool | CorrectDistortion (float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D, bool EnableSaveToDevice=true)
Correct distortion.
bool | SaveCorrectionParams ()
Save correction params.
bool | GetCorrectionParam (int HeadIndex, int ParamIndex, out float Param)
Get correction param.
bool | SetCorrectionParam (int HeadIndex, int ParamIndex, float Param)
Set correction param.
bool | SaveCorrectionParamToXML (string FileName)
Save correction param to file.
bool | LoadCorrectionParamFromXML (string FileName)
Load correction param from file.
bool | PhyRecconect ()
Force PHY to reconnect. Vender debug function.
bool | PhyReset ()
Reset PHY. Vender debug function.
bool | PhyDisconnect ()
Force PHY to disconnect. Vender debug function.
uint | GetPhyInstanceID ()
Get the PHY instance ID. Vender debug function.
float | GetPhyFWVersion ()
Get the PHY firmware version. Vender debug function.
bool | CoreHardReset ()
Hard reset the core. Vender debug function.
bool | CoreSoftReset ()
Soft reset the core. Vender debug function.
byte | GetLogImportanceLevel ()
Get log importance level.
bool | SetLogImportanceLevel (byte LogImportanceLevel)
Set log importance level.
byte | GetLogTypeLevel ()
Get log type level.
bool | SetLogTypeLevel (byte LogTypeLevel)
Set log type level.
bool | SoftwarePreprocessClear ()
bool | SetSoftwarePreprocessEnable (bool Enable)
byte | TransferExpoIntensityToExpoTime (float ExposureIntensity, WorkingModeType WorkingMode, out float ExposureTime)
Transfer exposure intensity to exposure time.
byte | TransferExpoTimeToExpoIntensity (float ExposureTime, WorkingModeType WorkingMode, out float ExposureIntensity)
Transfer exposure time to exposure intensity.
bool | Dump (string TargetPath, DumpContentType Content=DumpContentType.Normal)
Save the data frame and log in the cache;.
bool | ReadSettingsFromFile (string TargetPath)
Save the data frame and log in the cache;.
bool | WriteSettingsToFile (string TargetPath)
Save the data frame and log in the cache;.
bool | GetExpIByTargetGray (out float ExpI, byte TargerGrayValue, byte GrayValueTH=10, int GrayWinSize=100)
Get exposure intensity by target gray.
bool | AutoSetExpertModeParam (WorkingModeType WorkingMode, uint NoiseLevel, float ZLowerRange, float ZUpperRange)
Auto set exper settign for SuperFast3D or SuperDynamic3D.
void | GetProjectorExpRegionInfoFromCamExpRegion (double CamExpXCenter, double CamExpYCenter, double CamExpWidth, double CamExpHeight, double Z, out double ProjectionExpXCenter, out double ProjectionExpYCenter, out double ProjectionExpWidth, out double ProjectionExpHeight, bool Reverse=false)
Gets the projector exp region information from cam exp region.
bool | TestMultiHeadError (out ManagedDataFrameFixZMapSimpleStruct Error3D, out double StandardDeviation, float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D)
Test multiHead error.

Static Public Member Functions

static float | GetSDKVersion ()
Get SDK version.
static void | LoadDll ()
Manually load Dll.
static unsafe bool | MPSizectorS_GetExpROINum (IntPtr PIMPSizectorS, out byte ExpROINum)
static unsafe byte | MPSizectorS_SetExpROINum (IntPtr PIMPSizectorS, byte ExpROINum)
static unsafe byte | MPSizectorS_GetExpROIXCenter (IntPtr PIMPSizectorS, out ushort ExpROIX, int Index)
static unsafe byte | MPSizectorS_SetExpROIXCenter (IntPtr PIMPSizectorS, ushort ExpROIX, int Index)
static unsafe byte | MPSizectorS_GetExpROIYCenter (IntPtr PIMPSizectorS, out ushort ExpROIY, int Index)
static unsafe byte | MPSizectorS_SetExpROIYCenter (IntPtr PIMPSizectorS, ushort ExpROIY, int Index)
static unsafe byte | MPSizectorS_GetExpROIWidth (IntPtr PIMPSizectorS, out ushort ExpROIWidth, int Index)
static unsafe byte | MPSizectorS_SetExpROIWidth (IntPtr PIMPSizectorS, ushort ExpROIWidth, int Index)
static unsafe byte | MPSizectorS_GetExpROIHeight (IntPtr PIMPSizectorS, out ushort ExpROIHeight, int Index)
static unsafe byte | MPSizectorS_SetExpROIHeight (IntPtr PIMPSizectorS, ushort ExpROIHeight, int Index)
static unsafe byte | MPSizectorS_GetExpROIShape (IntPtr PIMPSizectorS, out ExpROIShapeType ExpROIShape, int Index)
static unsafe byte | MPSizectorS_SetExpROIShape (IntPtr PIMPSizectorS, ExpROIShapeType ExpROIShape, int Index)
static unsafe byte | MPSizectorS_GetExpROIBaseEnable (IntPtr PIMPSizectorS, out byte ExpROIBaseEnable, int Index)
static unsafe byte | MPSizectorS_SetExpROIBaseEnable (IntPtr PIMPSizectorS, byte ExpROIBaseEnable, int Index)
static unsafe byte | MPSizectorS_GetExpROIPolarity (IntPtr PIMPSizectorS, out ExpROIPropertyType ExpROIPolarity, int Index)
static unsafe byte | MPSizectorS_SetExpROIPolarity (IntPtr PIMPSizectorS, ExpROIPropertyType ExpROIPolarity, int Index)

Public Attributes

IntPtr m_SizectorS_Instance = IntPtr.Zero
Pointer of current device class.

Properties

DeviceInfoStructType | CurrentDeviceInfo [get]
Get the device info of current device.
DeviceStateType | DeviceState [get]
Get current state of device.
WorkingModeType | WorkingMode [get, set]
Gets or sets working mode.
byte | HoldState [get, set]
Gets or sets hold state.
byte | BinningState [get, set]
Gets or sets binning state.
byte | ROIX0Ratio [get, set]
Gets or sets the positon of ROI X start compare to horizontal pixeles.
byte | ROIY0Ratio [get, set]
Gets or sets the positon of ROI Y start compare to vertical pixeles.
byte | ROIWidthRatio [get, set]
Gets or sets the width of ROI compare to horizontal pixeles.
byte | ROIHeightRatio [get, set]
Gets or sets the height of ROI compare to vertical pixeles.
BasicSettingsStructType | BasicSettings [get, set]
Gets or sets basic setting.
TriggerSourceType | TriggerSource [get, set]
Gets or sets trigger source.
ExposureBasicSettingStructType | ExposureBasicSetting [get, set]
Gets or sets exposure basic setting.
byte | UserGain [get, set]
Gets or sets user gain.
float | ExposureIntensity3D_1st [get, set]
Gets or sets 1st exposure intensity for 3D.
float | ExposureIntensity3D_2nd [get, set]
Gets or sets 2nd exposure intensity for 3D.
float | ExposureIntensity3D_3rd [get, set]
Gets or sets 3rd exposure intensity for 3D.
float | ExposureIntensity2D [get, set]
Gets or sets exposure intensity for 2D.
byte | MultiHeadExpoVarMode [get, set]
Gets or sets multi head exposure variance mode for 3D.
byte | MultiHeadExpoVarRatio [get, set]
Gets or sets multi head exposure variance ratio for 3D.
ExposureSettingsStructType | ExposureSettings [get, set]
Gets or sets exposure setting.
byte | ExternalExposureEnable [get, set]
Gets or sets enable of external light exposure. Bit 0 for white enable; Bit 1 for RGB enable; 1 : on, 0 : off.
ushort | ExternalExposureGain [get, set]
Gets or sets gain of external light exposure. Bit 0 ~ Bit 3 for white gain; Bit 4 ~ Bit 7 for red gain; Bit 8 ~ Bit 11 for green gain ;Bit 12 ~ Bit 15 for blue gain. Valid value range [0, 4].
ushort | ExternalExposureTimeWhite_us [get, set]
Gets or sets exposure time of external white light.
ushort | ExternalExposureTimeRed_us [get, set]
Gets or sets exposure time of external red light.
ushort | ExternalExposureTimeGreen_us [get, set]
Gets or sets exposure time of external green light.
ushort | ExternalExposureTimeBlue_us [get, set]
Gets or sets exposure time of external blue light.
ExternalExposureSettingsStructType | ExternalExposureSettings [get, set]
Gets or sets exposure setting for external light.
byte | OverExposureFilterThreshold [get, set]
Gets or sets over-exposure filter threshold.
MPSizectorS_HardwarePreprocessModeType | ValidPointThreshold_PresetMode [get, set]
Gets or sets valid point threshold preset mode.
byte | ValidPointThreshold0 [get, set]
Gets or sets valid point threshold 0.
byte | ValidPointThreshold1 [get, set]
Gets or sets valid point threshold 1.
MPSizectorS_HardwarePreprocessModeType | BurrFilter_PresetMode [get, set]
Gets or sets burr filter threshold preset mode.
byte | BurrFilterThreshold0 [get, set]
Gets or sets burr filter threshold 0.
byte | BurrFilterThreshold1 [get, set]
Gets or sets burr filter threshold 1.
MPSizectorS_HardwarePreprocessModeType | PreProcess_PresetMode [get, set]
Gets or sets preprocess preset mode.
byte | PreProcessLoopNum [get, set]
Gets or sets pre-process loop num.
byte | PreProcessThreshold [get, set]
Gets or sets pre-process threshold.
ReconstructionSettingsStructType | ReconstructionSettings [get, set]
Gets or sets reconstruction settings.
byte | ProjectionMode [get, set]
Gets or sets multiple projection mode settings. Bit 0 for projecting 0 enable; Bit 1 for projecting 1 enable; Bit 2 for projecting 2 enable; Bit 3 for projecting 3 enable; 1 : on, 0 : off.
byte | MergeParam0 [get, set]
Gets or sets multiple projection merge parameter 0 settings. Valid value is [0, 7]. Higher value results higher affect of this factor.
byte | MergeParam1 [get, set]
Gets or sets multiple projection merge parameter 1 settings. Valid value is [0, 7]. Higher value results higher affect of this factor.
byte | MergeParam2 [get, set]
Gets or sets multiple projection merge parameter 2 settings. Valid value is [0, 7]. Higher value results higher affect of this factor.
byte | MergeParam3 [get, set]
Gets or sets multiple projection merge parameter 2 settings. Valid value is [0, 7]. Higher value results higher affect of this factor.
byte | MergeThreshold [get, set]
Gets or sets multiple projection merge threshold settings. Valid value is [0, 7]. Higher value results less heads to participate in merge.
byte | MergeNumber [get, set]
Gets or sets multiple projection merge number settings.Valid value is [1, 4]. Higher value results more heads to participate in merge.
MultiHeadSettingsStructType | MultiHeadSettings [get, set]
Gets or sets reconstruction setting for multiple projecting.
DataOutModeType | DataOutMode [get, set]
Gets or sets data output mode.
byte | UserRTMatrixEnableState [get, set]
Gets or sets user RT matrix enable state.
RTMatrixStructType | UserRTMatrix [get, set]
Gets or sets user RT matrix.
PointScaleSettingStructType | PointScaleSetting [get, set]
Gets or sets point scale setting.
byte | RangeCheckEnableState [get, set]
Gets or sets range check enable state.
RangeCheckSettingStructType | RangeCheckSetting [get, set]
Gets or sets range check setting.
PostProcessSettingsStructType | PostProcessSettings [get, set]
Gets or sets post-process settings.
byte | EXTIOOutput [get, set]
Gets or sets output pin register value.
OutputPinSettingStructType | EXTIO0Setting [get, set]
Gets or sets output pin 0 setting.
OutputPinSettingStructType | EXTIO1Setting [get, set]
Gets or sets output pin 1 setting.
HWTriggerSettingStructType | HWTriggerSeting [get, set]
Gets or sets hardware trigger setting.
IOSettingsStructType | IOSettings [get, set]
Gets or sets input pin 0 setting.
SettingsStructType | Settings [get, set]
Gets or sets all settings.
byte | AutoSleepEnableState [get, set]
Gets or sets auto-sleep enable state.
ushort | AutoSleepDelayMS [get, set]
Gets or sets auto-sleep delay.
GeneralSettingsStructType | GeneralSettings [get, set]
Gets or sets general setting.
SettingsStructType | DefaultSettings [get]
Gets or sets all settings.
CalibParamStructType | CalibParam [get]
Gets or sets camera calibration parameters.
ushort | DataTag [get, set]
Gets or sets data tag.
byte | EXTIOInput [get]
Gets input pin register value.
TemperatureFeedbackStructType | TempCore [get]
Get core temperature feedback information.
TemperatureFeedbackStructType | Temp0 [get]
Get temperature sensor 0 feedback information.
TemperatureFeedbackStructType | Temp1 [get]
Get temperature sensor 1 feedback information.
TemperatureFeedbackStructType | Temp2 [get]
Get temperature sensor 2 feedback information.
uint | StartUpTimeMS [get]
Get device start-up time.
uint | ConnectionTimeMS [get]
Get device connection time.
uint | SnapCnt [get]
Get snap count.
ushort | TotalTransferRetryNum [get]
Get total transfer retry count.
ushort | CurrentTransferRetryNum [get]
Get current frame transfer retry count.
ushort | TotalCaptureRetryNum [get]
Get total capture retry count.
TSNStructType | CurrentTSN [get]
Get current TSN.
TSNStructType | SoftwareTSN [get]
Get last software TSN.
TSNStructType | AutoTSN [get]
Get last auto TSN.
TSNStructType | HardwareTSN [get]
Get last hardware TSN.
DebugInfoStruct | DebugRegisters [get]
Get debug registers.
StatesStructType | States [get]
Get full device state information.
uint | MultiHeadConfig [get]
Get MultiHeadConfig.
ExpertSettingsStructType | ExpertSettings [get, set]
Gets or sets expert setting.
byte | SuppressExpo1Enable [get, set]
Get or set suppress exposure1 enable state.
byte | SuppressExpo2Enable [get, set]
Get or set suppress exposure2 enable state.
byte | SuppressExpo3Enable [get, set]
Get or set suppress exposure3 enable state.
byte | AutoHDRAdvanceSettingsEnable [get, set]
Auto hdr advance settings enable state.
byte | DiffPrejudgePatternEnable [get, set]
Diff prejudge pattern enable state.
byte | PrejudgePatternGain [get, set]
Prejudge pattern gain.
byte | FlipXEnable [get, set]
Gets or sets X axis flip.
byte | FlipYEnable [get, set]
Gets or sets Y axis flip.
byte | FlipNextBinningStateEnable [get, set]
Gets or sets flip next binning state enable.
AntiLampFlickerModeType | AntiLampFlickerMode [get, set]
Get or set anti-lamp flicker mode.
uint | CorrectionMode [get, set]
Get or set correction mode.
uint | SensorExpBaseTime [get, set]
Get or set exposure base time of expert working mode.
byte | AntiNoiseLevel [get, set]
Get or set anti noise level.
byte | PatternPeriod1 [get, set]
Get or set pattern period1 of expert working mode.
byte | PatternPeriod2 [get, set]
Get or set pattern period2 of expert working mode.
float | ZMin [get, set]
Get or set Z Min value of super fast 3d mode and super dynamic 3D mode.
float | ZMax [get, set]
Get or set Z Max value of super fast 3d mode and super dynamic 3D mode.

Constructor & Destructor Documentation

◆ MPSizectorS()

MPSizectorS_DotNet.MPSizectorS.MPSizectorS | ( | LogMediaType | LogMedia = LogMediaType::Off,
 |  | int | BufferRate = 1,
 |  | bool | EnableDependencyCheck = true )

Constructor.

Parameters
LogMedia | Optional parameter. Output media of log. Default is output off.
BufferRate | Rate of buffer,default value is 1。

Member Function Documentation

◆ CoreHardReset()

bool MPSizectorS_DotNet.MPSizectorS.CoreHardReset ( )

Hard reset the core. Vender debug function.

Returns
Success state of operation. Success is true, otherwise false.

◆ CoreSoftReset()

bool MPSizectorS_DotNet.MPSizectorS.CoreSoftReset ( )

Soft reset the core. Vender debug function.

Returns
Success state of operation. Success is true, otherwise false.

◆ CorrectDistortion()

bool MPSizectorS_DotNet.MPSizectorS.CorrectDistortion | ( | float | ExpI,
 |  | WorkingModeType | SnapWorkingMode = WorkingModeType::SuperPrecise3D,
 |  | bool | EnableSaveToDevice = true )

Correct distortion.

Parameters
ExpI | Exposure intensity when distortion is corrected.
SnapWorkingMode | Working mode when correcting distortion.
EnableSaveToDevice | Enable to save to device.
Returns
If action done.

◆ DataCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.DataCallBackType | ( | DataFormatType | DataFormat,
 |  | UnmanagedDataFrameUndefinedStruct | DataFrame )

Callback delegate of data.

Parameters
DataFormat | Data format of the date recieved.
DataFrame | Data frame recieved.

◆ DeviceStateChangeCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.DeviceStateChangeCallBackType ( DeviceStateType DeviceState )

Callback delegate of device state change.

Parameters
DeviceState Device state.

◆ Dump()

bool MPSizectorS_DotNet.MPSizectorS.Dump | ( | string | TargetPath,
 |  | DumpContentType | Content = DumpContentType::Normal )

Save the data frame and log in the cache;.

Parameters
FilePath Target Path.
Returns
Success state of operation. Success is true, otherwise false.

◆ FireSoftwareTrigger()

bool MPSizectorS_DotNet.MPSizectorS.FireSoftwareTrigger ( )

Fire software trigger.

Returns
Success state of operation. Success is true, otherwise false.

◆ GetDeviceCount()

int MPSizectorS_DotNet.MPSizectorS.GetDeviceCount ( )

Get total device number in the device list.

Returns
Total device number.

◆ GetDeviceInfo()

DeviceInfoStructType MPSizectorS_DotNet.MPSizectorS.GetDeviceInfo ( int Index )

Get the device info of device with specified index in the device list.

Parameters
Index Specified index.
Returns
Device info.

◆ GetExpIByTargetGray()

bool MPSizectorS_DotNet.MPSizectorS.GetExpIByTargetGray | ( | out float | ExpI,
 |  | byte | TargerGrayValue,
 |  | byte | GrayValueTH = 10,
 |  | int | GrayWinSize = 100 )

Get exposure intensity by target gray.

Parameters
TargerGrayValue | Target gray value.
ExpI | Exposure intensity.
GrayValueTH | Gray value threshold.
GrayWinSize | WinSize to calculate gray average.
Returns
If action done.

◆ GetLogImportanceLevel()

byte MPSizectorS_DotNet.MPSizectorS.GetLogImportanceLevel ( )

Get log importance level.

Returns
Log importance level.

◆ GetLogTypeLevel()

byte MPSizectorS_DotNet.MPSizectorS.GetLogTypeLevel ( )

Get log type level.

Returns
Log type level.

◆ GetPhyFWVersion()

float MPSizectorS_DotNet.MPSizectorS.GetPhyFWVersion ( )

Get the PHY firmware version. Vender debug function.

Returns
PHY firmware version.

◆ GetPhyInstanceID()

uint MPSizectorS_DotNet.MPSizectorS.GetPhyInstanceID ( )

Get the PHY instance ID. Vender debug function.

Returns
PHY instance ID.

◆ GetProjectorExpRegionInfoFromCamExpRegion()

void MPSizectorS_DotNet.MPSizectorS.GetProjectorExpRegionInfoFromCamExpRegion | ( | double | CamExpXCenter,
 |  | double | CamExpYCenter,
 |  | double | CamExpWidth,
 |  | double | CamExpHeight,
 |  | double | Z,
 |  | out double | ProjectionExpXCenter,
 |  | out double | ProjectionExpYCenter,
 |  | out double | ProjectionExpWidth,
 |  | out double | ProjectionExpHeight,
 |  | bool | Reverse = false )

Gets the projector exp region information from cam exp region.

Parameters
CamExpXCenter | Camera coordinate system exposure area center x.
CamExpYCenter | Camera coordinate system exposure area center y.
CamExpWidth | Camera coordinate system exposure area width.
CamExpHeight | Camera coordinate system exposure area height.
Z | The height of the position where the converted coordinate point is located.
ProjectionExpXCenter | Projector coordinate system exposure area center x.
ProjectionExpYCenter | Projector coordinate system exposure area center y.
ProjectionExpWidth | Projector coordinate system exposure area width.
ProjectionExpHeight | Projector coordinate system exposure area height.
Reverse | Whether to reverse the transformation direction.

◆ GetSDKVersion()

static float MPSizectorS_DotNet.MPSizectorS.GetSDKVersion ( )
static

Get SDK version.

Returns
SDK version.

◆ HeadPackCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.HeadPackCallBackType ( HeadPackStructType HeadPack )

Callback delegate of head pack.

Parameters
HeadPack Head pack recieved.

◆ LoadCorrectionParamFromXML()

bool MPSizectorS_DotNet.MPSizectorS.LoadCorrectionParamFromXML ( string FileName )

Load correction param from file.

Parameters
FileName File name。
Returns
Success state of operation. Success is true, otherwise false.

◆ LoadDefaultSettings()

bool MPSizectorS_DotNet.MPSizectorS.LoadDefaultSettings ( )

Apply the setting in FlashROM.

Returns
Success state of operation. Success is true, otherwise false.

◆ LoadDll()

static void MPSizectorS_DotNet.MPSizectorS.LoadDll ( )
static

Manually load Dll.

Returns

◆ LogCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.LogCallBackType ( string Log )

Callback delegate of log.

Parameters
Log Log information.

◆ Open()

bool MPSizectorS_DotNet.MPSizectorS.Open ( DeviceInfoStructType DeviceInfo )

Open device.

Parameters
DeviceInfo Device info of target device.
Returns
Success state of operation. Success is true, otherwise false.

◆ PhyDisconnect()

bool MPSizectorS_DotNet.MPSizectorS.PhyDisconnect ( )

Force PHY to disconnect. Vender debug function.

Returns
Success state of operation. Success is true, otherwise false.

◆ PhyRecconect()

bool MPSizectorS_DotNet.MPSizectorS.PhyRecconect ( )

Force PHY to reconnect. Vender debug function.

Returns
Success state of operation. Success is true, otherwise false.

◆ PhyReset()

bool MPSizectorS_DotNet.MPSizectorS.PhyReset ( )

Reset PHY. Vender debug function.

Returns
Success state of operation. Success is true, otherwise false.

◆ ReadSettingsFromFile()

bool MPSizectorS_DotNet.MPSizectorS.ReadSettingsFromFile ( string TargetPath )

Save the data frame and log in the cache;.

Parameters
FilePath Target Path.
Returns
Success state of operation. Success is true, otherwise false.

◆ Reconnect()

bool MPSizectorS_DotNet.MPSizectorS.Reconnect ( )

Reconnect the device. When auto-reconnect function is disabled, use this function to reconnect the device once the connection is lost.

Returns
Success state of operation. Success is true, otherwise false.

◆ SaveCorrectionParamToXML()

bool MPSizectorS_DotNet.MPSizectorS.SaveCorrectionParamToXML ( string FileName )

Save correction param to file.

Parameters
FileName File name。
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveSettingsAsDefault()

bool MPSizectorS_DotNet.MPSizectorS.SaveSettingsAsDefault ( )

Save current setting to FlashROM. It will be applied when device power up.

Returns
Success state of operation. Success is true, otherwise false.

◆ SetAutoReconnect()

void MPSizectorS_DotNet.MPSizectorS.SetAutoReconnect ( bool AutoReconnect )

Set the enable state of auto-reconnect function. The auto-reconnect function is enabled in default.

Parameters
AutoReconnect Enable state of auto-reconnect function.

◆ SetDataCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetDataCallBack ( DataCallBackType CallBackFn )

Register data callback function.

Parameters
CallBackFn Target function.

◆ SetDeviceStateChangeCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetDeviceStateChangeCallBack ( DeviceStateChangeCallBackType CallBackFn )

Register device state change callback function.

Parameters
CallBackFn Target function.

◆ SetHeadPackCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetHeadPackCallBack ( HeadPackCallBackType CallBackFn )

Register head pack callback function.

Parameters
CallBackFn Target function.

◆ SetLogCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetLogCallBack ( LogCallBackType CallBackFn )

Register log callback function.

Parameters
CallBackFn Target function.

◆ SetLogImportanceLevel()

bool MPSizectorS_DotNet.MPSizectorS.SetLogImportanceLevel ( byte LogImportanceLevel )

Set log importance level.

Parameters
LogImportanceLevel Log importance level.
Returns
Success state of operation. Success is true, otherwise false.

◆ SetLogTypeLevel()

bool MPSizectorS_DotNet.MPSizectorS.SetLogTypeLevel ( byte LogTypeLevel )

Set log type level.

Parameters
LogTypeLevel Log type level.
Returns
Success state of operation. Success is true, otherwise false.

◆ SnapUnmanaged()

bool MPSizectorS_DotNet.MPSizectorS.SnapUnmanaged | ( | bool | SoftwareTrigger,
 |  | out DataFormatType | DataFormat,
 |  | out UnmanagedDataFrameUndefinedStruct | Data,
 |  | uint | TimeOutMS )

Synchronized snap frame. Function returns after captured valid data frame, or time out.

Parameters
SoftwareTrigger | Whether to send a software trigger or not.
DataFormat | Return value by reference, Data format of captured frame.
Data | Return value by reference, Captured data frame.
TimeOutMS | Timeout delay in ms.
Returns
Success state of operation. Success is true, otherwise false.

◆ TestMultiHeadError()

bool MPSizectorS_DotNet.MPSizectorS.TestMultiHeadError | ( | out ManagedDataFrameFixZMapSimpleStruct | Error3D,
 |  | out double | StandardDeviation,
 |  | float | ExpI,
 |  | WorkingModeType | SnapWorkingMode = WorkingModeType::SuperPrecise3D )

Test multiHead error.

Parameters
Error3D | Error image.
StandardDeviation | Standard Deviation.
ExpI | Exposure intensity.
SnapWorkingMode | Working Mode.
Returns
If action done.

◆ TransferExpoIntensityToExpoTime()

byte MPSizectorS_DotNet.MPSizectorS.TransferExpoIntensityToExpoTime | ( | float | ExposureIntensity,
 |  | WorkingModeType | WorkingMode,
 |  | out float | ExposureTime )

Transfer exposure intensity to exposure time.

Parameters
ExposureIntensity | Exposure intensity.
WorkingMode | Working mode.
ExposureTime | Exposure time.
Returns
Success state of operation. Success is true, otherwise false.

◆ TransferExpoTimeToExpoIntensity()

byte MPSizectorS_DotNet.MPSizectorS.TransferExpoTimeToExpoIntensity | ( | float | ExposureTime,
 |  | WorkingModeType | WorkingMode,
 |  | out float | ExposureIntensity )

Transfer exposure time to exposure intensity.

Parameters
ExposureTime | Exposure time.
WorkingMode | Working mode.
ExposureIntensity | Exposure intensity.
Returns
Success state of operation. Success is true, otherwise false.

◆ UpdateDeviceList()

bool MPSizectorS_DotNet.MPSizectorS.UpdateDeviceList ( )

Refresh the device list.

Returns
Success state of operation. Success is true, otherwise false.

◆ WriteSettingsToFile()

bool MPSizectorS_DotNet.MPSizectorS.WriteSettingsToFile ( string TargetPath )

Save the data frame and log in the cache;.

Parameters
FilePath Target Path.
Returns
Success state of operation. Success is true, otherwise false.

Property Documentation

◆ CurrentDeviceInfo

DeviceInfoStructType MPSizectorS_DotNet.MPSizectorS.CurrentDeviceInfo
get

Get the device info of current device.

Returns
Current device info.

◆ DeviceState

DeviceStateType MPSizectorS_DotNet.MPSizectorS.DeviceState
get

Get current state of device.

Returns
Device state.


MPSizector .NET Programmer's Manual: Member List

  • MPSizectorS
MPSizectorS_DotNet.MPSizectorS Member List

This is the complete list of members for MPSizectorS_DotNet.MPSizectorS, including all inherited members.

AntiLampFlickerMode | MPSizectorS_DotNet.MPSizectorS |
AntiNoiseLevel | MPSizectorS_DotNet.MPSizectorS |
AutoHDRAdvanceSettingsEnable | MPSizectorS_DotNet.MPSizectorS |
AutoSetExpertModeParam(WorkingModeType WorkingMode, uint NoiseLevel, float ZLowerRange, float ZUpperRange) | MPSizectorS_DotNet.MPSizectorS |
AutoSleepDelayMS | MPSizectorS_DotNet.MPSizectorS |
AutoSleepEnableState | MPSizectorS_DotNet.MPSizectorS |
AutoTSN | MPSizectorS_DotNet.MPSizectorS |
BasicSettings | MPSizectorS_DotNet.MPSizectorS |
BinningState | MPSizectorS_DotNet.MPSizectorS |
BurrFilter_PresetMode | MPSizectorS_DotNet.MPSizectorS |
BurrFilterThreshold0 | MPSizectorS_DotNet.MPSizectorS |
BurrFilterThreshold1 | MPSizectorS_DotNet.MPSizectorS |
CalibParam | MPSizectorS_DotNet.MPSizectorS |
Close() | MPSizectorS_DotNet.MPSizectorS |
ConnectionTimeMS | MPSizectorS_DotNet.MPSizectorS |
CoreHardReset() | MPSizectorS_DotNet.MPSizectorS |
CoreSoftReset() | MPSizectorS_DotNet.MPSizectorS |
CorrectDistortion(float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D, bool EnableSaveToDevice=true) | MPSizectorS_DotNet.MPSizectorS |
CorrectionMode | MPSizectorS_DotNet.MPSizectorS |
CurrentDeviceInfo | MPSizectorS_DotNet.MPSizectorS |
CurrentTransferRetryNum | MPSizectorS_DotNet.MPSizectorS |
CurrentTSN | MPSizectorS_DotNet.MPSizectorS |
DataCallBackType(DataFormatType DataFormat, UnmanagedDataFrameUndefinedStruct DataFrame) | MPSizectorS_DotNet.MPSizectorS |
DataOutMode | MPSizectorS_DotNet.MPSizectorS |
DataTag | MPSizectorS_DotNet.MPSizectorS |
DebugRegisters | MPSizectorS_DotNet.MPSizectorS |
DefaultSettings | MPSizectorS_DotNet.MPSizectorS |
DeviceState | MPSizectorS_DotNet.MPSizectorS |
DeviceStateChangeCallBackType(DeviceStateType DeviceState) | MPSizectorS_DotNet.MPSizectorS |
DiffPrejudgePatternEnable | MPSizectorS_DotNet.MPSizectorS |
Dump(string TargetPath, DumpContentType Content=DumpContentType.Normal) | MPSizectorS_DotNet.MPSizectorS |
ExpertSettings | MPSizectorS_DotNet.MPSizectorS |
ExposureBasicSetting | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity2D | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity3D_1st | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity3D_2nd | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity3D_3rd | MPSizectorS_DotNet.MPSizectorS |
ExposureSettings | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureEnable | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureGain | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureSettings | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeBlue_us | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeGreen_us | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeRed_us | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeWhite_us | MPSizectorS_DotNet.MPSizectorS |
EXTIO0Setting | MPSizectorS_DotNet.MPSizectorS |
EXTIO1Setting | MPSizectorS_DotNet.MPSizectorS |
EXTIOInput | MPSizectorS_DotNet.MPSizectorS |
EXTIOOutput | MPSizectorS_DotNet.MPSizectorS |
FireSoftwareTrigger() | MPSizectorS_DotNet.MPSizectorS |
FlipNextBinningStateEnable | MPSizectorS_DotNet.MPSizectorS |
FlipXEnable | MPSizectorS_DotNet.MPSizectorS |
FlipYEnable | MPSizectorS_DotNet.MPSizectorS |
GeneralSettings | MPSizectorS_DotNet.MPSizectorS |
GetCorrectionParam(int HeadIndex, int ParamIndex, out float Param) | MPSizectorS_DotNet.MPSizectorS |
GetDeviceCount() | MPSizectorS_DotNet.MPSizectorS |
GetDeviceInfo(int Index) | MPSizectorS_DotNet.MPSizectorS |
GetExpIByTargetGray(out float ExpI, byte TargerGrayValue, byte GrayValueTH=10, int GrayWinSize=100) | MPSizectorS_DotNet.MPSizectorS |
GetHardwareTimeStamps(out HardwareTimeStampsStructType HardwareTimeStamps) | MPSizectorS_DotNet.MPSizectorS |
GetLastZAt(byte Position, byte Head) | MPSizectorS_DotNet.MPSizectorS |
GetLogImportanceLevel() | MPSizectorS_DotNet.MPSizectorS |
GetLogTypeLevel() | MPSizectorS_DotNet.MPSizectorS |
GetMonitorPosition(byte Position, out ushort X, out ushort Y) | MPSizectorS_DotNet.MPSizectorS |
GetPhyFWVersion() | MPSizectorS_DotNet.MPSizectorS |
GetPhyInstanceID() | MPSizectorS_DotNet.MPSizectorS |
GetProjectorExpRegionInfoFromCamExpRegion(double CamExpXCenter, double CamExpYCenter, double CamExpWidth, double CamExpHeight, double Z, out double ProjectionExpXCenter, out double ProjectionExpYCenter, out double ProjectionExpWidth, out double ProjectionExpHeight, bool Reverse=false) | MPSizectorS_DotNet.MPSizectorS |
GetSDKVersion() | MPSizectorS_DotNet.MPSizectorS | static
HardwareTSN | MPSizectorS_DotNet.MPSizectorS |
HeadPackCallBackType(HeadPackStructType HeadPack) | MPSizectorS_DotNet.MPSizectorS |
HoldState | MPSizectorS_DotNet.MPSizectorS |
HWTriggerSeting | MPSizectorS_DotNet.MPSizectorS |
IOSettings | MPSizectorS_DotNet.MPSizectorS |
LoadCorrectionParamFromXML(string FileName) | MPSizectorS_DotNet.MPSizectorS |
LoadDefaultSettings() | MPSizectorS_DotNet.MPSizectorS |
LoadDll() | MPSizectorS_DotNet.MPSizectorS | static
LogCallBackType(string Log) | MPSizectorS_DotNet.MPSizectorS |
m_SizectorS_Instance | MPSizectorS_DotNet.MPSizectorS |
MergeNumber | MPSizectorS_DotNet.MPSizectorS |
MergeParam0 | MPSizectorS_DotNet.MPSizectorS |
MergeParam1 | MPSizectorS_DotNet.MPSizectorS |
MergeParam2 | MPSizectorS_DotNet.MPSizectorS |
MergeParam3 | MPSizectorS_DotNet.MPSizectorS |
MergeThreshold | MPSizectorS_DotNet.MPSizectorS |
MPSizectorS(LogMediaType LogMedia=LogMediaType.Off, int BufferRate=1, bool EnableDependencyCheck=true) | MPSizectorS_DotNet.MPSizectorS |
MPSizectorS_GetExpROIBaseEnable(IntPtr PIMPSizectorS, out byte ExpROIBaseEnable, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIHeight(IntPtr PIMPSizectorS, out ushort ExpROIHeight, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROINum(IntPtr PIMPSizectorS, out byte ExpROINum) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIPolarity(IntPtr PIMPSizectorS, out ExpROIPropertyType ExpROIPolarity, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIShape(IntPtr PIMPSizectorS, out ExpROIShapeType ExpROIShape, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIWidth(IntPtr PIMPSizectorS, out ushort ExpROIWidth, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIXCenter(IntPtr PIMPSizectorS, out ushort ExpROIX, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIYCenter(IntPtr PIMPSizectorS, out ushort ExpROIY, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIBaseEnable(IntPtr PIMPSizectorS, byte ExpROIBaseEnable, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIHeight(IntPtr PIMPSizectorS, ushort ExpROIHeight, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROINum(IntPtr PIMPSizectorS, byte ExpROINum) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIPolarity(IntPtr PIMPSizectorS, ExpROIPropertyType ExpROIPolarity, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIShape(IntPtr PIMPSizectorS, ExpROIShapeType ExpROIShape, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIWidth(IntPtr PIMPSizectorS, ushort ExpROIWidth, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIXCenter(IntPtr PIMPSizectorS, ushort ExpROIX, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIYCenter(IntPtr PIMPSizectorS, ushort ExpROIY, int Index) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MultiHeadConfig | MPSizectorS_DotNet.MPSizectorS |
MultiHeadExpoVarMode | MPSizectorS_DotNet.MPSizectorS |
MultiHeadExpoVarRatio | MPSizectorS_DotNet.MPSizectorS |
MultiHeadSettings | MPSizectorS_DotNet.MPSizectorS |
Open(DeviceInfoStructType DeviceInfo) | MPSizectorS_DotNet.MPSizectorS |
OverExposureFilterThreshold | MPSizectorS_DotNet.MPSizectorS |
PatternPeriod1 | MPSizectorS_DotNet.MPSizectorS |
PatternPeriod2 | MPSizectorS_DotNet.MPSizectorS |
PhyDisconnect() | MPSizectorS_DotNet.MPSizectorS |
PhyRecconect() | MPSizectorS_DotNet.MPSizectorS |
PhyReset() | MPSizectorS_DotNet.MPSizectorS |
PointScaleSetting | MPSizectorS_DotNet.MPSizectorS |
PostProcessSettings | MPSizectorS_DotNet.MPSizectorS |
PrejudgePatternGain | MPSizectorS_DotNet.MPSizectorS |
PreProcess_PresetMode | MPSizectorS_DotNet.MPSizectorS |
PreProcessLoopNum | MPSizectorS_DotNet.MPSizectorS |
PreProcessThreshold | MPSizectorS_DotNet.MPSizectorS |
ProjectionMode | MPSizectorS_DotNet.MPSizectorS |
RangeCheckEnableState | MPSizectorS_DotNet.MPSizectorS |
RangeCheckSetting | MPSizectorS_DotNet.MPSizectorS |
ReadSettingsFromFile(string TargetPath) | MPSizectorS_DotNet.MPSizectorS |
Reconnect() | MPSizectorS_DotNet.MPSizectorS |
ReconstructionSettings | MPSizectorS_DotNet.MPSizectorS |
ROIHeightRatio | MPSizectorS_DotNet.MPSizectorS |
ROIWidthRatio | MPSizectorS_DotNet.MPSizectorS |
ROIX0Ratio | MPSizectorS_DotNet.MPSizectorS |
ROIY0Ratio | MPSizectorS_DotNet.MPSizectorS |
SaveCorrectionParams() | MPSizectorS_DotNet.MPSizectorS |
SaveCorrectionParamToXML(string FileName) | MPSizectorS_DotNet.MPSizectorS |
SaveSettingsAsDefault() | MPSizectorS_DotNet.MPSizectorS |
SensorExpBaseTime | MPSizectorS_DotNet.MPSizectorS |
SetAutoReconnect(bool AutoReconnect) | MPSizectorS_DotNet.MPSizectorS |
SetCorrectionParam(int HeadIndex, int ParamIndex, float Param) | MPSizectorS_DotNet.MPSizectorS |
SetDataCallBack(DataCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetDeviceStateChangeCallBack(DeviceStateChangeCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetHeadPackCallBack(HeadPackCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetLogCallBack(LogCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetLogImportanceLevel(byte LogImportanceLevel) | MPSizectorS_DotNet.MPSizectorS |
SetLogTypeLevel(byte LogTypeLevel) | MPSizectorS_DotNet.MPSizectorS |
SetMonitorPosition(byte Position, ushort X, ushort Y) | MPSizectorS_DotNet.MPSizectorS |
SetSoftwarePreprocessEnable(bool Enable) (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS |
Settings | MPSizectorS_DotNet.MPSizectorS |
SnapCnt | MPSizectorS_DotNet.MPSizectorS |
SnapUnmanaged(bool SoftwareTrigger, out DataFormatType DataFormat, out UnmanagedDataFrameUndefinedStruct Data, uint TimeOutMS) | MPSizectorS_DotNet.MPSizectorS |
SoftwarePreprocessClear() (defined in MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS |
SoftwareTSN | MPSizectorS_DotNet.MPSizectorS |
StartUpTimeMS | MPSizectorS_DotNet.MPSizectorS |
States | MPSizectorS_DotNet.MPSizectorS |
SuppressExpo1Enable | MPSizectorS_DotNet.MPSizectorS |
SuppressExpo2Enable | MPSizectorS_DotNet.MPSizectorS |
SuppressExpo3Enable | MPSizectorS_DotNet.MPSizectorS |
Temp0 | MPSizectorS_DotNet.MPSizectorS |
Temp1 | MPSizectorS_DotNet.MPSizectorS |
Temp2 | MPSizectorS_DotNet.MPSizectorS |
TempCore | MPSizectorS_DotNet.MPSizectorS |
TestMultiHeadError(out ManagedDataFrameFixZMapSimpleStruct Error3D, out double StandardDeviation, float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D) | MPSizectorS_DotNet.MPSizectorS |
TotalCaptureRetryNum | MPSizectorS_DotNet.MPSizectorS |
TotalTransferRetryNum | MPSizectorS_DotNet.MPSizectorS |
TransferExpoIntensityToExpoTime(float ExposureIntensity, WorkingModeType WorkingMode, out float ExposureTime) | MPSizectorS_DotNet.MPSizectorS |
TransferExpoTimeToExpoIntensity(float ExposureTime, WorkingModeType WorkingMode, out float ExposureIntensity) | MPSizectorS_DotNet.MPSizectorS |
TriggerSource | MPSizectorS_DotNet.MPSizectorS |
UpdateDeviceList() | MPSizectorS_DotNet.MPSizectorS |
UserGain | MPSizectorS_DotNet.MPSizectorS |
UserRTMatrix | MPSizectorS_DotNet.MPSizectorS |
UserRTMatrixEnableState | MPSizectorS_DotNet.MPSizectorS |
ValidPointThreshold0 | MPSizectorS_DotNet.MPSizectorS |
ValidPointThreshold1 | MPSizectorS_DotNet.MPSizectorS |
ValidPointThreshold_PresetMode | MPSizectorS_DotNet.MPSizectorS |
WorkingMode | MPSizectorS_DotNet.MPSizectorS |
WriteSettingsToFile(string TargetPath) | MPSizectorS_DotNet.MPSizectorS |
ZMax | MPSizectorS_DotNet.MPSizectorS |
ZMin | MPSizectorS_DotNet.MPSizectorS |


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType Struct Reference

  • MPSizectorS_AutoHDRAdvanceSettingsStructType
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType Struct Reference

Structure of auto hdr advance settings. More...

Public Attributes

byte | AutoHDRAdvanceSettingsEnable
Auto hdr advance settings enable.
byte | DiffPrejudgePatternEnable
Diff prejudge pattern enable.
byte | PrejudgePatternGain
Prejudge pattern gain.

Properties

byte | _AutoHDRAdvanceSettingsEnable [get]
byte | _DiffPrejudgePatternEnable [get]
byte | _PrejudgePatternGain [get]

Detailed Description

Structure of auto hdr advance settings.


MPSizector .NET Programmer's Manual: Member List

  • MPSizectorS_AutoHDRAdvanceSettingsStructType
MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType, including all inherited members.

_AutoHDRAdvanceSettingsEnable (defined in MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
_DiffPrejudgePatternEnable (defined in MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
_PrejudgePatternGain (defined in MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
AutoHDRAdvanceSettingsEnable | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
DiffPrejudgePatternEnable | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
PrejudgePatternGain | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType Struct Reference

  • MPSizectorS_ExpICoefSettingsStructType
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType Struct Reference

Exposure intensity coef settings. More...

Public Attributes

float | ExpICoef
Exposure intensity coef.
float | ExpICoefMax
Max exposure intensity coef.

Properties

float | _ExpICoef [get]
float | _ExpICoefMax [get]

Detailed Description

Exposure intensity coef settings.


MPSizector .NET Programmer's Manual: Member List

  • MPSizectorS_ExpICoefSettingsStructType
MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType, including all inherited members.

_ExpICoef (defined in MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
_ExpICoefMax (defined in MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
ExpICoef | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
ExpICoefMax | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.MultiHeadSettingsStructType Struct Reference

  • MultiHeadSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.MultiHeadSettingsStructType Struct Reference

Structure of reconstruction setting for multiple projecting. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | ProjectionMode
Projection mode. Bit 0 for projecting 0 enable; Bit 1 for projecting 1 enable; Bit 2 for projecting 2 enable; Bit 3 for projecting 3 enable; 1 : on, 0 : off.
byte | MergeParam0
Merge parameter 0. Valid value is [0, 7]. Higher value results higher affect of this factor.
byte | MergeParam1
Merge parameter 1. Valid value is [0, 7]. Higher value results higher affect of this factor.
byte | MergeParam2
Merge parameter 2. Valid value is [0, 7]. Higher value results higher affect of this factor.
byte | MergeThreshold
Merge threshold. Valid value is [0, 7]. Higher value results less heads to participate in merge.

Properties

byte | _ProjectionMode [get]
byte | _MergeParam0 [get]
byte | _MergeParam1 [get]
byte | _MergeParam2 [get]
byte | _MergeThreshold [get]
int | ProjectionNumber [get]
Projecting number.

Detailed Description

Structure of reconstruction setting for multiple projecting.


MPSizector .NET Programmer's Manual: Member List

  • MultiHeadSettingsStructType
MPSizectorS_DotNet.MultiHeadSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.MultiHeadSettingsStructType, including all inherited members.

_MergeParam0 (defined in MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_MergeParam1 (defined in MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_MergeParam2 (defined in MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_MergeThreshold (defined in MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_ProjectionMode (defined in MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeParam0 | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeParam1 | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeParam2 | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeThreshold | MPSizectorS_DotNet.MultiHeadSettingsStructType
ProjectionMode | MPSizectorS_DotNet.MultiHeadSettingsStructType
ProjectionNumber | MPSizectorS_DotNet.MultiHeadSettingsStructType
ToString() (defined in MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.OutputPinSettingStructType Struct Reference

  • OutputPinSettingStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.OutputPinSettingStructType Struct Reference

Structure of output pin setting (for one pin). More...

Public Member Functions

override string ToString ()

Public Attributes

OutputPinModeType | PinMode
Output pin mode.
byte | IsReversedForSpecialFunction
Polarity of special function output signal. true to reverse the polarity.

Properties

OutputPinModeType | _PinMode [get]
byte | _IsReversedForSpecialFunction [get]

Detailed Description

Structure of output pin setting (for one pin).


MPSizector .NET Programmer's Manual: Member List

  • OutputPinSettingStructType
MPSizectorS_DotNet.OutputPinSettingStructType Member List

This is the complete list of members for MPSizectorS_DotNet.OutputPinSettingStructType, including all inherited members.

_IsReversedForSpecialFunction (defined in MPSizectorS_DotNet.OutputPinSettingStructType) | MPSizectorS_DotNet.OutputPinSettingStructType
_PinMode (defined in MPSizectorS_DotNet.OutputPinSettingStructType) | MPSizectorS_DotNet.OutputPinSettingStructType
IsReversedForSpecialFunction | MPSizectorS_DotNet.OutputPinSettingStructType
PinMode | MPSizectorS_DotNet.OutputPinSettingStructType
ToString() (defined in MPSizectorS_DotNet.OutputPinSettingStructType) | MPSizectorS_DotNet.OutputPinSettingStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.PartialFactorySettingsStructType Struct Reference

  • PartialFactorySettingsStructType
Public Attributes | Properties | List of all members
MPSizectorS_DotNet.PartialFactorySettingsStructType Struct Reference

Partial factory settings struct type. More...

Public Attributes

uint | MultiHeadConfig
float | ExpICoef
float | ExpICoefMax
float | LED0Coef
float | LED1Coef
float | LED2Coef
float | LED3Coef
uint | LEDCoefEN
float | PreJudgeExpI_0
float | PreJudgeExpI_1
float | PreJudgeExpI_2
byte | PreJudge_AmpTH
byte | PreJudge_AmpRatioTH
float | PreJudge_IdealGray
byte | PreJudge_RSideWidth_Standard
byte | PreJudge_RSideWidth_Precise
byte | PreJudge_RSideWidth_SuperPrecise
byte | PreJudge_LSideWidth_Standard
byte | PreJudge_LSideWidth_Precise
byte | PreJudge_LSideWidth_SuperPrecise
byte | BtoG_Enable
float | BtoG_Recon_Weight_R
float | BtoG_Recon_Weight_G
float | BtoG_Recon_Weight_B
byte | BtoC_Enable
float | BtoC_2D_Weight_R
float | BtoC_2D_Weight_G
float | BtoC_2D_Weight_B
byte[] | Reserve

Properties

uint | _MultiHeadConfig [get]
float | _ExpICoef [get]
float | _ExpICoefMax [get]
float | _LED0Coef [get]
float | _LED1Coef [get]
float | _LED2Coef [get]
float | _LED3Coef [get]
uint | _LEDCoefEN [get]
float | _PreJudgeExpI_0 [get]
float | _PreJudgeExpI_1 [get]
float | _PreJudgeExpI_2 [get]
byte | _PreJudge_AmpTH [get]
byte | _PreJudge_AmpRatioTH [get]
float | _PreJudge_IdealGray [get]
byte | _PreJudge_RSideWidth_Standard [get]
byte | _PreJudge_RSideWidth_Precise [get]
byte | _PreJudge_RSideWidth_SuperPrecise [get]
byte | _PreJudge_LSideWidth_Standard [get]
byte | _PreJudge_LSideWidth_Precise [get]
byte | _PreJudge_LSideWidth_SuperPrecise [get]
byte | _BtoG_Enable [get]
float | _BtoG_Recon_Weight_R [get]
float | _BtoG_Recon_Weight_G [get]
float | _BtoG_Recon_Weight_B [get]
byte | _BtoC_Enable [get]
float | _BtoC_2D_Weight_R [get]
float | _BtoC_2D_Weight_G [get]
float | _BtoC_2D_Weight_B [get]

Detailed Description

Partial factory settings struct type.


MPSizector .NET Programmer's Manual: Member List

  • PartialFactorySettingsStructType
MPSizectorS_DotNet.PartialFactorySettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.PartialFactorySettingsStructType, including all inherited members.

_BtoC_2D_Weight_B (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoC_2D_Weight_G (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoC_2D_Weight_R (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoC_Enable (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Enable (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Recon_Weight_B (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Recon_Weight_G (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Recon_Weight_R (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_ExpICoef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_ExpICoefMax (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED0Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED1Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED2Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED3Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LEDCoefEN (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_MultiHeadConfig (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_AmpRatioTH (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_AmpTH (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_IdealGray (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_LSideWidth_Precise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_LSideWidth_Standard (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_LSideWidth_SuperPrecise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_RSideWidth_Precise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_RSideWidth_Standard (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_RSideWidth_SuperPrecise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudgeExpI_0 (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudgeExpI_1 (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudgeExpI_2 (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_2D_Weight_B (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_2D_Weight_G (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_2D_Weight_R (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_Enable (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Enable (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Recon_Weight_B (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Recon_Weight_G (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Recon_Weight_R (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
ExpICoef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
ExpICoefMax (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED0Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED1Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED2Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED3Coef (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LEDCoefEN (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
MultiHeadConfig (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_AmpRatioTH (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_AmpTH (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_IdealGray (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_LSideWidth_Precise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_LSideWidth_Standard (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_LSideWidth_SuperPrecise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_RSideWidth_Precise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_RSideWidth_Standard (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_RSideWidth_SuperPrecise (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudgeExpI_0 (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudgeExpI_1 (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudgeExpI_2 (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
Reserve (defined in MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.PointScaleSettingStructType Struct Reference

  • PointScaleSettingStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.PointScaleSettingStructType Struct Reference

Structure of point scale setting. Used to convert between float point cloud and fixed point cloud format.
e.g., relationship between float and fixed point X value: XFloat = XIncrement * XFixedPoint + X0Pos. More...

Public Member Functions

override string ToString ()

Public Attributes

float | X0Pos
Coordinate value for X fixed point data = 0.
float | XIncrement
Value increment for X.
float | XReserved
Reserved.
float | Y0Pos
Coordinate value for Y fixed point data = 0.
float | YIncrement
Value increment for Y.
float | YReserved
Reserved.
float | Z0Pos
Coordinate value for Z fixed point data = 0.
float | ZIncrement
Value increment for Z.

Properties

float | _X0Pos [get]
float | _XIncrement [get]
float | _Y0Pos [get]
float | _YIncrement [get]
float | _Z0Pos [get]
float | _ZIncrement [get]

Detailed Description

Structure of point scale setting. Used to convert between float point cloud and fixed point cloud format.
e.g., relationship between float and fixed point X value: XFloat = XIncrement * XFixedPoint + X0Pos.


MPSizector .NET Programmer's Manual: Member List

  • PointScaleSettingStructType
MPSizectorS_DotNet.PointScaleSettingStructType Member List

This is the complete list of members for MPSizectorS_DotNet.PointScaleSettingStructType, including all inherited members.

_X0Pos (defined in MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_XIncrement (defined in MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_Y0Pos (defined in MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_YIncrement (defined in MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_Z0Pos (defined in MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_ZIncrement (defined in MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
ToString() (defined in MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
X0Pos | MPSizectorS_DotNet.PointScaleSettingStructType
XIncrement | MPSizectorS_DotNet.PointScaleSettingStructType
XReserved | MPSizectorS_DotNet.PointScaleSettingStructType
Y0Pos | MPSizectorS_DotNet.PointScaleSettingStructType
YIncrement | MPSizectorS_DotNet.PointScaleSettingStructType
YReserved | MPSizectorS_DotNet.PointScaleSettingStructType
Z0Pos | MPSizectorS_DotNet.PointScaleSettingStructType
ZIncrement | MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.PostProcessSettingsStructType Struct Reference

  • PostProcessSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.PostProcessSettingsStructType Struct Reference

Structure of post-process setting. More...

Public Member Functions

override string ToString ()

Public Attributes

DataOutModeType | DataOutMode
3D data output mode.
byte | UserRTMatrixEnableState
Enable state of user RT matrix.
RTMatrixStructType | UserRTMatrix
User RT matrix.
PointScaleSettingStructType | PointScaleSetting
Point scale setting, applied when generating fixed point cloud.
byte | RangeCheckEnableState
Enable state of range check function.
RangeCheckSettingStructType | RangeCheckSetting
Range check setting.

Properties

DataOutModeType | _DataOutMode [get]
byte | _UserRTMatrixEnableState [get]
RTMatrixStructType | _UserRTMatrix [get]
PointScaleSettingStructType | _PointScaleSetting [get]
byte | _RangeCheckEnableState [get]
RangeCheckSettingStructType | _RangeCheckSetting [get]

Detailed Description

Structure of post-process setting.


MPSizector .NET Programmer's Manual: Member List

  • PostProcessSettingsStructType
MPSizectorS_DotNet.PostProcessSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.PostProcessSettingsStructType, including all inherited members.

_DataOutMode (defined in MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_PointScaleSetting (defined in MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_RangeCheckEnableState (defined in MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_RangeCheckSetting (defined in MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_UserRTMatrix (defined in MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_UserRTMatrixEnableState (defined in MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
DataOutMode | MPSizectorS_DotNet.PostProcessSettingsStructType
PointScaleSetting | MPSizectorS_DotNet.PostProcessSettingsStructType
RangeCheckEnableState | MPSizectorS_DotNet.PostProcessSettingsStructType
RangeCheckSetting | MPSizectorS_DotNet.PostProcessSettingsStructType
ToString() (defined in MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
UserRTMatrix | MPSizectorS_DotNet.PostProcessSettingsStructType
UserRTMatrixEnableState | MPSizectorS_DotNet.PostProcessSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.Process Class Reference

  • Process
Classes | Public Member Functions | Static Public Member Functions | List of all members
MPSizectorS_DotNet.Process Class Reference

Classes

struct RotatedRectangle

Public Member Functions

static bool Undistort (UnmanagedDataFrameUndefinedStruct Frame, CalibParamStructType CalibParam)
Undistort data.

Static Public Member Functions

static unsafe byte | ConvertZMapFrameToFloat3DFrame (UnmanagedDataFrameUndefinedStruct data, out UnmanagedDataFrameUndefinedStruct float3DData, CalibParamStructType calibParam)
Convert zMap frame to float3d frame.
static unsafe void | ConvertToRangeImage (ManagedDataFrameFloat3DStruct src_frame, RangeImageManaged dst_image)
Converts a ManagedDataFrameFix3DStruct of src_frame to a RangeImageManaged of dst_image.
static unsafe void | ConvertToRangeImage (ManagedDataFrameFix3DStruct src_frame, RangeImageManaged dst_image)
Converts a ManagedDataFrameFix3DStruct of src_frame to a RangeImageManaged of dst_image.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, string FileName)
Save managed Fix3D data to a text format point cloud file.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, string FileName)
Save unmanaged Fix3D data to a text format point cloud file.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, string FileName)
Save managed FixZMap data to a text format point cloud file.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, string FileName)
Save unmanaged FixZMap data to a text format point cloud file.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, ushort[] Z, string FileName)
Save managed fixed point Z data to text format point cloud file.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, ushort *Z, string FileName)
Save unmanaged fixed point Z data to text format point cloud file.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, string FileName)
Save managed Float3D data to text format point cloud file.
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, string FileName)
Save unmanaged Float3D data to text format point cloud file.
static unsafe bool | SavePLY (UnmanagedDataFrameUndefinedStruct DataFrame, string FileName)
Save unmanaged Undefined data to PLY format point cloud file.
static unsafe bool | SavePCD (UnmanagedDataFrameUndefinedStruct DataFrame, string FileName)
Save unmanaged Undefined data to PCD format point cloud file.
static unsafe bool | SaveTIFF (UnmanagedDataFrameUndefinedStruct DataFrame, bool ConvertToRangeImage, string FileName, bool EnableSaveFloatTypeData=false)
Save unmanaged Undefined data to TIFF format point cloud file.
static void | InitGpu (int gpuId=0, bool useGlobalBuffer=false)
Initializes GPU acceleration.
static unsafe void | FreeGpu ()
Release post-processing related GPU computing resources.
static unsafe void | PostProcessRangeCheckRingEndRect (UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax)
Post process : Check Range.
static unsafe void | PostProcessRangeCheckRect (UnmanagedDataFrameUndefinedStruct dataFrame, float RecCenterX, float RecCenterY, float InnerRecWidth, float InnerRecHeight, float OuterRecWidth, float OuterRecHeight, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax)
Post process : Check Range.
static unsafe void | PostProcessRangeCheckCircle (UnmanagedDataFrameUndefinedStruct dataFrame, float CircleCenterX, float CircleCenterY, float InnerCricleRadius, float OuterCircleRadius, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax)
Post process : Check Range.
static unsafe void | PostProcessCircleRangeCheck_ByReferencePlan (UnmanagedDataFrameUndefinedStruct dataFrame, float circleCenterX, float circleCenterY, float innerCricleRadius, float outerCircleRadius, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax)
Post process : Check Range By Reference Plane.
static unsafe void | PostProcessRectangleRangeCheck_ByReferencePlan (UnmanagedDataFrameUndefinedStruct dataFrame, float recCenterX, float recCenterY, float innerRecWidth, float innerRecHeight, float outerRecWidth, float outerRecHeight, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax)
Post process : Check Range By Reference Plane in Rectangle.
static unsafe void | PostProcessRingEndRectRangeCheck_ByReferencePlan (UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax)
Post process : Check Range By Reference Plane in Rectangle.
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post process : remove burrs.
static unsafe void | PostProcessMend (UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessMend (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
Post process : mend empty point.
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | PostProcessFiltrate (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
Post process : filtrate.
static unsafe void | GetDataPtr (HeadPackStructType srcFrameInfo, byte *srcDataPtr, ref ushort *srcUshortZPtr, ref byte *srcWhiteArrayPtr, ref byte *srcRGBArrayPtr)
Gets the pointers corresponding to the data frame by providing srcFrameInfo of type HeadPackStructType and srcDataPtr of type byte.
static unsafe void | RgbToHsv_Cpu (byte *rgbPtr, int imageWidth, int imageHeight, byte *hsvPtr)
Converts an RGB image to an HSV image using CPU.
static unsafe void | GenThresholdTable_Cpu (byte *tablePtr, byte lowThreshold, byte highThreshold)
Generates a threshold lookup table using CPU.
static unsafe void | Threshold_Cpu (byte *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr)
Executes a threshold operation using CPU.
static unsafe void | Threshold3Channel_Cpu (byte *data1Ptr, byte *data2Ptr, byte *data3Ptr, int imageWidth, int imageHeight, byte *maskPtr, byte *minThresholdArray, byte *maxThresholdArray)
Executes a three-channel threshold operation using CPU.
static unsafe void | GenCircleKernel_Cpu (byte *kernelPtr, int kernelWidth, int kernelHeight, float radius)
Generates a circular kernel using CPU.
static unsafe void | Dilate_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
Dilates a binary image using a kernel.
static unsafe void | Erosion_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
Performs image erosion on a binary image using a kernel.
static unsafe void | Closing_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
Performs closing on a binary image using a kernel.
static unsafe void | Opening_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
Performs opening on a binary image using a kernel.
static unsafe void | PostProcessSPI (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
锡膏检查后处理接口
static unsafe void | PostProcessSPI (ManagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
锡膏检查后处理接口
static unsafe void | PostProcessSPIChannel3 (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
Post-processing interface for solder paste inspection.
static unsafe void | PostProcessSPIChannel3 (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
Post-processing interface for solder paste inspection.
static double | Distance (Point p1, Point p2)
static double | DotProduct (Point v1, Point v2)
static double | AngleBetween (Point v1, Point v2)
static List< Point > | ConvexHull (List< Point > points)
static double | CrossProduct (Point p1, Point p2, Point p3)
static PointF | RotatePoint (Point point, Point center, double radianAngle)
static RotatedRectangle | FindMinimumRotatedRectangle (List< Point > points)
static float[] | FitPlane (float[] xyzList)
static unsafe short[][] | calculateMarkCoordinates (int imageWidth, int imageHeight, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int arrayLen, int markWidth, int markHeight, int planeRegionGridSize=240)
static unsafe List< short > | GetGridNearestMarkList (int imageWidth, int imageHeight, short[][] markCoordinateList, int gridX, int gridY, int planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=float.MaxValue)
static unsafe void | PostProcessPlaneCorrection (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f)
static unsafe void | PostProcessPlaneCorrection (ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f)
static unsafe void | GenThresholdTableUshort_Cpu (byte *tablePtr, ushort lowThreshold, ushort highThreshold)
Generate threshold table.
static unsafe void | ThresholdUshort_Cpu (ushort *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr)
Threshold an input image based on a threshold table.
static unsafe void | PostProcessSegmentMedianFilter (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
Separates the plane-corrected image by height and performs median filtering on each section.
static unsafe void | PostProcessSegmentMedianFilter (ManagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
Separates the plane-corrected image by height and performs median filtering on each section.
static unsafe void | PostProcessMendByFeatures (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post processing: Mend empty points based on features. Estimate itself according to the adjacent point information of the invalid point.
static unsafe void | PostProcessMendByFeatures (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post processing: Mend empty points based on features. Estimate itself according to the adjacent point information of the invalid point.
static unsafe void | PostProcessMendByFeatures (HeadPackStructType frameInfo, byte *dataPtr, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
Post processing: Mend empty points based on features. Estimate itself according to the adjacent point information of the invalid point.
static void | selectionSort_Gpu (float[] list, int length, int offset)
static void | quickSort (float[] list, int left, int right)
static unsafe void | PostProcessRegionMend (ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0)
Postprocess the input depth image with region mending.
static unsafe void | PostProcessRegionMend (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0)
Postprocess the input depth image with region mending.
static unsafe void | PostProcessRegionMend (HeadPackStructType frameInfo, byte *dataPtr, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0)
Postprocess the input depth image with region mending.
static unsafe bool | PostProcessTransformImage (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
Geometric transformation of non-managed FixZMapSimple format image.
static unsafe bool | PostProcessTransformImage (ManagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
Geometric transformation of managed FixZMapSimple format image.
static unsafe UnmanagedDataFrameUndefinedStruct | UpSamplingData (UnmanagedDataFrameUndefinedStruct dataFrame)
Up-sample unmanaged undefined format data.
static unsafe UnmanagedDataFrameUndefinedStruct | ConvertBayerToRGB (UnmanagedDataFrameUndefinedStruct DataFrame, BayerTransferType bayerTransferType, bool btoCEnable, float gainR, float gainG, float gainB, bool btoGEnable, float gainR_forGray, float gainG_forGray, float gainB_forGray)
Bayer resolves unmanaged Undefined format data.
static unsafe UnmanagedDataFrameUndefinedStruct | ConvertFrame2DBayerToGray (UnmanagedDataFrameUndefinedStruct DataFrame, int startIndex, int endIndex, float gainR, float gainG, float gainB)
Bayer resolves unmanaged Undefined format data to grayscale.
static unsafe ManagedDataFrameFixZMapSimpleStruct | DownSamplingData (ManagedDataFrameFixZMapSimpleStruct DataFrame, int samplingRate, int mode)
Get downsampling data for the current data.
static unsafe UnmanagedDataFrameUndefinedStruct | DownSamplingData (UnmanagedDataFrameUndefinedStruct DataFrame, int samplingRate, int mode)
Get Down Sampling Data.
static unsafe UnmanagedDataFrameUndefinedStruct | MergeWRGBData (UnmanagedDataFrameUndefinedStruct dataFrame3D, UnmanagedDataFrameUndefinedStruct dataFrame2D, int WIndex, int RGBIndex)
Make unmanaged undefined data3D and unmanaged undefined data2D merge.
static unsafe UnmanagedDataFrameUndefinedStruct | GetROIData (UnmanagedDataFrameUndefinedStruct dataFrame, int StartX, int StartY, int Width, int Height)
Get ROI Data.

Member Function Documentation

◆ Closing_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Closing_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

Performs closing on a binary image using a kernel.

Parameters
maskPtr | A pointer to the original mask data.
maskDstPtr | A pointer to the output mask data.
maskWidth | The width of the original mask.
maskHeight | The height of the original mask.
kernelPtr | Pointer to kernel data.
kernelWidth | The width of the kernel.
kernelHeight | The height of the kernel.

◆ ConvertBayerToRGB()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.ConvertBayerToRGB | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | BayerTransferType | bayerTransferType,
 |  | bool | btoCEnable,
 |  | float | gainR,
 |  | float | gainG,
 |  | float | gainB,
 |  | bool | btoGEnable,
 |  | float | gainR_forGray,
 |  | float | gainG_forGray,
 |  | float | gainB_forGray )
 static

Bayer resolves unmanaged Undefined format data.

Parameters
DataFrame Data struct.
Returns
The data structure after Bayer solution.

◆ ConvertFrame2DBayerToGray()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.ConvertFrame2DBayerToGray | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | int | startIndex,
 |  | int | endIndex,
 |  | float | gainR,
 |  | float | gainG,
 |  | float | gainB )
 static

Bayer resolves unmanaged Undefined format data to grayscale.

Parameters
DataFrame Data struct.
Returns
The data structure after Bayer solution.

◆ ConvertToRangeImage() [1/2]

static unsafe void MPSizectorS_DotNet.Process.ConvertToRangeImage | ( | ManagedDataFrameFix3DStruct | src_frame,
 |  | RangeImageManaged | dst_image )
 static

Converts a ManagedDataFrameFix3DStruct of src_frame to a RangeImageManaged of dst_image.

Parameters
src_frame | The source data frame to be converted.
dst_image | The target range image object where the converted result will be stored.

◆ ConvertToRangeImage() [2/2]

static unsafe void MPSizectorS_DotNet.Process.ConvertToRangeImage | ( | ManagedDataFrameFloat3DStruct | src_frame,
 |  | RangeImageManaged | dst_image )
 static

Converts a ManagedDataFrameFix3DStruct of src_frame to a RangeImageManaged of dst_image.

Parameters
src_frame | The source data frame to be converted.
dst_image | The target range image object where the converted result will be stored.

◆ ConvertZMapFrameToFloat3DFrame()

static unsafe byte MPSizectorS_DotNet.Process.ConvertZMapFrameToFloat3DFrame | ( | UnmanagedDataFrameUndefinedStruct | data,
 |  | out UnmanagedDataFrameUndefinedStruct | float3DData,
 |  | CalibParamStructType | calibParam )
 static

Convert zMap frame to float3d frame.

Parameters
data | The z map data.
float3DData | The float3d data.
calibParam | The calib parameter.
Returns

◆ Dilate_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Dilate_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

Dilates a binary image using a kernel.

Parameters
maskPtr | A pointer to the original mask data.
maskDstPtr | A pointer to the output mask data.
maskWidth | The width of the original mask.
maskHeight | The height of the original mask.
kernelPtr | Pointer to kernel data.
kernelWidth | The width of the kernel.
kernelHeight | The height of the kernel.

◆ DownSamplingData() [1/2]

static unsafe ManagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.Process.DownSamplingData | ( | ManagedDataFrameFixZMapSimpleStruct | DataFrame,
 |  | int | samplingRate,
 |  | int | mode )
 static

Get downsampling data for the current data.

Parameters
DataFrame | Data struct.
samplingRate | Rate of downsampling.
Returns
Data after downsampling.

◆ DownSamplingData() [2/2]

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.DownSamplingData | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | int | samplingRate,
 |  | int | mode )
 static

Get Down Sampling Data.

Parameters
DataFrame | Data struct.
samplingRate | Binning Num.
Returns
Down Sampling Data.

◆ Erosion_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Erosion_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

Performs image erosion on a binary image using a kernel.

Parameters
maskPtr | A pointer to the original mask data.
maskDstPtr | A pointer to the output mask data.
maskWidth | The width of the original mask.
maskHeight | The height of the original mask.
kernelPtr | Pointer to kernel data.
kernelWidth | The width of the kernel.
kernelHeight | The height of the kernel.

◆ GenCircleKernel_Cpu()

static unsafe void MPSizectorS_DotNet.Process.GenCircleKernel_Cpu | ( | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight,
 |  | float | radius )
 static

Generates a circular kernel using CPU.

Parameters
kernelPtr | A byte pointer used to store the generated kernel.
kernelWidth | The width of the kernel.
kernelHeight | The height of the kernel.
radius | The radius of the circle.

◆ GenThresholdTable_Cpu()

static unsafe void MPSizectorS_DotNet.Process.GenThresholdTable_Cpu | ( | byte * | tablePtr,
 |  | byte | lowThreshold,
 |  | byte | highThreshold )
 static

Generates a threshold lookup table using CPU.

Parameters
tablePtr | A byte pointer pointing to the lookup table to generate.
lowThreshold | The low threshold.
highThreshold | The high threshold.

◆ GenThresholdTableUshort_Cpu()

static unsafe void MPSizectorS_DotNet.Process.GenThresholdTableUshort_Cpu | ( | byte * | tablePtr,
 |  | ushort | lowThreshold,
 |  | ushort | highThreshold )
 static

Generate threshold table.

Parameters
tablePtr | A pointer to the output threshold table.
lowThreshold | The low threshold value.
highThreshold | The high threshold value.

◆ GetDataPtr()

static unsafe void MPSizectorS_DotNet.Process.GetDataPtr | ( | HeadPackStructType | srcFrameInfo,
 |  | byte * | srcDataPtr,
 |  | ref ushort * | srcUshortZPtr,
 |  | ref byte * | srcWhiteArrayPtr,
 |  | ref byte * | srcRGBArrayPtr )
 static

Gets the pointers corresponding to the data frame by providing srcFrameInfo of type HeadPackStructType and srcDataPtr of type byte.

Parameters
srcFrameInfo | A HeadPackStructType structure containing the data frame information.
srcDataPtr | A byte pointer pointing to the raw data.
srcUshortZPtr | A ushort pointer pointing to the depth value data.
srcWhiteArrayPtr | A byte pointer pointing to the white light image data (if available).
srcRGBArrayPtr | A byte pointer pointing to the color image data (if available).

◆ GetROIData()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.GetROIData | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | int | StartX,
 |  | int | StartY,
 |  | int | Width,
 |  | int | Height )
 static

Get ROI Data.

Parameters
DataFrame | Data struct.
StartX | Start X.
StartY | Start Y.
Width | Width.
Height | Height.
Returns
ROI Data.

◆ InitGpu()

static void MPSizectorS_DotNet.Process.InitGpu | ( | int | gpuId = 0,
 |  | bool | useGlobalBuffer = false )
 static

Initializes GPU acceleration.

Parameters
gpuId | The ID of the GPU device to use. Default is 0.
useGlobalBuffer | Whether to use global buffer. Default is false.

◆ MergeWRGBData()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.MergeWRGBData | ( | UnmanagedDataFrameUndefinedStruct | dataFrame3D,
 |  | UnmanagedDataFrameUndefinedStruct | dataFrame2D,
 |  | int | WIndex,
 |  | int | RGBIndex )
 static

Make unmanaged undefined data3D and unmanaged undefined data2D merge.

Parameters
dataFrame3D | 3D Data struct.
dataFrame2D | 2D Data struct.
WIndex | Index of white data.
RGBIndex | Begin index of RGB data.
Returns
Data struct after merge.

◆ Opening_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Opening_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

Performs opening on a binary image using a kernel.

Parameters
maskPtr | A pointer to the original mask data.
maskDstPtr | A pointer to the output mask data.
maskWidth | The width of the original mask.
maskHeight | The height of the original mask.
kernelPtr | Pointer to kernel data.
kernelWidth | The width of the kernel.
kernelHeight | The height of the kernel.

◆ PostProcessCircleRangeCheck_ByReferencePlan()

static unsafe void MPSizectorS_DotNet.Process.PostProcessCircleRangeCheck_ByReferencePlan | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | circleCenterX,
 |  | float | circleCenterY,
 |  | float | innerCricleRadius,
 |  | float | outerCircleRadius,
 |  | float | planeNormalX,
 |  | float | planeNormalY,
 |  | float | planeNormalZ,
 |  | float | planeMeanX,
 |  | float | planeMeanY,
 |  | float | planeMeanZ,
 |  | float | distanceMin,
 |  | float | distanceMax )
 static

Post process : Check Range By Reference Plane.

Parameters
dataFrame | Data
CircleCenterX | Circle center X
CircleCenterY | Circle center Y
InnerCricleRadius | Inner circle radius
OuterCircleRadius | Outer circle radius
planeNormalX | Plane normal X
planeNormalY | Plane normal Y
planeNormalZ | Plane normal Z
planeMeanX | Plane center X
planeMeanY | Plane center Y
planeMeanZ | Plane center Z
distanceMin | distance Min
distanceMax | distance Max

◆ PostProcessFiltrate() [1/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [2/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [3/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [4/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [5/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [6/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [7/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [8/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessFiltrate() [9/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

Post process : filtrate.

Parameters
dataFrame | Data
paramWinSize | Window size
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the smaller the value, the more points are filtrated
paramNeighborNumLevel | Close number parameter, range [0, 100], the smaller the value, the more points are filtrated

◆ PostProcessMend() [1/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [2/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [3/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [4/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [5/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [6/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [7/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [8/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMend() [9/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

Post process : mend empty point.

Parameters
dataFrame | Data
paramWinSize | Window size
method | Method, 0 : dilate, 1 : interpolation
paramWinSize | Extra window size for dilate method

◆ PostProcessMendByFeatures() [1/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMendByFeatures | ( | HeadPackStructType | frameInfo,
 |  | byte * | dataPtr,
 |  | uint | mendMode,
 |  | uint | channel1Diff,
 |  | uint | channel2Diff,
 |  | uint | channel3Diff,
 |  | float | validPtRate,
 |  | float | heightLowThreshold = 0,
 |  | float | heightHighThreshold = 0,
 |  | uint | paramWinSize = 10,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post processing: Mend empty points based on features. Estimate itself according to the adjacent point information of the invalid point.

Parameters
dataFrame | 3D Frame
dataPtr | A pointer to the input image data.
mendMode | Patch based on feature mode, 0 represents W, 1 represents RGB, 2 represents HSV, 3 represents height
channel1Diff | Channel 1 grayscale difference value, channel 1 is R (H, W)
channel2Diff | Channel 2 grayscale difference value, channel 2 is G (S)
channel3Diff | Channel 3 grayscale difference value, channel 3 is B (V)
validPtRate | Valid point ratio, when the valid point ratio in the window is greater than this value, patching will be performed
heightLowThreshold | Low height threshold
heightHighThreshold | High height threshold
paramWinSize | The range of adjacent points

◆ PostProcessMendByFeatures() [2/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMendByFeatures | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mendMode,
 |  | uint | channel1Diff,
 |  | uint | channel2Diff,
 |  | uint | channel3Diff,
 |  | float | validPtRate,
 |  | float | heightLowThreshold = 0,
 |  | float | heightHighThreshold = 0,
 |  | uint | paramWinSize = 10,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post processing: Mend empty points based on features. Estimate itself according to the adjacent point information of the invalid point.

Parameters
dataFrame | 3D Frame
mendMode | Patch based on feature mode, 0 represents W, 1 represents RGB, 2 represents HSV, 3 represents height
channel1Diff | Channel 1 grayscale difference value, channel 1 is R (H, W)
channel2Diff | Channel 2 grayscale difference value, channel 2 is G (S)
channel3Diff | Channel 3 grayscale difference value, channel 3 is B (V)
validPtRate | Valid point ratio, when the valid point ratio in the window is greater than this value, patching will be performed
heightLowThreshold | Low height threshold
heightHighThreshold | High height threshold
paramWinSize | The range of adjacent points

◆ PostProcessMendByFeatures() [3/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMendByFeatures | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mendMode,
 |  | uint | channel1Diff,
 |  | uint | channel2Diff,
 |  | uint | channel3Diff,
 |  | float | validPtRate,
 |  | float | heightLowThreshold = 0,
 |  | float | heightHighThreshold = 0,
 |  | uint | paramWinSize = 10,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post processing: Mend empty points based on features. Estimate itself according to the adjacent point information of the invalid point.

Parameters
dataFrame | 3D Frame
mendMode | Patch based on feature mode, 0 represents W, 1 represents RGB, 2 represents HSV, 3 represents height
channel1Diff | Channel 1 grayscale difference value, channel 1 is R (H, W)
channel2Diff | Channel 2 grayscale difference value, channel 2 is G (S)
channel3Diff | Channel 3 grayscale difference value, channel 3 is B (V)
validPtRate | Valid point ratio, when the valid point ratio in the window is greater than this value, patching will be performed
heightLowThreshold | Low height threshold
heightHighThreshold | High height threshold
paramWinSize | The range of adjacent points

◆ PostProcessPlaneCorrection() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessPlaneCorrection | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | markTopLeftXArray,
 |  | ushort[] | markTopLeftYArray,
 |  | int | markTopLeftPointLen,
 |  | int | markWidth,
 |  | int | markHeight,
 |  | short | markOffsetX = 0,
 |  | short | markOffsetY = 0,
 |  | uint | planeRegionGridSize = 240,
 |  | float | minPlaneMarkDistanceRatio = 1::1f,
 |  | float | minGridMarksDistanceRatio = 1::0f,
 |  | float | rangeCheckMinZ = -5,
 |  | float | rangeCheckMaxZ = 5,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f )
 static

Corrects the plane based on mark point data.

Parameters
dataFrame | Image data.
markTopLeftXArray | Array of x-coordinates of the upper-left corner of the rectanglar marking point on the base plane.
markTopLeftYArray | Array of y-coordinates of the upper-left corner of the rectanglar marking point on the base plane.
markTopLeftPointLen | Number of rectanglar marking points on the base plane.
markWidth | Width of the rectanglar marking point on the base plane.
markHeight | Height of the rectanglar marking point on the base plane.
markOffsetX | X-coordinate offset of the given mark points.
markOffsetY | Y-coordinate offset of the given mark points.
planeRegionGridSize | Size of the plane correction grid region based on mark points.
minPlaneMarkDistanceRatio | The minimum distance magnification between mark points used in the plane correction area.
minGridMarksDistanceRatio | The distance multiplier from the grid center to the mark collection (multiple of planeRegionGridSize).
rangeCheckMinZ | Minimum z-value for range checking.
rangeCheckMaxZ | Maximum z-value for range checking.
offsetMode | Compensation mode for corrected data. Mode 0 = kx+b, Mode 1 = k(x/k)^b.
solderOffsetParam1 | Parameter 1 for correcting solder data: k.
solderOffsetParam2 | Parameter 2 for correcting solder data: b.

◆ PostProcessPlaneCorrection() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessPlaneCorrection | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | markTopLeftXArray,
 |  | ushort[] | markTopLeftYArray,
 |  | int | markTopLeftPointLen,
 |  | int | markWidth,
 |  | int | markHeight,
 |  | short | markOffsetX = 0,
 |  | short | markOffsetY = 0,
 |  | uint | planeRegionGridSize = 240,
 |  | float | minPlaneMarkDistanceRatio = 1::1f,
 |  | float | minGridMarksDistanceRatio = 1::0f,
 |  | float | rangeCheckMinZ = -5,
 |  | float | rangeCheckMaxZ = 5,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f )
 static

Corrects the plane based on mark point data.

Parameters
dataFrame | Image data.
markTopLeftXArray | Array of x-coordinates of the upper-left corner of the rectanglar marking point on the base plane.
markTopLeftYArray | Array of y-coordinates of the upper-left corner of the rectanglar marking point on the base plane.
markTopLeftPointLen | Number of rectanglar marking points on the base plane.
markWidth | Width of the rectanglar marking point on the base plane.
markHeight | Height of the rectanglar marking point on the base plane.
markOffsetX | X-coordinate offset of the given mark points.
markOffsetY | Y-coordinate offset of the given mark points.
minPlaneMarkDistanceRatio | The minimum distance magnification between mark points used in the plane correction area.
minGridMarksDistanceRatio | The distance multiplier from the grid center to the mark collection (multiple of planeRegionGridSize).
rangeCheckMinZ | Minimum z-value for range checking.
rangeCheckMaxZ | Maximum z-value for range checking.
offsetMode | Compensation mode for corrected data. Mode 0 = kx+b, Mode 1 = k(x/k)^b.
solderOffsetParam1 | Parameter 1 for correcting solder data: k.
solderOffsetParam2 | Parameter 2 for correcting solder data: b.

◆ PostProcessRangeCheckCircle()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRangeCheckCircle | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | CircleCenterX,
 |  | float | CircleCenterY,
 |  | float | InnerCricleRadius,
 |  | float | OuterCircleRadius,
 |  | float | XMin,
 |  | float | XMax,
 |  | float | YMin,
 |  | float | YMax,
 |  | float | ZMin,
 |  | float | ZMax )
 static

Post process : Check Range.

Parameters
dataFrame | Data
CircleCenterX | Circle center X
CircleCenterY | Circle center Y
InnerCricleRadius | Inner circle radius
OuterCircleRadius | Outer circle radius
XMin | XMin
XMax | XMax
YMin | YMin
YMax | YMax
ZMin | ZMin
ZMax | ZMax

◆ PostProcessRangeCheckRect()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRangeCheckRect | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | RecCenterX,
 |  | float | RecCenterY,
 |  | float | InnerRecWidth,
 |  | float | InnerRecHeight,
 |  | float | OuterRecWidth,
 |  | float | OuterRecHeight,
 |  | float | XMin,
 |  | float | XMax,
 |  | float | YMin,
 |  | float | YMax,
 |  | float | ZMin,
 |  | float | ZMax )
 static

Post process : Check Range.

Parameters
dataFrame | Data
RecCenterX | Rectangle Center X
RecCenterY | Rectangle Center Y
InnerRecWidth | Inner Rectangle Width
InnerRecHeight | Inner Rectangle Height
OuterRecWidth | Outer Rectangle Width
OuterRecHeight | Outer Rectangle Height
XMin | XMin
XMax | XMax
YMin | YMin
YMax | YMax
ZMin | ZMin
ZMax | ZMax

◆ PostProcessRangeCheckRingEndRect()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRangeCheckRingEndRect | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | RingEndRectCenterX,
 |  | float | RingEndRectCenterY,
 |  | float | RingEndRectWidth,
 |  | float | RingEndRectOuterR,
 |  | float | RingEndRectInnerR,
 |  | float | RingEndRectAngle,
 |  | float | XMin,
 |  | float | XMax,
 |  | float | YMin,
 |  | float | YMax,
 |  | float | ZMin,
 |  | float | ZMax )
 static

Post process : Check Range.

Parameters
dataFrame | Data
RingEndRectCenterX | RingEndRect Center X
RingEndRectCenterY | RingEndRect Center Y
RingEndRectWidth | RingEndRect Width
RingEndRect OuterR | RingEndRect OuterR
RingEndRect InnerR | RingEndRect InnerR
XMin | XMin
XMax | XMax
YMin | YMin
YMax | YMax
ZMin | ZMin
ZMax | ZMax

◆ PostProcessRectangleRangeCheck_ByReferencePlan()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRectangleRangeCheck_ByReferencePlan | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | recCenterX,
 |  | float | recCenterY,
 |  | float | innerRecWidth,
 |  | float | innerRecHeight,
 |  | float | outerRecWidth,
 |  | float | outerRecHeight,
 |  | float | planeNormalX,
 |  | float | planeNormalY,
 |  | float | planeNormalZ,
 |  | float | planeMeanX,
 |  | float | planeMeanY,
 |  | float | planeMeanZ,
 |  | float | distanceMin,
 |  | float | distanceMax )
 static

Post process : Check Range By Reference Plane in Rectangle.

Parameters
dataFrame | Data
recCenterX | Rectangel center X
recCenterY | Rectangel center Y
innerRecWidth | Inner rectangle width
innerRecHeight | Inner rectangle height
outerRecWidth | Outer rectangle width
outerRecHeight | Outer rectangle height
planeNormalX | Plane normal X
planeNormalY | Plane normal Y
planeNormalZ | Plane normal Z
planeMeanX | Plane center X
planeMeanY | Plane center Y
planeMeanZ | Plane center Z
distanceMin | distance Min
distanceMax | distance Max

◆ PostProcessRegionMend() [1/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRegionMend | ( | HeadPackStructType | frameInfo,
 |  | byte * | dataPtr,
 |  | ushort[] | regionTopLeftPtX,
 |  | ushort[] | regionTopLeftPtY,
 |  | ushort[] | regionWidth,
 |  | ushort[] | regionHeight,
 |  | float[] | lowThreshold,
 |  | float[] | highThreshold,
 |  | uint | validPtCount,
 |  | short | regionOffsetX = 0,
 |  | short | regionOffsetY = 0 )
 static

Postprocess the input depth image with region mending.

Parameters
frameInfo | The header info of depth image data.
dataPtr | A pointer to the input depth image data.
regionTopLeftPtX | The x-coordinate array of the top-left points for each region.
regionTopLeftPtY | The y-coordinate array of the top-left points for each region.
regionWidth | The width array of each region.
regionHeight | The height array of each region.
lowThreshold | The low threshold array for each region.
highThreshold | The high threshold array for each region.
validPtCount | The number of valid points.
regionOffsetX | The offset value of the x-coordinate for the region.
regionOffsetY | The offset value of the y-coordinate for the region.

◆ PostProcessRegionMend() [2/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRegionMend | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | regionTopLeftPtX,
 |  | ushort[] | regionTopLeftPtY,
 |  | ushort[] | regionWidth,
 |  | ushort[] | regionHeight,
 |  | float[] | lowThreshold,
 |  | float[] | highThreshold,
 |  | uint | validPtCount,
 |  | short | regionOffsetX = 0,
 |  | short | regionOffsetY = 0 )
 static

Postprocess the input depth image with region mending.

Parameters
dataFrame | Image data.
regionTopLeftPtX | The x-coordinate array of the top-left points for each region.
regionTopLeftPtY | The y-coordinate array of the top-left points for each region.
regionWidth | The width array of each region.
regionHeight | The height array of each region.
lowThreshold | The low threshold array for each region.
highThreshold | The high threshold array for each region.
validPtCount | The number of valid points.
regionOffsetX | The offset value of the x-coordinate for the region.
regionOffsetY | The offset value of the y-coordinate for the region.

◆ PostProcessRegionMend() [3/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRegionMend | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | regionTopLeftPtX,
 |  | ushort[] | regionTopLeftPtY,
 |  | ushort[] | regionWidth,
 |  | ushort[] | regionHeight,
 |  | float[] | lowThreshold,
 |  | float[] | highThreshold,
 |  | uint | validPtCount,
 |  | short | regionOffsetX = 0,
 |  | short | regionOffsetY = 0 )
 static

Postprocess the input depth image with region mending.

Parameters
dataFrame | Image data.
regionTopLeftPtX | The x-coordinate array of the top-left points for each region.
regionTopLeftPtY | The y-coordinate array of the top-left points for each region.
regionWidth | The width array of each region.
regionHeight | The height array of each region.
lowThreshold | The low threshold array for each region.
highThreshold | The high threshold array for each region.
validPtCount | The number of valid points.
regionOffsetX | The offset value of the x-coordinate for the region.
regionOffsetY | The offset value of the y-coordinate for the region.

◆ PostProcessRemoveBurrs() [1/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [2/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [3/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [4/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [5/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [6/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [7/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [8/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRemoveBurrs() [9/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

Post process : remove burrs.

Parameters
dataFrame | Data
paramWinSize | Window size
paramWinSize2 | Window size
paramSlopeLevel | Slope parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborCloseLevel | Close judge parameter, range [0, 100], the larger the value, the more burrs are removed
paramNeighborNumLevel | Close number parameter, range [0, 100], the larger the value, the more burrs are removed
paramEdgeSuppressLevel | Edge parameter, range [0, 100], the larger the value, the more burrs are removed

◆ PostProcessRingEndRectRangeCheck_ByReferencePlan()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRingEndRectRangeCheck_ByReferencePlan | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | RingEndRectCenterX,
 |  | float | RingEndRectCenterY,
 |  | float | RingEndRectWidth,
 |  | float | RingEndRectOuterR,
 |  | float | RingEndRectInnerR,
 |  | float | RingEndRectAngle,
 |  | float | planeNormalX,
 |  | float | planeNormalY,
 |  | float | planeNormalZ,
 |  | float | planeMeanX,
 |  | float | planeMeanY,
 |  | float | planeMeanZ,
 |  | float | distanceMin,
 |  | float | distanceMax )
 static

Post process : Check Range By Reference Plane in Rectangle.

Parameters
dataFrame Data

<param name=""RingEndRectCenterX">RingEndRectCenterX</param>
<param name="RingEndRectCenterY">RingEndRectCenterY</param>
<param name="RingEndRectWidth">RingEndRectWidth</param>
<param name="RingEndRectOuterR">RingEndRectOuterR</param>
<param name="RingEndRectInnerR">RingEndRectInnerR</param>
<param name="RingEndRectAngle">RingEndRectAngle</param>
<param name="planeNormalX"> Plane normal X </param>
<param name="planeNormalY"> Plane normal Y </param>
<param name="planeNormalZ"> Plane normal Z </param>
<param name="planeMeanX"> Plane center X </param>
<param name="planeMeanY"> Plane center Y </param>
<param name="planeMeanZ"> Plane center Z </param>
<param name="distanceMin"> distance Min </param>
<param name="distanceMax"> distance Max

◆ PostProcessSegmentMedianFilter() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSegmentMedianFilter | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float | segmentLowThreshold,
 |  | float | segmentHighThreshold,
 |  | float | minZ,
 |  | float | maxZ,
 |  | uint | filterSize = 10,
 |  | float | filterTargetPercentage = 0::5f,
 |  | float | validPercentage = 0::2f,
 |  | float | histZPrecision = 0::0025f,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

Separates the plane-corrected image by height and performs median filtering on each section.

Parameters
dataFrame | Image data.
segmentlowThreshold | Low threshold for height segmentation. low-high = 255, others = 0; When low = high, it is set to 255.
segmentHighThreshold | High threshold for height segmentation. low-high = 255, others = 0; When low = high, it is set to 255.
minZ | Minimum z value of the range where the target value is located. Any value lower than this will be statistically placed at the first position of the histogram. The target value should be between minZ and maxZ, otherwise the statistical result will be incorrect.
maxZ | Maximum z value of the range where the target value is located. Any value higher than this will be statistically placed at the last position of the histogram. The target value should be between minZ and maxZ, otherwise the statistical result will be incorrect.
filterSize | Half kernel size of the median filter.
filterTargetPercentage | Percentage of the target value in the neighborhood value used to calculate the median. The median should be set to 0.5f.
validPercentage | Percentage of effective points that are targets and valid in the window when calculating the median. ValidCount = validPercentage * 4 * filterSize * filterSize.
histZPrecision | z-direction precision for statistical calculation process.
UseGpu | Whether to use GPU.
gpuGridSize | Thread grid size for GPU.
gpuBlockSize | Thread block size for GPU.

◆ PostProcessSegmentMedianFilter() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSegmentMedianFilter | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float | segmentLowThreshold,
 |  | float | segmentHighThreshold,
 |  | float | minZ,
 |  | float | maxZ,
 |  | uint | filterSize = 10,
 |  | float | filterTargetPercentage = 0::5f,
 |  | float | validPercentage = 0::2f,
 |  | float | histZPrecision = 0::0025f,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

Separates the plane-corrected image by height and performs median filtering on each section.

Parameters
dataFrame | Image data.
segmentlowThreshold | Low threshold for height segmentation. low-high = 255, others = 0; When low = high, it is set to 255.
segmentHighThreshold | High threshold for height segmentation. low-high = 255, others = 0; When low = high, it is set to 255.
minZ | Minimum z value of the range where the target value is located. Any value lower than this will be statistically placed at the first position of the histogram. The target value should be between minZ and maxZ, otherwise the statistical result will be incorrect.
maxZ | Maximum z value of the range where the target value is located. Any value higher than this will be statistically placed at the last position of the histogram. The target value should be between minZ and maxZ, otherwise the statistical result will be incorrect.
filterSize | Half kernel size of the median filter.
filterTargetPercentage | Percentage of the target value in the neighborhood value used to calculate the median. The median should be set to 0.5f.
validPercentage | Percentage of effective points that are targets and valid in the window when calculating the median. ValidCount = validPercentage * 4 * filterSize * filterSize.
histZPrecision | z-direction precision for statistical calculation process.
UseGpu | Whether to use GPU.
gpuGridSize | Thread grid size for GPU.
gpuBlockSize | Thread block size for GPU.

◆ PostProcessSPI() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPI | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | byte[] | hist2DMapHost,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | uint | offsetMode = 0,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | uint | hist2DChannelIndex1 = 0,
 |  | uint | hist2DChannelIndex2 = 2,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

锡膏检查后处理接口

Parameters
dataFrame | 简化深度数据
hist2DMapHost | 特征区域直方图
op1CloseKernelSize | 闭运算核心尺寸
op2OpenKernelSize | 开运算核心尺寸
op3CloseKernelSize | 闭运算核心尺寸
filterSize | 最终数据平滑窗口尺寸
hist2DChannelIndex1 | 特征区域直方图通道1
hist2DChannelIndex2 | 特征区域直方图通道2
minNeighborCount | 计算当前像素位置焊锡基准高度的邻域像素个数
minMendNeighborCount | 填补无效像素位置焊锡相对高度时属于求均值的焊锡邻域像素个数
neighborSize
UseGpu
gpuGridSize
gpuBlockSize

◆ PostProcessSPI() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPI | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | byte[] | hist2DMapHost,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | uint | offsetMode = 0,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | uint | hist2DChannelIndex1 = 0,
 |  | uint | hist2DChannelIndex2 = 2,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

锡膏检查后处理接口

Parameters
dataFrame | 简化深度数据
hist2DMapHost | 特征区域直方图
op1CloseKernelSize | 闭运算核心尺寸
op2OpenKernelSize | 开运算核心尺寸
op3CloseKernelSize | 闭运算核心尺寸
filterSize | 最终数据平滑窗口尺寸
hist2DChannelIndex1 | 特征区域直方图通道1
hist2DChannelIndex2 | 特征区域直方图通道2
minNeighborCount | 计算当前像素位置焊锡基准高度的邻域像素个数
minMendNeighborCount | 填补无效像素位置焊锡相对高度时属于求均值的焊锡邻域像素个数
neighborSize
UseGpu
gpuGridSize
gpuBlockSize

◆ PostProcessSPIChannel3() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPIChannel3 | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mode,
 |  | byte * | lowThresholdArray,
 |  | byte * | highThresholdArray,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | float | maxSolderHeightThreshould = 0::2f,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

Post-processing interface for solder paste inspection.

Parameters
dataFrame | Simplified depth data
mode | Color mode, odd for RGB and even for HSV; Neighborhood mode, less than or equal to 1 for board search-direction priority: when calculating relative height, the board height is first found in each direction (calculated based on multiple-side board points of the solder); greater than 1 for board search-count priority: when calculating relative height, the nearest board height is first found (calculated based solely on single-side board points of the solder)
lowThresholdArray | List of low segmentation thresholds
highThresholdArray | List of high segmentation thresholds
op1CloseKernelSize | Kernel size for operation 1 (closing) after image segmentation
op2OpenKernelSize | Kernel size for operation 2 (opening) after image segmentation
op3DilateKernelSize | Kernel size for operation 3 (dilation) after image segmentation
offsetMode | Compensation mode for corrected data, Mode 0: kx+b, Mode 1: k(x/k)^b
solderOffsetParam1 | Parameter 1 for corrected data compensation, k
solderOffsetParam2 | Parameter 2 for corrected data compensation, b
boardFilterSize | Board filtering size. Larger than 0 for mean filtering; less than 0 for local minimum lowering within filter window
solderFilterSize | Solder filtering size. Larger than 0 for mean filtering; less than 0 for local maximum raising within filter window
maxSolderHeightThreshold | Maximum solder height threshold. When the relative height of the solder exceeds this value, if the solder height is normal, the board surface can be distinguished from the abnormal height; if the solder height is abnormal, the solder height is set to the maximum solder height threshold
minNeighborCount | Minimum number of neighboring points used to calculate board height
minMendNeighborCount | Minimum number of neighboring solder points used for filling in the relative solder height of invalid points belonging to solder colors during data correction
neighborSize | Board point search radius when calculating board height
useGpu | Whether to use GPU
gpuGridSize | Grid size
gpuBlockSize | Block size

◆ PostProcessSPIChannel3() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPIChannel3 | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mode,
 |  | byte * | lowThresholdArray,
 |  | byte * | highThresholdArray,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | float | maxSolderHeightThreshould = 0::2f,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

Post-processing interface for solder paste inspection.

Parameters
dataFrame | Simplified depth data
mode | Color mode, odd for RGB and even for HSV; Neighborhood mode, less than or equal to 1 for board search-direction priority: when calculating relative height, the board height is first found in each direction (calculated based on multiple-side board points of the solder); greater than 1 for board search-count priority: when calculating relative height, the nearest board height is first found (calculated based solely on single-side board points of the solder)
lowThresholdArray | List of low segmentation thresholds
highThresholdArray | List of high segmentation thresholds
op1CloseKernelSize | Kernel size for operation 1 (closing) after image segmentation
op2OpenKernelSize | Kernel size for operation 2 (opening) after image segmentation
op3DilateKernelSize | Kernel size for operation 3 (dilation) after image segmentation
offsetMode | Compensation mode for corrected data, Mode 0: kx+b, Mode 1: k(x/k)^b
solderOffsetParam1 | Parameter 1 for corrected data compensation, k
solderOffsetParam2 | Parameter 2 for corrected data compensation, b
boardFilterSize | Board filtering size. Larger than 0 for mean filtering; less than 0 for local minimum lowering within filter window
solderFilterSize | Solder filtering size. Larger than 0 for mean filtering; less than 0 for local maximum raising within filter window
maxSolderHeightThreshold | Maximum solder height threshold. When the relative height of the solder exceeds this value, if the solder height is normal, the board surface can be distinguished from the abnormal height; if the solder height is abnormal, the solder height is set to the maximum solder height threshold
minNeighborCount | Minimum number of neighboring points used to calculate board height
minMendNeighborCount | Minimum number of neighboring solder points used for filling in the relative solder height of invalid points belonging to solder colors during data correction
neighborSize | Board point search radius when calculating board height
useGpu | Whether to use GPU
gpuGridSize | Grid size
gpuBlockSize | Block size

◆ PostProcessTransformImage() [1/2]

static unsafe bool MPSizectorS_DotNet.Process.PostProcessTransformImage | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float[] | transformMatrix,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

Geometric transformation of managed FixZMapSimple format image.

Parameters
dataFrame | Managed original image data.
transformArray | 2D transformation matrix parameters, float[6]{m11,m12,m21,m22,offsetX,offsetY}. Calculation method: dstX = m11 * srcX + m12 * srcY + offsetX; dstY = m21 * srcX + m22 * srcY + offsetY.
UseGpu | Whether to enable GPU.
gpuGridSize | GPU grid size.
gpuBlockSize | GPU block size.

◆ PostProcessTransformImage() [2/2]

static unsafe bool MPSizectorS_DotNet.Process.PostProcessTransformImage | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float[] | transformMatrix,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

Geometric transformation of non-managed FixZMapSimple format image.

Parameters
dataFrame | Non-managed original image data.
transformArray | 2D transformation matrix parameters, float[6]{m11,m12,m21,m22,offsetX,offsetY}. Calculation method: dstX = m11 * srcX + m12 * srcY + offsetX; dstY = m21 * srcX + m22 * srcY + offsetY.
UseGpu | Whether to enable GPU.
gpuGridSize | GPU grid size.
gpuBlockSize | GPU block size.

◆ RgbToHsv_Cpu()

static unsafe void MPSizectorS_DotNet.Process.RgbToHsv_Cpu | ( | byte * | rgbPtr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | hsvPtr )
 static

Converts an RGB image to an HSV image using CPU.

Parameters
rgbPtr | A byte pointer pointing to the RGB image data.
imageWidth | The width of the image.
imageHeight | The height of the image.
hsvPtr | A byte pointer pointing to the HSV image data.

◆ SavePCD()

static unsafe bool MPSizectorS_DotNet.Process.SavePCD | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName )
 static

Save unmanaged Undefined data to PCD format point cloud file.

Parameters
DataFrame | Data struct.
FileName | File name to save.
Returns
Success state of operation. Success is true, otherwise false.

◆ SavePLY()

static unsafe bool MPSizectorS_DotNet.Process.SavePLY | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName )
 static

Save unmanaged Undefined data to PLY format point cloud file.

Parameters
DataFrame | Data struct.
FileName | File name to save.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [1/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data,
 |  | string | FileName )
 static

Save unmanaged Fix3D data to a text format point cloud file.

Parameters
FrameInfo | Information about the data frame.
Data | The Fix3D data.
FileName | The name of the file to be saved.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [2/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data,
 |  | string | FileName )
 static

Save managed Fix3D data to a text format point cloud file.

Parameters
FrameInfo | Information about the data frame.
Data | The Fix3D data.
FileName | The name of the file to be saved.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [3/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data,
 |  | string | FileName )
 static

Save unmanaged FixZMap data to a text format point cloud file.

Parameters
FrameInfo | Information about the data frame.
Data | The unmanaged FixZMap data.
FileName | The name of the file to be saved.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [4/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data,
 |  | string | FileName )
 static

Save managed FixZMap data to a text format point cloud file.

Parameters
FrameInfo | Information about the data frame.
Data | The FixZMap data.
FileName | The name of the file to be saved.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [5/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data,
 |  | string | FileName )
 static

Save unmanaged Float3D data to text format point cloud file.

Parameters
FrameInfo | Data frame info.
Data | Data.
FileName | File name to save.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [6/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data,
 |  | string | FileName )
 static

Save managed Float3D data to text format point cloud file.

Parameters
FrameInfo | Data frame info.
Data | Data.
FileName | File name to save.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [7/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | string | FileName )
 static

Save unmanaged fixed point Z data to text format point cloud file.

Parameters
FrameInfo | Data frame info.
Z | Z Data.
FileName | File name to save.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud() [8/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | string | FileName )
 static

Save managed fixed point Z data to text format point cloud file.

Parameters
FrameInfo | Data frame info.
Z | Z Data.
FileName | File name to save.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTIFF()

static unsafe bool MPSizectorS_DotNet.Process.SaveTIFF | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | bool | ConvertToRangeImage,
 |  | string | FileName,
 |  | bool | EnableSaveFloatTypeData = false )
 static

Save unmanaged Undefined data to TIFF format point cloud file.

Parameters
DataFrame | Data struct.
ConvertToRangeImage | whether convert to RangeImage format before save.
FileName | File name to save.
Returns
Success state of operation. Success is true, otherwise false.

◆ Threshold3Channel_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Threshold3Channel_Cpu | ( | byte * | data1Ptr,
 |  | byte * | data2Ptr,
 |  | byte * | data3Ptr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | maskPtr,
 |  | byte * | minThresholdArray,
 |  | byte * | maxThresholdArray )
 static

Executes a three-channel threshold operation using CPU.

Parameters
data1Ptr | A byte pointer pointing to the pixel data of the first (red) channel.
data2Ptr | A byte pointer pointing to the pixel data of the second (green) channel.
data3Ptr | A byte pointer pointing to the pixel data of the third (blue) channel.
imageWidth | The width of the image.
imageHeight | The height of the image.
maskPtr | A byte pointer pointing to an optional mask.
minThresholdArray | A byte pointer pointing to an array of minimum thresholds.
maxThresholdArray | A byte pointer pointing to an array of maximum thresholds.

◆ Threshold_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Threshold_Cpu | ( | byte * | dataPtr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | tablePtr,
 |  | byte * | maskPtr )
 static

Executes a threshold operation using CPU.

Parameters
dataPtr | A byte pointer pointing to the original pixel data.
imageWidth | The width of the image.
imageHeight | The height of the image.
tablePtr | A byte pointer pointing to a pre-generated lookup table.
maskPtr | A byte pointer pointing to an optional mask.

◆ ThresholdUshort_Cpu()

static unsafe void MPSizectorS_DotNet.Process.ThresholdUshort_Cpu | ( | ushort * | dataPtr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | tablePtr,
 |  | byte * | maskPtr )
 static

Threshold an input image based on a threshold table.

Parameters
dataPtr | A pointer to the input image data.
imageWidth | The width of the image.
imageHeight | The height of the image.
tablePtr | A pointer to the threshold table.
maskPtr | A pointer to the mask data .

◆ Undistort()

static bool MPSizectorS_DotNet.Process.Undistort | ( | UnmanagedDataFrameUndefinedStruct | Frame,
 |  | CalibParamStructType | CalibParam )

Undistort data.

Parameters
Frame | Image data.
CalibParam | Calib param.
Returns
Success state of operation. Success is true, otherwise false.

◆ UpSamplingData()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.UpSamplingData ( UnmanagedDataFrameUndefinedStruct dataFrame )
static

Up-sample unmanaged undefined format data.

Parameters
DataFrame Data struct.
Returns
Data struct after up sampling.


MPSizector .NET Programmer's Manual: Member List

  • Process
MPSizectorS_DotNet.Process Member List

This is the complete list of members for MPSizectorS_DotNet.Process, including all inherited members.

AngleBetween(Point v1, Point v2) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
calculateMarkCoordinates(int imageWidth, int imageHeight, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int arrayLen, int markWidth, int markHeight, int planeRegionGridSize=240) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
Closing_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
ConvertBayerToRGB(UnmanagedDataFrameUndefinedStruct DataFrame, BayerTransferType bayerTransferType, bool btoCEnable, float gainR, float gainG, float gainB, bool btoGEnable, float gainR_forGray, float gainG_forGray, float gainB_forGray) | MPSizectorS_DotNet.Process | static
ConvertFrame2DBayerToGray(UnmanagedDataFrameUndefinedStruct DataFrame, int startIndex, int endIndex, float gainR, float gainG, float gainB) | MPSizectorS_DotNet.Process | static
ConvertToRangeImage(ManagedDataFrameFloat3DStruct src_frame, RangeImageManaged dst_image) | MPSizectorS_DotNet.Process | static
ConvertToRangeImage(ManagedDataFrameFix3DStruct src_frame, RangeImageManaged dst_image) | MPSizectorS_DotNet.Process | static
ConvertZMapFrameToFloat3DFrame(UnmanagedDataFrameUndefinedStruct data, out UnmanagedDataFrameUndefinedStruct float3DData, CalibParamStructType calibParam) | MPSizectorS_DotNet.Process | static
ConvexHull(List< Point > points) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
CrossProduct(Point p1, Point p2, Point p3) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
Dilate_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
Distance(Point p1, Point p2) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
DotProduct(Point v1, Point v2) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
DownSamplingData(ManagedDataFrameFixZMapSimpleStruct DataFrame, int samplingRate, int mode) | MPSizectorS_DotNet.Process | static
DownSamplingData(UnmanagedDataFrameUndefinedStruct DataFrame, int samplingRate, int mode) | MPSizectorS_DotNet.Process | static
Erosion_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
FindMinimumRotatedRectangle(List< Point > points) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
FitPlane(float[] xyzList) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
FreeGpu() | MPSizectorS_DotNet.Process | static
GenCircleKernel_Cpu(byte *kernelPtr, int kernelWidth, int kernelHeight, float radius) | MPSizectorS_DotNet.Process | static
GenThresholdTable_Cpu(byte *tablePtr, byte lowThreshold, byte highThreshold) | MPSizectorS_DotNet.Process | static
GenThresholdTableUshort_Cpu(byte *tablePtr, ushort lowThreshold, ushort highThreshold) | MPSizectorS_DotNet.Process | static
GetDataPtr(HeadPackStructType srcFrameInfo, byte *srcDataPtr, ref ushort *srcUshortZPtr, ref byte *srcWhiteArrayPtr, ref byte *srcRGBArrayPtr) | MPSizectorS_DotNet.Process | static
GetGridNearestMarkList(int imageWidth, int imageHeight, short[][] markCoordinateList, int gridX, int gridY, int planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=float.MaxValue) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
GetROIData(UnmanagedDataFrameUndefinedStruct dataFrame, int StartX, int StartY, int Width, int Height) | MPSizectorS_DotNet.Process | static
InitGpu(int gpuId=0, bool useGlobalBuffer=false) | MPSizectorS_DotNet.Process | static
MergeWRGBData(UnmanagedDataFrameUndefinedStruct dataFrame3D, UnmanagedDataFrameUndefinedStruct dataFrame2D, int WIndex, int RGBIndex) | MPSizectorS_DotNet.Process | static
Opening_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
PostProcessCircleRangeCheck_ByReferencePlan(UnmanagedDataFrameUndefinedStruct dataFrame, float circleCenterX, float circleCenterY, float innerCricleRadius, float outerCircleRadius, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMendByFeatures(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessMendByFeatures(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessMendByFeatures(HeadPackStructType frameInfo, byte *dataPtr, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessPlaneCorrection(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f) | MPSizectorS_DotNet.Process | static
PostProcessPlaneCorrection(ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f) | MPSizectorS_DotNet.Process | static
PostProcessRangeCheckCircle(UnmanagedDataFrameUndefinedStruct dataFrame, float CircleCenterX, float CircleCenterY, float InnerCricleRadius, float OuterCircleRadius, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax) | MPSizectorS_DotNet.Process | static
PostProcessRangeCheckRect(UnmanagedDataFrameUndefinedStruct dataFrame, float RecCenterX, float RecCenterY, float InnerRecWidth, float InnerRecHeight, float OuterRecWidth, float OuterRecHeight, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax) | MPSizectorS_DotNet.Process | static
PostProcessRangeCheckRingEndRect(UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax) | MPSizectorS_DotNet.Process | static
PostProcessRectangleRangeCheck_ByReferencePlan(UnmanagedDataFrameUndefinedStruct dataFrame, float recCenterX, float recCenterY, float innerRecWidth, float innerRecHeight, float outerRecWidth, float outerRecHeight, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax) | MPSizectorS_DotNet.Process | static
PostProcessRegionMend(ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0) | MPSizectorS_DotNet.Process | static
PostProcessRegionMend(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0) | MPSizectorS_DotNet.Process | static
PostProcessRegionMend(HeadPackStructType frameInfo, byte *dataPtr, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRingEndRectRangeCheck_ByReferencePlan(UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax) | MPSizectorS_DotNet.Process | static
PostProcessSegmentMedianFilter(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSegmentMedianFilter(ManagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPI(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPI(ManagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPIChannel3(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPIChannel3(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessTransformImage(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessTransformImage(ManagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
quickSort(float[] list, int left, int right) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
RgbToHsv_Cpu(byte *rgbPtr, int imageWidth, int imageHeight, byte *hsvPtr) | MPSizectorS_DotNet.Process | static
RotatePoint(Point point, Point center, double radianAngle) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
SavePCD(UnmanagedDataFrameUndefinedStruct DataFrame, string FileName) | MPSizectorS_DotNet.Process | static
SavePLY(UnmanagedDataFrameUndefinedStruct DataFrame, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, ushort[] Z, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, ushort *Z, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTIFF(UnmanagedDataFrameUndefinedStruct DataFrame, bool ConvertToRangeImage, string FileName, bool EnableSaveFloatTypeData=false) | MPSizectorS_DotNet.Process | static
selectionSort_Gpu(float[] list, int length, int offset) (defined in MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
Threshold3Channel_Cpu(byte *data1Ptr, byte *data2Ptr, byte *data3Ptr, int imageWidth, int imageHeight, byte *maskPtr, byte *minThresholdArray, byte *maxThresholdArray) | MPSizectorS_DotNet.Process | static
Threshold_Cpu(byte *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr) | MPSizectorS_DotNet.Process | static
ThresholdUshort_Cpu(ushort *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr) | MPSizectorS_DotNet.Process | static
Undistort(UnmanagedDataFrameUndefinedStruct Frame, CalibParamStructType CalibParam) | MPSizectorS_DotNet.Process |
UpSamplingData(UnmanagedDataFrameUndefinedStruct dataFrame) | MPSizectorS_DotNet.Process | static


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.Process.RotatedRectangle Struct Reference

  • Process
  • RotatedRectangle
Public Member Functions | Properties | List of all members
MPSizectorS_DotNet.Process.RotatedRectangle Struct Reference

Public Member Functions

RotatedRectangle (double x, double y, double width, double height, double angle)

Properties

double | X [get, set]
double | Y [get, set]
double | Width [get, set]
double | Height [get, set]
double | Angle [get, set]


MPSizector .NET Programmer's Manual: Member List

  • Process
  • RotatedRectangle
MPSizectorS_DotNet.Process.RotatedRectangle Member List

This is the complete list of members for MPSizectorS_DotNet.Process.RotatedRectangle, including all inherited members.

Angle (defined in MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
Height (defined in MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
RotatedRectangle(double x, double y, double width, double height, double angle) (defined in MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
Width (defined in MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
X (defined in MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
Y (defined in MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.RangeCheckSettingStructType Struct Reference

  • RangeCheckSettingStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.RangeCheckSettingStructType Struct Reference

Structure of user defined range check setting. Contains the valid range value of X, Y, Z. More...

Public Member Functions

override string ToString ()

Public Attributes

float | UXmax
X max value.
float | UXmin
X min value.
float | UYmax
Y max value.
float | UYmin
Y min value.
float | UZmax
Z max value.
float | UZmin
Z min value.

Properties

float | _UXmax [get]
float | _UXmin [get]
float | _UYmax [get]
float | _UYmin [get]
float | _UZmax [get]
float | _UZmin [get]

Detailed Description

Structure of user defined range check setting. Contains the valid range value of X, Y, Z.


MPSizector .NET Programmer's Manual: Member List

  • RangeCheckSettingStructType
MPSizectorS_DotNet.RangeCheckSettingStructType Member List

This is the complete list of members for MPSizectorS_DotNet.RangeCheckSettingStructType, including all inherited members.

_UXmax (defined in MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UXmin (defined in MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UYmax (defined in MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UYmin (defined in MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UZmax (defined in MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UZmin (defined in MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
ToString() (defined in MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
UXmax | MPSizectorS_DotNet.RangeCheckSettingStructType
UXmin | MPSizectorS_DotNet.RangeCheckSettingStructType
UYmax | MPSizectorS_DotNet.RangeCheckSettingStructType
UYmin | MPSizectorS_DotNet.RangeCheckSettingStructType
UZmax | MPSizectorS_DotNet.RangeCheckSettingStructType
UZmin | MPSizectorS_DotNet.RangeCheckSettingStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.RangeImageManaged Struct Reference

  • RangeImageManaged
Public Attributes | List of all members
MPSizectorS_DotNet.RangeImageManaged Struct Reference

Managed range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width].
 More...

Public Attributes

float[] | ZRawData
Height data array, in mm.
ushort[] | RangeData
Height data array stored as unsigned short type, in mm.
byte[] | Textures
Gray scale value array.
bool[] | Mask
Pointer to the mask data, indicate whether the height data is valid.
uint | Width
The pixel resolution of X direction.
uint | Height
The pixel resolution of Y direction.
float | XOffset
The offset of X direction, in mm.
float | YOffset
The offset of Y direction, in mm.
float | ZOffset
The offset of Z direction, in mm.
float | PixelInterval
The pixel interval of X and Y direction, in mm.
float | ZInterval
The pixel interval of Z direction, in mm.

Detailed Description

Managed range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width].


MPSizector .NET Programmer's Manual: Member List

  • RangeImageManaged
MPSizectorS_DotNet.RangeImageManaged Member List

This is the complete list of members for MPSizectorS_DotNet.RangeImageManaged, including all inherited members.

Height | MPSizectorS_DotNet.RangeImageManaged
Mask | MPSizectorS_DotNet.RangeImageManaged
PixelInterval | MPSizectorS_DotNet.RangeImageManaged
RangeData | MPSizectorS_DotNet.RangeImageManaged
Textures | MPSizectorS_DotNet.RangeImageManaged
Width | MPSizectorS_DotNet.RangeImageManaged
XOffset | MPSizectorS_DotNet.RangeImageManaged
YOffset | MPSizectorS_DotNet.RangeImageManaged
ZInterval | MPSizectorS_DotNet.RangeImageManaged
ZOffset | MPSizectorS_DotNet.RangeImageManaged
ZRawData | MPSizectorS_DotNet.RangeImageManaged


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.RangeImageUnmanaged Struct Reference

  • RangeImageUnmanaged
Public Attributes | List of all members
MPSizectorS_DotNet.RangeImageUnmanaged Struct Reference

Unmanaged range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width].
 More...

Public Attributes

float * | ZRawData
Height data array, in mm.
ushort * | RangeData
Height data array stored as unsigned short type, in mm.
byte * | Textures
Gray scale value array.
bool * | Mask
Pointer to the mask data, indicate whether the height data is valid.
uint | Width
The pixel resolution of X direction.
uint | Height
The pixel resolution of Y direction.
float | XOffset
The offset of X direction, in mm.
float | YOffset
The offset of Y direction, in mm.
float | ZOffset
The offset of Z direction, in mm.
float | PixelInterval
The pixel interval of X and Y direction, in mm.
float | ZInterval
The pixel interval of Z direction, in mm.

Detailed Description

Unmanaged range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width].


MPSizector .NET Programmer's Manual: Member List

  • RangeImageUnmanaged
MPSizectorS_DotNet.RangeImageUnmanaged Member List

This is the complete list of members for MPSizectorS_DotNet.RangeImageUnmanaged, including all inherited members.

Height | MPSizectorS_DotNet.RangeImageUnmanaged
Mask | MPSizectorS_DotNet.RangeImageUnmanaged
PixelInterval | MPSizectorS_DotNet.RangeImageUnmanaged
RangeData | MPSizectorS_DotNet.RangeImageUnmanaged
Textures | MPSizectorS_DotNet.RangeImageUnmanaged
Width | MPSizectorS_DotNet.RangeImageUnmanaged
XOffset | MPSizectorS_DotNet.RangeImageUnmanaged
YOffset | MPSizectorS_DotNet.RangeImageUnmanaged
ZInterval | MPSizectorS_DotNet.RangeImageUnmanaged
ZOffset | MPSizectorS_DotNet.RangeImageUnmanaged
ZRawData | MPSizectorS_DotNet.RangeImageUnmanaged


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.ReconstructionSettingsStructType Struct Reference

  • ReconstructionSettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.ReconstructionSettingsStructType Struct Reference

Structure of reconstruction setting. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | OverExposureFilterThreshold
Over exposure filter threshold. Valid value is [0, 16] and 254.
Value 0 results all over-exposured pixels are still reconstructed.
Value 16 results all over-exposured pixels are marked as invalid point.
Value 254 results a auto-decided threshold for different 3D working modes.
byte | ValidPointThreshold0
Valid point threshold 0. Valid value is [0, 100]. 0 for most loosest, 100 for tightest.
byte | ValidPointThreshold1
Valid point threshold 1. Valid value is [0, 100]. 0 for most loosest, 100 for tightest.
byte | BurrFilterThreshold0
Burr filter threshold 0. Valid value is [0, 100]. 0 for most loosest, 100 for tightest.
byte | BurrFilterThreshold1
Burr filter threshold 1. Valid value is [0, 100]. 0 for most loosest, 100 for tightest.
byte | PreProcessLoopNum
Pre-process loop number. Valid value is [0, 5]. 0 for pre-process function disabled. Higher loop number will result a smoother surface, but loosing more details.
byte | PreProcessThreshold
Pre-process threshod. Valid value is [0, 100]. Higher value results less deformation at the edge.

Properties

byte | _OverExposureFilterThreshold [get]
byte | _ValidPointThreshold0 [get]
byte | _ValidPointThreshold1 [get]
byte | _BurrFilterThreshold0 [get]
byte | _BurrFilterThreshold1 [get]
byte | _PreProcessLoopNum [get]
byte | _PreProcessThreshold [get]

Detailed Description

Structure of reconstruction setting.


MPSizector .NET Programmer's Manual: Member List

  • ReconstructionSettingsStructType
MPSizectorS_DotNet.ReconstructionSettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.ReconstructionSettingsStructType, including all inherited members.

_BurrFilterThreshold0 (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_BurrFilterThreshold1 (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_OverExposureFilterThreshold (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_PreProcessLoopNum (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_PreProcessThreshold (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_ValidPointThreshold0 (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_ValidPointThreshold1 (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
BurrFilterThreshold0 | MPSizectorS_DotNet.ReconstructionSettingsStructType
BurrFilterThreshold1 | MPSizectorS_DotNet.ReconstructionSettingsStructType
OverExposureFilterThreshold | MPSizectorS_DotNet.ReconstructionSettingsStructType
PreProcessLoopNum | MPSizectorS_DotNet.ReconstructionSettingsStructType
PreProcessThreshold | MPSizectorS_DotNet.ReconstructionSettingsStructType
ToString() (defined in MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
ValidPointThreshold0 | MPSizectorS_DotNet.ReconstructionSettingsStructType
ValidPointThreshold1 | MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.RTMatrixStructType Struct Reference

  • RTMatrixStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.RTMatrixStructType Struct Reference

Structure of RT matrix. More...

Public Member Functions

override string ToString ()

Public Attributes

float | R00
Rotation 00.
float | R01
Rotation 01.
float | R02
Rotation 02.
float | R10
Rotation 10.
float | R11
Rotation 11.
float | R12
Rotation 12.
float | R20
Rotation 20.
float | R21
Rotation 21.
float | R22
Rotation 22.
float | T0
Transfer 0.
float | T1
Transfer 1.
float | T2
Transfer 2.

Properties

float | _R00 [get]
float | _R01 [get]
float | _R02 [get]
float | _R10 [get]
float | _R11 [get]
float | _R12 [get]
float | _R20 [get]
float | _R21 [get]
float | _R22 [get]
float | _T0 [get]
float | _T1 [get]
float | _T2 [get]

Detailed Description

Structure of RT matrix.


MPSizector .NET Programmer's Manual: Member List

  • RTMatrixStructType
MPSizectorS_DotNet.RTMatrixStructType Member List

This is the complete list of members for MPSizectorS_DotNet.RTMatrixStructType, including all inherited members.

_R00 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R01 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R02 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R10 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R11 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R12 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R20 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R21 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R22 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_T0 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_T1 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_T2 (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
R00 | MPSizectorS_DotNet.RTMatrixStructType
R01 | MPSizectorS_DotNet.RTMatrixStructType
R02 | MPSizectorS_DotNet.RTMatrixStructType
R10 | MPSizectorS_DotNet.RTMatrixStructType
R11 | MPSizectorS_DotNet.RTMatrixStructType
R12 | MPSizectorS_DotNet.RTMatrixStructType
R20 | MPSizectorS_DotNet.RTMatrixStructType
R21 | MPSizectorS_DotNet.RTMatrixStructType
R22 | MPSizectorS_DotNet.RTMatrixStructType
T0 | MPSizectorS_DotNet.RTMatrixStructType
T1 | MPSizectorS_DotNet.RTMatrixStructType
T2 | MPSizectorS_DotNet.RTMatrixStructType
ToString() (defined in MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SettingsStructType Struct Reference

  • SettingsStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.SettingsStructType Struct Reference

Structure of all the settings. More...

Public Member Functions

override string | ToString ()
void | SetAuxiliaryWhite (bool enable)
Set whether enabled external white exposure light.
void | SetAuxiliaryRGB (bool enable)
Set whether enabled external RGB exposure light.

Public Attributes

BasicSettingsStructType | BasicSetings
Basic settings.
ExposureSettingsStructType | ExposureSettings
Exposure settings.
ExternalExposureSettingsStructType | ExternalExposureSettings
Exposure settings for external light.
ReconstructionSettingsStructType | ReconstructionSettings
Reconstruction settings.
MultiHeadSettingsStructType | MultiHeadSettings
Reconstruction settings for multiple projecting.
PostProcessSettingsStructType | PostProcessSettings
Post-process settings.
IOSettingsStructType | IOSettings
IO settings.
GeneralSettingsStructType | GeneralSettings
General settings.
byte | CorrectDistortionEnable
Correct distortion enable state.
ExpertSettingsStructType | ExpertSettings
Expert settings.
MPSizectorS_AutoHDRAdvanceSettingsStructType | AutoHDRAdvanceSettings
Auto hdr advance settings.
SoftwarePreprocessListRegisters | SoftwarePreprocessList
Software preprocess list.
HardwarePreprocessModeListStructType | HardwarePreprocessModeList
Software preprocess list.
SoftwarePreprocessPresetParamListStructType | SoftwarePreprocessPresetParamList
Software preprocess preset param list.
CompensationStructType | CompensationParams
Temperature compensation params.

Properties

BasicSettingsStructType | _BasicSettings [get]
ExposureSettingsStructType | _ExposureSettings [get]
ExternalExposureSettingsStructType | _ExternalExposureSettings [get]
ReconstructionSettingsStructType | _ReconstructionSettings [get]
MultiHeadSettingsStructType | _MultiHeadSettings [get]
PostProcessSettingsStructType | _PostProcessSettings [get]
IOSettingsStructType | _IOSettings [get]
GeneralSettingsStructType | _GeneralSettings [get]
byte | _CorrectDistortionEnable [get]
ExpertSettingsStructType | _ExpertSettings [get]
bool | HasAuxiliaryWhiteImage [get]
Whether enabled external white exposure light.
bool | HasAuxiliaryRGBImage [get]
Whether enabled external RGB exposure light.

Detailed Description

Structure of all the settings.


MPSizector .NET Programmer's Manual: Member List

  • SettingsStructType
MPSizectorS_DotNet.SettingsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SettingsStructType, including all inherited members.

_BasicSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_CorrectDistortionEnable (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ExpertSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ExposureSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ExternalExposureSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_GeneralSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_IOSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_MultiHeadSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_PostProcessSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ReconstructionSettings (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
AutoHDRAdvanceSettings | MPSizectorS_DotNet.SettingsStructType
BasicSetings | MPSizectorS_DotNet.SettingsStructType
CompensationParams | MPSizectorS_DotNet.SettingsStructType
CorrectDistortionEnable | MPSizectorS_DotNet.SettingsStructType
ExpertSettings | MPSizectorS_DotNet.SettingsStructType
ExposureSettings | MPSizectorS_DotNet.SettingsStructType
ExternalExposureSettings | MPSizectorS_DotNet.SettingsStructType
GeneralSettings | MPSizectorS_DotNet.SettingsStructType
HardwarePreprocessModeList | MPSizectorS_DotNet.SettingsStructType
HasAuxiliaryRGBImage | MPSizectorS_DotNet.SettingsStructType
HasAuxiliaryWhiteImage | MPSizectorS_DotNet.SettingsStructType
IOSettings | MPSizectorS_DotNet.SettingsStructType
MultiHeadSettings | MPSizectorS_DotNet.SettingsStructType
PostProcessSettings | MPSizectorS_DotNet.SettingsStructType
ReconstructionSettings | MPSizectorS_DotNet.SettingsStructType
SetAuxiliaryRGB(bool enable) | MPSizectorS_DotNet.SettingsStructType
SetAuxiliaryWhite(bool enable) | MPSizectorS_DotNet.SettingsStructType
SoftwarePreprocessList | MPSizectorS_DotNet.SettingsStructType
SoftwarePreprocessPresetParamList | MPSizectorS_DotNet.SettingsStructType
ToString() (defined in MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePostProcessSetting Struct Reference

  • SoftwarePostProcessSetting
Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePostProcessSetting Struct Reference

Structure of software post process. More...

Public Attributes

SoftwarePostProcessType | Type
float[] | Param

Detailed Description

Structure of software post process.


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePostProcessSetting
MPSizectorS_DotNet.SoftwarePostProcessSetting Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePostProcessSetting, including all inherited members.

Param (defined in MPSizectorS_DotNet.SoftwarePostProcessSetting) | MPSizectorS_DotNet.SoftwarePostProcessSetting
Type (defined in MPSizectorS_DotNet.SoftwarePostProcessSetting) | MPSizectorS_DotNet.SoftwarePostProcessSetting


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessListRegisters Struct Reference

  • SoftwarePreprocessListRegisters
Classes | Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessListRegisters Struct Reference

Structure of software preprocess list. More...

Classes

struct PreprocessStructType

Public Attributes

byte | Number
byte | Enable
byte[] | Reserved
PreprocessStructType[] | Preprocess
uint[] | Parameters

Detailed Description

Structure of software preprocess list.


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessListRegisters
MPSizectorS_DotNet.SoftwarePreprocessListRegisters Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessListRegisters, including all inherited members.

Enable (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Number (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Parameters (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Preprocess (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Reserved (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType Struct Reference

  • SoftwarePreprocessListRegisters
  • PreprocessStructType
Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType Struct Reference

Public Attributes

byte | Size
byte | Address
byte | VersionAndMode
byte | Type


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessListRegisters
  • PreprocessStructType
MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType, including all inherited members.

Address (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
Size (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
Type (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
VersionAndMode (defined in MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType Struct Reference

  • SoftwarePreprocessPresetParamListStructType
Classes | Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType Struct Reference

Structure of software preprocess preset param list. More...

Classes

struct | PreprocessPresetFiltrateStructType
struct | PreprocessPresetMedianFilterStructType
struct | PreprocessPresetMendStructType
struct | PreprocessPresetRemoveBurrsStructType
struct | PreprocessPresetStructType

Public Attributes

ushort[] | Version
float | MinZ
float | MaxZ
float | ZPrecision
PreprocessPresetStructType[] | PresetParam

Detailed Description

Structure of software preprocess preset param list.


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessPresetParamListStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType, including all inherited members.

MaxZ (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
MinZ (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
PresetParam (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
Version (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
ZPrecision (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetRemoveBurrsStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType, including all inherited members.

ParamEdgeSuppressLevel (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamNeighborCloseLevel (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamNeighborNumLevel (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamSlopeLevel (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamWinSize (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamWinSize2 (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
Reserved (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType Struct Reference

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetFiltrateStructType
Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType Struct Reference

Public Attributes

byte | ParamWinSize
byte | ParamNeighborCloseLevel
byte | ParamNeighborNumLevel
byte | filtrateMendPointOnly


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType Struct Reference

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMedianFilterStructType
Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType Struct Reference

Public Attributes

byte | FilterWinSize
byte[] | Reserved


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType Struct Reference

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMendStructType
Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType Struct Reference

Public Attributes

byte | ParamWinSize
byte | ParamWinSize2
byte | Method
byte | Reserved


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType Struct Reference

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetRemoveBurrsStructType
Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType Struct Reference

Public Attributes

byte | ParamWinSize
byte | ParamWinSize2
byte | ParamSlopeLevel
byte | ParamNeighborCloseLevel
byte | ParamNeighborNumLevel
byte | ParamEdgeSuppressLevel
byte[] | Reserved


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType Struct Reference

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetStructType
Public Attributes | List of all members
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType Struct Reference

Public Attributes

PreprocessPresetRemoveBurrsStructType | RemoveBurrsPreset
PreprocessPresetMendStructType | MendPreset
PreprocessPresetFiltrateStructType | FiltratePreset
PreprocessPresetMedianFilterStructType | MedianFilterPreset


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType, including all inherited members.

FiltratePreset (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
MedianFilterPreset (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
MendPreset (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
RemoveBurrsPreset (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.StatesStructType Struct Reference

  • StatesStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.StatesStructType Struct Reference

Structure of full device state information. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | EXTIOInput
Input pin register value. Bitwise represented.
TemperatureFeedbackStructType | TempCore
Core temperature sensor feedback.
TemperatureFeedbackStructType | Temp0
Temprature sensor 0 feedback.
TemperatureFeedbackStructType | Temp1
Temprature sensor 1 feedback.
TemperatureFeedbackStructType | Temp2
Temprature sensor 2 feedback.
uint | StartUpTimeMS
Device start-up time in ms.
uint | ConnectionTimeMS
Device connected time in ms.
uint | SnapCnt
Device snap counter (include 2D and 3D).
ushort | TotalTransferRetryNum
Total transfer retry counter.
ushort | CurrentTransferRetryNum
Current frame transfer retry counter.
ushort | TotalCaptureRetryNum
Total capture retry number.
TSNStructType | CurrentTSN
Current executing frame TSN. Under idle state, it is last frame TSN.
TSNStructType | SoftwareTSN
Latest TSN triggered by software trigger.
TSNStructType | AutoTSN
Latest TSN triggered by keep running trigger.
TSNStructType | HardwareTSN
Lastest TSN triggered by hardware trigger.
DebugInfoStruct | DebugRegisters
Vender debug purpose registers.

Properties

byte | _EXTIOInput [get]
TemperatureFeedbackStructType | _TempCore [get]
TemperatureFeedbackStructType | _Temp0 [get]
TemperatureFeedbackStructType | _Temp1 [get]
TemperatureFeedbackStructType | _Temp2 [get]
uint | _StartUpTimeMS [get]
uint | _ConnectionTimeMS [get]
uint | _SnapCnt [get]
ushort | _TotalTransferRetryNum [get]
ushort | _CurrentTransferRetryNum [get]
ushort | _TotalCaptureRetryNum [get]
TSNStructType | _CurrentTSN [get]
TSNStructType | _SoftwareTSN [get]
TSNStructType | _AutoTSN [get]
TSNStructType | _HardwareTSN [get]
DebugInfoStruct | _DebugRegisters [get]

Detailed Description

Structure of full device state information.


MPSizector .NET Programmer's Manual: Member List

  • StatesStructType
MPSizectorS_DotNet.StatesStructType Member List

This is the complete list of members for MPSizectorS_DotNet.StatesStructType, including all inherited members.

_AutoTSN (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_ConnectionTimeMS (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_CurrentTransferRetryNum (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_CurrentTSN (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_DebugRegisters (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_EXTIOInput (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_HardwareTSN (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_SnapCnt (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_SoftwareTSN (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_StartUpTimeMS (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_Temp0 (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_Temp1 (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_Temp2 (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_TempCore (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_TotalCaptureRetryNum (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_TotalTransferRetryNum (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
AutoTSN | MPSizectorS_DotNet.StatesStructType
ConnectionTimeMS | MPSizectorS_DotNet.StatesStructType
CurrentTransferRetryNum | MPSizectorS_DotNet.StatesStructType
CurrentTSN | MPSizectorS_DotNet.StatesStructType
DebugRegisters | MPSizectorS_DotNet.StatesStructType
EXTIOInput | MPSizectorS_DotNet.StatesStructType
HardwareTSN | MPSizectorS_DotNet.StatesStructType
SnapCnt | MPSizectorS_DotNet.StatesStructType
SoftwareTSN | MPSizectorS_DotNet.StatesStructType
StartUpTimeMS | MPSizectorS_DotNet.StatesStructType
Temp0 | MPSizectorS_DotNet.StatesStructType
Temp1 | MPSizectorS_DotNet.StatesStructType
Temp2 | MPSizectorS_DotNet.StatesStructType
TempCore | MPSizectorS_DotNet.StatesStructType
ToString() (defined in MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
TotalCaptureRetryNum | MPSizectorS_DotNet.StatesStructType
TotalTransferRetryNum | MPSizectorS_DotNet.StatesStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.SuppressExpParamsEnableStructType Struct Reference

  • SuppressExpParamsEnableStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.SuppressExpParamsEnableStructType Struct Reference

Suppress Exposure Params. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | SuppressExpParam1Enable
Suppress Exposure Param1.
byte | SuppressExpParam2Enable
Suppress Exposure Param2.
byte | SuppressExpParam3Enable
Suppress Exposure Param2.

Properties

byte | _SuppressExpParam1Enable [get]
byte | _SuppressExpParam2Enable [get]
byte | _SuppressExpParam3Enable [get]

Detailed Description

Suppress Exposure Params.


MPSizector .NET Programmer's Manual: Member List

  • SuppressExpParamsEnableStructType
MPSizectorS_DotNet.SuppressExpParamsEnableStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SuppressExpParamsEnableStructType, including all inherited members.

_SuppressExpParam1Enable (defined in MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
_SuppressExpParam2Enable (defined in MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
_SuppressExpParam3Enable (defined in MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
SuppressExpParam1Enable | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
SuppressExpParam2Enable | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
SuppressExpParam3Enable | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
ToString() (defined in MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.TemperatureFeedbackStructType Struct Reference

  • TemperatureFeedbackStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.TemperatureFeedbackStructType Struct Reference

Structure of temperature feed back information. More...

Public Member Functions

override string ToString ()

Public Attributes

byte | SensorValid
State of the sensor. If the sensor does not exist or can not access, value is false.
sbyte | TempValueC
Temperature reading in Celsius.
TemperatureFeedBackStateType | State
State judgement. Indicates the temperature is in range or not.

Properties

byte | _SensorValid [get]
sbyte | _TempValueC [get]
TemperatureFeedBackStateType | _State [get]

Detailed Description

Structure of temperature feed back information.


MPSizector .NET Programmer's Manual: Member List

  • TemperatureFeedbackStructType
MPSizectorS_DotNet.TemperatureFeedbackStructType Member List

This is the complete list of members for MPSizectorS_DotNet.TemperatureFeedbackStructType, including all inherited members.

_SensorValid (defined in MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType
_State (defined in MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType
_TempValueC (defined in MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType
SensorValid | MPSizectorS_DotNet.TemperatureFeedbackStructType
State | MPSizectorS_DotNet.TemperatureFeedbackStructType
TempValueC | MPSizectorS_DotNet.TemperatureFeedbackStructType
ToString() (defined in MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.TSNStructType Struct Reference

  • TSNStructType
Public Member Functions | Public Attributes | Properties | List of all members
MPSizectorS_DotNet.TSNStructType Struct Reference

TSN structure. Indicates the ID of a valid trigger signal: source of trigger, SN of trigger. More...

Public Member Functions

override string ToString ()

Public Attributes

TSNSourceType | Source
Source of trigger.
uint | SN
Serial number of trigger.

Properties

TSNSourceType | _Source [get]
uint | _SN [get]

Detailed Description

TSN structure. Indicates the ID of a valid trigger signal: source of trigger, SN of trigger.


MPSizector .NET Programmer's Manual: Member List

  • TSNStructType
MPSizectorS_DotNet.TSNStructType Member List

This is the complete list of members for MPSizectorS_DotNet.TSNStructType, including all inherited members.

_SN (defined in MPSizectorS_DotNet.TSNStructType) | MPSizectorS_DotNet.TSNStructType
_Source (defined in MPSizectorS_DotNet.TSNStructType) | MPSizectorS_DotNet.TSNStructType
SN | MPSizectorS_DotNet.TSNStructType
Source | MPSizectorS_DotNet.TSNStructType
ToString() (defined in MPSizectorS_DotNet.TSNStructType) | MPSizectorS_DotNet.TSNStructType


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.UnmanagedDataFrame2DStruct Struct Reference

  • UnmanagedDataFrame2DStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.UnmanagedDataFrame2DStruct Struct Reference

Structure of unmanaged 2D data frame. More...

Public Member Functions

Bitmap | GetGrayBitmap (byte PicIndex=0)
Get bitmap of gray.
Bitmap | GetExposurePredictionBitmap ()
Get bitmap of exposure prediction image.
bool | SaveDataFrame (string FileName)
Save data frame to file.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
byte * | Data
Unmanaged 2D image data.

Detailed Description

Structure of unmanaged 2D data frame.

Member Function Documentation

◆ GetExposurePredictionBitmap()

Bitmap MPSizectorS_DotNet.UnmanagedDataFrame2DStruct.GetExposurePredictionBitmap ( )

Get bitmap of exposure prediction image.

Returns
Bitmap of exposure prediction image.

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.UnmanagedDataFrame2DStruct.GetGrayBitmap ( byte PicIndex = 0 )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrame2DStruct.SaveDataFrame ( string FileName )

Save data frame to file.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.


MPSizector .NET Programmer's Manual: Member List

  • UnmanagedDataFrame2DStruct
MPSizectorS_DotNet.UnmanagedDataFrame2DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, including all inherited members.

Data | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
GetExposurePredictionBitmap() | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
GetGrayBitmap(byte PicIndex=0) | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
SaveDataFrame(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct Struct Reference

  • UnmanagedDataFrameFix3DStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct Struct Reference

Structure of unmanaged 3D data frame in fix point format. More...

Public Member Functions

unsafe Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
unsafe Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
unsafe Bitmap | GetHDRMaskBitmap ()
Get bitmap of HDR mask.
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.
unsafe bool | FreeHGlobalMemory ()
When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.
unsafe void | CopyToManagedFix3D (ManagedDataFrameFix3DStruct ManagedDataFrame)
Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
DataPointFix3DStruct * | Data
Point cloud data in unmanaged fix point format.
byte * | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte * | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of unmanaged 3D data frame in fix point format.

Member Function Documentation

◆ CopyToManagedFix3D()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.CopyToManagedFix3D ( ManagedDataFrameFix3DStruct ManagedDataFrame )

Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Parameters
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.FreeHGlobalMemory ( )

When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.

Returns
Return true if success.

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetHDRMaskBitmap ( )

Get bitmap of HDR mask.

Returns
Bitmap of HDR mask.

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.


MPSizector .NET Programmer's Manual: Member List

  • UnmanagedDataFrameFix3DStruct
MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
CopyToManagedFix3D(ManagedDataFrameFix3DStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
Data | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct Struct Reference

  • UnmanagedDataFrameFixZMapSimpleStruct
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct Struct Reference

Structure of unmanaged 3D data frame in simplified fixed point z map format. More...

Public Member Functions

unsafe Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
unsafe Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.
unsafe bool | FreeHGlobalMemory ()
When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.
unsafe void | CopyToManagedFixZMapSimple (ManagedDataFrameFixZMapSimpleStruct ManagedDataFrame)
Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Static Public Member Functions

static bool | IsValid (ushort point)
Judge whether a fixed point Z data point is valid.
static byte | GetMaskValue (ushort point)
Get mask of a fixed point Z data point.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
byte * | Data
Start pointer to all data.
ushort * | Z
Rescaled Z value.0 and 65535 mean invalid data.
byte * | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte * | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of unmanaged 3D data frame in simplified fixed point z map format.

Member Function Documentation

◆ CopyToManagedFixZMapSimple()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.CopyToManagedFixZMapSimple ( ManagedDataFrameFixZMapSimpleStruct ManagedDataFrame )

Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Parameters
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.FreeHGlobalMemory ( )

When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.

Returns
Return true if success.

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetMaskValue()

static byte MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetMaskValue ( ushort point )
static

Get mask of a fixed point Z data point.

Parameters
point Fixed point Z data。
Returns
Mask.

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ IsValid()

static bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.IsValid ( ushort point )
static

Judge whether a fixed point Z data point is valid.

Parameters
point Fixed point Z data。
Returns
Return true if valid.

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.


MPSizector .NET Programmer's Manual: Member List

  • UnmanagedDataFrameFixZMapSimpleStruct
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct Member List

This is the complete list of members for MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
CopyToManagedFixZMapSimple(ManagedDataFrameFixZMapSimpleStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
Data | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetMaskValue(ushort point) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct | static
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
IsValid(ushort point) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct | static
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
Z | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct Struct Reference

  • UnmanagedDataFrameFixZMapStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct Struct Reference

Structure of unmanaged 3D data frame in fixed point z map format. More...

Public Member Functions

unsafe Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
unsafe Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
unsafe Bitmap | GetHDRMaskBitmap ()
Get bitmap of HDR mask.
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.
unsafe bool | FreeHGlobalMemory ()
When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.
unsafe void | CopyToManagedFixZMap (ManagedDataFrameFixZMapStruct ManagedDataFrame)
Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
DataPointFixZMapStruct * | Data
Z map data in fixed point format.
byte * | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte * | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of unmanaged 3D data frame in fixed point z map format.

Member Function Documentation

◆ CopyToManagedFixZMap()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.CopyToManagedFixZMap ( ManagedDataFrameFixZMapStruct ManagedDataFrame )

Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Parameters
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.FreeHGlobalMemory ( )

When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.

Returns
Return true if success.

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetHDRMaskBitmap ( )

Get bitmap of HDR mask.

Returns
Bitmap of HDR mask.

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.


MPSizector .NET Programmer's Manual: Member List

  • UnmanagedDataFrameFixZMapStruct
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct Member List

This is the complete list of members for MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
CopyToManagedFixZMap(ManagedDataFrameFixZMapStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
Data | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct Struct Reference

  • UnmanagedDataFrameFloat3DStruct
Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct Struct Reference

Structure of unmanaged 3D data frame in float point format. More...

Public Member Functions

unsafe Bitmap | GetGrayBitmap ()
Get bitmap of gray.
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
Get bitmap of external exposure image.
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
Get bitmap of color depth image.
unsafe Bitmap | GetValidMaskBitmap ()
Get bitmap of valid mask.
unsafe Bitmap | GetHDRMaskBitmap ()
Get bitmap of HDR mask.
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
unsafe bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.
unsafe bool | FreeHGlobalMemory ()
When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.
unsafe void | CopyToManagedFloat3D (ManagedDataFrameFloat3DStruct ManagedDataFrame)
Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
DataPointFloat3DStruct * | Data
Point cloud data in unmanaged float point format.
byte * | AuxiliaryWhite
Auxiliary 2D image captured when external white light turned on. If not enable external white exposure, then it is null.
byte * | AuxiliaryRGB
Three auxiliary 2D images captured when external RGB light turned on. If not enable external RGB exposure, then it is null.

Detailed Description

Structure of unmanaged 3D data frame in float point format.

Member Function Documentation

◆ CopyToManagedFloat3D()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.CopyToManagedFloat3D ( ManagedDataFrameFloat3DStruct ManagedDataFrame )

Copy the data in the current UnmanagedDataFrame to the ManagedDataFrame.

Parameters
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.FreeHGlobalMemory ( )

When the data is converted from Managed to Unmanaged in the .NET environment, the data needs to be released.

Returns
Return true if success.

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

Get bitmap of external exposure image.

Parameters
type Image type。
Returns
Bitmap.

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

Get bitmap of color depth image.

Parameters
Max | Min value of color depth range.
Min | Max value of color depth range.
Returns
Bitmap of color depth image.

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetGrayBitmap ( )

Get bitmap of gray.

Returns
Bitmap of gray.

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetHDRMaskBitmap ( )

Get bitmap of HDR mask.

Returns
Bitmap of HDR mask.

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetValidMaskBitmap ( )

Get bitmap of valid mask.

Returns
Bitmap of valid mask.

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.


MPSizector .NET Programmer's Manual: Member List

  • UnmanagedDataFrameFloat3DStruct
MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct Member List

This is the complete list of members for MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, including all inherited members.

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
CopyToManagedFloat3D(ManagedDataFrameFloat3DStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
Data | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct Struct Reference

  • UnmanagedDataFrameUndefinedStruct
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct Struct Reference

Structure of unmanaged undefined format data. This is the only data type delievered from callback. It is an intermediate data format to avoid using different callback functions to deliever different format of data. More...

Public Member Functions

unsafe UnmanagedDataFrameUndefinedStruct | GetCopy ()
Get an individual copy of current data frame. The buffer of driver is used in a loop sequence. If the data delievered by callback is not used immediately, the data could be covered by later data. In applications that require to buffer multiple frames, please use this function to get the individual copy. User need to destroy the data.
unsafe bool | DestroyCopy ()
Destroy the data when this frame of data is a copy created in .NET.
UnmanagedDataFrameFloat3DStruct ToUnmanagedFloat3D ()
Conver type to UnmanagedFloat3D. This function only change the type but do not modify data. The raw data must be Float3D.
UnmanagedDataFrameFix3DStruct ToUnmanagedFix3D ()
Conver type to UnmanagedFloat3D. This function only change the type but do not modify data. The raw data must be Fix3D.
UnmanagedDataFrameFixZMapStruct ToUnmanagedFixZMap ()
Conver type to UnmanagedDataFrameFixZMap. This function only change the type but do not modify data. The raw data must be FixZMap.
UnmanagedDataFrameFixZMapSimpleStruct ToUnmanagedFixZMapSimple ()
Conver type to UnmanagedDataFrameFixZMapSimple. This function only change the type but do not modify data. The raw data must be FixZMapSimple.
UnmanagedDataFrame2DStruct ToUnmanaged2D ()
Conver type to Unmanaged2D. This function only change the type but do not modify data. The raw data must be 2D.
unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
Convert type to ManagedFloat3D. The raw data can be Fix3D or Float3D. Function will convert between float and fix if it is required.
unsafe ManagedDataFrameFix3DStruct | ToManagedFix3D ()
Convert type to ManagedFix3D. The raw data can be Fix3D or Float3D. Function will convert between float and fix if it is required.
unsafe ManagedDataFrameFixZMapStruct | ToManagedFixZMap ()
Convert type to ManagedFixZMap. The raw data can be any. Function will convert if it is required.
unsafe ManagedDataFrameFixZMapSimpleStruct | ToManagedFixZMapSimple ()
Convert type to ManagedFixZMapSimple. The raw data can be any. Function will convert if it is required.
unsafe ManagedDataFrame2DStruct | ToManaged2D ()
Conver type to Managed2D.The raw data must be 2D.
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save data frame to file.
bool | SaveTextPointCloud (string FileName)
Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Static Public Member Functions

static bool LoadDataFrame (out UnmanagedDataFrameUndefinedStruct Data, string FileName, out float ColorDepthMin, out float ColorDepthMax)
Load data frame from file.

Public Attributes

HeadPackStructType | FrameInfo
Frame information.
byte * | Data
Data.

Detailed Description

Structure of unmanaged undefined format data. This is the only data type delievered from callback. It is an intermediate data format to avoid using different callback functions to deliever different format of data.

Member Function Documentation

◆ DestroyCopy()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.DestroyCopy ( )

Destroy the data when this frame of data is a copy created in .NET.

Returns
Return true if success.

◆ LoadDataFrame()

static bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.LoadDataFrame | ( | out UnmanagedDataFrameUndefinedStruct | Data,
 |  | string | FileName,
 |  | out float | ColorDepthMin,
 |  | out float | ColorDepthMax )
 static

Load data frame from file.

Parameters
Data | The loaded data frame.
FileName | File name including path. If path is not included, file will be searched under current folder.
ColorDepthMin | The min value of color depth range read out from file. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | The min value of color depth range read out from file. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

Save data frame to file.

Parameters
FileName | File name including path. If path is not included, file will be saved under current folder.
ColorDepthMin | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
ColorDepthMax | Option parameter. The min value of color depth range. When opening a saved 3D data, the color depth range setting when saving will be applied. Only valid for 3D data frame. Default value is 0.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveTextPointCloud()

bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.SaveTextPointCloud ( string FileName )

Save 3D data frame to text format point cloud. This format is usually applied when trying to import data to thrid-party point cloud analysis software.

Parameters
FileName File name including path. If path is not included, file will be saved under current folder.
Returns
Success state of operation. Success is true, otherwise false.

◆ ToManaged2D()

unsafe ManagedDataFrame2DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManaged2D ( )

Conver type to Managed2D.The raw data must be 2D.

Returns
Data frame after conversion.

◆ ToManagedFix3D()

unsafe ManagedDataFrameFix3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFix3D ( )

Convert type to ManagedFix3D. The raw data can be Fix3D or Float3D. Function will convert between float and fix if it is required.

Returns
Data frame after conversion.

◆ ToManagedFixZMap()

unsafe ManagedDataFrameFixZMapStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFixZMap ( )

Convert type to ManagedFixZMap. The raw data can be any. Function will convert if it is required.

Returns
Data frame after conversion.

◆ ToManagedFixZMapSimple()

unsafe ManagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFixZMapSimple ( )

Convert type to ManagedFixZMapSimple. The raw data can be any. Function will convert if it is required.

Returns
Data frame after conversion.

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFloat3D ( )

Convert type to ManagedFloat3D. The raw data can be Fix3D or Float3D. Function will convert between float and fix if it is required.

Returns
Data frame after conversion.

◆ ToUnmanaged2D()

UnmanagedDataFrame2DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanaged2D ( )

Conver type to Unmanaged2D. This function only change the type but do not modify data. The raw data must be 2D.

Returns
Data frame after conversion.

◆ ToUnmanagedFix3D()

UnmanagedDataFrameFix3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFix3D ( )

Conver type to UnmanagedFloat3D. This function only change the type but do not modify data. The raw data must be Fix3D.

Returns
Data frame after conversion.

◆ ToUnmanagedFixZMap()

UnmanagedDataFrameFixZMapStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFixZMap ( )

Conver type to UnmanagedDataFrameFixZMap. This function only change the type but do not modify data. The raw data must be FixZMap.

Returns
Data frame after conversion.

◆ ToUnmanagedFixZMapSimple()

UnmanagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFixZMapSimple ( )

Conver type to UnmanagedDataFrameFixZMapSimple. This function only change the type but do not modify data. The raw data must be FixZMapSimple.

Returns
Data frame after conversion.

◆ ToUnmanagedFloat3D()

UnmanagedDataFrameFloat3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFloat3D ( )

Conver type to UnmanagedFloat3D. This function only change the type but do not modify data. The raw data must be Float3D.

Returns
Data frame after conversion.


MPSizector .NET Programmer's Manual: Member List

  • UnmanagedDataFrameUndefinedStruct
MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct Member List

This is the complete list of members for MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct, including all inherited members.

Data | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
DestroyCopy() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
GetCopy() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
LoadDataFrame(out UnmanagedDataFrameUndefinedStruct Data, string FileName, out float ColorDepthMin, out float ColorDepthMax) | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct | static
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManaged2D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFix3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFixZMap() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFixZMapSimple() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFloat3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanaged2D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFix3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFixZMap() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFixZMapSimple() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFloat3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |


MPSizector .NET Programmer's Manual: MPSizectorS_DotNet.Utils Class Reference

  • Utils
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
MPSizectorS_DotNet.Utils Class Reference

Public Member Functions

static void | CopyMemory (IntPtr dest, IntPtr src, uint count)
Unmanaged memory copy. Wrapper of CopyMemory in kernel32.dll.
static unsafe void | FreeUnmanagedData (UnmanagedDataFrameUndefinedStruct DataFrame)
Free unmanaged data.
static unsafe void | TransformROISettingToROIPixel (DeviceInfoStructType DevInfo, byte VSensorX0Ratio, byte VSensorY0Ratio, byte VSensorWRatio, byte VSensorHRatio, out uint OSensorX0, out uint OSensorY0, out uint OSensorXResol, out uint OSensorYResol, bool IsBinningMode=false)
Transform setting of number range from 0 to 255 to pixel ROI setting.
static unsafe void | TransformROIPixelToROISetting (DeviceInfoStructType DevInfo, uint IXStartPixel, uint IYStartPixel, uint IWidthPixel, uint IHeightPixel, out byte OROIX0Ratio, out byte OROIY0Ratio, out byte OROIWidthRatio, out byte OROIHeightRatio, out uint OXStartPixel, out uint OYStartPixel, out uint OWidthPixel, out uint OHeightPixel, bool IsBinningMode=false)
Transform ROI setting of pixel to ROI setting of number range from 0 to 255 that are accepted by hardware.
static unsafe uint | Get3DDataLen (HeadPackDataInfoStructType DataInfo)
Get 3D data length.
static unsafe uint | GetDataLen (HeadPackStructType FrameInfo)
Get 3D data length.
static unsafe bool | CalculateCorrectDistortionParamFromData (UnmanagedDataFrameUndefinedStruct Data, out CorrectDistortionParamStructType CorrectDistortionMatrix, int Interval=16)
Get postprocess setting from mppp file.
static unsafe void | CompensateData (UnmanagedDataFrameUndefinedStruct data, UnmanagedDataFrameUndefinedStruct compensationData)
data 与 compensationData 点对点相减， 用于校正data中的畸变，仅支持UnmanagedDataFrameUndefinedStruct。

Static Public Member Functions

static bool | SaveUnmanagedDataFrameUndefined (UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
Save Undefined data to file.
static unsafe bool | LoadUnmanagedDataFrameUndefined (out UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, out float ColorDepthMin, out float ColorDepthMax)
Load Undefined data from file.
static unsafe bool | SaveDataFrame_ManagedFixZMapSimpleDataFrame (FileStream fs, ManagedDataFrameFixZMapSimpleStruct DataFrame, out int Size, float ColorDepthMin=0, float ColorDepthMax=0)
Save dataframe by filestream。
static unsafe bool | SaveDataFrame_FileStream (FileStream fs, HeadPackStructType FrameInfo, Byte *Data, out int Size, float ColorDepthMin=0, float ColorDepthMax=0)
Save dataframe by filestream。
static unsafe Bitmap | ConvertGrayByteArrayToGrayBitmap (byte[] Gray, uint Width, uint Height, byte Index=0)
Convert 1d array of gray points to grayscale bitmap.
static unsafe Bitmap | ConvertGrayByteArrayToGrayBitmap (byte *Gray, uint Width, uint Height, byte Index=0)
Convert unmanaged gray data to gray bitmap.
static unsafe Bitmap | ConvertRGBByteArrayToRGBBitmap (byte[] Red, byte[] Green, byte[] Blue, uint Width, uint Height)
Convert 1d arrays of three channels (RGB) to color bitmap.
static unsafe Bitmap | ConvertRGBByteArrayToRGBBitmap (byte *Red, byte *Green, byte *Blue, uint Width, uint Height)
Convert 1d arrays of three channels (RGB) to color bitmap.
static unsafe Bitmap | GetAuxiliaryBitmap (byte *data, Auxiliary2DType type, int width, int height)
Get gray or color bitmap from unmanaged gray data.
static unsafe Bitmap | GetAuxiliaryBitmap (byte[] data, Auxiliary2DType type, int width, int height)
Get gray or color bitmap from managed gray data.
static float | GetExposureValueFromExposurePredictionData (byte Data)
Convert gray value of exposure prediction image to exposure intensity value.
static unsafe Bitmap | GetExposurePredictionBitmap (HeadPackStructType FrameInfo, byte *Data)
Get exposure prediction bitmap from unmanaged data frame. The data frame must be capture result of exposure prediction.
static unsafe Bitmap | GetExposurePredictionBitmap (HeadPackStructType FrameInfo, byte[] Data)
Get exposure prediction bitmap from managed data frame. The data frame must be capture result of exposure prediction.
static Bitmap | Convert32bppTo8bpp (Bitmap source, int dataIndex=0)
Convert bitmap format from 32 bit to 8 bit.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data)
Get gray bitmap from unmanaged float 3D point cloud data.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data)
Get gray bitmap from managed float 3D point cloud data.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data)
Get gray bitmap from unmanaged fix 3D point cloud data.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data)
Get gray bitmap from managed fix 3D point cloud data.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data)
Get gray bitmap from unmanaged fix point z map image data.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data)
Get gray bitmap from managed fix point z map image data.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, byte *Data)
Get gray bitmap from unmanaged gray data.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, byte[] Data)
Get gray bitmap from managed gray data.
static Color | GetDepthColor (float Ratio)

Get color from color spectrum
static void | PrepareColorArr ()
Generate fine color spectrum array according to the defined color stops. This function will be called automatically when first generating the color depth range. If the color stops are changed, this function need to be called manually.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, float Max, float Min)
Get color depth image from unmanaged float 3D data frame.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, float Max, float Min)
Get color depth image from managed float 3D data frame.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, float Max, float Min)
Get color depth image from managed fix 3D data frame.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, float Max, float Min)
Get color depth image from managed fix 3D data frame.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, float Max, float Min)
Get color depth image from unmanaged fixed point z map data frame.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, float Max, float Min)
Get color depth image from managed fixed point z map data frame.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, ushort *Z, byte *Gray, float Max, float Min)
Get color depth image from unmanaged fixed point z data frame and gray data frame.
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray, float Max, float Min)
Get color depth image from managed fixed point z data frame and gray data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data)
Get valid mask bitmap from unmanaged float 3D data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data)
Get valid mask bitmap from managed float 3D data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data)
Get valid mask bitmap from unmanaged fix 3D data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data)
Get valid mask bitmap from managed fix 3D data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data)
Get valid mask bitmap from unmanaged fixed z map data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data)
Get valid mask bitmap from managed fixed z map data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, ushort *Z, byte *Gray)
Get valid mask bitmap from unmanaged fixed point z data frame and gray data frame.
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray)
Get valid mask bitmap from managed fixed point z data frame and gray data frame.
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data)
Get HDR mask bitmap from unmanaged float 3D data frame.
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data)
Get HDR mask bitmap from managed float 3D data frame.
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data)
Get HDR mask bitmap from unmanaged fix 3D data frame.
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data)
Get HDR mask bitmap from managed fix 3D data frame.
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data)
Get HDR mask bitmap from unmanaged fixed point z map data frame.
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data)
Get HDR mask bitmap from managed fixed point z map data frame.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of unmanaged Float3D.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of managed Float3D.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of unmanaged Fix3D.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of managed Fix3D.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of unmanaged FixZMap.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of managed FixZMap.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, ushort *Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of unmanaged FixZMapSimple.
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, ushort[] Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
Get the auto color depth range of managed FixZMapSimple.
static List< SoftwarePostProcessSetting > | LoadPostProcessFile (string FileName)
Get postprocess setting from mppp file.
static string | FilterLog (string logStr, bool filterDetailLog=true, bool filterOperationLog=false, bool filterSystemLog=false, bool filterInfoLog=false, bool filterNoticeLog=false, bool filterSuccessLog=false, bool filterFailureLog=false)
Filter log return from Sizector S.
static unsafe void | OffsetGrayData (UnmanagedDataFrameUndefinedStruct dataFrame, int xOffset, int yOffset, byte paddingValue=0)
static double | GetStandardDeviation (double[] Data)

Static Public Attributes

static Color[] | DepthColorStops
Defines the color spectrum of the image converted from the 3D data dimensions,.
static Color | TooHighColor = Color.FromArgb(230, 230, 230)
Defines the color displayed when dimension exceeds Max.
static Color | TooLowColor = Color.FromArgb(20, 20, 20)
Defines the color displayed when dimension is lower than Min.
static Color[] | ColorArr = new Color[10001]
Fine color spectrum array including 10001 different colors.

Member Function Documentation

◆ CalculateCorrectDistortionParamFromData()

static unsafe bool MPSizectorS_DotNet.Utils.CalculateCorrectDistortionParamFromData | ( | UnmanagedDataFrameUndefinedStruct | Data,
 |  | out CorrectDistortionParamStructType | CorrectDistortionMatrix,
 |  | int | Interval = 16 )

Get postprocess setting from mppp file.

Parameters
Data | Image Data.
CorrectDistortionMatrix | Correct distortion matrix.
Interval | Pixel interval。
Returns
Success state of operation. Success is true, otherwise false.

◆ CompensateData()

static unsafe void MPSizectorS_DotNet.Utils.CompensateData | ( | UnmanagedDataFrameUndefinedStruct | data,
 |  | UnmanagedDataFrameUndefinedStruct | compensationData )

data 与 compensationData 点对点相减， 用于校正data中的畸变，仅支持UnmanagedDataFrameUndefinedStruct。

Parameters
data | 原数据
compensationData | 补偿数据

Point-to-point subtraction of data and compensationData is used to correct distortion in data, only supports UnmanagedDataFrameUndefinedStruct.

Parameters
data | The data.
compensationData | The compensation data.

◆ Convert32bppTo8bpp()

static Bitmap MPSizectorS_DotNet.Utils.Convert32bppTo8bpp | ( | Bitmap | source,
 |  | int | dataIndex = 0 )
 static

Convert bitmap format from 32 bit to 8 bit.

Parameters
source | The source.
dataIndex | Which channel does the 8-bit data come from.
Returns

◆ ConvertGrayByteArrayToGrayBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertGrayByteArrayToGrayBitmap | ( | byte * | Gray,
 |  | uint | Width,
 |  | uint | Height,
 |  | byte | Index = 0 )
 static

Convert unmanaged gray data to gray bitmap.

Parameters
Gray | Unmanaged gray data.
Width | Width of gray image.
Height | Height of gray image.
Index | Index of the gray image in the data frame. Default value is 0.
Returns
Bitmap result after conversion.

◆ ConvertGrayByteArrayToGrayBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertGrayByteArrayToGrayBitmap | ( | byte[] | Gray,
 |  | uint | Width,
 |  | uint | Height,
 |  | byte | Index = 0 )
 static

Convert 1d array of gray points to grayscale bitmap.

Parameters
Gray | [输入]:灰度数组。 [INPUT]:Gray intensity array.
Width | [输入]:图像宽度。 [INPUT]:Image Width.
Height | [输入]:图像高度。 [INPUT]:Image Height.
Returns
转换后的Bitmap图像。 The target bitmap.

◆ ConvertRGBByteArrayToRGBBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertRGBByteArrayToRGBBitmap | ( | byte * | Red,
 |  | byte * | Green,
 |  | byte * | Blue,
 |  | uint | Width,
 |  | uint | Height )
 static

Convert 1d arrays of three channels (RGB) to color bitmap.

Parameters
Red | [输入]:红色数组。 [INPUT]:Red channel array.
Green | [输入]:绿色数组。 [INPUT]:Green channel array.
Blue | [输入]:蓝色数组。 [INPUT]:Blue channel array.
Width | [输入]:图像宽度。 [INPUT]:Image Width.
Height | [输入]:图像高度。 [INPUT]:Image Height.
Returns
转换后的Bitmap图像。 The result bitmap.

◆ ConvertRGBByteArrayToRGBBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertRGBByteArrayToRGBBitmap | ( | byte[] | Red,
 |  | byte[] | Green,
 |  | byte[] | Blue,
 |  | uint | Width,
 |  | uint | Height )
 static

Convert 1d arrays of three channels (RGB) to color bitmap.

Parameters
Red | [输入]:红色数组。 [INPUT]:Red channel array.
Green | [输入]:绿色数组。 [INPUT]:Green channel array.
Blue | [输入]:蓝色数组。 [INPUT]:Blue channel array.
Width | [输入]:图像宽度。 [INPUT]:Image Width.
Height | [输入]:图像高度。 [INPUT]:Image Height.
Returns
转换后的Bitmap图像。 The result bitmap.

◆ CopyMemory()

static void MPSizectorS_DotNet.Utils.CopyMemory | ( | IntPtr | dest,
 |  | IntPtr | src,
 |  | uint | count )

Unmanaged memory copy. Wrapper of CopyMemory in kernel32.dll.

Parameters
dest | Pointer of destination.
src | Pointer of source.
count | Byte length of copy.

◆ FilterLog()

static string MPSizectorS_DotNet.Utils.FilterLog | ( | string | logStr,
 |  | bool | filterDetailLog = true,
 |  | bool | filterOperationLog = false,
 |  | bool | filterSystemLog = false,
 |  | bool | filterInfoLog = false,
 |  | bool | filterNoticeLog = false,
 |  | bool | filterSuccessLog = false,
 |  | bool | filterFailureLog = false )
 static

Filter log return from Sizector S.

Parameters
logStr | Log string.
filterDetailLog | Whethter filter Detail log.
filterOperationLog | Whethter filter Operation log
filterSystemLog | Whethter filter System log
filterInfoLog | Whethter filter Info log
filterNoticeLog | Whethter filter Notice log
filterSuccessLog | Whethter filter Success log
filterFailureLog | Whethter filter Failure log
Returns
Return null if log is filtered, otherwise return resolved log.

◆ FreeUnmanagedData()

static unsafe void MPSizectorS_DotNet.Utils.FreeUnmanagedData ( UnmanagedDataFrameUndefinedStruct DataFrame )

Free unmanaged data.

Parameters
DataFrame Unmanaged data.

◆ Get3DDataLen()

static unsafe uint MPSizectorS_DotNet.Utils.Get3DDataLen ( HeadPackDataInfoStructType DataInfo )

Get 3D data length.

Parameters
DataInfo Data info.
Returns
3D data length

◆ GetAutoColorDepthRange() [1/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of unmanaged Fix3D.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAutoColorDepthRange() [2/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of managed Fix3D.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAutoColorDepthRange() [3/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of unmanaged FixZMap.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAutoColorDepthRange() [4/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of managed FixZMap.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAutoColorDepthRange() [5/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of unmanaged Float3D.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAutoColorDepthRange() [6/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of managed Float3D.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAutoColorDepthRange() [7/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of unmanaged FixZMapSimple.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAutoColorDepthRange() [8/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

Get the auto color depth range of managed FixZMapSimple.

Parameters
FrameInfo | Data frame info.
Data | 3D point cloud data.
Stride | Adjacent sampling point pixel stride.
DropRatio | The ratio of dropped top and bottom data points when doing statistics.
ReservedRatio | The margin reserved at the boundary of color depth range.
Returns
Auto color depth range result obtained after calculation.

◆ GetAuxiliaryBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetAuxiliaryBitmap | ( | byte * | data,
 |  | Auxiliary2DType | type,
 |  | int | width,
 |  | int | height )
 static

Get gray or color bitmap from unmanaged gray data.

Parameters
data | Data。
type | Image type。
width | Image width。
width | Image height。
Returns
Bitmap result after conversion.

◆ GetAuxiliaryBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetAuxiliaryBitmap | ( | byte[] | data,
 |  | Auxiliary2DType | type,
 |  | int | width,
 |  | int | height )
 static

Get gray or color bitmap from managed gray data.

Parameters
data | Data。
type | Image type。
width | Image width。
width | Image height。
Returns
Bitmap result after conversion.

◆ GetColorDepthBitmap() [1/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from managed fix 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetColorDepthBitmap() [2/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from managed fix 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetColorDepthBitmap() [3/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from unmanaged fixed point z map data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetColorDepthBitmap() [4/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from managed fixed point z map data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetColorDepthBitmap() [5/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from unmanaged float 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetColorDepthBitmap() [6/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from managed float 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetColorDepthBitmap() [7/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | byte * | Gray,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from unmanaged fixed point z data frame and gray data frame.

Parameters
FrameInfo | Info of data frame.
Z | Z data.
Gray | Gray data。
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetColorDepthBitmap() [8/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | byte[] | Gray,
 |  | float | Max,
 |  | float | Min )
 static

Get color depth image from managed fixed point z data frame and gray data frame.

Parameters
FrameInfo | Info of data frame.
Z | Z data.
Gray | Gray data。
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
Color depth bitmap result after conversion.

◆ GetDataLen()

static unsafe uint MPSizectorS_DotNet.Utils.GetDataLen ( HeadPackStructType FrameInfo )

Get 3D data length.

Parameters
FrameInfo Frame info.
Returns
Data length

◆ GetDepthColor()

static Color MPSizectorS_DotNet.Utils.GetDepthColor ( float Ratio )
static

Get color from color spectrum

Parameters
Ratio [输入]:色谱的偏置值。[0,1]为色谱中的有效值。 [INPUT]:Offset value in the color spectrum.Ratio lies in [0,1].
Returns
获得的颜色。 Acquired color.

◆ GetExposurePredictionBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetExposurePredictionBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte * | Data )
 static

Get exposure prediction bitmap from unmanaged data frame. The data frame must be capture result of exposure prediction.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetExposurePredictionBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetExposurePredictionBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte[] | Data )
 static

Get exposure prediction bitmap from managed data frame. The data frame must be capture result of exposure prediction.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetExposureValueFromExposurePredictionData()

static float MPSizectorS_DotNet.Utils.GetExposureValueFromExposurePredictionData ( byte Data )
static

Convert gray value of exposure prediction image to exposure intensity value.

Parameters
Data The gray value of one pixel in exposure prediction image.
Returns
Exposure intensity value after conversion.

◆ GetGrayBitmap() [1/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte * | Data )
 static

Get gray bitmap from unmanaged gray data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetGrayBitmap() [2/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte[] | Data )
 static

Get gray bitmap from managed gray data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetGrayBitmap() [3/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data )
 static

Get gray bitmap from unmanaged fix 3D point cloud data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetGrayBitmap() [4/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data )
 static

Get gray bitmap from managed fix 3D point cloud data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetGrayBitmap() [5/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data )
 static

Get gray bitmap from unmanaged fix point z map image data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetGrayBitmap() [6/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data )
 static

Get gray bitmap from managed fix point z map image data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetGrayBitmap() [7/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data )
 static

Get gray bitmap from unmanaged float 3D point cloud data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetGrayBitmap() [8/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data )
 static

Get gray bitmap from managed float 3D point cloud data.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Bitmap result after conversion.

◆ GetHDRMaskBitmap() [1/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data )
 static

Get HDR mask bitmap from unmanaged fix 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
HDR mask bitmap result after conversion.

◆ GetHDRMaskBitmap() [2/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data )
 static

Get HDR mask bitmap from managed fix 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
HDR mask bitmap result after conversion.

◆ GetHDRMaskBitmap() [3/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data )
 static

Get HDR mask bitmap from unmanaged fixed point z map data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
HDR mask bitmap result after conversion.

◆ GetHDRMaskBitmap() [4/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data )
 static

Get HDR mask bitmap from managed fixed point z map data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
HDR mask bitmap result after conversion.

◆ GetHDRMaskBitmap() [5/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data )
 static

Get HDR mask bitmap from unmanaged float 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
HDR mask bitmap result after conversion.

◆ GetHDRMaskBitmap() [6/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data )
 static

Get HDR mask bitmap from managed float 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Max | Max value of the color depth range.
Min | Min value of the color depth range.
Returns
HDR mask bitmap result after conversion.

◆ GetValidMaskBitmap() [1/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data )
 static

Get valid mask bitmap from unmanaged fix 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Valid mask bitmap result after conversion.

◆ GetValidMaskBitmap() [2/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data )
 static

Get valid mask bitmap from managed fix 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Valid mask bitmap result after conversion.

◆ GetValidMaskBitmap() [3/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data )
 static

Get valid mask bitmap from unmanaged fixed z map data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Valid mask bitmap result after conversion.

◆ GetValidMaskBitmap() [4/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data )
 static

Get valid mask bitmap from managed fixed z map data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Valid mask bitmap result after conversion.

◆ GetValidMaskBitmap() [5/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data )
 static

Get valid mask bitmap from unmanaged float 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Valid mask bitmap result after conversion.

◆ GetValidMaskBitmap() [6/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data )
 static

Get valid mask bitmap from managed float 3D data frame.

Parameters
FrameInfo | Info of data frame.
Data | Data.
Returns
Valid mask bitmap result after conversion.

◆ GetValidMaskBitmap() [7/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | byte * | Gray )
 static

Get valid mask bitmap from unmanaged fixed point z data frame and gray data frame.

Parameters
FrameInfo | Info of data frame.
Z | Z data.
Gray | Gray data。
Returns
Valid mask bitmap result after conversion.

◆ GetValidMaskBitmap() [8/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | byte[] | Gray )
 static

Get valid mask bitmap from managed fixed point z data frame and gray data frame.

Parameters
FrameInfo | Info of data frame.
Z | Z data.
Gray | Gray data。
Returns
Valid mask bitmap result after conversion.

◆ LoadPostProcessFile()

static List< SoftwarePostProcessSetting > MPSizectorS_DotNet.Utils.LoadPostProcessFile ( string FileName )
static

Get postprocess setting from mppp file.

Parameters
FileName File Name.
Returns
Postprocess setting.

◆ LoadUnmanagedDataFrameUndefined()

static unsafe bool MPSizectorS_DotNet.Utils.LoadUnmanagedDataFrameUndefined | ( | out UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName,
 |  | out float | ColorDepthMin,
 |  | out float | ColorDepthMax )
 static

Load Undefined data from file.

Parameters
DataFrame | Return by reference, data frame loaded.
FileName | File name to load.
ColorDepthMin | Min of color depth range.
ColorDepthMax | Max of color depth range.
Returns
Success state of operation. Success is true, otherwise false.

◆ SaveDataFrame_FileStream()

static unsafe bool MPSizectorS_DotNet.Utils.SaveDataFrame_FileStream | ( | FileStream | fs,
 |  | HeadPackStructType | FrameInfo,
 |  | Byte * | Data,
 |  | out int | Size,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )
 static

Save dataframe by filestream。

Parameters
fs | File stream.
FrameInfo | Frame Info。
Data | Data.
Size | Data size.
ColorDepthMin | Min ColorDepth.
ColorDepthMax | Max ColorDepth.
Returns
If save success.

◆ SaveDataFrame_ManagedFixZMapSimpleDataFrame()

static unsafe bool MPSizectorS_DotNet.Utils.SaveDataFrame_ManagedFixZMapSimpleDataFrame | ( | FileStream | fs,
 |  | ManagedDataFrameFixZMapSimpleStruct | DataFrame,
 |  | out int | Size,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )
 static

Save dataframe by filestream。

Parameters
fs | File stream.
DataFrame | Data.
Size | Data size.
ColorDepthMin | Min ColorDepth.
ColorDepthMax | Max ColorDepth.
Returns
If save success.

◆ SaveUnmanagedDataFrameUndefined()

static bool MPSizectorS_DotNet.Utils.SaveUnmanagedDataFrameUndefined | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )
 static

Save Undefined data to file.

Parameters
DataFrame | Data frame to be saved.
FileName | File name to save.
ColorDepthMin | Min of color depth range.
ColorDepthMax | Max of color depth range.
Returns
Success state of operation. Success is true, otherwise false.

◆ TransformROIPixelToROISetting()

static unsafe void MPSizectorS_DotNet.Utils.TransformROIPixelToROISetting | ( | DeviceInfoStructType | DevInfo,
 |  | uint | IXStartPixel,
 |  | uint | IYStartPixel,
 |  | uint | IWidthPixel,
 |  | uint | IHeightPixel,
 |  | out byte | OROIX0Ratio,
 |  | out byte | OROIY0Ratio,
 |  | out byte | OROIWidthRatio,
 |  | out byte | OROIHeightRatio,
 |  | out uint | OXStartPixel,
 |  | out uint | OYStartPixel,
 |  | out uint | OWidthPixel,
 |  | out uint | OHeightPixel,
 |  | bool | IsBinningMode = false )

Transform ROI setting of pixel to ROI setting of number range from 0 to 255 that are accepted by hardware.

Parameters
devInfo | Device info
iXStartPixel | Expected ROI X start of pixel
iYStartPixel | Expected ROI Y start of pixel
iWidthPixel | Expected ROI width of pixel
iHeightPixel | Expected ROI height of pixel
oROIX0Ratio | Accepted ROI X start of number range from 0 to 255
oROIY0Ratio | Accepted ROI Y start of number range from 0 to 255
oROIWidthRatio | Accepted ROI width of number range from 0 to 255
oROIHeightRatio | Accepted ROI height of number range from 0 to 255
oXStartPixel | Accepted ROI X start of pixel
oYStartPixel | Accepted ROI Y start of pixel
oWidthPixel | Accepted ROI width of pixel
oHeightPixel | Accepted ROI height of pixel
isBinningMode | If binning mode

◆ TransformROISettingToROIPixel()

static unsafe void MPSizectorS_DotNet.Utils.TransformROISettingToROIPixel | ( | DeviceInfoStructType | DevInfo,
 |  | byte | VSensorX0Ratio,
 |  | byte | VSensorY0Ratio,
 |  | byte | VSensorWRatio,
 |  | byte | VSensorHRatio,
 |  | out uint | OSensorX0,
 |  | out uint | OSensorY0,
 |  | out uint | OSensorXResol,
 |  | out uint | OSensorYResol,
 |  | bool | IsBinningMode = false )

Transform setting of number range from 0 to 255 to pixel ROI setting.

Parameters
devInfo | Device info
vSensorX0Ratio | ROI X start of number range from 0 to 255
vSensorY0Ratio | ROI Y start of number range from 0 to 255
vSensorWRatio | ROI width of number range from 0 to 255
vSensorHRatio | ROI height of number range from 0 to 255
vSensorX0 | ROI X start of pixel
vSensorY0 | ROI Y start of pixel
vSensorXResol | ROI width of pixel
vSensorYResol | ROI height of pixel
isBinningMode | If binning mode

Member Data Documentation

◆ DepthColorStops

Color [] MPSizectorS_DotNet.Utils.DepthColorStops
static
Initial value:
= new Color[]
{
Color.FromArgb(0xFF, 0xA0, 0x00, 0xA0),
Color.FromArgb(0xFF, 0x00, 0x00, 0xFF),
Color.FromArgb(0xFF, 0x00, 0x90, 0x90),
Color.FromArgb(0xFF, 0x00, 0xC0, 0x00),
Color.FromArgb(0xFF, 0xB0, 0xB0, 0x00),
Color.FromArgb(0xFF, 0xFF, 0x00, 0x00),
}

Defines the color spectrum of the image converted from the 3D data dimensions,.


MPSizector .NET Programmer's Manual: Member List

  • Utils
MPSizectorS_DotNet.Utils Member List

This is the complete list of members for MPSizectorS_DotNet.Utils, including all inherited members.

CalculateCorrectDistortionParamFromData(UnmanagedDataFrameUndefinedStruct Data, out CorrectDistortionParamStructType CorrectDistortionMatrix, int Interval=16) | MPSizectorS_DotNet.Utils |
ColorArr | MPSizectorS_DotNet.Utils | static
CompensateData(UnmanagedDataFrameUndefinedStruct data, UnmanagedDataFrameUndefinedStruct compensationData) | MPSizectorS_DotNet.Utils |
Convert32bppTo8bpp(Bitmap source, int dataIndex=0) | MPSizectorS_DotNet.Utils | static
ConvertGrayByteArrayToGrayBitmap(byte[] Gray, uint Width, uint Height, byte Index=0) | MPSizectorS_DotNet.Utils | static
ConvertGrayByteArrayToGrayBitmap(byte *Gray, uint Width, uint Height, byte Index=0) | MPSizectorS_DotNet.Utils | static
ConvertRGBByteArrayToRGBBitmap(byte[] Red, byte[] Green, byte[] Blue, uint Width, uint Height) | MPSizectorS_DotNet.Utils | static
ConvertRGBByteArrayToRGBBitmap(byte *Red, byte *Green, byte *Blue, uint Width, uint Height) | MPSizectorS_DotNet.Utils | static
CopyMemory(IntPtr dest, IntPtr src, uint count) | MPSizectorS_DotNet.Utils |
DepthColorStops | MPSizectorS_DotNet.Utils | static
FilterLog(string logStr, bool filterDetailLog=true, bool filterOperationLog=false, bool filterSystemLog=false, bool filterInfoLog=false, bool filterNoticeLog=false, bool filterSuccessLog=false, bool filterFailureLog=false) | MPSizectorS_DotNet.Utils | static
FreeUnmanagedData(UnmanagedDataFrameUndefinedStruct DataFrame) | MPSizectorS_DotNet.Utils |
Get3DDataLen(HeadPackDataInfoStructType DataInfo) | MPSizectorS_DotNet.Utils |
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, ushort *Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, ushort[] Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAuxiliaryBitmap(byte *data, Auxiliary2DType type, int width, int height) | MPSizectorS_DotNet.Utils | static
GetAuxiliaryBitmap(byte[] data, Auxiliary2DType type, int width, int height) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, ushort *Z, byte *Gray, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetDataLen(HeadPackStructType FrameInfo) | MPSizectorS_DotNet.Utils |
GetDepthColor(float Ratio) | MPSizectorS_DotNet.Utils | static
GetExposurePredictionBitmap(HeadPackStructType FrameInfo, byte *Data) | MPSizectorS_DotNet.Utils | static
GetExposurePredictionBitmap(HeadPackStructType FrameInfo, byte[] Data) | MPSizectorS_DotNet.Utils | static
GetExposureValueFromExposurePredictionData(byte Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, byte *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, byte[] Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetStandardDeviation(double[] Data) (defined in MPSizectorS_DotNet.Utils) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, ushort *Z, byte *Gray) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray) | MPSizectorS_DotNet.Utils | static
LoadPostProcessFile(string FileName) | MPSizectorS_DotNet.Utils | static
LoadUnmanagedDataFrameUndefined(out UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, out float ColorDepthMin, out float ColorDepthMax) | MPSizectorS_DotNet.Utils | static
OffsetGrayData(UnmanagedDataFrameUndefinedStruct dataFrame, int xOffset, int yOffset, byte paddingValue=0) (defined in MPSizectorS_DotNet.Utils) | MPSizectorS_DotNet.Utils | static
PrepareColorArr() | MPSizectorS_DotNet.Utils | static
SaveDataFrame_FileStream(FileStream fs, HeadPackStructType FrameInfo, Byte *Data, out int Size, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.Utils | static
SaveDataFrame_ManagedFixZMapSimpleDataFrame(FileStream fs, ManagedDataFrameFixZMapSimpleStruct DataFrame, out int Size, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.Utils | static
SaveUnmanagedDataFrameUndefined(UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.Utils | static
TooHighColor | MPSizectorS_DotNet.Utils | static
TooLowColor | MPSizectorS_DotNet.Utils | static
TransformROIPixelToROISetting(DeviceInfoStructType DevInfo, uint IXStartPixel, uint IYStartPixel, uint IWidthPixel, uint IHeightPixel, out byte OROIX0Ratio, out byte OROIY0Ratio, out byte OROIWidthRatio, out byte OROIHeightRatio, out uint OXStartPixel, out uint OYStartPixel, out uint OWidthPixel, out uint OHeightPixel, bool IsBinningMode=false) | MPSizectorS_DotNet.Utils |
TransformROISettingToROIPixel(DeviceInfoStructType DevInfo, byte VSensorX0Ratio, byte VSensorY0Ratio, byte VSensorWRatio, byte VSensorHRatio, out uint OSensorX0, out uint OSensorY0, out uint OSensorXResol, out uint OSensorYResol, bool IsBinningMode=false) | MPSizectorS_DotNet.Utils |


MPSizector .NET Programmer's Manual: Class Index

Class Index
A | B | C | D | E | F | G | H | I | L | M | O | P | R | S | T | U | V
A
AutoHDRResultStructType (MPSizectorS_DotNet)
B
BasicSettingsStructType (MPSizectorS_DotNet)
C
CalibParamStructType (MPSizectorS_DotNet)
ColorDepthRangeStruct (MPSizectorS_DotNet)
CompensationStructType (MPSizectorS_DotNet)
CorrectDistortionParamStructType (MPSizectorS_DotNet)
D
DataPointFix3DStruct (MPSizectorS_DotNet)
DataPointFixZMapStruct (MPSizectorS_DotNet)
DataPointFloat3DStruct (MPSizectorS_DotNet)
DebugInfoStruct (MPSizectorS_DotNet)
DeviceInfoStructType (MPSizectorS_DotNet)
E
ExpertSettingsStructType (MPSizectorS_DotNet)
ExposureBasicSettingStructType (MPSizectorS_DotNet)
ExposureSettingsStructType (MPSizectorS_DotNet)
ExpROIStructType (MPSizectorS_DotNet)
Extension (MPSizectorS_DotNet)
ExternalExposureSettingsStructType (MPSizectorS_DotNet)
F
FlipEnableStructType (MPSizectorS_DotNet)
G
GeneralSettingsStructType (MPSizectorS_DotNet)
H
HardwarePreprocessModeListStructType (MPSizectorS_DotNet)
HardwareTimeStampsStructType (MPSizectorS_DotNet)
HeadDebugInfoStructType (MPSizectorS_DotNet)
HeadPackDataInfoStructType (MPSizectorS_DotNet)
HeadPackStructType (MPSizectorS_DotNet)
HWTriggerSettingStructType (MPSizectorS_DotNet)
I
IOSettingsStructType (MPSizectorS_DotNet)
L
LinearTemperatureDriftCompensationStructType (MPSizectorS_DotNet)
M
ManagedDataFrame2DStruct (MPSizectorS_DotNet)
ManagedDataFrameFix3DStruct (MPSizectorS_DotNet)
ManagedDataFrameFixZMapSimpleStruct (MPSizectorS_DotNet)
ManagedDataFrameFixZMapStruct (MPSizectorS_DotNet)
ManagedDataFrameFloat3DStruct (MPSizectorS_DotNet)
MonitorPositionStructType (MPSizectorS_DotNet)
MonitorZStructType (MPSizectorS_DotNet)
MPDisplayer2D (MPSizectorS_DotNet)
MPDisplayer3D (MPSizectorS_DotNet)
MPSizectorS (MPSizectorS_DotNet)
MPSizectorS_AutoHDRAdvanceSettingsStructType (MPSizectorS_DotNet)
MPSizectorS_ExpICoefSettingsStructType (MPSizectorS_DotNet)
MultiHeadSettingsStructType (MPSizectorS_DotNet)
O
OutputPinSettingStructType (MPSizectorS_DotNet)
P
PartialFactorySettingsStructType (MPSizectorS_DotNet)
PointScaleSettingStructType (MPSizectorS_DotNet)
PostProcessSettingsStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType (MPSizectorS_DotNet)
SoftwarePreprocessListRegisters.PreprocessStructType (MPSizectorS_DotNet)
Process (MPSizectorS_DotNet)
R
RangeCheckSettingStructType (MPSizectorS_DotNet)
RangeImageManaged (MPSizectorS_DotNet)
RangeImageUnmanaged (MPSizectorS_DotNet)
ReconstructionSettingsStructType (MPSizectorS_DotNet)
Process.RotatedRectangle (MPSizectorS_DotNet)
RTMatrixStructType (MPSizectorS_DotNet)
S
SettingsStructType (MPSizectorS_DotNet)
SoftwarePostProcessSetting (MPSizectorS_DotNet)
SoftwarePreprocessListRegisters (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType (MPSizectorS_DotNet)
StatesStructType (MPSizectorS_DotNet)
SuppressExpParamsEnableStructType (MPSizectorS_DotNet)
T
TemperatureFeedbackStructType (MPSizectorS_DotNet)
TSNStructType (MPSizectorS_DotNet)
U
UnmanagedDataFrame2DStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFix3DStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFixZMapSimpleStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFixZMapStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFloat3DStruct (MPSizectorS_DotNet)
UnmanagedDataFrameUndefinedStruct (MPSizectorS_DotNet)
Utils (MPSizectorS_DotNet)
V
MPDisplayer3D.ViewMatrixStruct (MPSizectorS_DotNet)


MPSizector .NET Programmer's Manual: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12]
C MPSizectorS_DotNet.AutoHDRResultStructType | Structure of Auto HDR calculation result. This structure is generated by device and sent to user through head pack
C MPSizectorS_DotNet.BasicSettingsStructType | Structure of basic setting
C MPSizectorS_DotNet.CalibParamStructType | Structure of calib param
C MPSizectorS_DotNet.ColorDepthRangeStruct | Structure of color depth range setting
C MPSizectorS_DotNet.CompensationStructType | Structure of compensation
C MPSizectorS_DotNet.CorrectDistortionParamStructType
C MPSizectorS_DotNet.DataPointFix3DStruct | Structure of 3D data point in fixed point format. The data scale information is saved in the FrameInfo of data frame
C MPSizectorS_DotNet.DataPointFixZMapStruct | Structure of 3D data point in fixed point z map format. The data scale information is saved in the FrameInfo of data frame
C MPSizectorS_DotNet.DataPointFloat3DStruct | Structure of 3D data point in float format
C MPSizectorS_DotNet.DebugInfoStruct | Debug register array information structure, reserved for vendor debug purpose
C MPSizectorS_DotNet.DeviceInfoStructType | Device info structure
C MPSizectorS_DotNet.ExpertSettingsStructType | Structure of expert settings
C MPSizectorS_DotNet.ExposureBasicSettingStructType | Structure of exposure basic setting
C MPSizectorS_DotNet.ExposureSettingsStructType | Structure of exposure setting
C MPSizectorS_DotNet.ExpROIStructType | Structure of exposure roi region
C MPSizectorS_DotNet.Extension
C MPSizectorS_DotNet.ExternalExposureSettingsStructType | Structure of exposure setting for external light
C MPSizectorS_DotNet.FlipEnableStructType | Flip Params
C MPSizectorS_DotNet.GeneralSettingsStructType | Structure of general setting
C MPSizectorS_DotNet.HardwarePreprocessModeListStructType | Structure of hardware preprocess mode list
C MPSizectorS_DotNet.HardwareTimeStampsStructType | Structure of hardware timestamp
C MPSizectorS_DotNet.HeadDebugInfoStructType | Debug info structure generated by device and sent to PC through head pack. This is a compact version of StatesStructType
C MPSizectorS_DotNet.HeadPackDataInfoStructType | Data info structure, used in head pack
C MPSizectorS_DotNet.HeadPackStructType | Structure of head pack. It is regularly sent from device to PC, and also included in every data frame
C MPSizectorS_DotNet.HWTriggerSettingStructType | Structure of hardware trigger setting
C MPSizectorS_DotNet.IOSettingsStructType | Structure of IO settings
C MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType | Structure of linear temperature drift compensation
C MPSizectorS_DotNet.ManagedDataFrame2DStruct | Structure of managed 2D data frame
C MPSizectorS_DotNet.ManagedDataFrameFix3DStruct | Structure of managed 3D data frame in fix point format
C MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct | Structure of managed 3D data frame in simplified fixed point z map format
C MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct | Structure of managed 3D data frame in fixed point z map format
C MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct | Structure of managed 3D data frame in float point format
C MPSizectorS_DotNet.MonitorPositionStructType | Monitor Positions
C MPSizectorS_DotNet.MonitorZStructType | Monitor Z
C MPSizectorS_DotNet.MPSizectorS
C MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType | Structure of auto hdr advance settings
C MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType | Exposure intensity coef settings
C MPSizectorS_DotNet.MultiHeadSettingsStructType | Structure of reconstruction setting for multiple projecting
C MPSizectorS_DotNet.OutputPinSettingStructType | Structure of output pin setting (for one pin)
C MPSizectorS_DotNet.PartialFactorySettingsStructType | Partial factory settings struct type
C MPSizectorS_DotNet.PointScaleSettingStructType Structure of point scale setting. Used to convert between float point cloud and fixed point cloud format.
e.g., relationship between float and fixed point X value: XFloat = XIncrement * XFixedPoint + X0Pos
C MPSizectorS_DotNet.PostProcessSettingsStructType | Structure of post-process setting
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
C MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
C MPSizectorS_DotNet.Process
C MPSizectorS_DotNet.RangeCheckSettingStructType | Structure of user defined range check setting. Contains the valid range value of X, Y, Z
C MPSizectorS_DotNet.RangeImageManaged Managed range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C MPSizectorS_DotNet.RangeImageUnmanaged Unmanaged range image struct, data is stored as 1-dimensional array. 3D coordinates of any pixel(i, j) is：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C MPSizectorS_DotNet.ReconstructionSettingsStructType | Structure of reconstruction setting
C MPSizectorS_DotNet.Process.RotatedRectangle
C MPSizectorS_DotNet.RTMatrixStructType | Structure of RT matrix
C MPSizectorS_DotNet.SettingsStructType | Structure of all the settings
C MPSizectorS_DotNet.SoftwarePostProcessSetting | Structure of software post process
C MPSizectorS_DotNet.SoftwarePreprocessListRegisters | Structure of software preprocess list
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType | Structure of software preprocess preset param list
C MPSizectorS_DotNet.StatesStructType | Structure of full device state information
C MPSizectorS_DotNet.SuppressExpParamsEnableStructType | Suppress Exposure Params
C MPSizectorS_DotNet.TemperatureFeedbackStructType | Structure of temperature feed back information
C MPSizectorS_DotNet.TSNStructType | TSN structure. Indicates the ID of a valid trigger signal: source of trigger, SN of trigger
C MPSizectorS_DotNet.UnmanagedDataFrame2DStruct | Structure of unmanaged 2D data frame
C MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct | Structure of unmanaged 3D data frame in fix point format
C MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct | Structure of unmanaged 3D data frame in simplified fixed point z map format
C MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct | Structure of unmanaged 3D data frame in fixed point z map format
C MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct | Structure of unmanaged 3D data frame in float point format
C MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct | Structure of unmanaged undefined format data. This is the only data type delievered from callback. It is an intermediate data format to avoid using different callback functions to deliever different format of data
▼C UserControl
C MPSizectorS_DotNet.MPDisplayer2D | 2D image display control
C MPSizectorS_DotNet.MPDisplayer3D | 3D model display control
C MPSizectorS_DotNet.Utils
C MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct | The matrix structure of view and object pose


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AntiLampFlickerMode : MPSizectorS_DotNet.ExpertSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • AntiNoiseLevel : MPSizectorS_DotNet.MPSizectorS
  • AutoHDR_ExposureIntensity3D_1st : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_2nd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_3rd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDRAdvanceSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • AutoHDRAdvanceSettingsEnable : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • AutoHDRPriority : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoHDRResult : MPSizectorS_DotNet.HeadPackStructType
  • AutoPHDRQuality : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoSetExpertModeParam() : MPSizectorS_DotNet.MPSizectorS
  • AutoSleepDelayMS : MPSizectorS_DotNet.GeneralSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • AutoSleepEnableState : MPSizectorS_DotNet.GeneralSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • AutoTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • AuxiliaryRGB : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • AuxiliaryWhite : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BasicSetings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • BasicSettings : MPSizectorS_DotNet.MPSizectorS
  • Binning : MPSizectorS_DotNet.MPDisplayer2D
  • BinningPossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • BinningState : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • Bitmap : MPSizectorS_DotNet.MPDisplayer2D
  • BurrFilter_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • BurrFilterThreshold0 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • BurrFilterThreshold1 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CalculateCorrectDistortionParamFromData() : MPSizectorS_DotNet.Utils
  • CalibDate : MPSizectorS_DotNet.CalibParamStructType
  • CalibParam : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS
  • CC1 : MPSizectorS_DotNet.CalibParamStructType
  • CC2 : MPSizectorS_DotNet.CalibParamStructType
  • CF1 : MPSizectorS_DotNet.CalibParamStructType
  • CF2 : MPSizectorS_DotNet.CalibParamStructType
  • CKappa : MPSizectorS_DotNet.CalibParamStructType
  • Close() : MPSizectorS_DotNet.MPSizectorS
  • Closing_Cpu() : MPSizectorS_DotNet.Process
  • ColorArr : MPSizectorS_DotNet.Utils
  • ColorDepthImageMax : MPSizectorS_DotNet.MPDisplayer3D
  • ColorDepthImageMin : MPSizectorS_DotNet.MPDisplayer3D
  • CompensateData() : MPSizectorS_DotNet.Utils
  • CompensationParams : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ConnectionTimeMS : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Convert32bppTo8bpp() : MPSizectorS_DotNet.Utils
  • ConvertBayerToRGB() : MPSizectorS_DotNet.Process
  • ConvertFrame2DBayerToGray() : MPSizectorS_DotNet.Process
  • ConvertGrayByteArrayToGrayBitmap() : MPSizectorS_DotNet.Utils
  • ConvertRGBByteArrayToRGBBitmap() : MPSizectorS_DotNet.Utils
  • ConvertToRangeImage() : MPSizectorS_DotNet.Process
  • ConvertZMapFrameToFloat3DFrame() : MPSizectorS_DotNet.Process
  • CopyMemory() : MPSizectorS_DotNet.Utils
  • CopyToManagedFix3D() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
  • CopyToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
  • CopyToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • CopyToManagedFloat3D() : MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • CoreHardReset() : MPSizectorS_DotNet.MPSizectorS
  • CoreSoftReset() : MPSizectorS_DotNet.MPSizectorS
  • CorrectDistortion() : MPSizectorS_DotNet.MPSizectorS
  • CorrectDistortionEnable : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • CorrectionMode : MPSizectorS_DotNet.MPSizectorS
  • CR00 : MPSizectorS_DotNet.CalibParamStructType
  • CR01 : MPSizectorS_DotNet.CalibParamStructType
  • CR02 : MPSizectorS_DotNet.CalibParamStructType
  • CR10 : MPSizectorS_DotNet.CalibParamStructType
  • CR11 : MPSizectorS_DotNet.CalibParamStructType
  • CR12 : MPSizectorS_DotNet.CalibParamStructType
  • CR20 : MPSizectorS_DotNet.CalibParamStructType
  • CR21 : MPSizectorS_DotNet.CalibParamStructType
  • CR22 : MPSizectorS_DotNet.CalibParamStructType
  • CSx : MPSizectorS_DotNet.CalibParamStructType
  • CSy : MPSizectorS_DotNet.CalibParamStructType
  • CT0 : MPSizectorS_DotNet.CalibParamStructType
  • CT1 : MPSizectorS_DotNet.CalibParamStructType
  • CT2 : MPSizectorS_DotNet.CalibParamStructType
  • CurPixelCord : MPSizectorS_DotNet.MPDisplayer2D
  • CurrentDeviceInfo : MPSizectorS_DotNet.MPSizectorS
  • CurrentTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • CurrentTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • Data : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DataCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • DataFormat : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataInfo : MPSizectorS_DotNet.HeadPackStructType
  • DataNumber : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataOutMode : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • DataTag : MPSizectorS_DotNet.HeadPackDataInfoStructType, MPSizectorS_DotNet.MPSizectorS
  • DebugInfo : MPSizectorS_DotNet.HeadPackStructType
  • DebugRegisters : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • DefaultSettings : MPSizectorS_DotNet.MPSizectorS
  • DelayIn100us : MPSizectorS_DotNet.HWTriggerSettingStructType
  • DepthColorStops : MPSizectorS_DotNet.Utils
  • DestroyCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DeviceInfo : MPSizectorS_DotNet.HeadPackStructType
  • DeviceName : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceSerialNumber : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceState : MPSizectorS_DotNet.MPSizectorS
  • DeviceStateChangeCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • DeviceTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DiffPrejudgePatternEnable : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • Dilate_Cpu() : MPSizectorS_DotNet.Process
  • Display() : MPSizectorS_DotNet.MPDisplayer3D
  • Dispose() : MPSizectorS_DotNet.MPDisplayer2D, MPSizectorS_DotNet.MPDisplayer3D
  • DownSamplingData() : MPSizectorS_DotNet.Process
  • Dump() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • Enable : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
  • EnableDisplayFilter : MPSizectorS_DotNet.MPDisplayer3D
  • Erosion_Cpu() : MPSizectorS_DotNet.Process
  • ExpertSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • ExpICoef : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefMax : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefSettings : MPSizectorS_DotNet.HeadPackStructType
  • ExposureBasicSetting : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity2D : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_1st : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_2nd : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_3rd : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureMode : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureNum : MPSizectorS_DotNet.AutoHDRResultStructType
  • ExposureNumber : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • ExpROIHeight : MPSizectorS_DotNet.ExpROIStructType
  • ExpROINum : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIs : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIWidth : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIXCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIYCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExternalExposureEnable : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureGain : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposurePossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • ExternalExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • ExternalExposureTimeBlue_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeGreen_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeRed_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeWhite_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • EXTIO0Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIO1Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIOInput : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • EXTIOO0Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOO1Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOOutput : MPSizectorS_DotNet.IOSettingsStructType, MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FilterLog() : MPSizectorS_DotNet.Utils
  • FireSoftwareTrigger() : MPSizectorS_DotNet.MPSizectorS
  • FlipEnable : MPSizectorS_DotNet.ExpertSettingsStructType
  • FlipNextBinningStateEnable : MPSizectorS_DotNet.MPSizectorS
  • FlipXEnable : MPSizectorS_DotNet.FlipEnableStructType, MPSizectorS_DotNet.MPSizectorS
  • FlipYEnable : MPSizectorS_DotNet.FlipEnableStructType, MPSizectorS_DotNet.MPSizectorS
  • FrameInfo : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • FreeGpu() : MPSizectorS_DotNet.Process
  • FreeHGlobalMemory() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • FreeUnmanagedData() : MPSizectorS_DotNet.Utils
  • FWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GenCircleKernel_Cpu() : MPSizectorS_DotNet.Process
  • GeneralSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • GenThresholdTable_Cpu() : MPSizectorS_DotNet.Process
  • GenThresholdTableUshort_Cpu() : MPSizectorS_DotNet.Process
  • Get3DDataLen() : MPSizectorS_DotNet.Utils
  • GetAutoColorDepthRange() : MPSizectorS_DotNet.Utils
  • GetAuxiliaryBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetColorDepthBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • GetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • GetDataLen() : MPSizectorS_DotNet.Utils
  • GetDataPtr() : MPSizectorS_DotNet.Process
  • GetDepthColor() : MPSizectorS_DotNet.Utils
  • GetDeviceCount() : MPSizectorS_DotNet.MPSizectorS
  • GetDeviceInfo() : MPSizectorS_DotNet.MPSizectorS
  • GetExpIByTargetGray() : MPSizectorS_DotNet.MPSizectorS
  • GetExposurePredictionBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.Utils
  • GetExposureValueFromExposurePredictionData() : MPSizectorS_DotNet.Utils
  • GetGrayBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetHardwareTimeStamps() : MPSizectorS_DotNet.MPSizectorS
  • GetHDRMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetLastZAt() : MPSizectorS_DotNet.MPSizectorS
  • GetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetMaskValue() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • GetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyFWVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyInstanceID() : MPSizectorS_DotNet.MPSizectorS
  • GetProjectorExpRegionInfoFromCamExpRegion() : MPSizectorS_DotNet.MPSizectorS
  • GetROIData() : MPSizectorS_DotNet.Process
  • GetSDKVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetValidMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • Gray : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HardwarePreprocessModeList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HardwareTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • HasAuxiliaryRGBImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HasAuxiliaryWhiteImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HeadPackCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • Height : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • HoldState : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • HWTriggerSeting : MPSizectorS_DotNet.IOSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • HWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • ImageOrigin : MPSizectorS_DotNet.MPDisplayer2D
  • InitGpu() : MPSizectorS_DotNet.Process
  • InitStates : MPSizectorS_DotNet.HeadDebugInfoStructType
  • InterfaceType : MPSizectorS_DotNet.DeviceInfoStructType
  • IOSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • IsActivated : MPSizectorS_DotNet.DeviceInfoStructType
  • IsBase : MPSizectorS_DotNet.ExpROIStructType
  • IsLoaded : MPSizectorS_DotNet.MPDisplayer3D
  • IsReversed : MPSizectorS_DotNet.HWTriggerSettingStructType
  • IsReversedForSpecialFunction : MPSizectorS_DotNet.OutputPinSettingStructType
  • IsUsingAutoHDRResult : MPSizectorS_DotNet.AutoHDRResultStructType
  • IsValid : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • K : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • LinearTemperatureDriftCompensationParam : MPSizectorS_DotNet.CompensationStructType
  • LoadCorrectionParamFromXML() : MPSizectorS_DotNet.MPSizectorS
  • LoadDataFrame() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • LoadDefaultSettings() : MPSizectorS_DotNet.MPSizectorS
  • LoadDll() : MPSizectorS_DotNet.MPSizectorS
  • LoadPostProcessFile() : MPSizectorS_DotNet.Utils
  • LoadSettingFromXML() : MPSizectorS_DotNet.Extension
  • LoadUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • LoadUnmanagedDataFrameUndefined_FileStream() : MPSizectorS_DotNet.Extension
  • LogCallBackType() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • m_SizectorS_Instance : MPSizectorS_DotNet.MPSizectorS
  • Mask : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Max : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MergeNumber : MPSizectorS_DotNet.MPSizectorS
  • MergeParam0 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam1 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam2 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam3 : MPSizectorS_DotNet.MPSizectorS
  • MergeThreshold : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeWRGBData() : MPSizectorS_DotNet.Process
  • Min : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MinimumSDKVersion : MPSizectorS_DotNet.DeviceInfoStructType
  • ModelPolygon : MPSizectorS_DotNet.MPDisplayer3D
  • ModelTexture : MPSizectorS_DotNet.MPDisplayer3D
  • MonitorPositions : MPSizectorS_DotNet.ExpertSettingsStructType
  • MonitorPositionX : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorPositionY : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorZArr : MPSizectorS_DotNet.ExpertSettingsStructType
  • MPDisplayer2D() : MPSizectorS_DotNet.MPDisplayer2D
  • MPDisplayer3D() : MPSizectorS_DotNet.MPDisplayer3D
  • MPModelPolygonType : MPSizectorS_DotNet.MPDisplayer3D
  • MPModelTextureType : MPSizectorS_DotNet.MPDisplayer3D
  • MPSizectorS() : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadConfig : MPSizectorS_DotNet.DeviceInfoStructType, MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarMode : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarRatio : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • MultiHeadSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • Open() : MPSizectorS_DotNet.MPSizectorS
  • Opening_Cpu() : MPSizectorS_DotNet.Process
  • OverExposureFilterThreshold : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PartialFactorySettings : MPSizectorS_DotNet.HeadPackStructType
  • PatternPeriod1 : MPSizectorS_DotNet.MPSizectorS
  • PatternPeriod2 : MPSizectorS_DotNet.MPSizectorS
  • PC1 : MPSizectorS_DotNet.CalibParamStructType
  • PC2 : MPSizectorS_DotNet.CalibParamStructType
  • PCTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • PF1 : MPSizectorS_DotNet.CalibParamStructType
  • PF2 : MPSizectorS_DotNet.CalibParamStructType
  • PhyDisconnect() : MPSizectorS_DotNet.MPSizectorS
  • PhyRecconect() : MPSizectorS_DotNet.MPSizectorS
  • PhyReset() : MPSizectorS_DotNet.MPSizectorS
  • PinMode : MPSizectorS_DotNet.OutputPinSettingStructType
  • PixelCordChange : MPSizectorS_DotNet.MPDisplayer2D
  • PixelInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • PKappa : MPSizectorS_DotNet.CalibParamStructType
  • PointScaleSetting : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • Polarity : MPSizectorS_DotNet.ExpROIStructType
  • PostProcessCircleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessFiltrate() : MPSizectorS_DotNet.Process
  • PostProcessMend() : MPSizectorS_DotNet.Process
  • PostProcessMendByFeatures() : MPSizectorS_DotNet.Process
  • PostProcessPlaneCorrection() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckCircle() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRect() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRingEndRect() : MPSizectorS_DotNet.Process
  • PostProcessRectangleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessRegionMend() : MPSizectorS_DotNet.Process
  • PostProcessRemoveBurrs() : MPSizectorS_DotNet.Process
  • PostProcessRingEndRectRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessSegmentMedianFilter() : MPSizectorS_DotNet.Process
  • PostProcessSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • PostProcessSPI() : MPSizectorS_DotNet.Process
  • PostProcessSPIChannel3() : MPSizectorS_DotNet.Process
  • PostProcessTransformImage() : MPSizectorS_DotNet.Process
  • PR00 : MPSizectorS_DotNet.CalibParamStructType
  • PR01 : MPSizectorS_DotNet.CalibParamStructType
  • PR02 : MPSizectorS_DotNet.CalibParamStructType
  • PR10 : MPSizectorS_DotNet.CalibParamStructType
  • PR11 : MPSizectorS_DotNet.CalibParamStructType
  • PR12 : MPSizectorS_DotNet.CalibParamStructType
  • PR20 : MPSizectorS_DotNet.CalibParamStructType
  • PR21 : MPSizectorS_DotNet.CalibParamStructType
  • PR22 : MPSizectorS_DotNet.CalibParamStructType
  • PrejudgePatternGain : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • PrepareColorArr() : MPSizectorS_DotNet.Utils
  • PreProcess_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • PreProcessLoopNum : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • PreProcessThreshold : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ProjectionMode : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • ProjectionNumber : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • PSx : MPSizectorS_DotNet.CalibParamStructType
  • PSy : MPSizectorS_DotNet.CalibParamStructType
  • PT0 : MPSizectorS_DotNet.CalibParamStructType
  • PT1 : MPSizectorS_DotNet.CalibParamStructType
  • PT2 : MPSizectorS_DotNet.CalibParamStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • R00 : MPSizectorS_DotNet.RTMatrixStructType
  • R01 : MPSizectorS_DotNet.RTMatrixStructType
  • R02 : MPSizectorS_DotNet.RTMatrixStructType
  • R10 : MPSizectorS_DotNet.RTMatrixStructType
  • R11 : MPSizectorS_DotNet.RTMatrixStructType
  • R12 : MPSizectorS_DotNet.RTMatrixStructType
  • R20 : MPSizectorS_DotNet.RTMatrixStructType
  • R21 : MPSizectorS_DotNet.RTMatrixStructType
  • R22 : MPSizectorS_DotNet.RTMatrixStructType
  • RangeCheckEnableState : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeCheckSetting : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ReadSettingsFromFile() : MPSizectorS_DotNet.MPSizectorS
  • Reconnect() : MPSizectorS_DotNet.MPSizectorS
  • ReconstructionSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • Reserved : MPSizectorS_DotNet.ExpertSettingsStructType
  • RgbToHsv_Cpu() : MPSizectorS_DotNet.Process
  • ROIHeightRatio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ROIWidthRatio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ROIX0Ratio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ROIY0Ratio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • RotateAmplitude : MPSizectorS_DotNet.MPDisplayer3D
  • RotateMode : MPSizectorS_DotNet.MPDisplayer3D
  • RotateModeEnumType : MPSizectorS_DotNet.MPDisplayer3D
  • RotatePhase : MPSizectorS_DotNet.MPDisplayer3D
  • RotateSpeed : MPSizectorS_DotNet.MPDisplayer3D


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SaveCorrectionParams() : MPSizectorS_DotNet.MPSizectorS
  • SaveCorrectionParamToXML() : MPSizectorS_DotNet.MPSizectorS
  • SaveDataFrame() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveDataFrame_FileStream() : MPSizectorS_DotNet.Utils
  • SaveDataFrame_ManagedFixZMapSimpleDataFrame() : MPSizectorS_DotNet.Utils
  • SavePCD() : MPSizectorS_DotNet.Process
  • SavePLY() : MPSizectorS_DotNet.Process
  • SaveSettingsAsDefault() : MPSizectorS_DotNet.MPSizectorS
  • SaveSettingToXML() : MPSizectorS_DotNet.Extension
  • SaveTextPointCloud() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Process, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveTIFF() : MPSizectorS_DotNet.Process
  • SaveUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • Score : MPSizectorS_DotNet.AutoHDRResultStructType
  • Screenshot : MPSizectorS_DotNet.MPDisplayer3D
  • SensorBinningHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorExpBaseTime : MPSizectorS_DotNet.MPSizectorS
  • SensorHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorValid : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • SensorWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SetAutoReconnect() : MPSizectorS_DotNet.MPSizectorS
  • SetAuxiliaryRGB() : MPSizectorS_DotNet.SettingsStructType
  • SetAuxiliaryWhite() : MPSizectorS_DotNet.SettingsStructType
  • SetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • SetDataCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDeviceStateChangeCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDrawLines() : MPSizectorS_DotNet.MPDisplayer3D
  • SetHeadPackCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • Settings : MPSizectorS_DotNet.MPSizectorS
  • SettingsVersion : MPSizectorS_DotNet.HeadPackStructType
  • SettingValidation : MPSizectorS_DotNet.HeadDebugInfoStructType
  • shapeType : MPSizectorS_DotNet.ExpROIStructType
  • SN : MPSizectorS_DotNet.TSNStructType
  • SnapCnt : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • SnapUnmanaged() : MPSizectorS_DotNet.MPSizectorS
  • SoftwarePreprocessList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwarePreprocessPresetParamList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwareTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Source : MPSizectorS_DotNet.TSNStructType
  • SpecularReflection : MPSizectorS_DotNet.MPDisplayer3D
  • StartUpTimeMS : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • State : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • States : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo1Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo2Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo3Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpParam1Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam2Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam3Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParamsEnable : MPSizectorS_DotNet.ExpertSettingsStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • T0 : MPSizectorS_DotNet.RTMatrixStructType
  • T1 : MPSizectorS_DotNet.RTMatrixStructType
  • T2 : MPSizectorS_DotNet.RTMatrixStructType
  • Temp0 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Temp1 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Temp2 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • TempCore : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • TempValueC : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • TestMultiHeadError() : MPSizectorS_DotNet.MPSizectorS
  • Textures : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Threshold3Channel_Cpu() : MPSizectorS_DotNet.Process
  • Threshold_Cpu() : MPSizectorS_DotNet.Process
  • ThresholdUshort_Cpu() : MPSizectorS_DotNet.Process
  • ToManaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • TooHighColor : MPSizectorS_DotNet.Utils
  • TooLowColor : MPSizectorS_DotNet.Utils
  • TotalCaptureRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • TotalTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • ToUnmanaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMap() : MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMapSimple() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • TransferExpoIntensityToExpoTime() : MPSizectorS_DotNet.MPSizectorS
  • TransferExpoTimeToExpoIntensity() : MPSizectorS_DotNet.MPSizectorS
  • TransformROIPixelToROISetting() : MPSizectorS_DotNet.Utils
  • TransformROISettingToROIPixel() : MPSizectorS_DotNet.Utils
  • TransparentBackGroundSnapshot : MPSizectorS_DotNet.MPDisplayer3D
  • TriggerSource : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • TSN : MPSizectorS_DotNet.HeadPackDataInfoStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • Undistort() : MPSizectorS_DotNet.Process
  • UpdateDeviceList() : MPSizectorS_DotNet.MPSizectorS
  • UpSamplingData() : MPSizectorS_DotNet.Process
  • UseNormVector : MPSizectorS_DotNet.MPDisplayer3D
  • UserGain : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • UserRTMatrix : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • UserRTMatrixEnableState : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • UXmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UXmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmin : MPSizectorS_DotNet.RangeCheckSettingStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValidPointThreshold0 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ValidPointThreshold1 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ValidPointThreshold_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • ViewMatrix : MPSizectorS_DotNet.MPDisplayer3D


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • Width : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • WorkingMode : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • WriteSettingsToFile() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • X : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • X0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • XIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • XMax : MPSizectorS_DotNet.DeviceInfoStructType
  • XOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • XPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • XReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • Y : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • Y0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • YIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • YMax : MPSizectorS_DotNet.DeviceInfoStructType
  • YOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • YPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • YReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET Programmer's Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • Z : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • Z0 : MPSizectorS_DotNet.MonitorZStructType
  • Z0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • Z1 : MPSizectorS_DotNet.MonitorZStructType
  • Z2 : MPSizectorS_DotNet.MonitorZStructType
  • Z3 : MPSizectorS_DotNet.MonitorZStructType
  • ZIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • ZInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ZMax : MPSizectorS_DotNet.DeviceInfoStructType, MPSizectorS_DotNet.MPSizectorS
  • ZMin : MPSizectorS_DotNet.MPSizectorS
  • ZOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Zoom : MPSizectorS_DotNet.MPDisplayer2D
  • ZRawData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- a -

  • AutoSetExpertModeParam() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- c -

  • CalculateCorrectDistortionParamFromData() : MPSizectorS_DotNet.Utils
  • Close() : MPSizectorS_DotNet.MPSizectorS
  • Closing_Cpu() : MPSizectorS_DotNet.Process
  • CompensateData() : MPSizectorS_DotNet.Utils
  • Convert32bppTo8bpp() : MPSizectorS_DotNet.Utils
  • ConvertBayerToRGB() : MPSizectorS_DotNet.Process
  • ConvertFrame2DBayerToGray() : MPSizectorS_DotNet.Process
  • ConvertGrayByteArrayToGrayBitmap() : MPSizectorS_DotNet.Utils
  • ConvertRGBByteArrayToRGBBitmap() : MPSizectorS_DotNet.Utils
  • ConvertToRangeImage() : MPSizectorS_DotNet.Process
  • ConvertZMapFrameToFloat3DFrame() : MPSizectorS_DotNet.Process
  • CopyMemory() : MPSizectorS_DotNet.Utils
  • CopyToManagedFix3D() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
  • CopyToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
  • CopyToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • CopyToManagedFloat3D() : MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • CoreHardReset() : MPSizectorS_DotNet.MPSizectorS
  • CoreSoftReset() : MPSizectorS_DotNet.MPSizectorS
  • CorrectDistortion() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- d -

  • DataCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • DestroyCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DeviceStateChangeCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • Dilate_Cpu() : MPSizectorS_DotNet.Process
  • Display() : MPSizectorS_DotNet.MPDisplayer3D
  • Dispose() : MPSizectorS_DotNet.MPDisplayer2D, MPSizectorS_DotNet.MPDisplayer3D
  • DownSamplingData() : MPSizectorS_DotNet.Process
  • Dump() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- e -

  • Erosion_Cpu() : MPSizectorS_DotNet.Process


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- f -

  • FilterLog() : MPSizectorS_DotNet.Utils
  • FireSoftwareTrigger() : MPSizectorS_DotNet.MPSizectorS
  • FreeGpu() : MPSizectorS_DotNet.Process
  • FreeHGlobalMemory() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • FreeUnmanagedData() : MPSizectorS_DotNet.Utils


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- g -

  • GenCircleKernel_Cpu() : MPSizectorS_DotNet.Process
  • GenThresholdTable_Cpu() : MPSizectorS_DotNet.Process
  • GenThresholdTableUshort_Cpu() : MPSizectorS_DotNet.Process
  • Get3DDataLen() : MPSizectorS_DotNet.Utils
  • GetAutoColorDepthRange() : MPSizectorS_DotNet.Utils
  • GetAuxiliaryBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetColorDepthBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • GetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • GetDataLen() : MPSizectorS_DotNet.Utils
  • GetDataPtr() : MPSizectorS_DotNet.Process
  • GetDepthColor() : MPSizectorS_DotNet.Utils
  • GetDeviceCount() : MPSizectorS_DotNet.MPSizectorS
  • GetDeviceInfo() : MPSizectorS_DotNet.MPSizectorS
  • GetExpIByTargetGray() : MPSizectorS_DotNet.MPSizectorS
  • GetExposurePredictionBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.Utils
  • GetExposureValueFromExposurePredictionData() : MPSizectorS_DotNet.Utils
  • GetGrayBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetHardwareTimeStamps() : MPSizectorS_DotNet.MPSizectorS
  • GetHDRMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetLastZAt() : MPSizectorS_DotNet.MPSizectorS
  • GetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetMaskValue() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • GetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyFWVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyInstanceID() : MPSizectorS_DotNet.MPSizectorS
  • GetProjectorExpRegionInfoFromCamExpRegion() : MPSizectorS_DotNet.MPSizectorS
  • GetROIData() : MPSizectorS_DotNet.Process
  • GetSDKVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetValidMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- h -

  • HeadPackCallBackType() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- i -

  • InitGpu() : MPSizectorS_DotNet.Process
  • IsValid() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- l -

  • LoadCorrectionParamFromXML() : MPSizectorS_DotNet.MPSizectorS
  • LoadDataFrame() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • LoadDefaultSettings() : MPSizectorS_DotNet.MPSizectorS
  • LoadDll() : MPSizectorS_DotNet.MPSizectorS
  • LoadPostProcessFile() : MPSizectorS_DotNet.Utils
  • LoadSettingFromXML() : MPSizectorS_DotNet.Extension
  • LoadUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • LoadUnmanagedDataFrameUndefined_FileStream() : MPSizectorS_DotNet.Extension
  • LogCallBackType() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- m -

  • MergeWRGBData() : MPSizectorS_DotNet.Process
  • MPDisplayer2D() : MPSizectorS_DotNet.MPDisplayer2D
  • MPDisplayer3D() : MPSizectorS_DotNet.MPDisplayer3D
  • MPSizectorS() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- o -

  • Open() : MPSizectorS_DotNet.MPSizectorS
  • Opening_Cpu() : MPSizectorS_DotNet.Process


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- p -

  • PhyDisconnect() : MPSizectorS_DotNet.MPSizectorS
  • PhyRecconect() : MPSizectorS_DotNet.MPSizectorS
  • PhyReset() : MPSizectorS_DotNet.MPSizectorS
  • PostProcessCircleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessFiltrate() : MPSizectorS_DotNet.Process
  • PostProcessMend() : MPSizectorS_DotNet.Process
  • PostProcessMendByFeatures() : MPSizectorS_DotNet.Process
  • PostProcessPlaneCorrection() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckCircle() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRect() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRingEndRect() : MPSizectorS_DotNet.Process
  • PostProcessRectangleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessRegionMend() : MPSizectorS_DotNet.Process
  • PostProcessRemoveBurrs() : MPSizectorS_DotNet.Process
  • PostProcessRingEndRectRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessSegmentMedianFilter() : MPSizectorS_DotNet.Process
  • PostProcessSPI() : MPSizectorS_DotNet.Process
  • PostProcessSPIChannel3() : MPSizectorS_DotNet.Process
  • PostProcessTransformImage() : MPSizectorS_DotNet.Process
  • PrepareColorArr() : MPSizectorS_DotNet.Utils


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- r -

  • ReadSettingsFromFile() : MPSizectorS_DotNet.MPSizectorS
  • Reconnect() : MPSizectorS_DotNet.MPSizectorS
  • RgbToHsv_Cpu() : MPSizectorS_DotNet.Process


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- s -

  • SaveCorrectionParams() : MPSizectorS_DotNet.MPSizectorS
  • SaveCorrectionParamToXML() : MPSizectorS_DotNet.MPSizectorS
  • SaveDataFrame() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveDataFrame_FileStream() : MPSizectorS_DotNet.Utils
  • SaveDataFrame_ManagedFixZMapSimpleDataFrame() : MPSizectorS_DotNet.Utils
  • SavePCD() : MPSizectorS_DotNet.Process
  • SavePLY() : MPSizectorS_DotNet.Process
  • SaveSettingsAsDefault() : MPSizectorS_DotNet.MPSizectorS
  • SaveSettingToXML() : MPSizectorS_DotNet.Extension
  • SaveTextPointCloud() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Process, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveTIFF() : MPSizectorS_DotNet.Process
  • SaveUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • SetAutoReconnect() : MPSizectorS_DotNet.MPSizectorS
  • SetAuxiliaryRGB() : MPSizectorS_DotNet.SettingsStructType
  • SetAuxiliaryWhite() : MPSizectorS_DotNet.SettingsStructType
  • SetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • SetDataCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDeviceStateChangeCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDrawLines() : MPSizectorS_DotNet.MPDisplayer3D
  • SetHeadPackCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • SnapUnmanaged() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- t -

  • TestMultiHeadError() : MPSizectorS_DotNet.MPSizectorS
  • Threshold3Channel_Cpu() : MPSizectorS_DotNet.Process
  • Threshold_Cpu() : MPSizectorS_DotNet.Process
  • ThresholdUshort_Cpu() : MPSizectorS_DotNet.Process
  • ToManaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMap() : MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMapSimple() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • TransferExpoIntensityToExpoTime() : MPSizectorS_DotNet.MPSizectorS
  • TransferExpoTimeToExpoIntensity() : MPSizectorS_DotNet.MPSizectorS
  • TransformROIPixelToROISetting() : MPSizectorS_DotNet.Utils
  • TransformROISettingToROIPixel() : MPSizectorS_DotNet.Utils


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- u -

  • Undistort() : MPSizectorS_DotNet.Process
  • UpdateDeviceList() : MPSizectorS_DotNet.MPSizectorS
  • UpSamplingData() : MPSizectorS_DotNet.Process


MPSizector .NET Programmer's Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented functions with links to the class documentation for each member:

- w -

  • WriteSettingsToFile() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- a -

  • AntiLampFlickerMode : MPSizectorS_DotNet.ExpertSettingsStructType
  • AutoHDR_ExposureIntensity3D_1st : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_2nd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_3rd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDRAdvanceSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • AutoHDRAdvanceSettingsEnable : MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • AutoHDRPriority : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoHDRResult : MPSizectorS_DotNet.HeadPackStructType
  • AutoPHDRQuality : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoSleepDelayMS : MPSizectorS_DotNet.GeneralSettingsStructType
  • AutoSleepEnableState : MPSizectorS_DotNet.GeneralSettingsStructType
  • AutoTSN : MPSizectorS_DotNet.StatesStructType
  • AuxiliaryRGB : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • AuxiliaryWhite : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- b -

  • BasicSetings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • BinningPossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • BinningState : MPSizectorS_DotNet.BasicSettingsStructType
  • BurrFilterThreshold0 : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • BurrFilterThreshold1 : MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- c -

  • CalibDate : MPSizectorS_DotNet.CalibParamStructType
  • CalibParam : MPSizectorS_DotNet.HeadPackStructType
  • CC1 : MPSizectorS_DotNet.CalibParamStructType
  • CC2 : MPSizectorS_DotNet.CalibParamStructType
  • CF1 : MPSizectorS_DotNet.CalibParamStructType
  • CF2 : MPSizectorS_DotNet.CalibParamStructType
  • CKappa : MPSizectorS_DotNet.CalibParamStructType
  • ColorArr : MPSizectorS_DotNet.Utils
  • CompensationParams : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ConnectionTimeMS : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • CorrectDistortionEnable : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • CR00 : MPSizectorS_DotNet.CalibParamStructType
  • CR01 : MPSizectorS_DotNet.CalibParamStructType
  • CR02 : MPSizectorS_DotNet.CalibParamStructType
  • CR10 : MPSizectorS_DotNet.CalibParamStructType
  • CR11 : MPSizectorS_DotNet.CalibParamStructType
  • CR12 : MPSizectorS_DotNet.CalibParamStructType
  • CR20 : MPSizectorS_DotNet.CalibParamStructType
  • CR21 : MPSizectorS_DotNet.CalibParamStructType
  • CR22 : MPSizectorS_DotNet.CalibParamStructType
  • CSx : MPSizectorS_DotNet.CalibParamStructType
  • CSy : MPSizectorS_DotNet.CalibParamStructType
  • CT0 : MPSizectorS_DotNet.CalibParamStructType
  • CT1 : MPSizectorS_DotNet.CalibParamStructType
  • CT2 : MPSizectorS_DotNet.CalibParamStructType
  • CurrentTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • CurrentTSN : MPSizectorS_DotNet.StatesStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- d -

  • Data : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DataFormat : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataInfo : MPSizectorS_DotNet.HeadPackStructType
  • DataNumber : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataOutMode : MPSizectorS_DotNet.PostProcessSettingsStructType
  • DataTag : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DebugInfo : MPSizectorS_DotNet.HeadPackStructType
  • DebugRegisters : MPSizectorS_DotNet.StatesStructType
  • DelayIn100us : MPSizectorS_DotNet.HWTriggerSettingStructType
  • DepthColorStops : MPSizectorS_DotNet.Utils
  • DeviceInfo : MPSizectorS_DotNet.HeadPackStructType
  • DeviceName : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceSerialNumber : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DiffPrejudgePatternEnable : MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- e -

  • Enable : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
  • ExpertSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ExpICoef : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefMax : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefSettings : MPSizectorS_DotNet.HeadPackStructType
  • ExposureBasicSetting : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity2D : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity3D_1st : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity3D_2nd : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity3D_3rd : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureMode : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureNum : MPSizectorS_DotNet.AutoHDRResultStructType
  • ExposureNumber : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ExpROIHeight : MPSizectorS_DotNet.ExpROIStructType
  • ExpROINum : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIs : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIWidth : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIXCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIYCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExternalExposureEnable : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureGain : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposurePossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • ExternalExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ExternalExposureTimeBlue_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureTimeGreen_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureTimeRed_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureTimeWhite_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • EXTIOInput : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • EXTIOO0Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOO1Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOOutput : MPSizectorS_DotNet.IOSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- f -

  • FlipEnable : MPSizectorS_DotNet.ExpertSettingsStructType
  • FlipXEnable : MPSizectorS_DotNet.FlipEnableStructType
  • FlipYEnable : MPSizectorS_DotNet.FlipEnableStructType
  • FrameInfo : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • FWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- g -

  • GeneralSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • Gray : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- h -

  • HardwarePreprocessModeList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HardwareTSN : MPSizectorS_DotNet.StatesStructType
  • Height : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • HoldState : MPSizectorS_DotNet.BasicSettingsStructType
  • HWTriggerSeting : MPSizectorS_DotNet.IOSettingsStructType
  • HWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- i -

  • InitStates : MPSizectorS_DotNet.HeadDebugInfoStructType
  • InterfaceType : MPSizectorS_DotNet.DeviceInfoStructType
  • IOSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • IsActivated : MPSizectorS_DotNet.DeviceInfoStructType
  • IsBase : MPSizectorS_DotNet.ExpROIStructType
  • IsReversed : MPSizectorS_DotNet.HWTriggerSettingStructType
  • IsReversedForSpecialFunction : MPSizectorS_DotNet.OutputPinSettingStructType
  • IsUsingAutoHDRResult : MPSizectorS_DotNet.AutoHDRResultStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- k -

  • K : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- l -

  • LinearTemperatureDriftCompensationParam : MPSizectorS_DotNet.CompensationStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- m -

  • m_SizectorS_Instance : MPSizectorS_DotNet.MPSizectorS
  • Mask : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Max : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MergeParam0 : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam1 : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam2 : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeThreshold : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • Min : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MinimumSDKVersion : MPSizectorS_DotNet.DeviceInfoStructType
  • MonitorPositions : MPSizectorS_DotNet.ExpertSettingsStructType
  • MonitorPositionX : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorPositionY : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorZArr : MPSizectorS_DotNet.ExpertSettingsStructType
  • MultiHeadConfig : MPSizectorS_DotNet.DeviceInfoStructType
  • MultiHeadExpoVarMode : MPSizectorS_DotNet.ExposureSettingsStructType
  • MultiHeadExpoVarRatio : MPSizectorS_DotNet.ExposureSettingsStructType
  • MultiHeadSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- o -

  • OverExposureFilterThreshold : MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- p -

  • PartialFactorySettings : MPSizectorS_DotNet.HeadPackStructType
  • PC1 : MPSizectorS_DotNet.CalibParamStructType
  • PC2 : MPSizectorS_DotNet.CalibParamStructType
  • PCTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • PF1 : MPSizectorS_DotNet.CalibParamStructType
  • PF2 : MPSizectorS_DotNet.CalibParamStructType
  • PinMode : MPSizectorS_DotNet.OutputPinSettingStructType
  • PixelInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • PKappa : MPSizectorS_DotNet.CalibParamStructType
  • PointScaleSetting : MPSizectorS_DotNet.PostProcessSettingsStructType
  • Polarity : MPSizectorS_DotNet.ExpROIStructType
  • PostProcessSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • PR00 : MPSizectorS_DotNet.CalibParamStructType
  • PR01 : MPSizectorS_DotNet.CalibParamStructType
  • PR02 : MPSizectorS_DotNet.CalibParamStructType
  • PR10 : MPSizectorS_DotNet.CalibParamStructType
  • PR11 : MPSizectorS_DotNet.CalibParamStructType
  • PR12 : MPSizectorS_DotNet.CalibParamStructType
  • PR20 : MPSizectorS_DotNet.CalibParamStructType
  • PR21 : MPSizectorS_DotNet.CalibParamStructType
  • PR22 : MPSizectorS_DotNet.CalibParamStructType
  • PrejudgePatternGain : MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • PreProcessLoopNum : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • PreProcessThreshold : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ProjectionMode : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • PSx : MPSizectorS_DotNet.CalibParamStructType
  • PSy : MPSizectorS_DotNet.CalibParamStructType
  • PT0 : MPSizectorS_DotNet.CalibParamStructType
  • PT1 : MPSizectorS_DotNet.CalibParamStructType
  • PT2 : MPSizectorS_DotNet.CalibParamStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- r -

  • R00 : MPSizectorS_DotNet.RTMatrixStructType
  • R01 : MPSizectorS_DotNet.RTMatrixStructType
  • R02 : MPSizectorS_DotNet.RTMatrixStructType
  • R10 : MPSizectorS_DotNet.RTMatrixStructType
  • R11 : MPSizectorS_DotNet.RTMatrixStructType
  • R12 : MPSizectorS_DotNet.RTMatrixStructType
  • R20 : MPSizectorS_DotNet.RTMatrixStructType
  • R21 : MPSizectorS_DotNet.RTMatrixStructType
  • R22 : MPSizectorS_DotNet.RTMatrixStructType
  • RangeCheckEnableState : MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeCheckSetting : MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ReconstructionSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • Reserved : MPSizectorS_DotNet.ExpertSettingsStructType
  • ROIHeightRatio : MPSizectorS_DotNet.BasicSettingsStructType
  • ROIWidthRatio : MPSizectorS_DotNet.BasicSettingsStructType
  • ROIX0Ratio : MPSizectorS_DotNet.BasicSettingsStructType
  • ROIY0Ratio : MPSizectorS_DotNet.BasicSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- s -

  • Score : MPSizectorS_DotNet.AutoHDRResultStructType
  • SensorBinningHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorValid : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • SensorWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SettingsVersion : MPSizectorS_DotNet.HeadPackStructType
  • SettingValidation : MPSizectorS_DotNet.HeadDebugInfoStructType
  • shapeType : MPSizectorS_DotNet.ExpROIStructType
  • SN : MPSizectorS_DotNet.TSNStructType
  • SnapCnt : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • SoftwarePreprocessList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwarePreprocessPresetParamList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwareTSN : MPSizectorS_DotNet.StatesStructType
  • Source : MPSizectorS_DotNet.TSNStructType
  • StartUpTimeMS : MPSizectorS_DotNet.StatesStructType
  • State : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • SuppressExpParam1Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam2Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam3Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParamsEnable : MPSizectorS_DotNet.ExpertSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- t -

  • T0 : MPSizectorS_DotNet.RTMatrixStructType
  • T1 : MPSizectorS_DotNet.RTMatrixStructType
  • T2 : MPSizectorS_DotNet.RTMatrixStructType
  • Temp0 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • Temp1 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • Temp2 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TempCore : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TempValueC : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • Textures : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • TooHighColor : MPSizectorS_DotNet.Utils
  • TooLowColor : MPSizectorS_DotNet.Utils
  • TotalCaptureRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TotalTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TriggerSource : MPSizectorS_DotNet.BasicSettingsStructType
  • TSN : MPSizectorS_DotNet.HeadPackDataInfoStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- u -

  • UserGain : MPSizectorS_DotNet.ExposureSettingsStructType
  • UserRTMatrix : MPSizectorS_DotNet.PostProcessSettingsStructType
  • UserRTMatrixEnableState : MPSizectorS_DotNet.PostProcessSettingsStructType
  • UXmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UXmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmin : MPSizectorS_DotNet.RangeCheckSettingStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- v -

  • ValidPointThreshold0 : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ValidPointThreshold1 : MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- w -

  • Width : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • WorkingMode : MPSizectorS_DotNet.BasicSettingsStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- x -

  • X : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • X0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • XIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • XMax : MPSizectorS_DotNet.DeviceInfoStructType
  • XOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • XPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • XReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- y -

  • Y : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • Y0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • YIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • YMax : MPSizectorS_DotNet.DeviceInfoStructType
  • YOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • YPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • YReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET Programmer's Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all documented variables with links to the class documentation for each member:

- z -

  • Z : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • Z0 : MPSizectorS_DotNet.MonitorZStructType
  • Z0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • Z1 : MPSizectorS_DotNet.MonitorZStructType
  • Z2 : MPSizectorS_DotNet.MonitorZStructType
  • Z3 : MPSizectorS_DotNet.MonitorZStructType
  • ZIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • ZInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ZMax : MPSizectorS_DotNet.DeviceInfoStructType
  • ZOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ZRawData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged


MPSizector .NET Programmer's Manual: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
Here is a list of all documented enums with links to the class documentation for each member:
  • MPModelPolygonType : MPSizectorS_DotNet.MPDisplayer3D
  • MPModelTextureType : MPSizectorS_DotNet.MPDisplayer3D
  • RotateModeEnumType : MPSizectorS_DotNet.MPDisplayer3D


MPSizector .NET Programmer's Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z
Here is a list of all documented properties with links to the class documentation for each member:

- a -

  • AntiLampFlickerMode : MPSizectorS_DotNet.MPSizectorS
  • AntiNoiseLevel : MPSizectorS_DotNet.MPSizectorS
  • AutoHDRAdvanceSettingsEnable : MPSizectorS_DotNet.MPSizectorS
  • AutoSleepDelayMS : MPSizectorS_DotNet.MPSizectorS
  • AutoSleepEnableState : MPSizectorS_DotNet.MPSizectorS
  • AutoTSN : MPSizectorS_DotNet.MPSizectorS

- b -

  • BasicSettings : MPSizectorS_DotNet.MPSizectorS
  • Binning : MPSizectorS_DotNet.MPDisplayer2D
  • BinningState : MPSizectorS_DotNet.MPSizectorS
  • Bitmap : MPSizectorS_DotNet.MPDisplayer2D
  • BurrFilter_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • BurrFilterThreshold0 : MPSizectorS_DotNet.MPSizectorS
  • BurrFilterThreshold1 : MPSizectorS_DotNet.MPSizectorS

- c -

  • CalibParam : MPSizectorS_DotNet.MPSizectorS
  • ColorDepthImageMax : MPSizectorS_DotNet.MPDisplayer3D
  • ColorDepthImageMin : MPSizectorS_DotNet.MPDisplayer3D
  • ConnectionTimeMS : MPSizectorS_DotNet.MPSizectorS
  • CorrectionMode : MPSizectorS_DotNet.MPSizectorS
  • CurPixelCord : MPSizectorS_DotNet.MPDisplayer2D
  • CurrentDeviceInfo : MPSizectorS_DotNet.MPSizectorS
  • CurrentTransferRetryNum : MPSizectorS_DotNet.MPSizectorS
  • CurrentTSN : MPSizectorS_DotNet.MPSizectorS

- d -

  • DataOutMode : MPSizectorS_DotNet.MPSizectorS
  • DataTag : MPSizectorS_DotNet.MPSizectorS
  • DebugRegisters : MPSizectorS_DotNet.MPSizectorS
  • DefaultSettings : MPSizectorS_DotNet.MPSizectorS
  • DeviceState : MPSizectorS_DotNet.MPSizectorS
  • DiffPrejudgePatternEnable : MPSizectorS_DotNet.MPSizectorS

- e -

  • EnableDisplayFilter : MPSizectorS_DotNet.MPDisplayer3D
  • ExpertSettings : MPSizectorS_DotNet.MPSizectorS
  • ExposureBasicSetting : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity2D : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_1st : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_2nd : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_3rd : MPSizectorS_DotNet.MPSizectorS
  • ExposureSettings : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureEnable : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureGain : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureSettings : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeBlue_us : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeGreen_us : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeRed_us : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeWhite_us : MPSizectorS_DotNet.MPSizectorS
  • EXTIO0Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIO1Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIOInput : MPSizectorS_DotNet.MPSizectorS
  • EXTIOOutput : MPSizectorS_DotNet.MPSizectorS

- f -

  • FlipNextBinningStateEnable : MPSizectorS_DotNet.MPSizectorS
  • FlipXEnable : MPSizectorS_DotNet.MPSizectorS
  • FlipYEnable : MPSizectorS_DotNet.MPSizectorS

- g -

  • GeneralSettings : MPSizectorS_DotNet.MPSizectorS

- h -

  • HardwareTSN : MPSizectorS_DotNet.MPSizectorS
  • HasAuxiliaryRGBImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HasAuxiliaryWhiteImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HoldState : MPSizectorS_DotNet.MPSizectorS
  • HWTriggerSeting : MPSizectorS_DotNet.MPSizectorS

- i -

  • ImageOrigin : MPSizectorS_DotNet.MPDisplayer2D
  • IOSettings : MPSizectorS_DotNet.MPSizectorS
  • IsLoaded : MPSizectorS_DotNet.MPDisplayer3D
  • IsValid : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct

- m -

  • MergeNumber : MPSizectorS_DotNet.MPSizectorS
  • MergeParam0 : MPSizectorS_DotNet.MPSizectorS
  • MergeParam1 : MPSizectorS_DotNet.MPSizectorS
  • MergeParam2 : MPSizectorS_DotNet.MPSizectorS
  • MergeParam3 : MPSizectorS_DotNet.MPSizectorS
  • MergeThreshold : MPSizectorS_DotNet.MPSizectorS
  • ModelPolygon : MPSizectorS_DotNet.MPDisplayer3D
  • ModelTexture : MPSizectorS_DotNet.MPDisplayer3D
  • MultiHeadConfig : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarMode : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarRatio : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadSettings : MPSizectorS_DotNet.MPSizectorS

- o -

  • OverExposureFilterThreshold : MPSizectorS_DotNet.MPSizectorS

- p -

  • PatternPeriod1 : MPSizectorS_DotNet.MPSizectorS
  • PatternPeriod2 : MPSizectorS_DotNet.MPSizectorS
  • PointScaleSetting : MPSizectorS_DotNet.MPSizectorS
  • PostProcessSettings : MPSizectorS_DotNet.MPSizectorS
  • PrejudgePatternGain : MPSizectorS_DotNet.MPSizectorS
  • PreProcess_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • PreProcessLoopNum : MPSizectorS_DotNet.MPSizectorS
  • PreProcessThreshold : MPSizectorS_DotNet.MPSizectorS
  • ProjectionMode : MPSizectorS_DotNet.MPSizectorS
  • ProjectionNumber : MPSizectorS_DotNet.MultiHeadSettingsStructType

- r -

  • RangeCheckEnableState : MPSizectorS_DotNet.MPSizectorS
  • RangeCheckSetting : MPSizectorS_DotNet.MPSizectorS
  • ReconstructionSettings : MPSizectorS_DotNet.MPSizectorS
  • ROIHeightRatio : MPSizectorS_DotNet.MPSizectorS
  • ROIWidthRatio : MPSizectorS_DotNet.MPSizectorS
  • ROIX0Ratio : MPSizectorS_DotNet.MPSizectorS
  • ROIY0Ratio : MPSizectorS_DotNet.MPSizectorS
  • RotateAmplitude : MPSizectorS_DotNet.MPDisplayer3D
  • RotateMode : MPSizectorS_DotNet.MPDisplayer3D
  • RotatePhase : MPSizectorS_DotNet.MPDisplayer3D
  • RotateSpeed : MPSizectorS_DotNet.MPDisplayer3D

- s -

  • Screenshot : MPSizectorS_DotNet.MPDisplayer3D
  • SensorExpBaseTime : MPSizectorS_DotNet.MPSizectorS
  • Settings : MPSizectorS_DotNet.MPSizectorS
  • SnapCnt : MPSizectorS_DotNet.MPSizectorS
  • SoftwareTSN : MPSizectorS_DotNet.MPSizectorS
  • SpecularReflection : MPSizectorS_DotNet.MPDisplayer3D
  • StartUpTimeMS : MPSizectorS_DotNet.MPSizectorS
  • States : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo1Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo2Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo3Enable : MPSizectorS_DotNet.MPSizectorS

- t -

  • Temp0 : MPSizectorS_DotNet.MPSizectorS
  • Temp1 : MPSizectorS_DotNet.MPSizectorS
  • Temp2 : MPSizectorS_DotNet.MPSizectorS
  • TempCore : MPSizectorS_DotNet.MPSizectorS
  • TotalCaptureRetryNum : MPSizectorS_DotNet.MPSizectorS
  • TotalTransferRetryNum : MPSizectorS_DotNet.MPSizectorS
  • TransparentBackGroundSnapshot : MPSizectorS_DotNet.MPDisplayer3D
  • TriggerSource : MPSizectorS_DotNet.MPSizectorS

- u -

  • UseNormVector : MPSizectorS_DotNet.MPDisplayer3D
  • UserGain : MPSizectorS_DotNet.MPSizectorS
  • UserRTMatrix : MPSizectorS_DotNet.MPSizectorS
  • UserRTMatrixEnableState : MPSizectorS_DotNet.MPSizectorS

- v -

  • ValidPointThreshold0 : MPSizectorS_DotNet.MPSizectorS
  • ValidPointThreshold1 : MPSizectorS_DotNet.MPSizectorS
  • ValidPointThreshold_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • ViewMatrix : MPSizectorS_DotNet.MPDisplayer3D

- w -

  • WorkingMode : MPSizectorS_DotNet.MPSizectorS

- z -

  • ZMax : MPSizectorS_DotNet.MPSizectorS
  • ZMin : MPSizectorS_DotNet.MPSizectorS
  • Zoom : MPSizectorS_DotNet.MPDisplayer2D


MPSizector .NET Programmer's Manual: Class Members - Events

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
Here is a list of all documented events with links to the class documentation for each member:
  • PixelCordChange : MPSizectorS_DotNet.MPDisplayer2D


MPSizector .NET Programmer's Manual: D:/gitlab-runner/builds/k3GARMtj/0/megaphase/mp3dscontrol/SizectorS_SDK/MPSizectorS_DotNet/obj/Release Directory Reference

  • obj
  • Release
Release Directory Reference


MPSizector .NET Programmer's Manual: D:/gitlab-runner/builds/k3GARMtj/0/megaphase/mp3dscontrol/SizectorS_SDK/MPSizectorS_DotNet/obj Directory Reference

  • obj
obj Directory Reference

Directories

Release


MPSizector .NET Programmer's Manual: D:/gitlab-runner/builds/k3GARMtj/0/megaphase/mp3dscontrol/SizectorS_SDK/MPSizectorS_DotNet/Properties Directory Reference

  • Properties
Properties Directory Reference


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMedianFilterStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType, including all inherited members.

FilterWinSize (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType
Reserved (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetFiltrateStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType, including all inherited members.

filtrateMendPointOnly (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
ParamNeighborCloseLevel (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
ParamNeighborNumLevel (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
ParamWinSize (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType


MPSizector .NET Programmer's Manual: Member List

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMendStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType Member List

This is the complete list of members for MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType, including all inherited members.

Method (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
ParamWinSize (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
ParamWinSize2 (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
Reserved (defined in MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType