MPSizector .NET 编程文档: 盛相科技SizectorS 3D相机 .NET SDK

MPSizector .NET 编程文档 V2.717
  • 首页
  • 类
盛相科技SizectorS 3D相机 .NET SDK

简介

MPSizectorS .NET 提供了基于.NET Framework环境的类库。它同提供了托管和非托管两套接口，在托管环境下，还提供了诸如3D显示控件、3D数据后处理、数据格式转换等便利的功能

通过调用MPSizectorS .NET，您可以实现以下功能：

    ●设备实例的产生
    ●设备枚举和连接
    ●设备参数设置
    ●设备拍摄控制及数据获取
    ●设备IO控制
    ●3D模型显示
    ●3D数据后处理
    ●数据转换及文件操作

我们编写了一些基于MPSizectorS .NET编写的 C# 程序，演示如何实现MPSizectorS .NET的主要功能。详见示例代码目录。

我们撰写了一些专题，对设备及SDK的工作机理进行了描述性的说明，强烈建议您在开始编写代码之前阅读所有的专题文章，这将加快您的开发进程。请点击 Related Pages 查看。

文件

MPSizectorS .NET 包含以下文件：

    ●MPSizectorS_DotNet.dll - MPSizectorS .NET 动态链接库
    ●MPSizectorS_DotNetUI.dll - 界面控件动态链接库
    ●MPMeasure.dll - 开源测量工具动态链接库
    ●MathNet.Numerics.dll - MPMeasure.dll依赖的数学工具动态链接库
    ●EPPlus.dll - MPMeasure.dll依赖的表格工具动态链接库
    ●MPSizectorS_API.dll - MPSizectorS API 动态链接库
    ●OpenTK.dll - 3D显示动态链接库
    ●OpenTK.GLControl.dll - 3D显示动态链接库

请将以上文件一同拷贝到执行目录下，并将 MPSizectorS_DotNet.dll 添加至引用。

环境

Windows 7或以上版本的64位操作系统，以x64为目标计算机架构编写应用程序。

Visual C++ Redistributable for Visual Studio 2012 Update 4 (在安装MPSizector SDK时自动安装, 但用户发布应用程序时应考虑该运行库的安装情况)

.NET Framework 4.0(在安装MPSizector SDK时自动安装, 但用户发布应用程序时应考虑该运行库的安装情况)

必须安装3D相机驱动程序

版权

Copyright © 2014 - 2018 Mega Phase Industrial Inspection(Shanghai) Co., Ltd. All Rights Reserved.

制作者 doxygen 1.10.0


MPSizector .NET 编程文档: 包成员

  • 全部
  • 枚举
这里列出了所有文档化的命名空间成员，并附带其所属的文件:
  • AntiLampFlickerModeType : MPSizectorS_DotNet
  • Auxiliary2DType : MPSizectorS_DotNet
  • BayerTransferType : MPSizectorS_DotNet
  • DataFormatType : MPSizectorS_DotNet
  • DataOutModeType : MPSizectorS_DotNet
  • DeviceStateType : MPSizectorS_DotNet
  • DumpContentType : MPSizectorS_DotNet
  • ExposureModeType : MPSizectorS_DotNet
  • ExpROIPropertyType : MPSizectorS_DotNet
  • ExpROIShapeType : MPSizectorS_DotNet
  • InterfaceType : MPSizectorS_DotNet
  • LogMediaType : MPSizectorS_DotNet
  • MPSizectorS_HardwarePreprocessModeType : MPSizectorS_DotNet
  • MultiHeadConfigType : MPSizectorS_DotNet
  • OutputPinModeType : MPSizectorS_DotNet
  • SoftwarePostProcessType : MPSizectorS_DotNet
  • TemperatureFeedBackStateType : MPSizectorS_DotNet
  • TriggerSourceType : MPSizectorS_DotNet
  • TSNSourceType : MPSizectorS_DotNet
  • ValidMaskType : MPSizectorS_DotNet
  • WorkingModeType : MPSizectorS_DotNet


MPSizector .NET 编程文档: 包成员

  • 全部
  • 枚举
  • AntiLampFlickerModeType : MPSizectorS_DotNet
  • Auxiliary2DType : MPSizectorS_DotNet
  • BayerTransferType : MPSizectorS_DotNet
  • DataFormatType : MPSizectorS_DotNet
  • DataOutModeType : MPSizectorS_DotNet
  • DeviceStateType : MPSizectorS_DotNet
  • DumpContentType : MPSizectorS_DotNet
  • ExposureModeType : MPSizectorS_DotNet
  • ExpROIPropertyType : MPSizectorS_DotNet
  • ExpROIShapeType : MPSizectorS_DotNet
  • InterfaceType : MPSizectorS_DotNet
  • LogMediaType : MPSizectorS_DotNet
  • MPSizectorS_HardwarePreprocessModeType : MPSizectorS_DotNet
  • MultiHeadConfigType : MPSizectorS_DotNet
  • OutputPinModeType : MPSizectorS_DotNet
  • SoftwarePostProcessType : MPSizectorS_DotNet
  • TemperatureFeedBackStateType : MPSizectorS_DotNet
  • TriggerSourceType : MPSizectorS_DotNet
  • TSNSourceType : MPSizectorS_DotNet
  • ValidMaskType : MPSizectorS_DotNet
  • WorkingModeType : MPSizectorS_DotNet


MPSizector .NET 编程文档: 类列表

  • 类列表
  • 类索引
  • 类继承关系
  • 类成员
类列表
这里列出了所有类、结构、联合以及接口定义等，并附带简要说明:
[详情级别 123]
▼N MPSizectorS_DotNet
C AutoHDRResultStructType | 自动HDR的计算结果反馈结构体。该结构体的信息由设备产生，并通过head pack发回至用户端。
C BasicSettingsStructType | 基础设置结构体。
C CalibParamStructType | 标定参数结构体。
C ColorDepthRangeStruct | 深度色谱范围设置结构体。
C CompensationStructType | 补偿结构体。
C CorrectDistortionParamStructType
C DataPointFix3DStruct | 定点数格式3D数据点结构体。
C DataPointFixZMapStruct | 定点数深度图格式3D数据点结构体。
C DataPointFloat3DStruct | 浮点数格式3D数据点结构体。
C DebugInfoStruct | 调试寄存器数组信息结构体。厂商调试用途。
C DeviceInfoStructType | 用于存储设备信息的结构体。
C ExpertSettingsStructType | 专业设置的结构体。
C ExposureBasicSettingStructType | 基础曝光设置。
C ExposureSettingsStructType | 曝光设置结构体。
C ExpROIStructType | 曝光区域的结构体。
C Extension
C ExternalExposureSettingsStructType | 外部光源的曝光设置结构体。
C FlipEnableStructType | 翻转参数。
C GeneralSettingsStructType | 通用设置结构体。
C HardwarePreprocessModeListStructType | 硬件预处理模式列表结构体。
C HardwareTimeStampsStructType | 硬件时间戳的结构体。
C HeadDebugInfoStructType | 调试信息结构体，由设备产生并通过head pack发送至PC。该结构体是StatesStructType的简略版本。
C HeadPackDataInfoStructType | 数据信息结构体，在head pack中使用。
C HeadPackStructType | Head pack结构体。它被频繁且规律地发送回PC，并且被包含在每一个数据帧之中。
C HWTriggerSettingStructType | 硬件触发设置结构体。
C IOSettingsStructType | IO设置结构个体
C LinearTemperatureDriftCompensationStructType | 线性温漂补偿参数结构体。
C ManagedDataFrame2DStruct | 托管的2D数据帧结构体。
C ManagedDataFrameFix3DStruct | 托管定点数格式的3D数据帧结构体。
C ManagedDataFrameFixZMapSimpleStruct | 托管的简化的定点数深度图的3D数据帧结构体。
C ManagedDataFrameFixZMapStruct | 托管定点数深度图的3D数据帧结构体。
C ManagedDataFrameFloat3DStruct | 托管浮点数格式的3D数据帧结构体。
C MonitorPositionStructType | 监视位置。
C MonitorZStructType | 监视高度。
C MPDisplayer2D | 2D图像显示控件。
▼C MPDisplayer3D | 3D模型显示控件
C ViewMatrixStruct | 视角及物体姿态矩阵结构。
C MPSizectorS
C MPSizectorS_AutoHDRAdvanceSettingsStructType | 自动HDR高级设置结构体。
C MPSizectorS_ExpICoefSettingsStructType | 曝光系数设置结构体。
C MultiHeadSettingsStructType | 多头重构设置结构体。
C OutputPinSettingStructType | 输出引脚设置结构体（单个PIN脚的设置）。
C PartialFactorySettingsStructType | 部分工厂设置结构体。
C PointScaleSettingStructType 定点数映射设置结构体。用于在浮点数和定点数点云之间转换。
例：浮点数和定点数格式的X值关系如下：XFloat = XIncrement * XFixedPoint + X0Pos
C PostProcessSettingsStructType | 后处理设置结构体。
▼C Process
C RotatedRectangle
C RangeCheckSettingStructType | 由用户指定的范围检查设置结构体。包含了X, Y, Z轴的有效范围信息。
C RangeImageManaged 托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C RangeImageUnmanaged 非托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C ReconstructionSettingsStructType | 重构设置结构体。
C RTMatrixStructType | 旋转平移矩阵结构体。
C SettingsStructType | 所有设置的结构体。
C SoftwarePostProcessSetting | 软件后处理结构体。
▼C SoftwarePreprocessListRegisters | 软件预处理列表结构体。
C PreprocessStructType
▼C SoftwarePreprocessPresetParamListStructType | 软件预处理预设参数列表结构体。
C PreprocessPresetFiltrateStructType
C PreprocessPresetMedianFilterStructType
C PreprocessPresetMendStructType
C PreprocessPresetRemoveBurrsStructType
C PreprocessPresetStructType
C StatesStructType | 所有设备状态信息的结构体
C SuppressExpParamsEnableStructType | 曝光抑制参数。
C TemperatureFeedbackStructType | 温度反馈信息结构体。
C TSNStructType | TSN信息结构体。标示了一个有效的触发信号的信号来源，及其序列号。
C UnmanagedDataFrame2DStruct | 非托管的2D数据帧结构体。
C UnmanagedDataFrameFix3DStruct | 非托管定点数格式的3D数据帧结构体。
C UnmanagedDataFrameFixZMapSimpleStruct | 非托管的简化的定点数深度图的3D数据帧结构体。
C UnmanagedDataFrameFixZMapStruct | 非托管定点数深度图的3D数据帧结构体。
C UnmanagedDataFrameFloat3DStruct | 非托管浮点数格式的3D数据帧结构体。
C UnmanagedDataFrameUndefinedStruct | 非托管的未定义格式数据帧结构体。该类型为数据回调提供的唯一数据类型，它是一种中间数据格式，用于避免采用多个回调函数传递不同格式的数据。
C Utils


MPSizector .NET 编程文档: MPSizectorS_DotNet 命名空间参考

类 | 枚举
MPSizectorS_DotNet 命名空间参考

类

struct | AutoHDRResultStructType
自动HDR的计算结果反馈结构体。该结构体的信息由设备产生，并通过head pack发回至用户端。 更多...
struct | BasicSettingsStructType
基础设置结构体。 更多...
struct | CalibParamStructType
标定参数结构体。 更多...
struct | ColorDepthRangeStruct
深度色谱范围设置结构体。 更多...
struct | CompensationStructType
补偿结构体。 更多...
struct | CorrectDistortionParamStructType
struct | DataPointFix3DStruct
定点数格式3D数据点结构体。 更多...
struct | DataPointFixZMapStruct
定点数深度图格式3D数据点结构体。 更多...
struct | DataPointFloat3DStruct
浮点数格式3D数据点结构体。 更多...
struct | DebugInfoStruct
调试寄存器数组信息结构体。厂商调试用途。 更多...
struct | DeviceInfoStructType
用于存储设备信息的结构体。 更多...
struct | ExpertSettingsStructType
专业设置的结构体。 更多...
struct | ExposureBasicSettingStructType
基础曝光设置。 更多...
struct | ExposureSettingsStructType
曝光设置结构体。 更多...
struct | ExpROIStructType
曝光区域的结构体。 更多...
class | Extension
struct | ExternalExposureSettingsStructType
外部光源的曝光设置结构体。 更多...
struct | FlipEnableStructType
翻转参数。 更多...
struct | GeneralSettingsStructType
通用设置结构体。 更多...
struct | HardwarePreprocessModeListStructType
硬件预处理模式列表结构体。 更多...
struct | HardwareTimeStampsStructType
硬件时间戳的结构体。 更多...
struct | HeadDebugInfoStructType
调试信息结构体，由设备产生并通过head pack发送至PC。该结构体是StatesStructType的简略版本。 更多...
struct | HeadPackDataInfoStructType
数据信息结构体，在head pack中使用。 更多...
struct | HeadPackStructType
head pack结构体。它被频繁且规律地发送回PC，并且被包含在每一个数据帧之中。 更多...
struct | HWTriggerSettingStructType
硬件触发设置结构体。 更多...
struct | InternalCalibParam
使用Mat3和Point3表示RT矩阵的标定参数，方便计算；仅内部使用
struct | IOSettingsStructType
IO设置结构个体 更多...
struct | LinearTemperatureDriftCompensationStructType
线性温漂补偿参数结构体。 更多...
struct | ManagedDataFrame2DStruct
托管的2D数据帧结构体。 更多...
struct | ManagedDataFrameFix3DStruct
托管定点数格式的3D数据帧结构体。 更多...
struct | ManagedDataFrameFixZMapSimpleStruct
托管的简化的定点数深度图的3D数据帧结构体。 更多...
struct | ManagedDataFrameFixZMapStruct
托管定点数深度图的3D数据帧结构体。 更多...
struct | ManagedDataFrameFloat3DStruct
托管浮点数格式的3D数据帧结构体。 更多...
class | Mat3
3x3矩阵类
struct | MonitorPositionStructType
监视位置。 更多...
struct | MonitorZStructType
监视高度。 更多...
class | MPDisplayer2D
2D图像显示控件。 更多...
class | MPDisplayer3D
3D模型显示控件 更多...
class | MPSizectorS
struct | MPSizectorS_AutoHDRAdvanceSettingsStructType
自动HDR高级设置结构体。 更多...
struct | MPSizectorS_ExpICoefSettingsStructType
曝光系数设置结构体。 更多...
struct | MultiHeadSettingsStructType
多头重构设置结构体。 更多...
struct | OutputPinSettingStructType
输出引脚设置结构体（单个PIN脚的设置）。 更多...
struct | PartialFactorySettingsStructType
部分工厂设置结构体。 更多...
class | Point3
三维点类
struct | PointScaleSettingStructType
定点数映射设置结构体。用于在浮点数和定点数点云之间转换。
例：浮点数和定点数格式的X值关系如下：XFloat = XIncrement * XFixedPoint + X0Pos 更多...
struct | PostProcessSettingsStructType
后处理设置结构体。 更多...
class | Process
struct | RangeCheckSettingStructType
由用户指定的范围检查设置结构体。包含了X, Y, Z轴的有效范围信息。 更多...
struct | RangeImageManaged
托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width] 更多...
struct | RangeImageUnmanaged
非托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width] 更多...
struct | ReconstructionSettingsStructType
重构设置结构体。 更多...
struct | RTMatrixStructType
旋转平移矩阵结构体。 更多...
struct | SettingsStructType
所有设置的结构体。 更多...
struct | SoftwarePostProcessSetting
软件后处理结构体。 更多...
struct | SoftwarePreprocessListRegisters
软件预处理列表结构体。 更多...
struct | SoftwarePreprocessPresetParamListStructType
软件预处理预设参数列表结构体。 更多...
struct | StatesStructType
所有设备状态信息的结构体 更多...
struct | SuppressExpParamsEnableStructType
曝光抑制参数。 更多...
struct | TemperatureFeedbackStructType
温度反馈信息结构体。 更多...
struct | TSNStructType
TSN信息结构体。标示了一个有效的触发信号的信号来源，及其序列号。 更多...
struct | UnmanagedDataFrame2DStruct
非托管的2D数据帧结构体。 更多...
struct | UnmanagedDataFrameFix3DStruct
非托管定点数格式的3D数据帧结构体。 更多...
struct | UnmanagedDataFrameFixZMapSimpleStruct
非托管的简化的定点数深度图的3D数据帧结构体。 更多...
struct | UnmanagedDataFrameFixZMapStruct
非托管定点数深度图的3D数据帧结构体。 更多...
struct | UnmanagedDataFrameFloat3DStruct
非托管浮点数格式的3D数据帧结构体。 更多...
struct | UnmanagedDataFrameUndefinedStruct
非托管的未定义格式数据帧结构体。该类型为数据回调提供的唯一数据类型，它是一种中间数据格式，用于避免采用多个回调函数传递不同格式的数据。 更多...
class | Utils

枚举

enum | LogMediaType { Off = 0 , Console = 1 , File = 2 , CallBack = 3 }
日志输出媒介枚举。作为设备类的构造函数参数 更多...
enum DeviceStateType {
Disconnected = 0 , UnderInit = 1 , StandBy = 2 , UnderExposure = 3 ,
UnderTransfer = 4
}
设备状态枚举。 更多...
enum | MultiHeadConfigType { SingleHead = 0 , TwoHead = 1 , FourHead = 2 }
多头配置枚举。 更多...
enum | InterfaceType { NULL = 0 , U2 = 1 , U3 = 2 }
设备连接接口类型枚举。 更多...
enum DataFormatType {
FloatPointCloud = 0 , FixPointCloud = 1 , FixZMap = 3 , FixZMapSimple = 5 ,
Image2D = 8
}
数据格式枚举。 更多...
enum | TSNSourceType { Soft = 0 , Auto = 1 , Hard = 2 }
触发信号来源枚举 更多...
enum WorkingModeType {
Fast3D = 0 , Standard3D = 1 , Precise3D = 2 , SuperPrecise3D = 3 ,
White2D = 4 , Black2D = 5 , Grid2D = 6 , ExposurePrediction2D = 7 ,
SuperFast3D = 8 , FastPrecision3D = 9 , SuperDynamic3D = 10
}
设备工作模式枚举。 更多...
enum | TriggerSourceType { SoftTriggerOnly = 0 , KeepRunning = 1 , HardTriggerI0 = 2 , HardTriggerI1 = 3 }
触发源枚举。 更多...
enum | ExposureModeType { Manual = 0 , ManualRepeat = 1 , AutoNHDR = 2 , AutoPHDR = 3 }
曝光模式枚举。 更多...
enum | DataOutModeType { FloatPointCloud = 0 , FixPointCloud = 1 , FixZMap = 3 , FixZMapSimple = 5 }
3D数据输出模式枚举。 更多...
enum OutputPinModeType {
UserControlled = 0 , InitDone = 1 , UnderExposure = 2 , Busy = 3 ,
TriggerExternalExposure = 4
}
输出引脚模式枚举。 更多...
enum | TemperatureFeedBackStateType { InRange = 0 , TooHigh = 1 , TooLow = 2 }
温度反馈状态枚举。 更多...
enum | ExpROIShapeType { Rect = 0 , Circle = 1 }
曝光区域形状枚举。
enum | ExpROIPropertyType { Negative = 0 , Positive = 1 }
曝光区域极性枚举。
enum | AntiLampFlickerModeType { Off = 0 , Hz50 = 1 , Hz60 = 2 }
抗频闪模式枚举。
enum SoftwarePostProcessType {
RangeCheck , RemoveBurrs , Mend , Filtrate ,
Spi , SpiChannel3 , PlaneCorrection , MendByFeature ,
SegmentMedianFilter , MendByRegion
}
后处理类型枚举。
enum ValidMaskType {
OK = 0 , OverExposure = 1 , ReconFail = 2 , OverOfRange = 3 ,
Overflow = 4 , MaximumVal = 5
}
数据有效性掩码枚举。 更多...
enum Auxiliary2DType {
Gray = 0 , W = 1 , R = 2 , G = 3 ,
B = 4 , RGB = 5
}
辅助2D图类型枚举。 更多...
enum | MPSizectorS_HardwarePreprocessModeType { MPSizectorS_HardwarePreprocessModeType_Weak = 0 , MPSizectorS_HardwarePreprocessModeType_Normal = 1 , MPSizectorS_HardwarePreprocessModeType_Strong = 2 , MPSizectorS_HardwarePreprocessModeType_Custom = 3 }
硬件预处理参数类型枚举。
enum | DumpContentType { Basic = 0 , Normal = 1 , Expert = 2 }
Dump存储内容类型枚举。
enum | BayerTransferType { RGGB = 0 , GBRG = 1 }
Bayer转换排序类型枚举。

枚举类型说明

◆ Auxiliary2DType

enum MPSizectorS_DotNet.Auxiliary2DType

辅助2D图类型枚举。

枚举值
Gray | 灰度。
W | 白色。
R | 红色。
G | 绿色。
B | 蓝色。
RGB | 彩色。

◆ DataFormatType

enum MPSizectorS_DotNet.DataFormatType

数据格式枚举。

枚举值
FloatPointCloud | 浮点数点云，每个点占用16字节。
FixPointCloud | 定点数点云，每个点占用8字节。
FixZMap | 定点数深度图数据模式。没有X,Y的信息，Z通过16位定点数表示。
FixZMapSimple | 简化的定点数深度图数据模式。没有X,Y以及灰度和掩码的信息，Z通过16位定点数表示。
Image2D | 2D图像，每个像素占用1字节。

◆ DataOutModeType

enum MPSizectorS_DotNet.DataOutModeType

3D数据输出模式枚举。

枚举值
FloatPointCloud | 浮点数点云3D数据模式。X,Y,Z分别通过32位浮点数表示。
FixPointCloud | 定点数点云3D数据模式。X,Y,Z分别通过16位定点数表示。
FixZMap | 定点数深度图数据模式。没有X,Y的信息，Z通过16位定点数表示。
FixZMapSimple | 简化的定点数深度图数据模式。没有X,Y以及灰度和掩码的信息，Z通过16位定点数表示。

◆ DeviceStateType

enum MPSizectorS_DotNet.DeviceStateType

设备状态枚举。

枚举值
Disconnected | 设备未连接。
UnderInit | 设备正在初始化。
StandBy | 设备处于待命状态，可进行一次新的拍摄。
UnderExposure | 设备正在曝光。
UnderTransfer | 设备正在传输数据。

◆ ExposureModeType

enum MPSizectorS_DotNet.ExposureModeType

曝光模式枚举。

枚举值
Manual | 手动曝光模式。采用固定的曝光次数和曝光强度。在3D工作模式下，当曝光次数大于1，3D数据为HDR融合的结果。
ManualRepeat | 手动重复曝光模式。采用曝光强度1进行指定次数的重复拍摄。最终输出的3D数据为多次拍摄得到的多个3D数据的平均值。2D工作模式下不适用。
AutoNHDR | 自动NHDR曝光模式。设备根据指定的曝光次数自动决定曝光强度。2D工作模式下不适用。
AutoPHDR | 自动PHDR曝光模式。设备根据指定的3D成像质量阈值

◆ InterfaceType

enum MPSizectorS_DotNet.InterfaceType

设备连接接口类型枚举。

枚举值
NULL | 空类型，当未连接时或连接接口类型未确定时使用。
U2 | 连接接口为USB2.0。
U3 | 连接接口为USB3.0。

◆ LogMediaType

enum MPSizectorS_DotNet.LogMediaType

日志输出媒介枚举。作为设备类的构造函数参数

枚举值
Off | 无日志输出
Console | 当运行控制台程序时，将日志在控制台中打印输出。
File | 将日志存储在可执行文件同目录下的日志文件中。
CallBack | 将日志通过回调函数传递给客户处理。

◆ MultiHeadConfigType

enum MPSizectorS_DotNet.MultiHeadConfigType

多头配置枚举。

枚举值
SingleHead | 单头。
TwoHead | 两头。
FourHead | 四头。

◆ OutputPinModeType

enum MPSizectorS_DotNet.OutputPinModeType

输出引脚模式枚举。

枚举值
UserControlled | 由用户控制。输出值由用户控制的寄存器决定。
InitDone | 输出信号为初始化状态。对于正极性，1表示初始化完成。
UnderExposure | 输出信号为正在曝光状态。对于正极性，1表示正在曝光。
Busy | 输出信号为忙状态。对于正极性，1表示设备正忙。与正在曝光不同，当设备正在传输数据时，忙状态也为1。
TriggerExternalExposure | 输出触发外部光源的信号。取决于外部曝光的使能设置：如果使能了白光，将输出相应一个曝光触发信号；如果使能RGB，则输出相应连续3个曝光触发信号；如果同时使能白光和RGB，则输出相应连续4个曝光触发信号； 如果没有使能任何外部曝光，则无输出。

◆ TemperatureFeedBackStateType

enum MPSizectorS_DotNet.TemperatureFeedBackStateType

温度反馈状态枚举。

枚举值
InRange | 温度在范围内。
TooHigh | 温度过高。
TooLow | 温度过低。

◆ TriggerSourceType

enum MPSizectorS_DotNet.TriggerSourceType

触发源枚举。

枚举值
SoftTriggerOnly | 仅接收软件触发。
KeepRunning | 连续拍摄，当一次拍摄完成后自动开始下一次拍摄。
HardTriggerI0 | 通过硬件引脚I0触发或软件触发。
HardTriggerI1 | 通过硬件引脚I1触发或软件触发。

◆ TSNSourceType

enum MPSizectorS_DotNet.TSNSourceType

触发信号来源枚举

枚举值
Soft | 触发引号由软件触发产生。
Auto | 触发信号由自动触发产生（工作在连续拍摄模式下）。
Hard | 触发信号由外部硬件引脚产生。

◆ ValidMaskType

enum MPSizectorS_DotNet.ValidMaskType

数据有效性掩码枚举。

枚举值
OK | 有效点。
OverExposure | 过曝光。
ReconFail | 重构失败，可能是多次反射造成，也可能是过暗造成，也可能是该点在景深范围内没有物体。
OverOfRange | 被范围检查功能判定为超过范围。
Overflow | 输出定点数点云时，定点数数据超过的0~65535的定点数表达范围。
MaximumVal | 数据值超过了设备可能的探测范围，有可能是错误的数据。

◆ WorkingModeType

enum MPSizectorS_DotNet.WorkingModeType

设备工作模式枚举。

枚举值
Fast3D | 快速3D模式。
Standard3D | 标准3D模式。
Precise3D | 精准3D模式。
SuperPrecise3D | 超准3D模式。
White2D | 全白照明2D模式。
Black2D | 无照明2D模式。
Grid2D | 带有网格图案投影的2D模式。
ExposurePrediction2D | 曝光强度预测图。
SuperDynamic3D | 超动态。


MPSizector .NET 编程文档: MPSizectorS_DotNet.AutoHDRResultStructType结构体 参考

  • 类成员
  • MPSizectorS_DotNet
  • AutoHDRResultStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.AutoHDRResultStructType结构体 参考

自动HDR的计算结果反馈结构体。该结构体的信息由设备产生，并通过head pack发回至用户端。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | IsUsingAutoHDRResult
自动HDR结果是否被运用到当前拍摄。
byte | ExposureNum
曝光次数。提示了下列第1，2，3曝光强度的有效状态。当处于自动PHDR模式时，该值也是由设备自主产生。
float | AutoHDR_ExposureIntensity3D_1st
自动HDR得到的第1曝光强度，有效范围为[0, 100]。
float | AutoHDR_ExposureIntensity3D_2nd
自动HDR得到的第2曝光强度，有效范围为[0, 100]。
float | AutoHDR_ExposureIntensity3D_3rd
自动HDR得到的第3曝光强度，有效范围为[0, 100]。
byte | Score
自动HDR得到的曝光设置的预估得分。有效范围为[0, 100]。

属性

byte | _IsUsingAutoHDRResult [get]
byte | _ExposureNum [get]
float | _AutoHDR_ExposureIntensity3D_1st [get]
float | _AutoHDR_ExposureIntensity3D_2nd [get]
float | _AutoHDR_ExposureIntensity3D_3rd [get]
byte | _Score [get]

详细描述

自动HDR的计算结果反馈结构体。该结构体的信息由设备产生，并通过head pack发回至用户端。


MPSizector .NET 编程文档: 成员列表

  • AutoHDRResultStructType
MPSizectorS_DotNet.AutoHDRResultStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.AutoHDRResultStructType,包括所有继承而来的类成员

_AutoHDR_ExposureIntensity3D_1st (定义于 MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_AutoHDR_ExposureIntensity3D_2nd (定义于 MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_AutoHDR_ExposureIntensity3D_3rd (定义于 MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_ExposureNum (定义于 MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_IsUsingAutoHDRResult (定义于 MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
_Score (定义于 MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType
AutoHDR_ExposureIntensity3D_1st | MPSizectorS_DotNet.AutoHDRResultStructType
AutoHDR_ExposureIntensity3D_2nd | MPSizectorS_DotNet.AutoHDRResultStructType
AutoHDR_ExposureIntensity3D_3rd | MPSizectorS_DotNet.AutoHDRResultStructType
ExposureNum | MPSizectorS_DotNet.AutoHDRResultStructType
IsUsingAutoHDRResult | MPSizectorS_DotNet.AutoHDRResultStructType
Score | MPSizectorS_DotNet.AutoHDRResultStructType
ToString() (定义于 MPSizectorS_DotNet.AutoHDRResultStructType) | MPSizectorS_DotNet.AutoHDRResultStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.BasicSettingsStructType结构体 参考

  • BasicSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.BasicSettingsStructType结构体 参考

基础设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

WorkingModeType | WorkingMode
工作模式。
byte | HoldState
暂停状态。为true时，设备将忽略所有触发信号，不进入下一次拍摄。
byte | BinningState
像素合并状态。为true时，设备将工作在低分辨率模式（如果该设备具备此功能）。
byte | ROIX0Ratio
ROI X起始点。设置ROI X起始点在横向像素中的比值，取值范围为[0, 255]，0为最小像素，255为最大像素。
byte | ROIY0Ratio
ROI Y起始点。设置ROI Y起始点在竖向像素中的比值，取值范围为[0, 255]，0为最小像素，255为最大像素。
byte | ROIWidthRatio
ROI宽度。设置ROI宽度占横向像素中的比值，取值范围为[0, 255]，0为最少像素，255为全部像素。
byte | ROIHeightRatio
ROI高度。设置ROI高度占竖向像素中的比值，取值范围为[0, 255]，0为最少像素，255为全部像素。
TriggerSourceType | TriggerSource
触发源。

属性

WorkingModeType | _WorkingMode [get]
byte | _HoldState [get]
byte | _BinningState [get]
byte | _ROIX0Ratio [get]
byte | _ROIY0Ratio [get]
byte | _ROIWidthRatio [get]
byte | _ROIHeightRatio [get]
TriggerSourceType | _TriggerSource [get]

详细描述

基础设置结构体。


MPSizector .NET 编程文档: 成员列表

  • BasicSettingsStructType
MPSizectorS_DotNet.BasicSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.BasicSettingsStructType,包括所有继承而来的类成员

_BinningState (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_HoldState (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIHeightRatio (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIWidthRatio (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIX0Ratio (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_ROIY0Ratio (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_TriggerSource (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
_WorkingMode (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
BinningState | MPSizectorS_DotNet.BasicSettingsStructType
HoldState | MPSizectorS_DotNet.BasicSettingsStructType
ROIHeightRatio | MPSizectorS_DotNet.BasicSettingsStructType
ROIWidthRatio | MPSizectorS_DotNet.BasicSettingsStructType
ROIX0Ratio | MPSizectorS_DotNet.BasicSettingsStructType
ROIY0Ratio | MPSizectorS_DotNet.BasicSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.BasicSettingsStructType) | MPSizectorS_DotNet.BasicSettingsStructType
TriggerSource | MPSizectorS_DotNet.BasicSettingsStructType
WorkingMode | MPSizectorS_DotNet.BasicSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.CalibParamStructType结构体 参考

  • CalibParamStructType
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.CalibParamStructType结构体 参考

标定参数结构体。 更多...

Public 属性

uint | CalibDate
标定日期。
float | CF1
相机侧焦距除以Sx,单位毫米。
float | CF2
相机侧焦距除以Sy,单位毫米。
float | CC1
相机侧图像中主点的X坐标。
float | CC2
相机侧图像中主点的Y坐标。
float | CSx
相机侧传感器上两个相邻单元之间的水平距离。
float | CSy
相机侧传感器上两个相邻单元之间的垂直距离。
float | CKappa
相机侧畸变系数，用于模拟径向镜头的畸变。
float | CR00
相机侧旋转矩阵参数
float | CR01
相机侧旋转矩阵参数
float | CR02
相机侧旋转矩阵参数
float | CR10
相机侧旋转矩阵参数
float | CR11
相机侧旋转矩阵参数
float | CR12
相机侧旋转矩阵参数
float | CR20
相机侧旋转矩阵参数
float | CR21
相机侧旋转矩阵参数
float | CR22
相机侧旋转矩阵参数
float | CT0
相机侧X方向偏移量
float | CT1
相机侧Y方向偏移量
float | CT2
相机侧Z方向偏移量
float[] | PF1
投影侧焦距除以Sx,单位毫米。
float[] | PF2
投影侧焦距除以Sy,单位毫米。
float[] | PC1
投影侧图像中主点的X坐标。
float[] | PC2
投影侧图像中主点的Y坐标。
float[] | PSx
投影侧传感器上两个相邻单元之间的水平距离。
float[] | PSy
投影侧传感器上两个相邻单元之间的垂直距离。
float[] | PKappa
投影侧畸变系数，用于模拟径向镜头的畸变。
float[] | PR00
投影侧旋转矩阵参数
float[] | PR01
投影侧旋转矩阵参数
float[] | PR02
投影侧旋转矩阵参数
float[] | PR10
投影侧旋转矩阵参数
float[] | PR11
投影侧旋转矩阵参数
float[] | PR12
投影侧旋转矩阵参数
float[] | PR20
投影侧旋转矩阵参数
float[] | PR21
投影侧旋转矩阵参数
float[] | PR22
投影侧旋转矩阵参数
float[] | PT0
投影侧X方向偏移量
float[] | PT1
投影侧Y方向偏移量
float[] | PT2
投影侧Z方向偏移量

属性

uint | _CalibDate [get, set]
float | _CF1 [get, set]
float | _CF2 [get, set]
float | _CC1 [get, set]
float | _CC2 [get, set]
float | _CSx [get, set]
float | _CSy [get, set]
float | _CKappa [get, set]
float | _CR00 [get, set]
float | _CR01 [get, set]
float | _CR02 [get, set]
float | _CR10 [get, set]
float | _CR11 [get, set]
float | _CR12 [get, set]
float | _CR20 [get, set]
float | _CR21 [get, set]
float | _CR22 [get, set]
float | _CT0 [get, set]
float | _CT1 [get, set]
float | _CT2 [get, set]
float[] | _PF1 [get, set]
float[] | _PF2 [get, set]
float[] | _PC1 [get, set]
float[] | _PC2 [get, set]
float[] | _PSx [get, set]
float[] | _PSy [get, set]
float[] | _PKappa [get, set]
float[] | _PR00 [get, set]
float[] | _PR01 [get, set]
float[] | _PR02 [get, set]
float[] | _PR10 [get, set]
float[] | _PR11 [get, set]
float[] | _PR12 [get, set]
float[] | _PR20 [get, set]
float[] | _PR21 [get, set]
float[] | _PR22 [get, set]
float[] | _PT0 [get, set]
float[] | _PT1 [get, set]
float[] | _PT2 [get, set]

详细描述

标定参数结构体。


MPSizector .NET 编程文档: 成员列表

  • CalibParamStructType
MPSizectorS_DotNet.CalibParamStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.CalibParamStructType,包括所有继承而来的类成员

_CalibDate (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CC1 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CC2 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CF1 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CF2 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CKappa (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR00 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR01 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR02 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR10 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR11 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR12 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR20 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR21 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CR22 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CSx (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CSy (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CT0 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CT1 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_CT2 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PC1 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PC2 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PF1 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PF2 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PKappa (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR00 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR01 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR02 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR10 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR11 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR12 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR20 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR21 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PR22 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PSx (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PSy (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PT0 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PT1 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
_PT2 (定义于 MPSizectorS_DotNet.CalibParamStructType) | MPSizectorS_DotNet.CalibParamStructType
CalibDate | MPSizectorS_DotNet.CalibParamStructType
CC1 | MPSizectorS_DotNet.CalibParamStructType
CC2 | MPSizectorS_DotNet.CalibParamStructType
CF1 | MPSizectorS_DotNet.CalibParamStructType
CF2 | MPSizectorS_DotNet.CalibParamStructType
CKappa | MPSizectorS_DotNet.CalibParamStructType
CR00 | MPSizectorS_DotNet.CalibParamStructType
CR01 | MPSizectorS_DotNet.CalibParamStructType
CR02 | MPSizectorS_DotNet.CalibParamStructType
CR10 | MPSizectorS_DotNet.CalibParamStructType
CR11 | MPSizectorS_DotNet.CalibParamStructType
CR12 | MPSizectorS_DotNet.CalibParamStructType
CR20 | MPSizectorS_DotNet.CalibParamStructType
CR21 | MPSizectorS_DotNet.CalibParamStructType
CR22 | MPSizectorS_DotNet.CalibParamStructType
CSx | MPSizectorS_DotNet.CalibParamStructType
CSy | MPSizectorS_DotNet.CalibParamStructType
CT0 | MPSizectorS_DotNet.CalibParamStructType
CT1 | MPSizectorS_DotNet.CalibParamStructType
CT2 | MPSizectorS_DotNet.CalibParamStructType
PC1 | MPSizectorS_DotNet.CalibParamStructType
PC2 | MPSizectorS_DotNet.CalibParamStructType
PF1 | MPSizectorS_DotNet.CalibParamStructType
PF2 | MPSizectorS_DotNet.CalibParamStructType
PKappa | MPSizectorS_DotNet.CalibParamStructType
PR00 | MPSizectorS_DotNet.CalibParamStructType
PR01 | MPSizectorS_DotNet.CalibParamStructType
PR02 | MPSizectorS_DotNet.CalibParamStructType
PR10 | MPSizectorS_DotNet.CalibParamStructType
PR11 | MPSizectorS_DotNet.CalibParamStructType
PR12 | MPSizectorS_DotNet.CalibParamStructType
PR20 | MPSizectorS_DotNet.CalibParamStructType
PR21 | MPSizectorS_DotNet.CalibParamStructType
PR22 | MPSizectorS_DotNet.CalibParamStructType
PSx | MPSizectorS_DotNet.CalibParamStructType
PSy | MPSizectorS_DotNet.CalibParamStructType
PT0 | MPSizectorS_DotNet.CalibParamStructType
PT1 | MPSizectorS_DotNet.CalibParamStructType
PT2 | MPSizectorS_DotNet.CalibParamStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.ColorDepthRangeStruct结构体 参考

  • ColorDepthRangeStruct
Public 属性 | 所有成员列表
MPSizectorS_DotNet.ColorDepthRangeStruct结构体 参考

深度色谱范围设置结构体。 更多...

Public 属性

float | Min
深度色谱范围的下限。
float | Max
深度色谱范围的上限。

详细描述

深度色谱范围设置结构体。


MPSizector .NET 编程文档: 成员列表

  • ColorDepthRangeStruct
MPSizectorS_DotNet.ColorDepthRangeStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ColorDepthRangeStruct,包括所有继承而来的类成员

Max | MPSizectorS_DotNet.ColorDepthRangeStruct
Min | MPSizectorS_DotNet.ColorDepthRangeStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.CompensationStructType结构体 参考

  • CompensationStructType
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.CompensationStructType结构体 参考

补偿结构体。 更多...

Public 属性

LinearTemperatureDriftCompensationStructType LinearTemperatureDriftCompensationParam
线性温漂补偿参数。

属性

LinearTemperatureDriftCompensationStructType _LinearTemperatureDriftCompensationParam [get]

详细描述

补偿结构体。


MPSizector .NET 编程文档: 成员列表

  • CompensationStructType
MPSizectorS_DotNet.CompensationStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.CompensationStructType,包括所有继承而来的类成员

_LinearTemperatureDriftCompensationParam (定义于 MPSizectorS_DotNet.CompensationStructType) | MPSizectorS_DotNet.CompensationStructType
LinearTemperatureDriftCompensationParam | MPSizectorS_DotNet.CompensationStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.CorrectDistortionParamStructType结构体 参考

  • CorrectDistortionParamStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.CorrectDistortionParamStructType结构体 参考

Public 属性

double | p0
double | p1
double | p2
double | p3
double | p4
double | p5
double | p6
double | p7
double | p8
double | p9


MPSizector .NET 编程文档: 成员列表

  • CorrectDistortionParamStructType
MPSizectorS_DotNet.CorrectDistortionParamStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.CorrectDistortionParamStructType,包括所有继承而来的类成员

p0 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p1 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p2 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p3 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p4 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p5 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p6 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p7 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p8 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType
p9 (定义于 MPSizectorS_DotNet.CorrectDistortionParamStructType) | MPSizectorS_DotNet.CorrectDistortionParamStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.DataPointFix3DStruct结构体 参考

  • DataPointFix3DStruct
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.DataPointFix3DStruct结构体 参考

定点数格式3D数据点结构体。 更多...

Public 属性

byte | Gray
像素灰度值。
byte | Mask
像素掩码值。
注意！相比于Sizector-H/HD, Mask的定义已经发生改变，继续使用 Mask == 0 来判断是否是有效点将导致错误！
bit 0 至 bit 2: 有效状态掩码. 0x00为有效点。 0x01为过曝点。0x02为重构失败。0x03为超出用户设定范围（像素点被范围检查功能剔除）。0x04 为数据溢出 (转换至定点数的过程中，定点数的值超出 0~65535 的范围)。
bit 3 至 bit 4: HDR掩码, 有效点最终采用的数据的曝光次数。例如，当HDR融合采用了3次曝光，最终采用了第二次曝光的结果作为该像素点的结果，则为2。
bit 5 至 bit 7: HDR掩码, 各次曝光的有效状态。
ushort | X
转换后的X值。
ushort | Y
转换后的Y值。
ushort | Z
转换后的Z值。

属性

bool IsValid [get]
判断当前点是否为有效点。

详细描述

定点数格式3D数据点结构体。


MPSizector .NET 编程文档: 成员列表

  • DataPointFix3DStruct
MPSizectorS_DotNet.DataPointFix3DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.DataPointFix3DStruct,包括所有继承而来的类成员

Gray | MPSizectorS_DotNet.DataPointFix3DStruct
IsValid | MPSizectorS_DotNet.DataPointFix3DStruct
Mask | MPSizectorS_DotNet.DataPointFix3DStruct
X | MPSizectorS_DotNet.DataPointFix3DStruct
Y | MPSizectorS_DotNet.DataPointFix3DStruct
Z | MPSizectorS_DotNet.DataPointFix3DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.DataPointFixZMapStruct结构体 参考

  • DataPointFixZMapStruct
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.DataPointFixZMapStruct结构体 参考

定点数深度图格式3D数据点结构体。 更多...

Public 属性

byte | Gray
像素灰度值。
byte | Mask
像素掩码值。
注意！相比于Sizector-H/HD, Mask的定义已经发生改变，继续使用 Mask == 0 来判断是否是有效点将导致错误！
bit 0 至 bit 2: 有效状态掩码. 0x00为有效点。 0x01为过曝点。0x02为重构失败。0x03为超出用户设定范围（像素点被范围检查功能剔除）。0x04 为数据溢出 (转换至定点数的过程中，定点数的值超出 0~65535 的范围)。
bit 3 至 bit 4: HDR掩码, 有效点最终采用的数据的曝光次数。例如，当HDR融合采用了3次曝光，最终采用了第二次曝光的结果作为该像素点的结果，则为2。
bit 5 至 bit 7: HDR掩码, 各次曝光的有效状态。 当采用多个投影时, bit 3 至 bit 7的含义改变: bit 3 保留位, bit 4 至 bit 7分别表示投影0 至 投影3是否参与到该点的三维重构。
ushort | Z
转换后的Z值。

属性

bool IsValid [get]
判断当前点是否为有效点。

详细描述

定点数深度图格式3D数据点结构体。


MPSizector .NET 编程文档: 成员列表

  • DataPointFixZMapStruct
MPSizectorS_DotNet.DataPointFixZMapStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.DataPointFixZMapStruct,包括所有继承而来的类成员

Gray | MPSizectorS_DotNet.DataPointFixZMapStruct
IsValid | MPSizectorS_DotNet.DataPointFixZMapStruct
Mask | MPSizectorS_DotNet.DataPointFixZMapStruct
Z | MPSizectorS_DotNet.DataPointFixZMapStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.DataPointFloat3DStruct结构体 参考

  • DataPointFloat3DStruct
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.DataPointFloat3DStruct结构体 参考

浮点数格式3D数据点结构体。 更多...

Public 属性

byte | Gray
像素灰度值。
byte | Mask
像素掩码值。
注意！相比于Sizector-H/HD, Mask的定义已经发生改变，继续使用 Mask == 0 来判断是否是有效点将导致错误！
bit 0 至 bit 2: 有效状态掩码. 0x00为有效点。 0x01为过曝点。0x02为重构失败。0x03为超出用户设定范围（像素点被范围检查功能剔除）。0x04 为数据溢出 (转换至定点数的过程中，定点数的值超出 0~65535 的范围)。
bit 3 至 bit 4: HDR掩码, 有效点最终采用的数据的曝光次数。例如，当HDR融合采用了3次曝光，最终采用了第二次曝光的结果作为该像素点的结果，则为2。
bit 5 至 bit 7: HDR掩码, 各次曝光的有效状态。
float | X
X 坐标，单位mm。
float | Y
Y 坐标，单位mm。
float | Z
Z 坐标，单位mm。

属性

bool IsValid [get]
判断当前点是否为有效点。

详细描述

浮点数格式3D数据点结构体。


MPSizector .NET 编程文档: 成员列表

  • DataPointFloat3DStruct
MPSizectorS_DotNet.DataPointFloat3DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.DataPointFloat3DStruct,包括所有继承而来的类成员

Gray | MPSizectorS_DotNet.DataPointFloat3DStruct
IsValid | MPSizectorS_DotNet.DataPointFloat3DStruct
Mask | MPSizectorS_DotNet.DataPointFloat3DStruct
X | MPSizectorS_DotNet.DataPointFloat3DStruct
Y | MPSizectorS_DotNet.DataPointFloat3DStruct
Z | MPSizectorS_DotNet.DataPointFloat3DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.DebugInfoStruct结构体 参考

  • DebugInfoStruct
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.DebugInfoStruct结构体 参考

调试寄存器数组信息结构体。厂商调试用途。 更多...

Public 成员函数

override string ToString ()

Public 属性

uint | D0
uint | D1
uint | D2
uint | D3
uint | D4
uint | D5
uint | D6
uint | D7
uint | D8
uint | D9
uint | D10
uint | D11
uint | D12
uint | D13
uint | D14
uint | D15
uint | D16
uint | D17
uint | D18
uint | D19
uint | D20
uint | D21
uint | D22
uint | D23
uint | D24
uint | D25
uint | D26
uint | D27
uint | D28
uint | D29
uint | D30
uint | D31

属性

uint | _D0 [get]
uint | _D1 [get]
uint | _D2 [get]
uint | _D3 [get]
uint | _D4 [get]
uint | _D5 [get]
uint | _D6 [get]
uint | _D7 [get]
uint | _D8 [get]
uint | _D9 [get]
uint | _D10 [get]
uint | _D11 [get]
uint | _D12 [get]
uint | _D13 [get]
uint | _D14 [get]
uint | _D15 [get]
uint | _D16 [get]
uint | _D17 [get]
uint | _D18 [get]
uint | _D19 [get]
uint | _D20 [get]
uint | _D21 [get]
uint | _D22 [get]
uint | _D23 [get]
uint | _D24 [get]
uint | _D25 [get]
uint | _D26 [get]
uint | _D27 [get]
uint | _D28 [get]
uint | _D29 [get]
uint | _D30 [get]
uint | _D31 [get]

详细描述

调试寄存器数组信息结构体。厂商调试用途。


MPSizector .NET 编程文档: 成员列表

  • DebugInfoStruct
MPSizectorS_DotNet.DebugInfoStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.DebugInfoStruct,包括所有继承而来的类成员

_D0 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D1 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D10 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D11 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D12 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D13 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D14 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D15 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D16 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D17 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D18 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D19 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D2 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D20 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D21 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D22 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D23 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D24 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D25 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D26 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D27 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D28 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D29 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D3 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D30 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D31 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D4 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D5 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D6 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D7 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D8 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
_D9 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D0 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D1 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D10 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D11 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D12 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D13 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D14 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D15 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D16 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D17 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D18 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D19 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D2 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D20 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D21 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D22 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D23 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D24 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D25 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D26 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D27 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D28 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D29 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D3 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D30 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D31 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D4 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D5 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D6 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D7 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D8 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
D9 (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct
ToString() (定义于 MPSizectorS_DotNet.DebugInfoStruct) | MPSizectorS_DotNet.DebugInfoStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.DeviceInfoStructType结构体 参考

  • DeviceInfoStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.DeviceInfoStructType结构体 参考

用于存储设备信息的结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

string | DeviceName
设备名称.
string | DeviceSerialNumber
设备序列号。该序列号为设备的惟一序列号。
byte | IsActivated
设备的激活状态
float | HWVersion
设备的固件版本号
float | FWVersion
设备的硬件版本号
float | MinimumSDKVersion
设备所需要的最低SDK版本
uint | SensorWidth
设备的X方向像素分辨率
uint | SensorHeight
设备的Y方向像素分辨率
uint | SensorResolution
设备的像素分辨率
byte | BinningPossibility
设备是否支持低分辨率模式
byte | ExternalExposurePossibility
设备是否支持外部光源曝光的2D拍摄。
MultiHeadConfigType | MultiHeadConfig
设备的投影配置。
uint | SensorBinningWidth
设备的X方向像素分辨率(低分辨率模式)
uint | SensorBinningHeight
设备的Y方向像素分辨率(低分辨率模式)
uint | SensorBinningResolution
设备的像素分辨率(低分辨率模式)
float | XMax
设备的X方向物理坐标最大值(mm)
float | YMax
设备的Y方向物理坐标最大值(mm)
float | ZMax
设备的Z方向物理坐标最大值(mm)
InterfaceType | InterfaceType
设备连接接口。

属性

string | _DeviceName [get]
string | _DeviceSerialNumber [get]
byte | _IsActivated [get]
float | _HWVersion [get]
float | _FWVersion [get]
float | _MinimumSDKVersion [get]
uint | _SensorWidth [get]
uint | _SensorHeight [get]
uint | _SensorResolution [get]
byte | _BinningPossibility [get]
byte | _ExternalExposurePossibility [get]
MultiHeadConfigType | _MultiHeadConfig [get]
uint | _SensorBinningWidth [get]
uint | _SensorBinningHeight [get]
uint | _SensorBinningResolution [get]
float | _XMax [get]
float | _YMax [get]
float | _ZMax [get]
InterfaceType | _InterfaceType [get]

详细描述

用于存储设备信息的结构体。

Device Info Structure


MPSizector .NET 编程文档: 成员列表

  • DeviceInfoStructType
MPSizectorS_DotNet.DeviceInfoStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.DeviceInfoStructType,包括所有继承而来的类成员

_BinningPossibility (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_DeviceName (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_DeviceSerialNumber (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_ExternalExposurePossibility (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_FWVersion (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_HWVersion (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_InterfaceType (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_IsActivated (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_MinimumSDKVersion (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_MultiHeadConfig (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorBinningHeight (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorBinningResolution (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorBinningWidth (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorHeight (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorResolution (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_SensorWidth (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_XMax (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_YMax (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
_ZMax (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
BinningPossibility | MPSizectorS_DotNet.DeviceInfoStructType
DeviceName | MPSizectorS_DotNet.DeviceInfoStructType
DeviceSerialNumber | MPSizectorS_DotNet.DeviceInfoStructType
ExternalExposurePossibility | MPSizectorS_DotNet.DeviceInfoStructType
FWVersion | MPSizectorS_DotNet.DeviceInfoStructType
HWVersion | MPSizectorS_DotNet.DeviceInfoStructType
InterfaceType | MPSizectorS_DotNet.DeviceInfoStructType
IsActivated | MPSizectorS_DotNet.DeviceInfoStructType
MinimumSDKVersion | MPSizectorS_DotNet.DeviceInfoStructType
MultiHeadConfig | MPSizectorS_DotNet.DeviceInfoStructType
SensorBinningHeight | MPSizectorS_DotNet.DeviceInfoStructType
SensorBinningResolution | MPSizectorS_DotNet.DeviceInfoStructType
SensorBinningWidth | MPSizectorS_DotNet.DeviceInfoStructType
SensorHeight | MPSizectorS_DotNet.DeviceInfoStructType
SensorResolution | MPSizectorS_DotNet.DeviceInfoStructType
SensorWidth | MPSizectorS_DotNet.DeviceInfoStructType
ToString() (定义于 MPSizectorS_DotNet.DeviceInfoStructType) | MPSizectorS_DotNet.DeviceInfoStructType
XMax | MPSizectorS_DotNet.DeviceInfoStructType
YMax | MPSizectorS_DotNet.DeviceInfoStructType
ZMax | MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.ExpertSettingsStructType结构体 参考

  • ExpertSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.ExpertSettingsStructType结构体 参考

专业设置的结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | ExpROINum
曝光区域数量。
ExpROIStructType[] | ExpROIs
曝光区域。
byte | Reserved
保留。
SuppressExpParamsEnableStructType | SuppressExpParamsEnable
曝光抑制参数。
FlipEnableStructType | FlipEnable
翻转参数。
AntiLampFlickerModeType | AntiLampFlickerMode
抗频闪模式。
MonitorPositionStructType[] | MonitorPositions
监视位置。
MonitorZStructType[] | MonitorZArr
监视高度。

属性

byte | _ExpROINum [get]
ExpROIStructType | _ExpROI0 [get]
SuppressExpParamsEnableStructType | _SuppressExpParamsEnable [get]
FlipEnableStructType | _FlipEnable [get]
AntiLampFlickerModeType | _AntiLampFlickerMode [get]
MonitorPositionStructType | _MonitorPosition0 [get]
MonitorZStructType | _MonitorZArr0 [get]

详细描述

专业设置的结构体。


MPSizector .NET 编程文档: 成员列表

  • ExpertSettingsStructType
MPSizectorS_DotNet.ExpertSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ExpertSettingsStructType,包括所有继承而来的类成员

_AntiLampFlickerMode (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_ExpROI0 (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_ExpROINum (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_FlipEnable (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_MonitorPosition0 (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_MonitorZArr0 (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
_SuppressExpParamsEnable (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType
AntiLampFlickerMode | MPSizectorS_DotNet.ExpertSettingsStructType
ExpROINum | MPSizectorS_DotNet.ExpertSettingsStructType
ExpROIs | MPSizectorS_DotNet.ExpertSettingsStructType
FlipEnable | MPSizectorS_DotNet.ExpertSettingsStructType
MonitorPositions | MPSizectorS_DotNet.ExpertSettingsStructType
MonitorZArr | MPSizectorS_DotNet.ExpertSettingsStructType
Reserved | MPSizectorS_DotNet.ExpertSettingsStructType
SuppressExpParamsEnable | MPSizectorS_DotNet.ExpertSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.ExpertSettingsStructType) | MPSizectorS_DotNet.ExpertSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.ExposureBasicSettingStructType结构体 参考

  • ExposureBasicSettingStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.ExposureBasicSettingStructType结构体 参考

基础曝光设置。 更多...

Public 成员函数

override string ToString ()

Public 属性

ExposureModeType | ExposureMode
曝光模式，可在手动/自动HDR， 以及重复曝光模式之中切换。
byte | ExposureNumber
曝光次数，有效值为1，2，3。
byte | AutoHDRPriority
自动HDR优先级，有效范围为[0, 7]。0表示以完整性为最高优先级，7表示以重复精度为最高优先级。
byte | AutoPHDRQuality
自动PHDR质量，有效范围为[0, 100]。0表示最低的质量要求，100表示最高的质量要求。

属性

ExposureModeType | _ExposureMode [get]
byte | _ExposureNumber [get]
byte | _AutoHDRPriority [get]
byte | _AutoPHDRQuality [get]

详细描述

基础曝光设置。


MPSizector .NET 编程文档: 成员列表

  • ExposureBasicSettingStructType
MPSizectorS_DotNet.ExposureBasicSettingStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ExposureBasicSettingStructType,包括所有继承而来的类成员

_AutoHDRPriority (定义于 MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
_AutoPHDRQuality (定义于 MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
_ExposureMode (定义于 MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
_ExposureNumber (定义于 MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType
AutoHDRPriority | MPSizectorS_DotNet.ExposureBasicSettingStructType
AutoPHDRQuality | MPSizectorS_DotNet.ExposureBasicSettingStructType
ExposureMode | MPSizectorS_DotNet.ExposureBasicSettingStructType
ExposureNumber | MPSizectorS_DotNet.ExposureBasicSettingStructType
ToString() (定义于 MPSizectorS_DotNet.ExposureBasicSettingStructType) | MPSizectorS_DotNet.ExposureBasicSettingStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.ExposureSettingsStructType结构体 参考

  • ExposureSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.ExposureSettingsStructType结构体 参考

曝光设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

ExposureBasicSettingStructType | ExposureBasicSetting
基础曝光设置。
byte | UserGain
用户增益（仅对3D有效）。有效范围为[0, 3]。更高的用户增益将缩短曝光时间，但降低重复精度。
float | ExposureIntensity3D_1st
3D工作模式的第1曝光强度，有效范围为[0.1, 100]。
float | ExposureIntensity3D_2nd
3D工作模式的第2曝光强度，有效范围为[0.1, 100]。
float | ExposureIntensity3D_3rd
3D工作模式的第3曝光强度，有效范围为[0.1, 100]。
float | ExposureIntensity2D
2D工作模式及3D模式下灰度图像的曝光强度，有效范围为[0.1, 100]。
byte | MultiHeadExpoVarMode
3D工作模式的多头曝光差异模式，有效范围为[0, 15]。
byte | MultiHeadExpoVarRatio
3D工作模式的多头曝光差异比例，有效范围为[0, 15]。

属性

ExposureBasicSettingStructType | _ExposureBasicSetting [get]
byte | _UserGain [get]
float | _ExposureIntensity3D_1st [get]
float | _ExposureIntensity3D_2nd [get]
float | _ExposureIntensity3D_3rd [get]
float | _ExposureIntensity2D [get]
byte | _MultiHeadExpoVarMode [get]
byte | _MultiHeadExpoVarRatio [get]

详细描述

曝光设置结构体。


MPSizector .NET 编程文档: 成员列表

  • ExposureSettingsStructType
MPSizectorS_DotNet.ExposureSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ExposureSettingsStructType,包括所有继承而来的类成员

_ExposureBasicSetting (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity2D (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity3D_1st (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity3D_2nd (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_ExposureIntensity3D_3rd (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_MultiHeadExpoVarMode (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_MultiHeadExpoVarRatio (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
_UserGain (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureBasicSetting | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity2D | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity3D_1st | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity3D_2nd | MPSizectorS_DotNet.ExposureSettingsStructType
ExposureIntensity3D_3rd | MPSizectorS_DotNet.ExposureSettingsStructType
MultiHeadExpoVarMode | MPSizectorS_DotNet.ExposureSettingsStructType
MultiHeadExpoVarRatio | MPSizectorS_DotNet.ExposureSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.ExposureSettingsStructType) | MPSizectorS_DotNet.ExposureSettingsStructType
UserGain | MPSizectorS_DotNet.ExposureSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.ExpROIStructType结构体 参考

  • ExpROIStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.ExpROIStructType结构体 参考

曝光区域的结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

ushort | ExpROIXCenter
曝光区域的中心点X。
ushort | ExpROIYCenter
曝光区域的中心点Y。
ushort | ExpROIWidth
曝光区域的宽度。
ushort | ExpROIHeight
曝光区域的高度。
ExpROIShapeType | shapeType
曝光区域的形状。
byte | IsBase
曝光区域的是否为基准区域。
ExpROIPropertyType | Polarity
曝光区域的极性。

属性

ushort | _ExpROIXCenter [get]
ushort | _ExpROIYCenter [get]
ushort | _ExpROIWidth [get]
ushort | _ExpROIHeight [get]
ExpROIShapeType | _shapeType [get]
byte | _IsBase [get]
ExpROIPropertyType | _Polarity [get]

详细描述

曝光区域的结构体。


MPSizector .NET 编程文档: 成员列表

  • ExpROIStructType
MPSizectorS_DotNet.ExpROIStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ExpROIStructType,包括所有继承而来的类成员

_ExpROIHeight (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_ExpROIWidth (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_ExpROIXCenter (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_ExpROIYCenter (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_IsBase (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_Polarity (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
_shapeType (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType
ExpROIHeight | MPSizectorS_DotNet.ExpROIStructType
ExpROIWidth | MPSizectorS_DotNet.ExpROIStructType
ExpROIXCenter | MPSizectorS_DotNet.ExpROIStructType
ExpROIYCenter | MPSizectorS_DotNet.ExpROIStructType
IsBase | MPSizectorS_DotNet.ExpROIStructType
Polarity | MPSizectorS_DotNet.ExpROIStructType
shapeType | MPSizectorS_DotNet.ExpROIStructType
ToString() (定义于 MPSizectorS_DotNet.ExpROIStructType) | MPSizectorS_DotNet.ExpROIStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.Extension类 参考

  • Extension
Public 成员函数 | 静态 Public 成员函数 | 所有成员列表
MPSizectorS_DotNet.Extension类 参考

Public 成员函数

unsafe delegate void | CustomStreamReadImpl (byte *Dest, uint Len)
static bool | LoadSettingFromXML (string Filepath, ref SettingsStructType Setings)
从本地加载XML配置文件到SettingsStructType结构体
static bool | SaveSettingToXML (string Filepath, SettingsStructType Setings)
从SettingsStructType结构体中保存到本地路径

静态 Public 成员函数

static unsafe bool LoadUnmanagedDataFrameUndefined_FileStream (FileStream fs, out UnmanagedDataFrameUndefinedStruct DataFrame, out int Size, out float ColorDepthMin, out float ColorDepthMax, bool NeedCheckDataLength=true)
通过文件流加载数据。

成员函数说明

◆ LoadSettingFromXML()

static bool MPSizectorS_DotNet.Extension.LoadSettingFromXML | ( | string | Filepath,
 |  | ref SettingsStructType | Setings )

从本地加载XML配置文件到SettingsStructType结构体

参数
Filepath | XML的路径
Setings | SettingsStructType结构体

◆ LoadUnmanagedDataFrameUndefined_FileStream()

static unsafe bool MPSizectorS_DotNet.Extension.LoadUnmanagedDataFrameUndefined_FileStream | ( | FileStream | fs,
 |  | out UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | out int | Size,
 |  | out float | ColorDepthMin,
 |  | out float | ColorDepthMax,
 |  | bool | NeedCheckDataLength = true )
 static

通过文件流加载数据。

参数
fs | 文件流。
DataFrame | 数据帧。
Size | 总长度。
ColorDepthMin | 最小颜色深度。
ColorDepthMax | 最大颜色深度。
needCheckDataLength | 是否需要检查数据长度。
返回
加载是否成功。

◆ SaveSettingToXML()

static bool MPSizectorS_DotNet.Extension.SaveSettingToXML | ( | string | Filepath,
 |  | SettingsStructType | Setings )

从SettingsStructType结构体中保存到本地路径

参数
Filepath | XML的路径
Setings | SettingsStructType结构体


MPSizector .NET 编程文档: 成员列表

  • Extension
MPSizectorS_DotNet.Extension 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.Extension,包括所有继承而来的类成员

CustomStreamReadImpl(byte *Dest, uint Len) (定义于 MPSizectorS_DotNet.Extension) | MPSizectorS_DotNet.Extension |
LoadSettingFromXML(string Filepath, ref SettingsStructType Setings) | MPSizectorS_DotNet.Extension |
LoadUnmanagedDataFrameUndefined_FileStream(FileStream fs, out UnmanagedDataFrameUndefinedStruct DataFrame, out int Size, out float ColorDepthMin, out float ColorDepthMax, bool NeedCheckDataLength=true) | MPSizectorS_DotNet.Extension | static
SaveSettingToXML(string Filepath, SettingsStructType Setings) | MPSizectorS_DotNet.Extension |


MPSizector .NET 编程文档: MPSizectorS_DotNet.ExternalExposureSettingsStructType结构体 参考

  • ExternalExposureSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.ExternalExposureSettingsStructType结构体 参考

外部光源的曝光设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | ExternalExposureEnable
外部光源使能。Bit 0设置白光使能；Bit 1设置RGB使能；1为开启，0为关闭。
ushort | ExternalExposureGain
外部光源增益。Bit 0 ~ Bit 3设置白光增益；Bit 4 ~ Bit 7设置红光增益；Bit 8 ~ Bit 11设置绿光增益；Bit 12 ~ Bit 15设置蓝光增益。有效范围[0, 4]。
ushort | ExternalExposureTimeWhite_us
外部光源白光曝光时间，单位微秒。
ushort | ExternalExposureTimeRed_us
外部光源红光曝光时间，单位微秒。
ushort | ExternalExposureTimeGreen_us
外部光源绿光曝光时间，单位微秒。
ushort | ExternalExposureTimeBlue_us
外部光源蓝光曝光时间，单位微秒。

属性

byte | _ExternalExposureEnable [get]
float | _ExternalExposureGain [get]
float | _ExternalExposureTimeWhite_us [get]
float | _ExternalExposureTimeRed_us [get]
float | _ExternalExposureTimeGreen_us [get]
float | _ExternalExposureTimeBlue_us [get]

详细描述

外部光源的曝光设置结构体。


MPSizector .NET 编程文档: 成员列表

  • ExternalExposureSettingsStructType
MPSizectorS_DotNet.ExternalExposureSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ExternalExposureSettingsStructType,包括所有继承而来的类成员

_ExternalExposureEnable (定义于 MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureGain (定义于 MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeBlue_us (定义于 MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeGreen_us (定义于 MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeRed_us (定义于 MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
_ExternalExposureTimeWhite_us (定义于 MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureEnable | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureGain | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeBlue_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeGreen_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeRed_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ExternalExposureTimeWhite_us | MPSizectorS_DotNet.ExternalExposureSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.ExternalExposureSettingsStructType) | MPSizectorS_DotNet.ExternalExposureSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.FlipEnableStructType结构体 参考

  • FlipEnableStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.FlipEnableStructType结构体 参考

翻转参数。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | FlipXEnable
开启X翻转。
byte | FlipYEnable
开启Y翻转。

属性

byte | _FlipXEnable [get]
byte | _FlipYEnable [get]

详细描述

翻转参数。


MPSizector .NET 编程文档: 成员列表

  • FlipEnableStructType
MPSizectorS_DotNet.FlipEnableStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.FlipEnableStructType,包括所有继承而来的类成员

_FlipXEnable (定义于 MPSizectorS_DotNet.FlipEnableStructType) | MPSizectorS_DotNet.FlipEnableStructType
_FlipYEnable (定义于 MPSizectorS_DotNet.FlipEnableStructType) | MPSizectorS_DotNet.FlipEnableStructType
FlipXEnable | MPSizectorS_DotNet.FlipEnableStructType
FlipYEnable | MPSizectorS_DotNet.FlipEnableStructType
ToString() (定义于 MPSizectorS_DotNet.FlipEnableStructType) | MPSizectorS_DotNet.FlipEnableStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.GeneralSettingsStructType结构体 参考

  • GeneralSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.GeneralSettingsStructType结构体 参考

通用设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | AutoSleepEnableState
自动休眠功能的使能状态。值为true时，设备会在闲置指定时间后自动进入休眠状态，并且在触发信号到来时自动苏醒。
ushort | AutoSleepDelayMS
进入休眠状态的延时，单位为ms。

属性

byte | _AutoSleepEnableState [get]
ushort | _AutoSleepDelayMS [get]

详细描述

通用设置结构体。


MPSizector .NET 编程文档: 成员列表

  • GeneralSettingsStructType
MPSizectorS_DotNet.GeneralSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.GeneralSettingsStructType,包括所有继承而来的类成员

_AutoSleepDelayMS (定义于 MPSizectorS_DotNet.GeneralSettingsStructType) | MPSizectorS_DotNet.GeneralSettingsStructType
_AutoSleepEnableState (定义于 MPSizectorS_DotNet.GeneralSettingsStructType) | MPSizectorS_DotNet.GeneralSettingsStructType
AutoSleepDelayMS | MPSizectorS_DotNet.GeneralSettingsStructType
AutoSleepEnableState | MPSizectorS_DotNet.GeneralSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.GeneralSettingsStructType) | MPSizectorS_DotNet.GeneralSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.HardwarePreprocessModeListStructType结构体 参考

  • HardwarePreprocessModeListStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.HardwarePreprocessModeListStructType结构体 参考

硬件预处理模式列表结构体。 更多...

Public 属性

MPSizectorS_HardwarePreprocessModeType | PreProcess_PresetMode
MPSizectorS_HardwarePreprocessModeType | BurrFilter_PresetMode
MPSizectorS_HardwarePreprocessModeType | ValidPointThreshold_PresetMode

详细描述

硬件预处理模式列表结构体。


MPSizector .NET 编程文档: 成员列表

  • HardwarePreprocessModeListStructType
MPSizectorS_DotNet.HardwarePreprocessModeListStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.HardwarePreprocessModeListStructType,包括所有继承而来的类成员

BurrFilter_PresetMode (定义于 MPSizectorS_DotNet.HardwarePreprocessModeListStructType) | MPSizectorS_DotNet.HardwarePreprocessModeListStructType
PreProcess_PresetMode (定义于 MPSizectorS_DotNet.HardwarePreprocessModeListStructType) | MPSizectorS_DotNet.HardwarePreprocessModeListStructType
ValidPointThreshold_PresetMode (定义于 MPSizectorS_DotNet.HardwarePreprocessModeListStructType) | MPSizectorS_DotNet.HardwarePreprocessModeListStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.HardwareTimeStampsStructType结构体 参考

  • HardwareTimeStampsStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.HardwareTimeStampsStructType结构体 参考

硬件时间戳的结构体。 更多...

Public 属性

uint | TriggerTimeMs
uint | ExpStartTimeMs
uint | ExpEndTimeMs
uint | TransEndTimeMs

详细描述

硬件时间戳的结构体。


MPSizector .NET 编程文档: 成员列表

  • HardwareTimeStampsStructType
MPSizectorS_DotNet.HardwareTimeStampsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.HardwareTimeStampsStructType,包括所有继承而来的类成员

ExpEndTimeMs (定义于 MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType
ExpStartTimeMs (定义于 MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType
TransEndTimeMs (定义于 MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType
TriggerTimeMs (定义于 MPSizectorS_DotNet.HardwareTimeStampsStructType) | MPSizectorS_DotNet.HardwareTimeStampsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.HeadDebugInfoStructType结构体 参考

  • HeadDebugInfoStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.HeadDebugInfoStructType结构体 参考

调试信息结构体，由设备产生并通过head pack发送至PC。该结构体是StatesStructType的简略版本。 更多...

Public 成员函数

override string ToString ()

Public 属性

uint | ConnectionTimeMS
设备连接时间，单位为ms。
uint | SnapCnt
设备拍摄计数，包括2D拍摄与3D拍摄。
ushort | TotalTransferRetryNum
传输重试总次数。
ushort | CurrentTransferRetryNum
当前帧的传输重试次数。
ushort | TotalCaptureRetryNum
拍摄重试总计数。
TemperatureFeedbackStructType | TempCore
核心温度传感器的反馈信息。
TemperatureFeedbackStructType | Temp0
温度传感器0的反馈信息。
TemperatureFeedbackStructType | Temp1
温度传感器1的反馈信息。
TemperatureFeedbackStructType | Temp2
温度传感器2的反馈信息。
uint | InitStates
设备初始化状态寄存器。
byte 0: 0x00 表示正在初始化， 0x01 表示初始化完成且未进入睡眠模式。 0x02 表示正在睡眠模式。
其他字节为生产商预留的调试信息。
byte | EXTIOInput
硬件输入引脚状态。由于head pack被频繁且规律地发送回PC，用户可以通过读取head pack中的该变量来刷新输入引脚状态，而不是直接读取寄存器。
byte | SettingValidation
当前设备的设置是否有效，0时无效，其他时有效。设置无效时无法触发拍摄。

属性

uint | _ConnectionTimeMS [get]
uint | _SnapCnt [get]
ushort | _TotalTransferRetryNum [get]
ushort | _CurrentTransferRetryNum [get]
ushort | _TotalCaptureRetryNum [get]
TemperatureFeedbackStructType | _TempCore [get]
TemperatureFeedbackStructType | _Temp0 [get]
uint | _InitStates [get]
byte | _EXTIOInput [get]
byte | _SettingValidation [get]

详细描述

调试信息结构体，由设备产生并通过head pack发送至PC。该结构体是StatesStructType的简略版本。


MPSizector .NET 编程文档: 成员列表

  • HeadDebugInfoStructType
MPSizectorS_DotNet.HeadDebugInfoStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.HeadDebugInfoStructType,包括所有继承而来的类成员

_ConnectionTimeMS (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_CurrentTransferRetryNum (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_EXTIOInput (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_InitStates (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_SettingValidation (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_SnapCnt (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_Temp0 (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_TempCore (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_TotalCaptureRetryNum (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
_TotalTransferRetryNum (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
ConnectionTimeMS | MPSizectorS_DotNet.HeadDebugInfoStructType
CurrentTransferRetryNum | MPSizectorS_DotNet.HeadDebugInfoStructType
EXTIOInput | MPSizectorS_DotNet.HeadDebugInfoStructType
InitStates | MPSizectorS_DotNet.HeadDebugInfoStructType
SettingValidation | MPSizectorS_DotNet.HeadDebugInfoStructType
SnapCnt | MPSizectorS_DotNet.HeadDebugInfoStructType
Temp0 | MPSizectorS_DotNet.HeadDebugInfoStructType
Temp1 | MPSizectorS_DotNet.HeadDebugInfoStructType
Temp2 | MPSizectorS_DotNet.HeadDebugInfoStructType
TempCore | MPSizectorS_DotNet.HeadDebugInfoStructType
ToString() (定义于 MPSizectorS_DotNet.HeadDebugInfoStructType) | MPSizectorS_DotNet.HeadDebugInfoStructType
TotalCaptureRetryNum | MPSizectorS_DotNet.HeadDebugInfoStructType
TotalTransferRetryNum | MPSizectorS_DotNet.HeadDebugInfoStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.HeadPackDataInfoStructType结构体 参考

  • HeadPackDataInfoStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.HeadPackDataInfoStructType结构体 参考

数据信息结构体，在head pack中使用。 更多...

Public 成员函数

override string ToString ()

Public 属性

DataFormatType | DataFormat
数据格式。
byte | DataNumber
在此数据帧中包含的图像数量。对于3D数据帧，0表示仅包含1幅3D信息。
ushort | DataTag
数据标签。该变量由客户设置，用于在触发时标记不同的拍摄目的，并在回调中识别。
ushort | XPixResolution
X像素分辨率
ushort | YPixResolution
Y像素分辨率
uint | DeviceTimeStamp
设备收到触发信号瞬间的时间戳，时间通过设备启动时间表示。
UInt64 | PCTimeStamp
PC收到完整的数据帧的时间戳。
TSNStructType | TSN
当前数据的TSN。

属性

DataFormatType | _DataFormat [get]
byte | _DataNumber [get]
ushort | _DataTag [get]
ushort | _XPixResolution [get]
ushort | _YPixResolution [get]
uint | _DeviceTimeStamp [get]
string | _PCTimeStamp [get]
TSNStructType | _TSN [get]

详细描述

数据信息结构体，在head pack中使用。

Head Pack Structures


MPSizector .NET 编程文档: 成员列表

  • HeadPackDataInfoStructType
MPSizectorS_DotNet.HeadPackDataInfoStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.HeadPackDataInfoStructType,包括所有继承而来的类成员

_DataFormat (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_DataNumber (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_DataTag (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_DeviceTimeStamp (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_PCTimeStamp (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_TSN (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_XPixResolution (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
_YPixResolution (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
DataFormat | MPSizectorS_DotNet.HeadPackDataInfoStructType
DataNumber | MPSizectorS_DotNet.HeadPackDataInfoStructType
DataTag | MPSizectorS_DotNet.HeadPackDataInfoStructType
DeviceTimeStamp | MPSizectorS_DotNet.HeadPackDataInfoStructType
PCTimeStamp | MPSizectorS_DotNet.HeadPackDataInfoStructType
ToString() (定义于 MPSizectorS_DotNet.HeadPackDataInfoStructType) | MPSizectorS_DotNet.HeadPackDataInfoStructType
TSN | MPSizectorS_DotNet.HeadPackDataInfoStructType
XPixResolution | MPSizectorS_DotNet.HeadPackDataInfoStructType
YPixResolution | MPSizectorS_DotNet.HeadPackDataInfoStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.HeadPackStructType结构体 参考

  • HeadPackStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.HeadPackStructType结构体 参考

head pack结构体。它被频繁且规律地发送回PC，并且被包含在每一个数据帧之中。 更多...

Public 成员函数

override string ToString ()

Public 属性

DeviceInfoStructType | DeviceInfo
设备信息。
HeadPackDataInfoStructType | DataInfo
数据信息。
BasicSettingsStructType | BasicSetings
基础设置。
ExposureSettingsStructType | ExposureSettings
曝光设置。
ExternalExposureSettingsStructType | ExternalExposureSettings
外部光源的曝光设置。
AutoHDRResultStructType | AutoHDRResult
自动HDR结果。
ReconstructionSettingsStructType | ReconstructionSettings
重构设置。
MultiHeadSettingsStructType | MultiHeadSettings
多头重构设置。
PostProcessSettingsStructType | PostProcessSettings
后处理设置。
GeneralSettingsStructType | GeneralSettings
通用设置。
HeadDebugInfoStructType | DebugInfo
调试信息。
ExpertSettingsStructType | ExpertSettings
专业设置。
IOSettingsStructType | IOSettings
IO设置。
MPSizectorS_AutoHDRAdvanceSettingsStructType | AutoHDRAdvanceSettings
自动HDR高级设置。
MPSizectorS_ExpICoefSettingsStructType | ExpICoefSettings
曝光系数设置结构体。
byte | CorrectDistortionEnable
畸变矫正使能状态。
byte[] | Reserved1
float | SettingsVersion
设置版本。
CalibParamStructType | CalibParam
标定参数。
SoftwarePreprocessListRegisters | SoftwarePreprocessList
软件预处理列表。
HardwarePreprocessModeListStructType | HardwarePreprocessModeList
硬件预处理模式列表。
SoftwarePreprocessPresetParamListStructType | SoftwarePreprocessPresetParamList
软件预处理预设参数列表。
CompensationStructType | CompensationParams
补偿参数。
byte[] | Reserved2
PartialFactorySettingsStructType | PartialFactorySettings
补偿参数。

属性

DeviceInfoStructType | _DeviceInfo [get]
HeadPackDataInfoStructType | _DataInfo [get]
BasicSettingsStructType | _BasicSettings [get]
ExposureSettingsStructType | _ExposureSettings [get]
ExternalExposureSettingsStructType | _ExternalExposureSettings [get]
AutoHDRResultStructType | _AutoHDRResult [get]
ReconstructionSettingsStructType | _ReconstructionSettings [get]
MultiHeadSettingsStructType | _MultiHeadSettings [get]
PostProcessSettingsStructType | _PostProcessSettings [get]
GeneralSettingsStructType | _GeneralSettings [get]
HeadDebugInfoStructType | _DebugInfo [get]
ExpertSettingsStructType | _ExpertSettings [get]
float | _SettingsVersion [get]
CalibParamStructType | _CalibParam [get]
MPSizectorS_AutoHDRAdvanceSettingsStructType | _AutoHDRAdvanceSettings [get]
MPSizectorS_ExpICoefSettingsStructType | _ExpICoefSettings [get]
byte | _CorrectDistortionEnable [get]
byte | _SoftwarePreprocessEnable [get]
uint | _SoftwarePreprocessCnt [get]
CompensationStructType | _CompensationParams [get]
PartialFactorySettingsStructType | _PartialFactorySettings [get]
bool | HasAuxiliaryWhiteImage [get]
是否使能了外部白光光源曝光。
bool | HasAuxiliaryRGBImage [get]
是否使能了外部RGB光光源曝光。

详细描述

head pack结构体。它被频繁且规律地发送回PC，并且被包含在每一个数据帧之中。


MPSizector .NET 编程文档: 成员列表

  • HeadPackStructType
MPSizectorS_DotNet.HeadPackStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.HeadPackStructType,包括所有继承而来的类成员

_AutoHDRAdvanceSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_AutoHDRResult (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_BasicSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_CalibParam (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_CompensationParams (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_CorrectDistortionEnable (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_DataInfo (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_DebugInfo (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_DeviceInfo (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExpertSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExpICoefSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExposureSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ExternalExposureSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_GeneralSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_MultiHeadSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_PartialFactorySettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_PostProcessSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_ReconstructionSettings (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_SettingsVersion (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_SoftwarePreprocessCnt (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
_SoftwarePreprocessEnable (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
AutoHDRAdvanceSettings | MPSizectorS_DotNet.HeadPackStructType
AutoHDRResult | MPSizectorS_DotNet.HeadPackStructType
BasicSetings | MPSizectorS_DotNet.HeadPackStructType
CalibParam | MPSizectorS_DotNet.HeadPackStructType
CompensationParams | MPSizectorS_DotNet.HeadPackStructType
CorrectDistortionEnable | MPSizectorS_DotNet.HeadPackStructType
DataInfo | MPSizectorS_DotNet.HeadPackStructType
DebugInfo | MPSizectorS_DotNet.HeadPackStructType
DeviceInfo | MPSizectorS_DotNet.HeadPackStructType
ExpertSettings | MPSizectorS_DotNet.HeadPackStructType
ExpICoefSettings | MPSizectorS_DotNet.HeadPackStructType
ExposureSettings | MPSizectorS_DotNet.HeadPackStructType
ExternalExposureSettings | MPSizectorS_DotNet.HeadPackStructType
GeneralSettings | MPSizectorS_DotNet.HeadPackStructType
HardwarePreprocessModeList | MPSizectorS_DotNet.HeadPackStructType
HasAuxiliaryRGBImage | MPSizectorS_DotNet.HeadPackStructType
HasAuxiliaryWhiteImage | MPSizectorS_DotNet.HeadPackStructType
IOSettings | MPSizectorS_DotNet.HeadPackStructType
MultiHeadSettings | MPSizectorS_DotNet.HeadPackStructType
PartialFactorySettings | MPSizectorS_DotNet.HeadPackStructType
PostProcessSettings | MPSizectorS_DotNet.HeadPackStructType
ReconstructionSettings | MPSizectorS_DotNet.HeadPackStructType
Reserved1 (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
Reserved2 (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType
SettingsVersion | MPSizectorS_DotNet.HeadPackStructType
SoftwarePreprocessList | MPSizectorS_DotNet.HeadPackStructType
SoftwarePreprocessPresetParamList | MPSizectorS_DotNet.HeadPackStructType
ToString() (定义于 MPSizectorS_DotNet.HeadPackStructType) | MPSizectorS_DotNet.HeadPackStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.HWTriggerSettingStructType结构体 参考

  • HWTriggerSettingStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.HWTriggerSettingStructType结构体 参考

硬件触发设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | IsReversed
硬件触发的信号极性是否反转。值为true时上升沿触发，值为false时下降沿触发。
ushort | DelayIn100us
硬件触发的延迟时间，以100us为单位。

属性

byte | _IsReversed [get]
ushort | _DelayIn100us [get]

详细描述

硬件触发设置结构体。


MPSizector .NET 编程文档: 成员列表

  • HWTriggerSettingStructType
MPSizectorS_DotNet.HWTriggerSettingStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.HWTriggerSettingStructType,包括所有继承而来的类成员

_DelayIn100us (定义于 MPSizectorS_DotNet.HWTriggerSettingStructType) | MPSizectorS_DotNet.HWTriggerSettingStructType
_IsReversed (定义于 MPSizectorS_DotNet.HWTriggerSettingStructType) | MPSizectorS_DotNet.HWTriggerSettingStructType
DelayIn100us | MPSizectorS_DotNet.HWTriggerSettingStructType
IsReversed | MPSizectorS_DotNet.HWTriggerSettingStructType
ToString() (定义于 MPSizectorS_DotNet.HWTriggerSettingStructType) | MPSizectorS_DotNet.HWTriggerSettingStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.IOSettingsStructType结构体 参考

  • IOSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.IOSettingsStructType结构体 参考

IO设置结构个体 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | EXTIOOutput
硬件输出引脚的寄存器值。每个Bit表示一个Pin
OutputPinSettingStructType | EXTIOO0Setting
输出引脚0的设置
OutputPinSettingStructType | EXTIOO1Setting
输出引脚1的设置
HWTriggerSettingStructType | HWTriggerSeting
硬件触发设置

属性

byte | _EXTIOOutput [get]
OutputPinSettingStructType | _EXTIOO0Setting [get]
OutputPinSettingStructType | _EXTIOO1Setting [get]
HWTriggerSettingStructType | _HWTriggerSeting [get]

详细描述

IO设置结构个体


MPSizector .NET 编程文档: 成员列表

  • IOSettingsStructType
MPSizectorS_DotNet.IOSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.IOSettingsStructType,包括所有继承而来的类成员

_EXTIOO0Setting (定义于 MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
_EXTIOO1Setting (定义于 MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
_EXTIOOutput (定义于 MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
_HWTriggerSeting (定义于 MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType
EXTIOO0Setting | MPSizectorS_DotNet.IOSettingsStructType
EXTIOO1Setting | MPSizectorS_DotNet.IOSettingsStructType
EXTIOOutput | MPSizectorS_DotNet.IOSettingsStructType
HWTriggerSeting | MPSizectorS_DotNet.IOSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.IOSettingsStructType) | MPSizectorS_DotNet.IOSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType结构体 参考

  • LinearTemperatureDriftCompensationStructType
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType结构体 参考

线性温漂补偿参数结构体。 更多...

Public 属性

byte | Enable
启用状态。
float | K
补偿系数。

属性

byte | _Enable [get]
float | _K [get]

详细描述

线性温漂补偿参数结构体。


MPSizector .NET 编程文档: 成员列表

  • LinearTemperatureDriftCompensationStructType
MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType,包括所有继承而来的类成员

_Enable (定义于 MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType) | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
_K (定义于 MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType) | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
Enable | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
K | MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.ManagedDataFrame2DStruct结构体 参考

  • ManagedDataFrame2DStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.ManagedDataFrame2DStruct结构体 参考

托管的2D数据帧结构体。 更多...

Public 成员函数

Bitmap | GetGrayBitmap (byte PicIndex=0)
获取灰度图像的位图。
Bitmap | GetExposurePredictionBitmap ()
获取曝光预测图像的位图。
unsafe bool | SaveDataFrame (string FileName)
将数据帧保存至文件。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
byte[] | Data
托管的2D图像数据。

详细描述

托管的2D数据帧结构体。

成员函数说明

◆ GetExposurePredictionBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrame2DStruct.GetExposurePredictionBitmap ( )

获取曝光预测图像的位图。

返回
曝光预测图像的位图。

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrame2DStruct.GetGrayBitmap ( byte PicIndex = 0 )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrame2DStruct.SaveDataFrame ( string FileName )

将数据帧保存至文件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。


MPSizector .NET 编程文档: 成员列表

  • ManagedDataFrame2DStruct
MPSizectorS_DotNet.ManagedDataFrame2DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ManagedDataFrame2DStruct,包括所有继承而来的类成员

Data | MPSizectorS_DotNet.ManagedDataFrame2DStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrame2DStruct
GetExposurePredictionBitmap() | MPSizectorS_DotNet.ManagedDataFrame2DStruct
GetGrayBitmap(byte PicIndex=0) | MPSizectorS_DotNet.ManagedDataFrame2DStruct
SaveDataFrame(string FileName) | MPSizectorS_DotNet.ManagedDataFrame2DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.ManagedDataFrameFix3DStruct结构体 参考

  • ManagedDataFrameFix3DStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.ManagedDataFrameFix3DStruct结构体 参考

托管定点数格式的3D数据帧结构体。 更多...

Public 成员函数

unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
将当前数据帧转换为托管浮点数3D格式数据。
unsafe UnmanagedDataFrameFix3DStruct | ToUnmanagedFix3D ()
将当前数据帧转换为非托管定点数3D格式数据。
Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
Bitmap | GetHDRMaskBitmap ()
获取HDR掩码位图。
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
DataPointFix3DStruct[] | Data
托管的定点数格式的点云数据。
byte[] | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte[] | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

托管定点数格式的3D数据帧结构体。

成员函数说明

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetHDRMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetHDRMaskBitmap ( )

获取HDR掩码位图。

返回
HDR掩码位图。

◆ GetValidMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.ToManagedFloat3D ( )

将当前数据帧转换为托管浮点数3D格式数据。

返回
转换后的数据帧。

◆ ToUnmanagedFix3D()

unsafe UnmanagedDataFrameFix3DStruct MPSizectorS_DotNet.ManagedDataFrameFix3DStruct.ToUnmanagedFix3D ( )

将当前数据帧转换为非托管定点数3D格式数据。

返回
转换后的数据帧。


MPSizector .NET 编程文档: 成员列表

  • ManagedDataFrameFix3DStruct
MPSizectorS_DotNet.ManagedDataFrameFix3DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ManagedDataFrameFix3DStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
Data | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
ToManagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct
ToUnmanagedFix3D() | MPSizectorS_DotNet.ManagedDataFrameFix3DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct结构体 参考

  • ManagedDataFrameFixZMapSimpleStruct
Public 成员函数 | 静态 Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct结构体 参考

托管的简化的定点数深度图的3D数据帧结构体。 更多...

Public 成员函数

unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
将当前数据帧转换为托管浮点数3D格式数据。
unsafe UnmanagedDataFrameFixZMapSimpleStruct | ToUnmanagedFixZMapSimple ()
将当前数据帧转换为非托管简化的定点数深度图3D格式数据。
Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

静态 Public 成员函数

static bool | IsValid (ushort point)
判断定点数Z数据的点是否有效。
static byte | GetMaskValue (ushort point)
获取定点数Z数据的点的掩码。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
byte[] | Data
包含所有数据的数组。
ushort[] | Z
转换后的Z值。0和65535代表无效点数据。
byte[] | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte[] | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

托管的简化的定点数深度图的3D数据帧结构体。

成员函数说明

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetMaskValue()

static byte MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetMaskValue ( ushort point )
static

获取定点数Z数据的点的掩码。

参数
point 定点数Z数据点。
返回
掩码。

◆ GetValidMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ IsValid()

static bool MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.IsValid ( ushort point )
static

判断定点数Z数据的点是否有效。

参数
point 定点数Z数据点。
返回
如果有效返回true。

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.ToManagedFloat3D ( )

将当前数据帧转换为托管浮点数3D格式数据。

返回
转换后的数据帧。

◆ ToUnmanagedFixZMapSimple()

unsafe UnmanagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct.ToUnmanagedFixZMapSimple ( )

将当前数据帧转换为非托管简化的定点数深度图3D格式数据。

返回
转换后的数据帧。


MPSizector .NET 编程文档: 成员列表

  • ManagedDataFrameFixZMapSimpleStruct
MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
Data | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
GetMaskValue(ushort point) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct | static
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
IsValid(ushort point) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct | static
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
ToManagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
ToUnmanagedFixZMapSimple() | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |
Z | MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct |


MPSizector .NET 编程文档: MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct结构体 参考

  • ManagedDataFrameFixZMapStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct结构体 参考

托管定点数深度图的3D数据帧结构体。 更多...

Public 成员函数

unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
将当前数据帧转换为托管浮点数3D格式数据。
unsafe UnmanagedDataFrameFixZMapStruct | ToUnmanagedFixZMap ()
将当前数据帧转换为非托管定点数深度图3D格式数据。
Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
Bitmap | GetHDRMaskBitmap ()
获取HDR掩码位图。
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
DataPointFixZMapStruct[] | Data
定点数深度图格式3D数据点数据。
byte[] | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte[] | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

托管定点数深度图的3D数据帧结构体。

成员函数说明

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetHDRMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetHDRMaskBitmap ( )

获取HDR掩码位图。

返回
HDR掩码位图。

◆ GetValidMaskBitmap()

Bitmap MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.ToManagedFloat3D ( )

将当前数据帧转换为托管浮点数3D格式数据。

返回
转换后的数据帧。

◆ ToUnmanagedFixZMap()

unsafe UnmanagedDataFrameFixZMapStruct MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct.ToUnmanagedFixZMap ( )

将当前数据帧转换为非托管定点数深度图3D格式数据。

返回
转换后的数据帧。


MPSizector .NET 编程文档: 成员列表

  • ManagedDataFrameFixZMapStruct
MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
Data | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
ToManagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct
ToUnmanagedFixZMap() | MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct结构体 参考

  • ManagedDataFrameFloat3DStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct结构体 参考

托管浮点数格式的3D数据帧结构体。 更多...

Public 成员函数

ManagedDataFrameFix3DStruct ToManagedFix3D ()
将当前数据帧转换为托管定点数3D格式数据。
unsafe UnmanagedDataFrameFloat3DStruct | ToUnmanagedFloat3D ()
将当前数据帧转换为非托管浮点数3D格式数据。
unsafe Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
unsafe Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
unsafe Bitmap | GetHDRMaskBitmap ()
获取HDR掩码位图。
unsafe bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
DataPointFloat3DStruct[] | Data
托管的浮点数格式的点云数据。
byte[] | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte[] | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

托管浮点数格式的3D数据帧结构体。

成员函数说明

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetHDRMaskBitmap ( )

获取HDR掩码位图。

返回
HDR掩码位图。

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ SaveDataFrame()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。

◆ ToManagedFix3D()

ManagedDataFrameFix3DStruct MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.ToManagedFix3D ( )

将当前数据帧转换为托管定点数3D格式数据。

返回
转换后的数据帧。

◆ ToUnmanagedFloat3D()

unsafe UnmanagedDataFrameFloat3DStruct MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct.ToUnmanagedFloat3D ( )

将当前数据帧转换为非托管浮点数3D格式数据。

返回
转换后的数据帧。


MPSizector .NET 编程文档: 成员列表

  • ManagedDataFrameFloat3DStruct
MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
Data | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
FrameInfo | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
ToManagedFix3D() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct
ToUnmanagedFloat3D() | MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.MonitorPositionStructType结构体 参考

  • MonitorPositionStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.MonitorPositionStructType结构体 参考

监视位置。 更多...

Public 成员函数

override string ToString ()

Public 属性

ushort | MonitorPositionX
监视位置X。
ushort | MonitorPositionY
监视位置Y。

属性

ushort | _MonitorPositionX [get]
ushort | _MonitorPositionY [get]

详细描述

监视位置。


MPSizector .NET 编程文档: 成员列表

  • MonitorPositionStructType
MPSizectorS_DotNet.MonitorPositionStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MonitorPositionStructType,包括所有继承而来的类成员

_MonitorPositionX (定义于 MPSizectorS_DotNet.MonitorPositionStructType) | MPSizectorS_DotNet.MonitorPositionStructType
_MonitorPositionY (定义于 MPSizectorS_DotNet.MonitorPositionStructType) | MPSizectorS_DotNet.MonitorPositionStructType
MonitorPositionX | MPSizectorS_DotNet.MonitorPositionStructType
MonitorPositionY | MPSizectorS_DotNet.MonitorPositionStructType
ToString() (定义于 MPSizectorS_DotNet.MonitorPositionStructType) | MPSizectorS_DotNet.MonitorPositionStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.MonitorZStructType结构体 参考

  • MonitorZStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.MonitorZStructType结构体 参考

监视高度。 更多...

Public 成员函数

override string ToString ()

Public 属性

float | Z0
监视高度0。
float | Z1
监视高度1。
float | Z2
监视高度2。
float | Z3
监视高度3。

属性

float | _Z0 [get]
float | _Z1 [get]
float | _Z2 [get]
float | _Z3 [get]

详细描述

监视高度。


MPSizector .NET 编程文档: 成员列表

  • MonitorZStructType
MPSizectorS_DotNet.MonitorZStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MonitorZStructType,包括所有继承而来的类成员

_Z0 (定义于 MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
_Z1 (定义于 MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
_Z2 (定义于 MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
_Z3 (定义于 MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
ToString() (定义于 MPSizectorS_DotNet.MonitorZStructType) | MPSizectorS_DotNet.MonitorZStructType
Z0 | MPSizectorS_DotNet.MonitorZStructType
Z1 | MPSizectorS_DotNet.MonitorZStructType
Z2 | MPSizectorS_DotNet.MonitorZStructType
Z3 | MPSizectorS_DotNet.MonitorZStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.MPDisplayer2D类 参考

  • MPDisplayer2D
Public 成员函数 | Public 属性 | Protected 成员函数 | 属性 | 事件 | 所有成员列表
MPSizectorS_DotNet.MPDisplayer2D类 参考

2D图像显示控件。 更多...

继承自 UserControl .

Public 成员函数

MPDisplayer2D ()
构造函数，无参数。

Public 属性

bool InPainting = false

Protected 成员函数

override void Dispose (bool disposing)
清理所有正在使用的资源。

属性

float | Zoom [get, set]
获取或设置图像的缩放比例。
Point | ImageOrigin [get, set]
获取或设置图像的原点坐标。
Bitmap | Bitmap [get, set]
获取或设置所显示的位图。
bool | Binning [get, set]
获取或设置源图像的像素合并状态。
Point | CurPixelCord [get]
获取当前鼠标所指的像素坐标。

事件

EventHandler PixelCordChange
鼠标所指像素坐标变化事件。

详细描述

2D图像显示控件。

成员函数说明

◆ Dispose()

override void MPSizectorS_DotNet.MPDisplayer2D.Dispose ( bool disposing )
protected

清理所有正在使用的资源。

参数
disposing 如果应释放托管资源，为 true；否则为 false。


MPSizector .NET 编程文档: 成员列表

  • MPDisplayer2D
MPSizectorS_DotNet.MPDisplayer2D 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MPDisplayer2D,包括所有继承而来的类成员

Binning | MPSizectorS_DotNet.MPDisplayer2D |
Bitmap | MPSizectorS_DotNet.MPDisplayer2D |
CurPixelCord | MPSizectorS_DotNet.MPDisplayer2D |
Dispose(bool disposing) | MPSizectorS_DotNet.MPDisplayer2D | protected
ImageOrigin | MPSizectorS_DotNet.MPDisplayer2D |
InPainting (定义于 MPSizectorS_DotNet.MPDisplayer2D) | MPSizectorS_DotNet.MPDisplayer2D |
MPDisplayer2D() | MPSizectorS_DotNet.MPDisplayer2D |
PixelCordChange | MPSizectorS_DotNet.MPDisplayer2D |
Zoom | MPSizectorS_DotNet.MPDisplayer2D |


MPSizector .NET 编程文档: MPSizectorS_DotNet.MPDisplayer3D类 参考

  • MPDisplayer3D
类 | Public 类型 | Public 成员函数 | Public 属性 | Protected 成员函数 | 属性 | 所有成员列表
MPSizectorS_DotNet.MPDisplayer3D类 参考

3D模型显示控件 更多...

继承自 UserControl .

类

struct ViewMatrixStruct
视角及物体姿态矩阵结构。 更多...

Public 类型

enum | MPModelPolygonType { Point = 0 , Line = 1 , Fill = 2 }
3D显示中绘制多边形的方法枚举 更多...
enum | MPModelTextureType { GrayImage = 0 , ColorDepthImage = 1 , GrayAndColorDepthMixed = 2 }
3D显示的纹理贴图模式枚举 更多...
enum | RotateModeEnumType { Disabled = 0 , Swing = 1 , RoundZ = 2 }
自动旋转设置枚举类型。 更多...

Public 成员函数

delegate void | SelPointChangedCallBackType (Point point)
MPDisplayer3D ()
构造函数
void | Display (ManagedDataFrameFloat3DStruct DataFrame)
显示托管的Float3D格式数据帧。
void | Display (ManagedDataFrameFix3DStruct DataFrame)
显示托管的Fix3D格式数据帧。
void | Display (ManagedDataFrameFixZMapStruct DataFrame)
void | Display (ManagedDataFrameFixZMapSimpleStruct DataFrame)
void | Display (UnmanagedDataFrameFloat3DStruct DataFrame)
显示非托管的Float3D格式数据帧。
void | Display (UnmanagedDataFrameFix3DStruct DataFrame)
显示非托管的Fix3D格式数据帧。
void | Display (UnmanagedDataFrameFixZMapStruct DataFrame)
void | Display (UnmanagedDataFrameFixZMapSimpleStruct DataFrame)
new void | Refresh ()
void | SetDrawLines (Vector3[] LinePoints, Color4[] LineColors, uint[] PointOrder)
设置显示线段的参数。
void | SetLanguage (string lan)

Public 属性

SelPointChangedCallBackType | SelPointChangedCallBack
Vector3[] | m_NormCloud

Protected 成员函数

override void Dispose (bool disposing)
清理所有正在使用的资源。

属性

bool | DrawLineEnable [get, set]
bool | IsLoaded [get]
获取当前控件是否已经载入的状态。
bool | SettingVisible [get, set]
Color | BackgroundColor [get, set]
MPModelPolygonType | ModelPolygon [get, set]
3D显示中绘制多边形的方法
MPModelTextureType | ModelTexture [get, set]
3D显示的纹理贴图模式
Auxiliary2DType | TextureImageChannel [get, set]
bool | UseNormVector [get, set]
是否使能法向量
bool | SpecularReflection [get, set]
是否使能镜面反射
bool | TransparentBackGroundSnapshot [get, set]
是否在截图时使用透明背景。
bool | EnableDisplayFilter [get, set]
是否使能显示过滤器。
float | ColorDepthImageMin [get, set]
深度色谱图的范围最小值
float | ColorDepthImageMax [get, set]
深度色谱图的范围最大值
float | PointLineSize [get, set]
Bitmap | Screenshot [get]
获取当前3D显示区域的截图
ViewMatrixStruct | ViewMatrix [get, set]
获取或设置视角及物体姿态矩阵结构体。
RotateModeEnumType | RotateMode [get, set]
获取或设置自动旋转模式。
int | RotateSpeed [get, set]
旋转的速度
int | RotateAmplitude [get, set]
旋转的幅度
float | RotatePhase [get, set]
旋转的相位

详细描述

3D模型显示控件

成员枚举类型说明

◆ MPModelPolygonType

enum MPSizectorS_DotNet.MPDisplayer3D.MPModelPolygonType

3D显示中绘制多边形的方法枚举

枚举值
Point | 绘制点
Line | 绘制线
Fill | 绘制填充区域

◆ MPModelTextureType

enum MPSizectorS_DotNet.MPDisplayer3D.MPModelTextureType

3D显示的纹理贴图模式枚举

枚举值
GrayImage | 以灰度图作为纹理
ColorDepthImage | 以深度色谱图为纹理
GrayAndColorDepthMixed | 以灰度图和深度色谱图混合为纹理

◆ RotateModeEnumType

enum MPSizectorS_DotNet.MPDisplayer3D.RotateModeEnumType

自动旋转设置枚举类型。

枚举值
Disabled | 关闭。
Swing | 以摇摆物体的形式旋转。
RoundZ | 以Z轴为中心旋转。

成员函数说明

◆ Display() [1/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( ManagedDataFrameFix3DStruct DataFrame )

显示托管的Fix3D格式数据帧。

参数
DataFrame 待显示的数据帧。

◆ Display() [2/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( ManagedDataFrameFloat3DStruct DataFrame )

显示托管的Float3D格式数据帧。

参数
DataFrame 待显示的数据帧。

◆ Display() [3/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( UnmanagedDataFrameFix3DStruct DataFrame )

显示非托管的Fix3D格式数据帧。

参数
DataFrame 待显示的数据帧。

◆ Display() [4/4]

void MPSizectorS_DotNet.MPDisplayer3D.Display ( UnmanagedDataFrameFloat3DStruct DataFrame )

显示非托管的Float3D格式数据帧。

参数
DataFrame 待显示的数据帧。

◆ Dispose()

override void MPSizectorS_DotNet.MPDisplayer3D.Dispose ( bool disposing )
protected

清理所有正在使用的资源。

参数
disposing 如果应释放托管资源，为 true；否则为 false。

◆ SetDrawLines()

void MPSizectorS_DotNet.MPDisplayer3D.SetDrawLines | ( | Vector3[] | LinePoints,
 |  | Color4[] | LineColors,
 |  | uint[] | PointOrder )

设置显示线段的参数。

参数
LinePoints | 线段端点的数据。
LineColors | 线段颜色的数据。
PointOrder | 点组成线段的规则(顺序)。


MPSizector .NET 编程文档: 成员列表

  • MPDisplayer3D
MPSizectorS_DotNet.MPDisplayer3D 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MPDisplayer3D,包括所有继承而来的类成员

BackgroundColor (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
ColorDepthImageMax | MPSizectorS_DotNet.MPDisplayer3D |
ColorDepthImageMin | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFloat3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFix3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFixZMapStruct DataFrame) (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Display(ManagedDataFrameFixZMapSimpleStruct DataFrame) (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFloat3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFix3DStruct DataFrame) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFixZMapStruct DataFrame) (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Display(UnmanagedDataFrameFixZMapSimpleStruct DataFrame) (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Dispose(bool disposing) | MPSizectorS_DotNet.MPDisplayer3D | protected
DrawLineEnable (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
EnableDisplayFilter | MPSizectorS_DotNet.MPDisplayer3D |
IsLoaded | MPSizectorS_DotNet.MPDisplayer3D |
m_NormCloud (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
ModelPolygon | MPSizectorS_DotNet.MPDisplayer3D |
ModelTexture | MPSizectorS_DotNet.MPDisplayer3D |
MPDisplayer3D() | MPSizectorS_DotNet.MPDisplayer3D |
MPModelPolygonType 枚举名称 | MPSizectorS_DotNet.MPDisplayer3D |
MPModelTextureType 枚举名称 | MPSizectorS_DotNet.MPDisplayer3D |
PointLineSize (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
Refresh() (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
RotateAmplitude | MPSizectorS_DotNet.MPDisplayer3D |
RotateMode | MPSizectorS_DotNet.MPDisplayer3D |
RotateModeEnumType 枚举名称 | MPSizectorS_DotNet.MPDisplayer3D |
RotatePhase | MPSizectorS_DotNet.MPDisplayer3D |
RotateSpeed | MPSizectorS_DotNet.MPDisplayer3D |
Screenshot | MPSizectorS_DotNet.MPDisplayer3D |
SelPointChangedCallBack (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SelPointChangedCallBackType(Point point) (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SetDrawLines(Vector3[] LinePoints, Color4[] LineColors, uint[] PointOrder) | MPSizectorS_DotNet.MPDisplayer3D |
SetLanguage(string lan) (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SettingVisible (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
SpecularReflection | MPSizectorS_DotNet.MPDisplayer3D |
TextureImageChannel (定义于 MPSizectorS_DotNet.MPDisplayer3D) | MPSizectorS_DotNet.MPDisplayer3D |
TransparentBackGroundSnapshot | MPSizectorS_DotNet.MPDisplayer3D |
UseNormVector | MPSizectorS_DotNet.MPDisplayer3D |
ViewMatrix | MPSizectorS_DotNet.MPDisplayer3D |


MPSizector .NET 编程文档: MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct结构体 参考

  • MPDisplayer3D
  • ViewMatrixStruct
Public 属性 | 所有成员列表
MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct结构体 参考

视角及物体姿态矩阵结构。 更多...

Public 属性

float | XTrans
float | YTrans
float | Zoom
float | EyeXRotDeg
float | EyeYRotDeg
float | EyeZRotDeg
float | ObjXRotDeg
float | ObjYRotDeg
float | ObjZRotDeg

详细描述

视角及物体姿态矩阵结构。


MPSizector .NET 编程文档: 成员列表

  • MPDisplayer3D
  • ViewMatrixStruct
MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct,包括所有继承而来的类成员

EyeXRotDeg (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
EyeYRotDeg (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
EyeZRotDeg (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
ObjXRotDeg (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
ObjYRotDeg (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
ObjZRotDeg (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
XTrans (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
YTrans (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct
Zoom (定义于 MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct) | MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.MPSizectorS类 参考

  • MPSizectorS
Public 成员函数 | 静态 Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.MPSizectorS类 参考

Public 成员函数

MPSizectorS (LogMediaType LogMedia=LogMediaType.Off, int BufferRate=1, bool EnableDependencyCheck=true)
构造函数。
bool | UpdateDeviceList ()
刷新设备列表。
int | GetDeviceCount ()
获取设备计数。
DeviceInfoStructType | GetDeviceInfo (int Index)
获取设备列表中指定Index的设备信息。
bool | Open (DeviceInfoStructType DeviceInfo)
打开指定设备。
bool | Reconnect ()
重新建立连接。当自动重连功能被禁用时，调用该函数以恢复断开的连接。
void | Close ()
关闭当前连接。
void | SetAutoReconnect (bool AutoReconnect)
设置自动重连功能的使能状态。自动重连功能默认使能。
bool | FireSoftwareTrigger ()
发送软件触发。
bool | SnapUnmanaged (bool SoftwareTrigger, out DataFormatType DataFormat, out UnmanagedDataFrameUndefinedStruct Data, uint TimeOutMS)
同步拍摄数据帧。该函数在成功获取一帧完整的数据帧，或超时之后返回。
delegate void | DeviceStateChangeCallBackType (DeviceStateType DeviceState)
设备状态改变回调委托。
delegate void | LogCallBackType (string Log)
日志回调委托。
delegate void | DataCallBackType (DataFormatType DataFormat, UnmanagedDataFrameUndefinedStruct DataFrame)
数据回调委托。
delegate void | HeadPackCallBackType (HeadPackStructType HeadPack)
Head pack回调委托。
void | SetLogCallBack (LogCallBackType CallBackFn)
注册日志回调函数。
void | SetDeviceStateChangeCallBack (DeviceStateChangeCallBackType CallBackFn)
注册设备状态改变回调函数。
void | SetDataCallBack (DataCallBackType CallBackFn)
注册数据回调函数。
void | SetHeadPackCallBack (HeadPackCallBackType CallBackFn)
注册head pack回调函数。
bool | SaveSettingsAsDefault ()
将当前设置保存至FlashROM。将在设备上电时被调用。
bool | LoadDefaultSettings ()
调用FlashROM中保存的设置。
unsafe byte | GetHardwareTimeStamps (out HardwareTimeStampsStructType HardwareTimeStamps)
获取硬件时间戳。
bool | GetMonitorPosition (byte Position, out ushort X, out ushort Y)
获取多头高度监控位置。
bool | SetMonitorPosition (byte Position, ushort X, ushort Y)
设置多头高度监控位置。
float | GetLastZAt (byte Position, byte Head)
获取多头高度监控Z值。
bool | CorrectDistortion (float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D, bool EnableSaveToDevice=true)
矫正畸变。
bool | SaveCorrectionParams ()
保存矫正畸变参数。
bool | GetCorrectionParam (int HeadIndex, int ParamIndex, out float Param)
获取矫正畸变参数。
bool | SetCorrectionParam (int HeadIndex, int ParamIndex, float Param)
设置矫正畸变参数。
bool | SaveCorrectionParamToXML (string FileName)
保存矫正畸变参数到文件。
bool | LoadCorrectionParamFromXML (string FileName)
从文件加载矫正畸变参数。
bool | PhyRecconect ()
强制PHY重连，制造商调试功能。
bool | PhyReset ()
复位PHY，制造商调试功能。
bool | PhyDisconnect ()
强制PHY断开连接，制造商调试功能。
uint | GetPhyInstanceID ()
获取PHY的实例ID，制造商调试功能。
float | GetPhyFWVersion ()
获取PHY固件版本，制造商调试功能。
bool | CoreHardReset ()
硬复位核心，制造商调试功能。
bool | CoreSoftReset ()
软复位核心，制造商调试功能。
byte | GetLogImportanceLevel ()
获取日志重要性等级。
bool | SetLogImportanceLevel (byte LogImportanceLevel)
设置日志重要性等级。0:SystemLog,1:OperationLog(用户调用),2:DetailLog，大于当前设置的重要性等级的日志将不会被打印。
byte | GetLogTypeLevel ()
获取日志类型等级。
bool | SetLogTypeLevel (byte LogTypeLevel)
设置日志类型等级。0:InfoLog,1:NoticeLog,2:SuccessLog,3:FailureLog，小于当前设置的类型等级的日志将不会被打印
bool | SoftwarePreprocessClear ()
bool | SetSoftwarePreprocessEnable (bool Enable)
byte | TransferExpoIntensityToExpoTime (float ExposureIntensity, WorkingModeType WorkingMode, out float ExposureTime)
将曝光强度转化为曝光时间。
byte | TransferExpoTimeToExpoIntensity (float ExposureTime, WorkingModeType WorkingMode, out float ExposureIntensity)
将曝光时间转化为曝光强度。
bool | Dump (string TargetPath, DumpContentType Content=DumpContentType.Normal)
保存缓存中的数据帧和log；
bool | ReadSettingsFromFile (string TargetPath)
读取配置文件加载到相机中,文件名需要加文件后准.mpset
bool | WriteSettingsToFile (string TargetPath)
保存相机配置文件到XML文件中,文件名需要加文件后准.mpset
bool | GetExpIByTargetGray (out float ExpI, byte TargerGrayValue, byte GrayValueTH=10, int GrayWinSize=100)
通过目标灰度值, 获取相应曝光强度。
bool | AutoSetExpertModeParam (WorkingModeType WorkingMode, uint NoiseLevel, float ZLowerRange, float ZUpperRange)
自动SuperFast3D或SuperDynamic3D的专业设置。
void | GetProjectorExpRegionInfoFromCamExpRegion (double CamExpXCenter, double CamExpYCenter, double CamExpWidth, double CamExpHeight, double Z, out double ProjectionExpXCenter, out double ProjectionExpYCenter, out double ProjectionExpWidth, out double ProjectionExpHeight, bool Reverse=false)
从相机坐标系曝光区域获取投影仪坐标系曝光区域.
bool | TestMultiHeadError (out ManagedDataFrameFixZMapSimpleStruct Error3D, out double StandardDeviation, float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D)
测试多头误差

静态 Public 成员函数

static float | GetSDKVersion ()
获取当前SDK版本号
static void | LoadDll ()
手动载入Dll.
static unsafe bool | MPSizectorS_GetExpROINum (IntPtr PIMPSizectorS, out byte ExpROINum)
static unsafe byte | MPSizectorS_SetExpROINum (IntPtr PIMPSizectorS, byte ExpROINum)
static unsafe byte | MPSizectorS_GetExpROIXCenter (IntPtr PIMPSizectorS, out ushort ExpROIX, int Index)
static unsafe byte | MPSizectorS_SetExpROIXCenter (IntPtr PIMPSizectorS, ushort ExpROIX, int Index)
static unsafe byte | MPSizectorS_GetExpROIYCenter (IntPtr PIMPSizectorS, out ushort ExpROIY, int Index)
static unsafe byte | MPSizectorS_SetExpROIYCenter (IntPtr PIMPSizectorS, ushort ExpROIY, int Index)
static unsafe byte | MPSizectorS_GetExpROIWidth (IntPtr PIMPSizectorS, out ushort ExpROIWidth, int Index)
static unsafe byte | MPSizectorS_SetExpROIWidth (IntPtr PIMPSizectorS, ushort ExpROIWidth, int Index)
static unsafe byte | MPSizectorS_GetExpROIHeight (IntPtr PIMPSizectorS, out ushort ExpROIHeight, int Index)
static unsafe byte | MPSizectorS_SetExpROIHeight (IntPtr PIMPSizectorS, ushort ExpROIHeight, int Index)
static unsafe byte | MPSizectorS_GetExpROIShape (IntPtr PIMPSizectorS, out ExpROIShapeType ExpROIShape, int Index)
static unsafe byte | MPSizectorS_SetExpROIShape (IntPtr PIMPSizectorS, ExpROIShapeType ExpROIShape, int Index)
static unsafe byte | MPSizectorS_GetExpROIBaseEnable (IntPtr PIMPSizectorS, out byte ExpROIBaseEnable, int Index)
static unsafe byte | MPSizectorS_SetExpROIBaseEnable (IntPtr PIMPSizectorS, byte ExpROIBaseEnable, int Index)
static unsafe byte | MPSizectorS_GetExpROIPolarity (IntPtr PIMPSizectorS, out ExpROIPropertyType ExpROIPolarity, int Index)
static unsafe byte | MPSizectorS_SetExpROIPolarity (IntPtr PIMPSizectorS, ExpROIPropertyType ExpROIPolarity, int Index)

Public 属性

IntPtr m_SizectorS_Instance = IntPtr.Zero
当前的设备类实例指针。

属性

DeviceInfoStructType | CurrentDeviceInfo [get]
获取当前设备的设备信息。
DeviceStateType | DeviceState [get]
获取设备的当前状态。
WorkingModeType | WorkingMode [get, set]
获取或设置工作模式。
byte | HoldState [get, set]
获取或设置暂停状态。
byte | BinningState [get, set]
获取或设置像素合并使能状态。
byte | ROIX0Ratio [get, set]
获取或设置ROI X起始点在横向像素中的比值。
byte | ROIY0Ratio [get, set]
获取或设置ROI Y起始点在竖向像素中的比值。
byte | ROIWidthRatio [get, set]
获取ROI宽度占横向像素中的比值。
byte | ROIHeightRatio [get, set]
获取或设置ROI高度占竖向像素中的比值。
BasicSettingsStructType | BasicSettings [get, set]
获取或设置基础设置。
TriggerSourceType | TriggerSource [get, set]
获取或设置触发源。
ExposureBasicSettingStructType | ExposureBasicSetting [get, set]
获取或设置基础曝光设置。
byte | UserGain [get, set]
获取或设置用户增益。
float | ExposureIntensity3D_1st [get, set]
获取或设置3D拍摄第1曝光强度。
float | ExposureIntensity3D_2nd [get, set]
获取或设置3D拍摄第2曝光强度。
float | ExposureIntensity3D_3rd [get, set]
获取或设置3D拍摄第3曝光强度。
float | ExposureIntensity2D [get, set]
获取或设置2D拍摄曝光强度。
byte | MultiHeadExpoVarMode [get, set]
获取或设置多头曝光差异模式。
byte | MultiHeadExpoVarRatio [get, set]
获取或设置多头曝光差异比例。
ExposureSettingsStructType | ExposureSettings [get, set]
获取或设置曝光设置。
byte | ExternalExposureEnable [get, set]
获取或设置外部光源使能。Bit 0设置白光使能；Bit 1设置RGB使能；1为开启，0为关闭。
ushort | ExternalExposureGain [get, set]
获取或设置外部光源增益。Bit 0 ~ Bit 3设置白光增益；Bit 4 ~ Bit 7设置红光增益；Bit 8 ~ Bit 11设置绿光增益；Bit 12 ~ Bit 15设置蓝光增益。有效范围[0, 4]。
ushort | ExternalExposureTimeWhite_us [get, set]
获取或设置外部光源白光曝光时间，单位微秒。
ushort | ExternalExposureTimeRed_us [get, set]
获取或设置外部光源红光曝光时间，单位微秒。
ushort | ExternalExposureTimeGreen_us [get, set]
获取或设置外部光源绿光曝光时间，单位微秒。
ushort | ExternalExposureTimeBlue_us [get, set]
获取或设置外部光源蓝光曝光时间，单位微秒。
ExternalExposureSettingsStructType | ExternalExposureSettings [get, set]
获取或设置外部光源曝光设置。
byte | OverExposureFilterThreshold [get, set]
获取或设置过曝剔除阈值。
MPSizectorS_HardwarePreprocessModeType | ValidPointThreshold_PresetMode [get, set]
获取或设置有效点阈值预设模式。
byte | ValidPointThreshold0 [get, set]
获取或设置有效点阈值0。
byte | ValidPointThreshold1 [get, set]
获取或设置有效点阈值1。
MPSizectorS_HardwarePreprocessModeType | BurrFilter_PresetMode [get, set]
获取或设置飞点剔除阈值预设模式。
byte | BurrFilterThreshold0 [get, set]
获取或设置飞点剔除阈值0。
byte | BurrFilterThreshold1 [get, set]
获取或设置飞点剔除阈值1。
MPSizectorS_HardwarePreprocessModeType | PreProcess_PresetMode [get, set]
获取或设置预处理预设模式。
byte | PreProcessLoopNum [get, set]
获取或设置预处理迭代次数。
byte | PreProcessThreshold [get, set]
获取或设置预处理阈值。
ReconstructionSettingsStructType | ReconstructionSettings [get, set]
获取或设置重构设置。
byte | ProjectionMode [get, set]
获取或设置多头投影模式设置。Bit 0设置投影0的使能；Bit 1设置投影1的使能；Bit 2设置投影2的使能；Bit 3设置投影3的使能；1为开启，0为关闭。
byte | MergeParam0 [get, set]
获取或设置多头融合参数0设置。更大的值将增大该因素的影响。
byte | MergeParam1 [get, set]
获取或设置多头融合参数1设置。更大的值将增大该因素的影响。
byte | MergeParam2 [get, set]
获取或设置多头融合参数2设置。更大的值将增大该因素的影响。
byte | MergeParam3 [get, set]
获取或设置多头融合参数2设置。更大的值将增大该因素的影响。
byte | MergeThreshold [get, set]
获取或设置多头融合阈值设置。有效范围为[0, 7]。更大的值将减少参与融合的头的数量。
byte | MergeNumber [get, set]
获取或设置多头融合数量设置。有效范围为[1, 4]。更大的值将增加参与融合的头的数量。
MultiHeadSettingsStructType | MultiHeadSettings [get, set]
获取或设置多头重构设置。
DataOutModeType | DataOutMode [get, set]
获取或设置数据输出模式。
byte | UserRTMatrixEnableState [get, set]
获取或设置用户旋转平移矩阵使能状态。
RTMatrixStructType | UserRTMatrix [get, set]
获取或设置用户旋转平移矩阵。
PointScaleSettingStructType | PointScaleSetting [get, set]
获取或设置定点数映射设置。
byte | RangeCheckEnableState [get, set]
获取或设置范围检查使能状态。
RangeCheckSettingStructType | RangeCheckSetting [get, set]
获取或设置范围检查设置。
PostProcessSettingsStructType | PostProcessSettings [get, set]
获取或设置后处理设置。
byte | EXTIOOutput [get, set]
获取或设置输出引脚寄存器值。
OutputPinSettingStructType | EXTIO0Setting [get, set]
获取或设置输出引脚0设置。
OutputPinSettingStructType | EXTIO1Setting [get, set]
获取或设置输出引脚1设置。
HWTriggerSettingStructType | HWTriggerSeting [get, set]
获取或设置硬件触发设置。
IOSettingsStructType | IOSettings [get, set]
获取或设置输入引脚0设置。
SettingsStructType | Settings [get, set]
获取或设置所有设置。
byte | AutoSleepEnableState [get, set]
获取或设置自动休眠使能状态。
ushort | AutoSleepDelayMS [get, set]
获取或设置自动休眠延时。
GeneralSettingsStructType | GeneralSettings [get, set]
获取或设置通用设置。
SettingsStructType | DefaultSettings [get]
获取FlashROM中保存的设置。
CalibParamStructType | CalibParam [get]
获取或设置相机标定参数。
ushort | DataTag [get, set]
获取或设置数据标签。
byte | EXTIOInput [get]
获取输入引脚寄存器值。
TemperatureFeedbackStructType | TempCore [get]
获取核心温度反馈信息。
TemperatureFeedbackStructType | Temp0 [get]
获取温度传感器0反馈信息。
TemperatureFeedbackStructType | Temp1 [get]
获取温度传感器1反馈信息。
TemperatureFeedbackStructType | Temp2 [get]
获取温度传感器2反馈信息。
uint | StartUpTimeMS [get]
获取设备启动时间。
uint | ConnectionTimeMS [get]
获取设备连接时间。
uint | SnapCnt [get]
获取拍摄计数。
ushort | TotalTransferRetryNum [get]
获取传输重试总计数。
ushort | CurrentTransferRetryNum [get]
获取当前帧的传输重试计数。
ushort | TotalCaptureRetryNum [get]
获取拍摄重试总次数。
TSNStructType | CurrentTSN [get]
获取当前TSN。
TSNStructType | SoftwareTSN [get]
获取最后一次软件触发TSN。
TSNStructType | AutoTSN [get]
获取最后一次自动触发TSN。
TSNStructType | HardwareTSN [get]
获取最后一次硬件触发TSN。
DebugInfoStruct | DebugRegisters [get]
获取调试寄存器值。
StatesStructType | States [get]
获取设备全部状态信息。
uint | MultiHeadConfig [get]
获取多头出厂设置。
ExpertSettingsStructType | ExpertSettings [get, set]
获取或设置专业设置。
byte | SuppressExpo1Enable [get, set]
获取或设置曝光抑制1使能状态。
byte | SuppressExpo2Enable [get, set]
获取或设置曝光抑制2使能状态。
byte | SuppressExpo3Enable [get, set]
获取或设置曝光抑制3使能状态。
byte | AutoHDRAdvanceSettingsEnable [get, set]
自动HDR高级设置使能状态。
byte | DiffPrejudgePatternEnable [get, set]
差分预测图使能状态。
byte | PrejudgePatternGain [get, set]
预测图增益。
byte | FlipXEnable [get, set]
获取或设置X轴翻转。
byte | FlipYEnable [get, set]
获取或设置Y轴翻转。
byte | FlipNextBinningStateEnable [get, set]
获取或设置反转下次像素合并使能状态。
AntiLampFlickerModeType | AntiLampFlickerMode [get, set]
获取或设置消除灯光频闪模式。
uint | CorrectionMode [get, set]
获取或设置矫正畸变模式。
uint | SensorExpBaseTime [get, set]
获取或设置专业工作模式的曝光基准时间。
byte | AntiNoiseLevel [get, set]
获取或设置获取抗噪系数。
byte | PatternPeriod1 [get, set]
获取或设置专业工作模式的模型周期1。
byte | PatternPeriod2 [get, set]
获取或设置专业工作模式的模型周期2。
float | ZMin [get, set]
获取或设置超快模式和超动态模式的最小高度值。
float | ZMax [get, set]
获取或设置超快模式和超动态模式的最大高度值。

构造及析构函数说明

◆ MPSizectorS()

MPSizectorS_DotNet.MPSizectorS.MPSizectorS | ( | LogMediaType | LogMedia = LogMediaType::Off,
 |  | int | BufferRate = 1,
 |  | bool | EnableDependencyCheck = true )

构造函数。

参数
LogMedia | 可选参数，日志输出媒介，默认为不输出日志。
BufferRate | 分配内存的倍数,默认为1，仅在需要将数据大量缓存时使用。32位环境，128MB*BufferRate; 64位环境, 小于5MP型号0.5GB*BufferRate, 大于5MP型号1GB*BufferRate

成员函数说明

◆ CoreHardReset()

bool MPSizectorS_DotNet.MPSizectorS.CoreHardReset ( )

硬复位核心，制造商调试功能。

返回
操作是否成功。成功为true, 失败为false。

◆ CoreSoftReset()

bool MPSizectorS_DotNet.MPSizectorS.CoreSoftReset ( )

软复位核心，制造商调试功能。

返回
操作是否成功。成功为true, 失败为false。

◆ CorrectDistortion()

bool MPSizectorS_DotNet.MPSizectorS.CorrectDistortion | ( | float | ExpI,
 |  | WorkingModeType | SnapWorkingMode = WorkingModeType::SuperPrecise3D,
 |  | bool | EnableSaveToDevice = true )

矫正畸变。

参数
ExpI | 矫正畸变时的曝光强度。
SnapWorkingMode | 矫正畸变时的工作模式。
EnableSaveToDevice | 是否保存到设备。
返回
操作是否成功。

◆ DataCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.DataCallBackType | ( | DataFormatType | DataFormat,
 |  | UnmanagedDataFrameUndefinedStruct | DataFrame )

数据回调委托。

参数
DataFormat | 传回的数据类型。
DataFrame | 传回的数据帧。

◆ DeviceStateChangeCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.DeviceStateChangeCallBackType ( DeviceStateType DeviceState )

设备状态改变回调委托。

参数
DeviceState 设备状态。

◆ Dump()

bool MPSizectorS_DotNet.MPSizectorS.Dump | ( | string | TargetPath,
 |  | DumpContentType | Content = DumpContentType::Normal )

保存缓存中的数据帧和log；

参数
FilePath 目标路径
返回
操作是否成功。成功为true, 失败为false。

◆ FireSoftwareTrigger()

bool MPSizectorS_DotNet.MPSizectorS.FireSoftwareTrigger ( )

发送软件触发。

返回
操作是否成功。成功为true, 失败为false。

◆ GetDeviceCount()

int MPSizectorS_DotNet.MPSizectorS.GetDeviceCount ( )

获取设备计数。

返回
设备计数。

◆ GetDeviceInfo()

DeviceInfoStructType MPSizectorS_DotNet.MPSizectorS.GetDeviceInfo ( int Index )

获取设备列表中指定Index的设备信息。

参数
Index 指定的Index。
返回
设备信息。

◆ GetExpIByTargetGray()

bool MPSizectorS_DotNet.MPSizectorS.GetExpIByTargetGray | ( | out float | ExpI,
 |  | byte | TargerGrayValue,
 |  | byte | GrayValueTH = 10,
 |  | int | GrayWinSize = 100 )

通过目标灰度值, 获取相应曝光强度。

参数
TargerGrayValue | 目标灰度值。
ExpI | 曝光强度。
GrayValueTH | 灰度阈值, 目标灰度上下浮动的范围。
GrayWinSize | 图像中心计算平均灰度的窗口大小。
返回
操作是否成功。

◆ GetLogImportanceLevel()

byte MPSizectorS_DotNet.MPSizectorS.GetLogImportanceLevel ( )

获取日志重要性等级。

返回
日志重要性等级。

◆ GetLogTypeLevel()

byte MPSizectorS_DotNet.MPSizectorS.GetLogTypeLevel ( )

获取日志类型等级。

返回
日志类型等级。

◆ GetPhyFWVersion()

float MPSizectorS_DotNet.MPSizectorS.GetPhyFWVersion ( )

获取PHY固件版本，制造商调试功能。

返回
PHY固件版本。

◆ GetPhyInstanceID()

uint MPSizectorS_DotNet.MPSizectorS.GetPhyInstanceID ( )

获取PHY的实例ID，制造商调试功能。

返回
PHY实例ID。

◆ GetProjectorExpRegionInfoFromCamExpRegion()

void MPSizectorS_DotNet.MPSizectorS.GetProjectorExpRegionInfoFromCamExpRegion | ( | double | CamExpXCenter,
 |  | double | CamExpYCenter,
 |  | double | CamExpWidth,
 |  | double | CamExpHeight,
 |  | double | Z,
 |  | out double | ProjectionExpXCenter,
 |  | out double | ProjectionExpYCenter,
 |  | out double | ProjectionExpWidth,
 |  | out double | ProjectionExpHeight,
 |  | bool | Reverse = false )

从相机坐标系曝光区域获取投影仪坐标系曝光区域.

参数
CamExpXCenter | 相机坐标系曝光区域中心x.
CamExpYCenter | 相机坐标系曝光区域中心y.
CamExpWidth | 相机坐标系曝光区域宽度.
CamExpHeight | 相机坐标系曝光区域高度.
Z | 转换坐标点所在位置的高度.
ProjectionExpXCenter | 投影仪坐标系曝光区域中心x.
ProjectionExpYCenter | 投影仪坐标系曝光区域中心y.
ProjectionExpWidth 投影仪坐标系曝光区域宽度./param>
参数
ProjectionExpHeight | 投影仪坐标系曝光区域高度.
Reverse | 是否反转变换方向.

◆ GetSDKVersion()

static float MPSizectorS_DotNet.MPSizectorS.GetSDKVersion ( )
static

获取当前SDK版本号

返回
SDK版本号。

◆ HeadPackCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.HeadPackCallBackType ( HeadPackStructType HeadPack )

Head pack回调委托。

参数
HeadPack 传回的Head pack.

◆ LoadCorrectionParamFromXML()

bool MPSizectorS_DotNet.MPSizectorS.LoadCorrectionParamFromXML ( string FileName )

从文件加载矫正畸变参数。

参数
FileName 文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ LoadDefaultSettings()

bool MPSizectorS_DotNet.MPSizectorS.LoadDefaultSettings ( )

调用FlashROM中保存的设置。

返回
操作是否成功。成功为true, 失败为false。

◆ LoadDll()

static void MPSizectorS_DotNet.MPSizectorS.LoadDll ( )
static

手动载入Dll.

返回

◆ LogCallBackType()

delegate void MPSizectorS_DotNet.MPSizectorS.LogCallBackType ( string Log )

日志回调委托。

参数
Log 日志信息。

◆ Open()

bool MPSizectorS_DotNet.MPSizectorS.Open ( DeviceInfoStructType DeviceInfo )

打开指定设备。

参数
DeviceInfo 指定设备的设备信息。
返回
操作是否成功。成功为true, 失败为false。

◆ PhyDisconnect()

bool MPSizectorS_DotNet.MPSizectorS.PhyDisconnect ( )

强制PHY断开连接，制造商调试功能。

返回
操作是否成功。成功为true, 失败为false。

◆ PhyRecconect()

bool MPSizectorS_DotNet.MPSizectorS.PhyRecconect ( )

强制PHY重连，制造商调试功能。

返回
操作是否成功。成功为true, 失败为false。

◆ PhyReset()

bool MPSizectorS_DotNet.MPSizectorS.PhyReset ( )

复位PHY，制造商调试功能。

返回
操作是否成功。成功为true, 失败为false。

◆ ReadSettingsFromFile()

bool MPSizectorS_DotNet.MPSizectorS.ReadSettingsFromFile ( string TargetPath )

读取配置文件加载到相机中,文件名需要加文件后准.mpset

参数
FilePath 目标路径
返回
操作是否成功。成功为true, 失败为false。

◆ Reconnect()

bool MPSizectorS_DotNet.MPSizectorS.Reconnect ( )

重新建立连接。当自动重连功能被禁用时，调用该函数以恢复断开的连接。

返回
操作是否成功。成功为true, 失败为false。

◆ SaveCorrectionParamToXML()

bool MPSizectorS_DotNet.MPSizectorS.SaveCorrectionParamToXML ( string FileName )

保存矫正畸变参数到文件。

参数
FileName 文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveSettingsAsDefault()

bool MPSizectorS_DotNet.MPSizectorS.SaveSettingsAsDefault ( )

将当前设置保存至FlashROM。将在设备上电时被调用。

返回
操作是否成功。成功为true, 失败为false。

◆ SetAutoReconnect()

void MPSizectorS_DotNet.MPSizectorS.SetAutoReconnect ( bool AutoReconnect )

设置自动重连功能的使能状态。自动重连功能默认使能。

参数
AutoReconnect 自动重连功能的使能状态。

◆ SetDataCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetDataCallBack ( DataCallBackType CallBackFn )

注册数据回调函数。

参数
CallBackFn 目标函数。

◆ SetDeviceStateChangeCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetDeviceStateChangeCallBack ( DeviceStateChangeCallBackType CallBackFn )

注册设备状态改变回调函数。

参数
CallBackFn 目标函数。

◆ SetHeadPackCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetHeadPackCallBack ( HeadPackCallBackType CallBackFn )

注册head pack回调函数。

参数
CallBackFn 目标函数。

◆ SetLogCallBack()

void MPSizectorS_DotNet.MPSizectorS.SetLogCallBack ( LogCallBackType CallBackFn )

注册日志回调函数。

参数
CallBackFn 目标函数。

◆ SetLogImportanceLevel()

bool MPSizectorS_DotNet.MPSizectorS.SetLogImportanceLevel ( byte LogImportanceLevel )

设置日志重要性等级。0:SystemLog,1:OperationLog(用户调用),2:DetailLog，大于当前设置的重要性等级的日志将不会被打印。

参数
LogImportanceLevel 日志重要性等级。
返回
操作是否成功。成功为true, 失败为false。

◆ SetLogTypeLevel()

bool MPSizectorS_DotNet.MPSizectorS.SetLogTypeLevel ( byte LogTypeLevel )

设置日志类型等级。0:InfoLog,1:NoticeLog,2:SuccessLog,3:FailureLog，小于当前设置的类型等级的日志将不会被打印

参数
LogTypeLevel 日志类型等级。
返回
操作是否成功。成功为true, 失败为false。

◆ SnapUnmanaged()

bool MPSizectorS_DotNet.MPSizectorS.SnapUnmanaged | ( | bool | SoftwareTrigger,
 |  | out DataFormatType | DataFormat,
 |  | out UnmanagedDataFrameUndefinedStruct | Data,
 |  | uint | TimeOutMS )

同步拍摄数据帧。该函数在成功获取一帧完整的数据帧，或超时之后返回。

参数
SoftwareTrigger | 是否要发送软件触发。
DataFormat | 通过参考返回，拍摄得到的数据帧的格式。
Data | 通过参考返回，拍摄得到的数据帧。
TimeOutMS | 最长等待时间，以ms为单位。
返回
操作是否成功。成功为true, 失败为false。

◆ TestMultiHeadError()

bool MPSizectorS_DotNet.MPSizectorS.TestMultiHeadError | ( | out ManagedDataFrameFixZMapSimpleStruct | Error3D,
 |  | out double | StandardDeviation,
 |  | float | ExpI,
 |  | WorkingModeType | SnapWorkingMode = WorkingModeType::SuperPrecise3D )

测试多头误差

参数
Error3D | 误差3D图像。
StandardDeviation | 误差标准差。
ExpI | 测试时使用的曝光强度。
SnapWorkingMode | 测试时使用的工作模式。
返回
操作是否成功。

◆ TransferExpoIntensityToExpoTime()

byte MPSizectorS_DotNet.MPSizectorS.TransferExpoIntensityToExpoTime | ( | float | ExposureIntensity,
 |  | WorkingModeType | WorkingMode,
 |  | out float | ExposureTime )

将曝光强度转化为曝光时间。

参数
ExposureIntensity | 曝光强度。
WorkingMode | 工作模式。
ExposureTime | 曝光时间。
返回
操作是否成功。成功为true, 失败为false。

◆ TransferExpoTimeToExpoIntensity()

byte MPSizectorS_DotNet.MPSizectorS.TransferExpoTimeToExpoIntensity | ( | float | ExposureTime,
 |  | WorkingModeType | WorkingMode,
 |  | out float | ExposureIntensity )

将曝光时间转化为曝光强度。

参数
ExposureTime | 曝光时间。
WorkingMode | 工作模式。
ExposureIntensity | 曝光强度。
返回
操作是否成功。成功为true, 失败为false。

◆ UpdateDeviceList()

bool MPSizectorS_DotNet.MPSizectorS.UpdateDeviceList ( )

刷新设备列表。

返回
操作是否成功。成功为true, 失败为false。

◆ WriteSettingsToFile()

bool MPSizectorS_DotNet.MPSizectorS.WriteSettingsToFile ( string TargetPath )

保存相机配置文件到XML文件中,文件名需要加文件后准.mpset

参数
FilePath 目标路径
返回
操作是否成功。成功为true, 失败为false。

属性说明

◆ CurrentDeviceInfo

DeviceInfoStructType MPSizectorS_DotNet.MPSizectorS.CurrentDeviceInfo
get

获取当前设备的设备信息。

返回
当前设备的设备信息。

◆ DeviceState

DeviceStateType MPSizectorS_DotNet.MPSizectorS.DeviceState
get

获取设备的当前状态。

返回
设备的当前状态。

◆ ExposureIntensity3D_1st

float MPSizectorS_DotNet.MPSizectorS.ExposureIntensity3D_1st
getset

获取或设置3D拍摄第1曝光强度。

`

◆ MultiHeadExpoVarMode

byte MPSizectorS_DotNet.MPSizectorS.MultiHeadExpoVarMode
getset

获取或设置多头曝光差异模式。

`

◆ MultiHeadExpoVarRatio

byte MPSizectorS_DotNet.MPSizectorS.MultiHeadExpoVarRatio
getset

获取或设置多头曝光差异比例。

`


MPSizector .NET 编程文档: 成员列表

  • MPSizectorS
MPSizectorS_DotNet.MPSizectorS 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MPSizectorS,包括所有继承而来的类成员

AntiLampFlickerMode | MPSizectorS_DotNet.MPSizectorS |
AntiNoiseLevel | MPSizectorS_DotNet.MPSizectorS |
AutoHDRAdvanceSettingsEnable | MPSizectorS_DotNet.MPSizectorS |
AutoSetExpertModeParam(WorkingModeType WorkingMode, uint NoiseLevel, float ZLowerRange, float ZUpperRange) | MPSizectorS_DotNet.MPSizectorS |
AutoSleepDelayMS | MPSizectorS_DotNet.MPSizectorS |
AutoSleepEnableState | MPSizectorS_DotNet.MPSizectorS |
AutoTSN | MPSizectorS_DotNet.MPSizectorS |
BasicSettings | MPSizectorS_DotNet.MPSizectorS |
BinningState | MPSizectorS_DotNet.MPSizectorS |
BurrFilter_PresetMode | MPSizectorS_DotNet.MPSizectorS |
BurrFilterThreshold0 | MPSizectorS_DotNet.MPSizectorS |
BurrFilterThreshold1 | MPSizectorS_DotNet.MPSizectorS |
CalibParam | MPSizectorS_DotNet.MPSizectorS |
Close() | MPSizectorS_DotNet.MPSizectorS |
ConnectionTimeMS | MPSizectorS_DotNet.MPSizectorS |
CoreHardReset() | MPSizectorS_DotNet.MPSizectorS |
CoreSoftReset() | MPSizectorS_DotNet.MPSizectorS |
CorrectDistortion(float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D, bool EnableSaveToDevice=true) | MPSizectorS_DotNet.MPSizectorS |
CorrectionMode | MPSizectorS_DotNet.MPSizectorS |
CurrentDeviceInfo | MPSizectorS_DotNet.MPSizectorS |
CurrentTransferRetryNum | MPSizectorS_DotNet.MPSizectorS |
CurrentTSN | MPSizectorS_DotNet.MPSizectorS |
DataCallBackType(DataFormatType DataFormat, UnmanagedDataFrameUndefinedStruct DataFrame) | MPSizectorS_DotNet.MPSizectorS |
DataOutMode | MPSizectorS_DotNet.MPSizectorS |
DataTag | MPSizectorS_DotNet.MPSizectorS |
DebugRegisters | MPSizectorS_DotNet.MPSizectorS |
DefaultSettings | MPSizectorS_DotNet.MPSizectorS |
DeviceState | MPSizectorS_DotNet.MPSizectorS |
DeviceStateChangeCallBackType(DeviceStateType DeviceState) | MPSizectorS_DotNet.MPSizectorS |
DiffPrejudgePatternEnable | MPSizectorS_DotNet.MPSizectorS |
Dump(string TargetPath, DumpContentType Content=DumpContentType.Normal) | MPSizectorS_DotNet.MPSizectorS |
ExpertSettings | MPSizectorS_DotNet.MPSizectorS |
ExposureBasicSetting | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity2D | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity3D_1st | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity3D_2nd | MPSizectorS_DotNet.MPSizectorS |
ExposureIntensity3D_3rd | MPSizectorS_DotNet.MPSizectorS |
ExposureSettings | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureEnable | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureGain | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureSettings | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeBlue_us | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeGreen_us | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeRed_us | MPSizectorS_DotNet.MPSizectorS |
ExternalExposureTimeWhite_us | MPSizectorS_DotNet.MPSizectorS |
EXTIO0Setting | MPSizectorS_DotNet.MPSizectorS |
EXTIO1Setting | MPSizectorS_DotNet.MPSizectorS |
EXTIOInput | MPSizectorS_DotNet.MPSizectorS |
EXTIOOutput | MPSizectorS_DotNet.MPSizectorS |
FireSoftwareTrigger() | MPSizectorS_DotNet.MPSizectorS |
FlipNextBinningStateEnable | MPSizectorS_DotNet.MPSizectorS |
FlipXEnable | MPSizectorS_DotNet.MPSizectorS |
FlipYEnable | MPSizectorS_DotNet.MPSizectorS |
GeneralSettings | MPSizectorS_DotNet.MPSizectorS |
GetCorrectionParam(int HeadIndex, int ParamIndex, out float Param) | MPSizectorS_DotNet.MPSizectorS |
GetDeviceCount() | MPSizectorS_DotNet.MPSizectorS |
GetDeviceInfo(int Index) | MPSizectorS_DotNet.MPSizectorS |
GetExpIByTargetGray(out float ExpI, byte TargerGrayValue, byte GrayValueTH=10, int GrayWinSize=100) | MPSizectorS_DotNet.MPSizectorS |
GetHardwareTimeStamps(out HardwareTimeStampsStructType HardwareTimeStamps) | MPSizectorS_DotNet.MPSizectorS |
GetLastZAt(byte Position, byte Head) | MPSizectorS_DotNet.MPSizectorS |
GetLogImportanceLevel() | MPSizectorS_DotNet.MPSizectorS |
GetLogTypeLevel() | MPSizectorS_DotNet.MPSizectorS |
GetMonitorPosition(byte Position, out ushort X, out ushort Y) | MPSizectorS_DotNet.MPSizectorS |
GetPhyFWVersion() | MPSizectorS_DotNet.MPSizectorS |
GetPhyInstanceID() | MPSizectorS_DotNet.MPSizectorS |
GetProjectorExpRegionInfoFromCamExpRegion(double CamExpXCenter, double CamExpYCenter, double CamExpWidth, double CamExpHeight, double Z, out double ProjectionExpXCenter, out double ProjectionExpYCenter, out double ProjectionExpWidth, out double ProjectionExpHeight, bool Reverse=false) | MPSizectorS_DotNet.MPSizectorS |
GetSDKVersion() | MPSizectorS_DotNet.MPSizectorS | static
HardwareTSN | MPSizectorS_DotNet.MPSizectorS |
HeadPackCallBackType(HeadPackStructType HeadPack) | MPSizectorS_DotNet.MPSizectorS |
HoldState | MPSizectorS_DotNet.MPSizectorS |
HWTriggerSeting | MPSizectorS_DotNet.MPSizectorS |
IOSettings | MPSizectorS_DotNet.MPSizectorS |
LoadCorrectionParamFromXML(string FileName) | MPSizectorS_DotNet.MPSizectorS |
LoadDefaultSettings() | MPSizectorS_DotNet.MPSizectorS |
LoadDll() | MPSizectorS_DotNet.MPSizectorS | static
LogCallBackType(string Log) | MPSizectorS_DotNet.MPSizectorS |
m_SizectorS_Instance | MPSizectorS_DotNet.MPSizectorS |
MergeNumber | MPSizectorS_DotNet.MPSizectorS |
MergeParam0 | MPSizectorS_DotNet.MPSizectorS |
MergeParam1 | MPSizectorS_DotNet.MPSizectorS |
MergeParam2 | MPSizectorS_DotNet.MPSizectorS |
MergeParam3 | MPSizectorS_DotNet.MPSizectorS |
MergeThreshold | MPSizectorS_DotNet.MPSizectorS |
MPSizectorS(LogMediaType LogMedia=LogMediaType.Off, int BufferRate=1, bool EnableDependencyCheck=true) | MPSizectorS_DotNet.MPSizectorS |
MPSizectorS_GetExpROIBaseEnable(IntPtr PIMPSizectorS, out byte ExpROIBaseEnable, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIHeight(IntPtr PIMPSizectorS, out ushort ExpROIHeight, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROINum(IntPtr PIMPSizectorS, out byte ExpROINum) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIPolarity(IntPtr PIMPSizectorS, out ExpROIPropertyType ExpROIPolarity, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIShape(IntPtr PIMPSizectorS, out ExpROIShapeType ExpROIShape, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIWidth(IntPtr PIMPSizectorS, out ushort ExpROIWidth, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIXCenter(IntPtr PIMPSizectorS, out ushort ExpROIX, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_GetExpROIYCenter(IntPtr PIMPSizectorS, out ushort ExpROIY, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIBaseEnable(IntPtr PIMPSizectorS, byte ExpROIBaseEnable, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIHeight(IntPtr PIMPSizectorS, ushort ExpROIHeight, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROINum(IntPtr PIMPSizectorS, byte ExpROINum) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIPolarity(IntPtr PIMPSizectorS, ExpROIPropertyType ExpROIPolarity, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIShape(IntPtr PIMPSizectorS, ExpROIShapeType ExpROIShape, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIWidth(IntPtr PIMPSizectorS, ushort ExpROIWidth, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIXCenter(IntPtr PIMPSizectorS, ushort ExpROIX, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MPSizectorS_SetExpROIYCenter(IntPtr PIMPSizectorS, ushort ExpROIY, int Index) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS | static
MultiHeadConfig | MPSizectorS_DotNet.MPSizectorS |
MultiHeadExpoVarMode | MPSizectorS_DotNet.MPSizectorS |
MultiHeadExpoVarRatio | MPSizectorS_DotNet.MPSizectorS |
MultiHeadSettings | MPSizectorS_DotNet.MPSizectorS |
Open(DeviceInfoStructType DeviceInfo) | MPSizectorS_DotNet.MPSizectorS |
OverExposureFilterThreshold | MPSizectorS_DotNet.MPSizectorS |
PatternPeriod1 | MPSizectorS_DotNet.MPSizectorS |
PatternPeriod2 | MPSizectorS_DotNet.MPSizectorS |
PhyDisconnect() | MPSizectorS_DotNet.MPSizectorS |
PhyRecconect() | MPSizectorS_DotNet.MPSizectorS |
PhyReset() | MPSizectorS_DotNet.MPSizectorS |
PointScaleSetting | MPSizectorS_DotNet.MPSizectorS |
PostProcessSettings | MPSizectorS_DotNet.MPSizectorS |
PrejudgePatternGain | MPSizectorS_DotNet.MPSizectorS |
PreProcess_PresetMode | MPSizectorS_DotNet.MPSizectorS |
PreProcessLoopNum | MPSizectorS_DotNet.MPSizectorS |
PreProcessThreshold | MPSizectorS_DotNet.MPSizectorS |
ProjectionMode | MPSizectorS_DotNet.MPSizectorS |
RangeCheckEnableState | MPSizectorS_DotNet.MPSizectorS |
RangeCheckSetting | MPSizectorS_DotNet.MPSizectorS |
ReadSettingsFromFile(string TargetPath) | MPSizectorS_DotNet.MPSizectorS |
Reconnect() | MPSizectorS_DotNet.MPSizectorS |
ReconstructionSettings | MPSizectorS_DotNet.MPSizectorS |
ROIHeightRatio | MPSizectorS_DotNet.MPSizectorS |
ROIWidthRatio | MPSizectorS_DotNet.MPSizectorS |
ROIX0Ratio | MPSizectorS_DotNet.MPSizectorS |
ROIY0Ratio | MPSizectorS_DotNet.MPSizectorS |
SaveCorrectionParams() | MPSizectorS_DotNet.MPSizectorS |
SaveCorrectionParamToXML(string FileName) | MPSizectorS_DotNet.MPSizectorS |
SaveSettingsAsDefault() | MPSizectorS_DotNet.MPSizectorS |
SensorExpBaseTime | MPSizectorS_DotNet.MPSizectorS |
SetAutoReconnect(bool AutoReconnect) | MPSizectorS_DotNet.MPSizectorS |
SetCorrectionParam(int HeadIndex, int ParamIndex, float Param) | MPSizectorS_DotNet.MPSizectorS |
SetDataCallBack(DataCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetDeviceStateChangeCallBack(DeviceStateChangeCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetHeadPackCallBack(HeadPackCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetLogCallBack(LogCallBackType CallBackFn) | MPSizectorS_DotNet.MPSizectorS |
SetLogImportanceLevel(byte LogImportanceLevel) | MPSizectorS_DotNet.MPSizectorS |
SetLogTypeLevel(byte LogTypeLevel) | MPSizectorS_DotNet.MPSizectorS |
SetMonitorPosition(byte Position, ushort X, ushort Y) | MPSizectorS_DotNet.MPSizectorS |
SetSoftwarePreprocessEnable(bool Enable) (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS |
Settings | MPSizectorS_DotNet.MPSizectorS |
SnapCnt | MPSizectorS_DotNet.MPSizectorS |
SnapUnmanaged(bool SoftwareTrigger, out DataFormatType DataFormat, out UnmanagedDataFrameUndefinedStruct Data, uint TimeOutMS) | MPSizectorS_DotNet.MPSizectorS |
SoftwarePreprocessClear() (定义于 MPSizectorS_DotNet.MPSizectorS) | MPSizectorS_DotNet.MPSizectorS |
SoftwareTSN | MPSizectorS_DotNet.MPSizectorS |
StartUpTimeMS | MPSizectorS_DotNet.MPSizectorS |
States | MPSizectorS_DotNet.MPSizectorS |
SuppressExpo1Enable | MPSizectorS_DotNet.MPSizectorS |
SuppressExpo2Enable | MPSizectorS_DotNet.MPSizectorS |
SuppressExpo3Enable | MPSizectorS_DotNet.MPSizectorS |
Temp0 | MPSizectorS_DotNet.MPSizectorS |
Temp1 | MPSizectorS_DotNet.MPSizectorS |
Temp2 | MPSizectorS_DotNet.MPSizectorS |
TempCore | MPSizectorS_DotNet.MPSizectorS |
TestMultiHeadError(out ManagedDataFrameFixZMapSimpleStruct Error3D, out double StandardDeviation, float ExpI, WorkingModeType SnapWorkingMode=WorkingModeType.SuperPrecise3D) | MPSizectorS_DotNet.MPSizectorS |
TotalCaptureRetryNum | MPSizectorS_DotNet.MPSizectorS |
TotalTransferRetryNum | MPSizectorS_DotNet.MPSizectorS |
TransferExpoIntensityToExpoTime(float ExposureIntensity, WorkingModeType WorkingMode, out float ExposureTime) | MPSizectorS_DotNet.MPSizectorS |
TransferExpoTimeToExpoIntensity(float ExposureTime, WorkingModeType WorkingMode, out float ExposureIntensity) | MPSizectorS_DotNet.MPSizectorS |
TriggerSource | MPSizectorS_DotNet.MPSizectorS |
UpdateDeviceList() | MPSizectorS_DotNet.MPSizectorS |
UserGain | MPSizectorS_DotNet.MPSizectorS |
UserRTMatrix | MPSizectorS_DotNet.MPSizectorS |
UserRTMatrixEnableState | MPSizectorS_DotNet.MPSizectorS |
ValidPointThreshold0 | MPSizectorS_DotNet.MPSizectorS |
ValidPointThreshold1 | MPSizectorS_DotNet.MPSizectorS |
ValidPointThreshold_PresetMode | MPSizectorS_DotNet.MPSizectorS |
WorkingMode | MPSizectorS_DotNet.MPSizectorS |
WriteSettingsToFile(string TargetPath) | MPSizectorS_DotNet.MPSizectorS |
ZMax | MPSizectorS_DotNet.MPSizectorS |
ZMin | MPSizectorS_DotNet.MPSizectorS |


MPSizector .NET 编程文档: MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType结构体 参考

  • MPSizectorS_AutoHDRAdvanceSettingsStructType
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType结构体 参考

自动HDR高级设置结构体。 更多...

Public 属性

byte | AutoHDRAdvanceSettingsEnable
是否启用自动HDR高级设置。
byte | DiffPrejudgePatternEnable
是否启用差分预测图。
byte | PrejudgePatternGain
预测图增益。

属性

byte | _AutoHDRAdvanceSettingsEnable [get]
byte | _DiffPrejudgePatternEnable [get]
byte | _PrejudgePatternGain [get]

详细描述

自动HDR高级设置结构体。


MPSizector .NET 编程文档: 成员列表

  • MPSizectorS_AutoHDRAdvanceSettingsStructType
MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType,包括所有继承而来的类成员

_AutoHDRAdvanceSettingsEnable (定义于 MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
_DiffPrejudgePatternEnable (定义于 MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
_PrejudgePatternGain (定义于 MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
AutoHDRAdvanceSettingsEnable | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
DiffPrejudgePatternEnable | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
PrejudgePatternGain | MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType结构体 参考

  • MPSizectorS_ExpICoefSettingsStructType
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType结构体 参考

曝光系数设置结构体。 更多...

Public 属性

float | ExpICoef
曝光系数。
float | ExpICoefMax
最大曝光系数。

属性

float | _ExpICoef [get]
float | _ExpICoefMax [get]

详细描述

曝光系数设置结构体。


MPSizector .NET 编程文档: 成员列表

  • MPSizectorS_ExpICoefSettingsStructType
MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType,包括所有继承而来的类成员

_ExpICoef (定义于 MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
_ExpICoefMax (定义于 MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType) | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
ExpICoef | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
ExpICoefMax | MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.MultiHeadSettingsStructType结构体 参考

  • MultiHeadSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.MultiHeadSettingsStructType结构体 参考

多头重构设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | ProjectionMode
投影模式。Bit 0设置投影0的使能；Bit 1设置投影1的使能；Bit 2设置投影2的使能；Bit 3设置投影3的使能；1为开启，0为关闭。
byte | MergeParam0
融合参数0。有效范围为[0, 7]。更大的值将增大该因素的影响。
byte | MergeParam1
融合参数1。有效范围为[0, 7]。更大的值将增大该因素的影响。
byte | MergeParam2
融合参数2。有效范围为[0, 7]。更大的值将增大该因素的影响。
byte | MergeThreshold
融合阈值。有效范围为[0, 7]。更大的值将减少参与融合的头的数量。

属性

byte | _ProjectionMode [get]
byte | _MergeParam0 [get]
byte | _MergeParam1 [get]
byte | _MergeParam2 [get]
byte | _MergeThreshold [get]
int | ProjectionNumber [get]
投影数量。

详细描述

多头重构设置结构体。


MPSizector .NET 编程文档: 成员列表

  • MultiHeadSettingsStructType
MPSizectorS_DotNet.MultiHeadSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.MultiHeadSettingsStructType,包括所有继承而来的类成员

_MergeParam0 (定义于 MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_MergeParam1 (定义于 MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_MergeParam2 (定义于 MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_MergeThreshold (定义于 MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
_ProjectionMode (定义于 MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeParam0 | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeParam1 | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeParam2 | MPSizectorS_DotNet.MultiHeadSettingsStructType
MergeThreshold | MPSizectorS_DotNet.MultiHeadSettingsStructType
ProjectionMode | MPSizectorS_DotNet.MultiHeadSettingsStructType
ProjectionNumber | MPSizectorS_DotNet.MultiHeadSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.MultiHeadSettingsStructType) | MPSizectorS_DotNet.MultiHeadSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.OutputPinSettingStructType结构体 参考

  • OutputPinSettingStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.OutputPinSettingStructType结构体 参考

输出引脚设置结构体（单个PIN脚的设置）。 更多...

Public 成员函数

override string ToString ()

Public 属性

OutputPinModeType | PinMode
输出引脚模式。
byte | IsReversedForSpecialFunction
特殊功能输出信号的极性是否反转。

属性

OutputPinModeType | _PinMode [get]
byte | _IsReversedForSpecialFunction [get]

详细描述

输出引脚设置结构体（单个PIN脚的设置）。


MPSizector .NET 编程文档: 成员列表

  • OutputPinSettingStructType
MPSizectorS_DotNet.OutputPinSettingStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.OutputPinSettingStructType,包括所有继承而来的类成员

_IsReversedForSpecialFunction (定义于 MPSizectorS_DotNet.OutputPinSettingStructType) | MPSizectorS_DotNet.OutputPinSettingStructType
_PinMode (定义于 MPSizectorS_DotNet.OutputPinSettingStructType) | MPSizectorS_DotNet.OutputPinSettingStructType
IsReversedForSpecialFunction | MPSizectorS_DotNet.OutputPinSettingStructType
PinMode | MPSizectorS_DotNet.OutputPinSettingStructType
ToString() (定义于 MPSizectorS_DotNet.OutputPinSettingStructType) | MPSizectorS_DotNet.OutputPinSettingStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.PartialFactorySettingsStructType结构体 参考

  • PartialFactorySettingsStructType
Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.PartialFactorySettingsStructType结构体 参考

部分工厂设置结构体。 更多...

Public 属性

uint | MultiHeadConfig
float | ExpICoef
float | ExpICoefMax
float | LED0Coef
float | LED1Coef
float | LED2Coef
float | LED3Coef
uint | LEDCoefEN
float | PreJudgeExpI_0
float | PreJudgeExpI_1
float | PreJudgeExpI_2
byte | PreJudge_AmpTH
byte | PreJudge_AmpRatioTH
float | PreJudge_IdealGray
byte | PreJudge_RSideWidth_Standard
byte | PreJudge_RSideWidth_Precise
byte | PreJudge_RSideWidth_SuperPrecise
byte | PreJudge_LSideWidth_Standard
byte | PreJudge_LSideWidth_Precise
byte | PreJudge_LSideWidth_SuperPrecise
byte | BtoG_Enable
float | BtoG_Recon_Weight_R
float | BtoG_Recon_Weight_G
float | BtoG_Recon_Weight_B
byte | BtoC_Enable
float | BtoC_2D_Weight_R
float | BtoC_2D_Weight_G
float | BtoC_2D_Weight_B
byte[] | Reserve

属性

uint | _MultiHeadConfig [get]
float | _ExpICoef [get]
float | _ExpICoefMax [get]
float | _LED0Coef [get]
float | _LED1Coef [get]
float | _LED2Coef [get]
float | _LED3Coef [get]
uint | _LEDCoefEN [get]
float | _PreJudgeExpI_0 [get]
float | _PreJudgeExpI_1 [get]
float | _PreJudgeExpI_2 [get]
byte | _PreJudge_AmpTH [get]
byte | _PreJudge_AmpRatioTH [get]
float | _PreJudge_IdealGray [get]
byte | _PreJudge_RSideWidth_Standard [get]
byte | _PreJudge_RSideWidth_Precise [get]
byte | _PreJudge_RSideWidth_SuperPrecise [get]
byte | _PreJudge_LSideWidth_Standard [get]
byte | _PreJudge_LSideWidth_Precise [get]
byte | _PreJudge_LSideWidth_SuperPrecise [get]
byte | _BtoG_Enable [get]
float | _BtoG_Recon_Weight_R [get]
float | _BtoG_Recon_Weight_G [get]
float | _BtoG_Recon_Weight_B [get]
byte | _BtoC_Enable [get]
float | _BtoC_2D_Weight_R [get]
float | _BtoC_2D_Weight_G [get]
float | _BtoC_2D_Weight_B [get]

详细描述

部分工厂设置结构体。


MPSizector .NET 编程文档: 成员列表

  • PartialFactorySettingsStructType
MPSizectorS_DotNet.PartialFactorySettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.PartialFactorySettingsStructType,包括所有继承而来的类成员

_BtoC_2D_Weight_B (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoC_2D_Weight_G (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoC_2D_Weight_R (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoC_Enable (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Enable (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Recon_Weight_B (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Recon_Weight_G (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_BtoG_Recon_Weight_R (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_ExpICoef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_ExpICoefMax (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED0Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED1Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED2Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LED3Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_LEDCoefEN (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_MultiHeadConfig (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_AmpRatioTH (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_AmpTH (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_IdealGray (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_LSideWidth_Precise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_LSideWidth_Standard (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_LSideWidth_SuperPrecise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_RSideWidth_Precise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_RSideWidth_Standard (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudge_RSideWidth_SuperPrecise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudgeExpI_0 (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudgeExpI_1 (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
_PreJudgeExpI_2 (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_2D_Weight_B (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_2D_Weight_G (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_2D_Weight_R (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoC_Enable (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Enable (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Recon_Weight_B (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Recon_Weight_G (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
BtoG_Recon_Weight_R (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
ExpICoef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
ExpICoefMax (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED0Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED1Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED2Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LED3Coef (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
LEDCoefEN (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
MultiHeadConfig (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_AmpRatioTH (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_AmpTH (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_IdealGray (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_LSideWidth_Precise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_LSideWidth_Standard (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_LSideWidth_SuperPrecise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_RSideWidth_Precise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_RSideWidth_Standard (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudge_RSideWidth_SuperPrecise (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudgeExpI_0 (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudgeExpI_1 (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
PreJudgeExpI_2 (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType
Reserve (定义于 MPSizectorS_DotNet.PartialFactorySettingsStructType) | MPSizectorS_DotNet.PartialFactorySettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.PointScaleSettingStructType结构体 参考

  • PointScaleSettingStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.PointScaleSettingStructType结构体 参考

定点数映射设置结构体。用于在浮点数和定点数点云之间转换。
例：浮点数和定点数格式的X值关系如下：XFloat = XIncrement * XFixedPoint + X0Pos 更多...

Public 成员函数

override string ToString ()

Public 属性

float | X0Pos
当定点数数据为0时，所表示的X轴坐标值。
float | XIncrement
当定点数数据增加1时，所表示的X轴坐标值的增量。
float | XReserved
保留。
float | Y0Pos
当定点数数据为0时，所表示的Y轴坐标值。
float | YIncrement
当定点数数据增加1时，所表示的Y轴坐标值的增量。
float | YReserved
保留。
float | Z0Pos
当定点数数据为0时，所表示的Z轴坐标值。
float | ZIncrement
当定点数数据增加1时，所表示的Z轴坐标值的增量。

属性

float | _X0Pos [get]
float | _XIncrement [get]
float | _Y0Pos [get]
float | _YIncrement [get]
float | _Z0Pos [get]
float | _ZIncrement [get]

详细描述

定点数映射设置结构体。用于在浮点数和定点数点云之间转换。
例：浮点数和定点数格式的X值关系如下：XFloat = XIncrement * XFixedPoint + X0Pos


MPSizector .NET 编程文档: 成员列表

  • PointScaleSettingStructType
MPSizectorS_DotNet.PointScaleSettingStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.PointScaleSettingStructType,包括所有继承而来的类成员

_X0Pos (定义于 MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_XIncrement (定义于 MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_Y0Pos (定义于 MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_YIncrement (定义于 MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_Z0Pos (定义于 MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
_ZIncrement (定义于 MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
ToString() (定义于 MPSizectorS_DotNet.PointScaleSettingStructType) | MPSizectorS_DotNet.PointScaleSettingStructType
X0Pos | MPSizectorS_DotNet.PointScaleSettingStructType
XIncrement | MPSizectorS_DotNet.PointScaleSettingStructType
XReserved | MPSizectorS_DotNet.PointScaleSettingStructType
Y0Pos | MPSizectorS_DotNet.PointScaleSettingStructType
YIncrement | MPSizectorS_DotNet.PointScaleSettingStructType
YReserved | MPSizectorS_DotNet.PointScaleSettingStructType
Z0Pos | MPSizectorS_DotNet.PointScaleSettingStructType
ZIncrement | MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.PostProcessSettingsStructType结构体 参考

  • PostProcessSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.PostProcessSettingsStructType结构体 参考

后处理设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

DataOutModeType | DataOutMode
3D数据输出模式。
byte | UserRTMatrixEnableState
用户旋转平移矩阵的使能状态。
RTMatrixStructType | UserRTMatrix
用户旋转平移矩阵。
PointScaleSettingStructType | PointScaleSetting
定点数映射设置。用于在浮点数和定点数3D格式之间转换。
byte | RangeCheckEnableState
范围检查功能的使能状态。
RangeCheckSettingStructType | RangeCheckSetting
范围检查功能的设置。

属性

DataOutModeType | _DataOutMode [get]
byte | _UserRTMatrixEnableState [get]
RTMatrixStructType | _UserRTMatrix [get]
PointScaleSettingStructType | _PointScaleSetting [get]
byte | _RangeCheckEnableState [get]
RangeCheckSettingStructType | _RangeCheckSetting [get]

详细描述

后处理设置结构体。


MPSizector .NET 编程文档: 成员列表

  • PostProcessSettingsStructType
MPSizectorS_DotNet.PostProcessSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.PostProcessSettingsStructType,包括所有继承而来的类成员

_DataOutMode (定义于 MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_PointScaleSetting (定义于 MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_RangeCheckEnableState (定义于 MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_RangeCheckSetting (定义于 MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_UserRTMatrix (定义于 MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
_UserRTMatrixEnableState (定义于 MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
DataOutMode | MPSizectorS_DotNet.PostProcessSettingsStructType
PointScaleSetting | MPSizectorS_DotNet.PostProcessSettingsStructType
RangeCheckEnableState | MPSizectorS_DotNet.PostProcessSettingsStructType
RangeCheckSetting | MPSizectorS_DotNet.PostProcessSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.PostProcessSettingsStructType) | MPSizectorS_DotNet.PostProcessSettingsStructType
UserRTMatrix | MPSizectorS_DotNet.PostProcessSettingsStructType
UserRTMatrixEnableState | MPSizectorS_DotNet.PostProcessSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.Process类 参考

  • Process
类 | Public 成员函数 | 静态 Public 成员函数 | 所有成员列表
MPSizectorS_DotNet.Process类 参考

类

struct RotatedRectangle

Public 成员函数

static bool Undistort (UnmanagedDataFrameUndefinedStruct Frame, CalibParamStructType CalibParam)
将数据去畸变。

静态 Public 成员函数

static unsafe byte | ConvertZMapFrameToFloat3DFrame (UnmanagedDataFrameUndefinedStruct data, out UnmanagedDataFrameUndefinedStruct float3DData, CalibParamStructType calibParam)
转换深度图到浮点3D图.
static unsafe void | ConvertToRangeImage (ManagedDataFrameFloat3DStruct src_frame, RangeImageManaged dst_image)
将ManagedDataFrameFix3DStruct类型的src_frame转换为RangeImageManaged类型的dst_image。
static unsafe void | ConvertToRangeImage (ManagedDataFrameFix3DStruct src_frame, RangeImageManaged dst_image)
将ManagedDataFrameFix3DStruct类型的src_frame转换为RangeImageManaged类型的dst_image。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, string FileName)
将托管的Fix3D格式数据保存为文本格式点云文件。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, string FileName)
将非托管的Fix3D格式数据保存为文本格式点云文件。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, string FileName)
将托管的 FixZMap 格式数据保存为文本格式点云文件。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, string FileName)
将非托管的 FixZMap 格式数据保存为文本格式点云文件。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, ushort[] Z, string FileName)
保存托管的定点数Z数据到文本格式点云。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, ushort *Z, string FileName)
保存非托管的定点数Z数据到文本格式点云。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, string FileName)
保存托管的Float3D格式数据到文本格式点云。
static unsafe bool | SaveTextPointCloud (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, string FileName)
保存非托管的Float3D格式数据到文本格式点云。
static unsafe bool | SavePLY (UnmanagedDataFrameUndefinedStruct DataFrame, string FileName)
保存非托管的Undefined格式数据到PLY格式点云。
static unsafe bool | SavePCD (UnmanagedDataFrameUndefinedStruct DataFrame, string FileName)
保存非托管的Undefined格式数据到PCD格式点云。
static unsafe bool | SaveTIFF (UnmanagedDataFrameUndefinedStruct DataFrame, bool ConvertToRangeImage, string FileName, bool EnableSaveFloatTypeData=false)
保存非托管的Undefined格式数据到TIFF格式点云。
static void | InitGpu (int gpuId=0, bool useGlobalBuffer=false)
初始化GPU加速。
static unsafe void | FreeGpu ()
释放后处理相关GPU计算资源
static unsafe void | PostProcessRangeCheckRingEndRect (UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax)
后处理：范围检查。将超出所设置范围的点将视为无效点不做处理。
static unsafe void | PostProcessRangeCheckRect (UnmanagedDataFrameUndefinedStruct dataFrame, float RecCenterX, float RecCenterY, float InnerRecWidth, float InnerRecHeight, float OuterRecWidth, float OuterRecHeight, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax)
后处理：范围检查。将超出所设置范围的点将视为无效点不做处理。
static unsafe void | PostProcessRangeCheckCircle (UnmanagedDataFrameUndefinedStruct dataFrame, float CircleCenterX, float CircleCenterY, float InnerCricleRadius, float OuterCircleRadius, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax)
后处理：范围检查。将超出所设置范围的点将视为无效点不做处理。
static unsafe void | PostProcessCircleRangeCheck_ByReferencePlan (UnmanagedDataFrameUndefinedStruct dataFrame, float circleCenterX, float circleCenterY, float innerCricleRadius, float outerCircleRadius, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax)
后处理：通过参考平面进行圆环范围检查。将超出所设置范围的点将视为无效点不做处理。
static unsafe void | PostProcessRectangleRangeCheck_ByReferencePlan (UnmanagedDataFrameUndefinedStruct dataFrame, float recCenterX, float recCenterY, float innerRecWidth, float innerRecHeight, float outerRecWidth, float outerRecHeight, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax)
后处理：通过参考平面进行矩形框范围检查。将超出所设置范围的点将视为无效点不做处理。
static unsafe void | PostProcessRingEndRectRangeCheck_ByReferencePlan (UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax)
后处理：通过参考平面进行矩形框范围检查。将超出所设置范围的点将视为无效点不做处理。
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessRemoveBurrs (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。
static unsafe void | PostProcessMend (UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMend (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3)
后处理：修补空点。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | PostProcessFiltrate (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false)
后处理：降噪。
static unsafe void | GetDataPtr (HeadPackStructType srcFrameInfo, byte *srcDataPtr, ref ushort *srcUshortZPtr, ref byte *srcWhiteArrayPtr, ref byte *srcRGBArrayPtr)
通过提供HeadPackStructType类型的srcFrameInfo和byte类型的srcDataPtr，获得与数据帧对应的指针。
static unsafe void | RgbToHsv_Cpu (byte *rgbPtr, int imageWidth, int imageHeight, byte *hsvPtr)
使用CPU将RGB图像转换为HSV图像。
static unsafe void | GenThresholdTable_Cpu (byte *tablePtr, byte lowThreshold, byte highThreshold)
使用CPU生成阈值查找表。
static unsafe void | Threshold_Cpu (byte *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr)
使用CPU执行阈值操作。
static unsafe void | Threshold3Channel_Cpu (byte *data1Ptr, byte *data2Ptr, byte *data3Ptr, int imageWidth, int imageHeight, byte *maskPtr, byte *minThresholdArray, byte *maxThresholdArray)
使用CPU执行三通道阈值操作。
static unsafe void | GenCircleKernel_Cpu (byte *kernelPtr, int kernelWidth, int kernelHeight, float radius)
用CPU生成一个圆形卷积核。
static unsafe void | Dilate_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
对二值化图像进行膨胀运算
static unsafe void | Erosion_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
对二值化图像进行腐蚀运算
static unsafe void | Closing_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
对二值化图像进行闭运算
static unsafe void | Opening_Cpu (byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight)
对二值化图像进行开运算
static unsafe void | PostProcessSPI (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
锡膏检查后处理接口
static unsafe void | PostProcessSPI (ManagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
锡膏检查后处理接口
static unsafe void | PostProcessSPIChannel3 (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
锡膏检查后处理接口
static unsafe void | PostProcessSPIChannel3 (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
锡膏检查后处理接口
static double | Distance (Point p1, Point p2)
static double | DotProduct (Point v1, Point v2)
static double | AngleBetween (Point v1, Point v2)
static List< Point > | ConvexHull (List< Point > points)
static double | CrossProduct (Point p1, Point p2, Point p3)
static PointF | RotatePoint (Point point, Point center, double radianAngle)
static RotatedRectangle | FindMinimumRotatedRectangle (List< Point > points)
static float[] | FitPlane (float[] xyzList)
static unsafe short[][] | calculateMarkCoordinates (int imageWidth, int imageHeight, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int arrayLen, int markWidth, int markHeight, int planeRegionGridSize=240)
static unsafe List< short > | GetGridNearestMarkList (int imageWidth, int imageHeight, short[][] markCoordinateList, int gridX, int gridY, int planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=float.MaxValue)
static unsafe void | PostProcessPlaneCorrection (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f)
基于mark点对数据进行平面校正
static unsafe void | PostProcessPlaneCorrection (ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f)
基于mark点对数据进行平面校正
static unsafe void | GenThresholdTableUshort_Cpu (byte *tablePtr, ushort lowThreshold, ushort highThreshold)
生成阈值表
static unsafe void | ThresholdUshort_Cpu (ushort *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr)
根据阈值表对输入图像进行阈值处理
static unsafe void | PostProcessSegmentMedianFilter (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
对平面校正后的图像进行高度分割并分开进行中值滤波
static unsafe void | PostProcessSegmentMedianFilter (ManagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
对平面校正后的图像进行高度分割并分开进行中值滤波
static unsafe void | PostProcessMendByFeatures (ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：修补空点基于特征。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMendByFeatures (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：修补空点基于特征。根据无效点的相邻点信息估算其自身
static unsafe void | PostProcessMendByFeatures (HeadPackStructType frameInfo, byte *dataPtr, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0)
后处理：修补空点基于特征。根据无效点的相邻点信息估算其自身
static void | selectionSort_Gpu (float[] list, int length, int offset)
static void | quickSort (float[] list, int left, int right)
static unsafe void | PostProcessRegionMend (ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0)
对输入的深度图像进行区域修复操作。
static unsafe void | PostProcessRegionMend (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0)
对输入的深度图像进行区域修复操作。
static unsafe void | PostProcessRegionMend (HeadPackStructType frameInfo, byte *dataPtr, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0)
对输入的深度图像进行区域修复操作。
static unsafe bool | PostProcessTransformImage (UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
非托管FixZMapSimple格式图像几何变换
static unsafe bool | PostProcessTransformImage (ManagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128)
托管FixZMapSimple格式图像几何变换
static unsafe UnmanagedDataFrameUndefinedStruct | UpSamplingData (UnmanagedDataFrameUndefinedStruct dataFrame)
上采样非托管Undefined格式数据。
static unsafe UnmanagedDataFrameUndefinedStruct | ConvertBayerToRGB (UnmanagedDataFrameUndefinedStruct DataFrame, BayerTransferType bayerTransferType, bool btoCEnable, float gainR, float gainG, float gainB, bool btoGEnable, float gainR_forGray, float gainG_forGray, float gainB_forGray)
拜尔解算非托管Undefined格式数据。
static unsafe UnmanagedDataFrameUndefinedStruct | ConvertFrame2DBayerToGray (UnmanagedDataFrameUndefinedStruct DataFrame, int startIndex, int endIndex, float gainR, float gainG, float gainB)
拜尔解算非托管Undefined格式数据到灰度。
static unsafe ManagedDataFrameFixZMapSimpleStruct | DownSamplingData (ManagedDataFrameFixZMapSimpleStruct DataFrame, int samplingRate, int mode)
获取当前数据的下采样数据。
static unsafe UnmanagedDataFrameUndefinedStruct | DownSamplingData (UnmanagedDataFrameUndefinedStruct DataFrame, int samplingRate, int mode)
获取下采样的数据。
static unsafe UnmanagedDataFrameUndefinedStruct | MergeWRGBData (UnmanagedDataFrameUndefinedStruct dataFrame3D, UnmanagedDataFrameUndefinedStruct dataFrame2D, int WIndex, int RGBIndex)
将非托管的Undefined格式3D数据和2D数据合并。
static unsafe UnmanagedDataFrameUndefinedStruct | GetROIData (UnmanagedDataFrameUndefinedStruct dataFrame, int StartX, int StartY, int Width, int Height)
获取指定ROI区域的数据。

成员函数说明

◆ Closing_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Closing_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

对二值化图像进行闭运算

参数
maskPtr | 指向原图数据的指针
maskDstPtr | 指向输出图像数据的指针
maskWidth | 原始图像的宽度
maskHeight | 原始图像的高度
kernelPtr | 卷积核数据
kernelWidth | 卷积核的宽度
kernelHeight | 卷积核的高度

◆ ConvertBayerToRGB()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.ConvertBayerToRGB | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | BayerTransferType | bayerTransferType,
 |  | bool | btoCEnable,
 |  | float | gainR,
 |  | float | gainG,
 |  | float | gainB,
 |  | bool | btoGEnable,
 |  | float | gainR_forGray,
 |  | float | gainG_forGray,
 |  | float | gainB_forGray )
 static

拜尔解算非托管Undefined格式数据。

参数
DataFrame 数据结构体。
返回
拜尔解算后的数据结构体。

◆ ConvertFrame2DBayerToGray()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.ConvertFrame2DBayerToGray | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | int | startIndex,
 |  | int | endIndex,
 |  | float | gainR,
 |  | float | gainG,
 |  | float | gainB )
 static

拜尔解算非托管Undefined格式数据到灰度。

参数
DataFrame 数据结构体。
返回
拜尔解算后的数据结构体。

◆ ConvertToRangeImage() [1/2]

static unsafe void MPSizectorS_DotNet.Process.ConvertToRangeImage | ( | ManagedDataFrameFix3DStruct | src_frame,
 |  | RangeImageManaged | dst_image )
 static

将ManagedDataFrameFix3DStruct类型的src_frame转换为RangeImageManaged类型的dst_image。

参数
src_frame | 要转换的源数据帧。
dst_image | 存储转换结果的目标范围图像对象。

◆ ConvertToRangeImage() [2/2]

static unsafe void MPSizectorS_DotNet.Process.ConvertToRangeImage | ( | ManagedDataFrameFloat3DStruct | src_frame,
 |  | RangeImageManaged | dst_image )
 static

将ManagedDataFrameFix3DStruct类型的src_frame转换为RangeImageManaged类型的dst_image。

参数
src_frame | 要转换的源数据帧。
dst_image | 存储转换结果的目标范围图像对象。

◆ ConvertZMapFrameToFloat3DFrame()

static unsafe byte MPSizectorS_DotNet.Process.ConvertZMapFrameToFloat3DFrame | ( | UnmanagedDataFrameUndefinedStruct | data,
 |  | out UnmanagedDataFrameUndefinedStruct | float3DData,
 |  | CalibParamStructType | calibParam )
 static

转换深度图到浮点3D图.

参数
data | 输入的深度图数据.
float3DData | 输出的浮点3D数据.
calibParam | 相机标定参数.
返回

◆ Dilate_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Dilate_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

对二值化图像进行膨胀运算

参数
maskPtr | 指向原图数据的指针
maskDstPtr | 指向输出图像数据的指针
maskWidth | 原始图像的宽度
maskHeight | 原始图像的高度
kernelPtr | 卷积核数据
kernelWidth | 卷积核的宽度
kernelHeight | 卷积核的高度

◆ DownSamplingData() [1/2]

static unsafe ManagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.Process.DownSamplingData | ( | ManagedDataFrameFixZMapSimpleStruct | DataFrame,
 |  | int | samplingRate,
 |  | int | mode )
 static

获取当前数据的下采样数据。

参数
DataFrame | 数据结构体。
samplingRate | 下采样倍数。
返回
下采样后的数据。

◆ DownSamplingData() [2/2]

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.DownSamplingData | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | int | samplingRate,
 |  | int | mode )
 static

获取下采样的数据。

参数
DataFrame | 数据结构体。
samplingRate | 像素合并的步长。
返回
下采样的数据。

◆ Erosion_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Erosion_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

对二值化图像进行腐蚀运算

参数
maskPtr | 指向原图数据的指针
maskDstPtr | 指向输出图像数据的指针
maskWidth | 原始图像的宽度
maskHeight | 原始图像的高度
kernelPtr | 卷积核数据
kernelWidth | 卷积核的宽度
kernelHeight | 卷积核的高度

◆ GenCircleKernel_Cpu()

static unsafe void MPSizectorS_DotNet.Process.GenCircleKernel_Cpu | ( | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight,
 |  | float | radius )
 static

用CPU生成一个圆形卷积核。

参数
kernelPtr | 一个byte*类型的指针，用于存储生成的卷积核。
kernelWidth | 卷积核的宽度。
kernelHeight | 卷积核的高度。
radius | 圆的半径。

◆ GenThresholdTable_Cpu()

static unsafe void MPSizectorS_DotNet.Process.GenThresholdTable_Cpu | ( | byte * | tablePtr,
 |  | byte | lowThreshold,
 |  | byte | highThreshold )
 static

使用CPU生成阈值查找表。

参数
tablePtr | 一个byte*类型的指针，指向要生成的查找表。
lowThreshold | 低阈值。
highThreshold | 高阈值。

◆ GenThresholdTableUshort_Cpu()

static unsafe void MPSizectorS_DotNet.Process.GenThresholdTableUshort_Cpu | ( | byte * | tablePtr,
 |  | ushort | lowThreshold,
 |  | ushort | highThreshold )
 static

生成阈值表

参数
tablePtr | 指向输出阈值表的指针
lowThreshold | 低阈值
highThreshold | 高阈值

◆ GetDataPtr()

static unsafe void MPSizectorS_DotNet.Process.GetDataPtr | ( | HeadPackStructType | srcFrameInfo,
 |  | byte * | srcDataPtr,
 |  | ref ushort * | srcUshortZPtr,
 |  | ref byte * | srcWhiteArrayPtr,
 |  | ref byte * | srcRGBArrayPtr )
 static

通过提供HeadPackStructType类型的srcFrameInfo和byte类型的srcDataPtr，获得与数据帧对应的指针。

参数
srcFrameInfo | 包含数据帧信息HeadPackStructType结构体。
srcDataPtr | 一个byte*类型的指针，指向原始数据。
srcUshortZPtr | 一个ushort*类型的指针，指向深度值数据。
srcWhiteArrayPtr | 一个byte*类型的指针，指向白光图像数据（如果可用）。
srcRGBArrayPtr | 一个byte*类型的指针，指向彩色图像数据（如果可用）。

◆ GetROIData()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.GetROIData | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | int | StartX,
 |  | int | StartY,
 |  | int | Width,
 |  | int | Height )
 static

获取指定ROI区域的数据。

参数
DataFrame | 数据结构体。
StartX | 起始X。
StartY | 起始Y。
Width | 宽度。
Height | 高度。
返回
指定ROI区域的数据。

◆ InitGpu()

static void MPSizectorS_DotNet.Process.InitGpu | ( | int | gpuId = 0,
 |  | bool | useGlobalBuffer = false )
 static

初始化GPU加速。

参数
gpuId | 指定要使用的GPU设备ID，默认为0。
useGlobalBuffer | 是否使用全局缓冲区，默认为false。

◆ MergeWRGBData()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.MergeWRGBData | ( | UnmanagedDataFrameUndefinedStruct | dataFrame3D,
 |  | UnmanagedDataFrameUndefinedStruct | dataFrame2D,
 |  | int | WIndex,
 |  | int | RGBIndex )
 static

将非托管的Undefined格式3D数据和2D数据合并。

参数
dataFrame3D | 3D数据结构体。
dataFrame2D | 2D数据结构体。
WIndex | White数据的序号。
RGBIndex | RGB数据的起始序号。
返回
合并后的数据。

◆ Opening_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Opening_Cpu | ( | byte * | maskPtr,
 |  | byte * | maskDstPtr,
 |  | int | maskWidth,
 |  | int | maskHeight,
 |  | byte * | kernelPtr,
 |  | int | kernelWidth,
 |  | int | kernelHeight )
 static

对二值化图像进行开运算

参数
maskPtr | 指向原图数据的指针
maskDstPtr | 指向输出图像数据的指针
maskWidth | 原始图像的宽度
maskHeight | 原始图像的高度
kernelPtr | 卷积核数据
kernelWidth | 卷积核的宽度
kernelHeight | 卷积核的高度

◆ PostProcessCircleRangeCheck_ByReferencePlan()

static unsafe void MPSizectorS_DotNet.Process.PostProcessCircleRangeCheck_ByReferencePlan | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | circleCenterX,
 |  | float | circleCenterY,
 |  | float | innerCricleRadius,
 |  | float | outerCircleRadius,
 |  | float | planeNormalX,
 |  | float | planeNormalY,
 |  | float | planeNormalZ,
 |  | float | planeMeanX,
 |  | float | planeMeanY,
 |  | float | planeMeanZ,
 |  | float | distanceMin,
 |  | float | distanceMax )
 static

后处理：通过参考平面进行圆环范围检查。将超出所设置范围的点将视为无效点不做处理。

参数
dataFrame | 三维帧
CircleCenterX | 圆心X
CircleCenterY | 圆心Y
InnerCricleRadius | 内圆半径
OuterCircleRadius | 外圆半径
planeNormalX | 平面法相量X
planeNormalY | 平面法相量Y
planeNormalZ | 平面法相量Z
planeMeanX | 平面中心点X
planeMeanY | 平面中心点Y
planeMeanZ | 平面中心点Z
distanceMin | 距离下限
distanceMax | 距离上限

◆ PostProcessFiltrate() [1/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [2/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [3/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [4/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | ManagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [5/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [6/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [7/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [8/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessFiltrate() [9/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessFiltrate | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | bool | filtrateMendPointOnly = false )
 static

后处理：降噪。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越小则越多点参与降噪
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越小则越多点参与降噪

◆ PostProcessMend() [1/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [2/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [3/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [4/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | ManagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [5/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [6/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [7/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [8/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMend() [9/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMend | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | method = 1,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0,
 |  | uint | paramWinSize2 = 3 )
 static

后处理：修补空点。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
method | 方法，0：膨胀法，1：插值法
paramWinSize2 | 膨胀法额外的相邻点的范围

◆ PostProcessMendByFeatures() [1/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMendByFeatures | ( | HeadPackStructType | frameInfo,
 |  | byte * | dataPtr,
 |  | uint | mendMode,
 |  | uint | channel1Diff,
 |  | uint | channel2Diff,
 |  | uint | channel3Diff,
 |  | float | validPtRate,
 |  | float | heightLowThreshold = 0,
 |  | float | heightHighThreshold = 0,
 |  | uint | paramWinSize = 10,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：修补空点基于特征。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
dataPtr | 输入图像数据指针
mendMode | 修补基于特征模式，0代表W，1代表RGB，2代表HSV，3代表高度
channel1Diff | 通道1灰度差值,通道1为R(H,W)
channel2Diff | 通道2灰度差值,通道2为G(S)
channel3Diff | 通道3灰度差值,通道3为B(V)
validPtRate | 有效点比列，窗口内有效点比例大于此值时才会执行修补
heightLowThreshold | 高度低阈值
heightHighThreshold | 高度高阈值
paramWinSize | 相邻点的范围

◆ PostProcessMendByFeatures() [2/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMendByFeatures | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mendMode,
 |  | uint | channel1Diff,
 |  | uint | channel2Diff,
 |  | uint | channel3Diff,
 |  | float | validPtRate,
 |  | float | heightLowThreshold = 0,
 |  | float | heightHighThreshold = 0,
 |  | uint | paramWinSize = 10,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：修补空点基于特征。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
mendMode | 修补基于特征模式，0代表W，1代表RGB，2代表HSV，3代表高度
channel1Diff | 通道1灰度差值,通道1为R(H,W)
channel2Diff | 通道2灰度差值,通道2为G(S)
channel3Diff | 通道3灰度差值,通道3为B(V)
validPtRate | 有效点比列，窗口内有效点比例大于此值时才会执行修补
heightLowThreshold | 高度低阈值
heightHighThreshold | 高度高阈值
paramWinSize | 相邻点的范围

◆ PostProcessMendByFeatures() [3/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessMendByFeatures | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mendMode,
 |  | uint | channel1Diff,
 |  | uint | channel2Diff,
 |  | uint | channel3Diff,
 |  | float | validPtRate,
 |  | float | heightLowThreshold = 0,
 |  | float | heightHighThreshold = 0,
 |  | uint | paramWinSize = 10,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：修补空点基于特征。根据无效点的相邻点信息估算其自身

参数
dataFrame | 三维帧
mendMode | 修补基于特征模式，0代表W，1代表RGB，2代表HSV，3代表高度
channel1Diff | 通道1灰度差值,通道1为R(H,W)
channel2Diff | 通道2灰度差值,通道2为G(S)
channel3Diff | 通道3灰度差值,通道3为B(V)
validPtRate | 有效点比列，窗口内有效点比例大于此值时才会执行修补
heightLowThreshold | 高度低阈值
heightHighThreshold | 高度高阈值
paramWinSize | 相邻点的范围

◆ PostProcessPlaneCorrection() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessPlaneCorrection | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | markTopLeftXArray,
 |  | ushort[] | markTopLeftYArray,
 |  | int | markTopLeftPointLen,
 |  | int | markWidth,
 |  | int | markHeight,
 |  | short | markOffsetX = 0,
 |  | short | markOffsetY = 0,
 |  | uint | planeRegionGridSize = 240,
 |  | float | minPlaneMarkDistanceRatio = 1::1f,
 |  | float | minGridMarksDistanceRatio = 1::0f,
 |  | float | rangeCheckMinZ = -5,
 |  | float | rangeCheckMaxZ = 5,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f )
 static

基于mark点对数据进行平面校正

参数
dataFrame | 图像数据
markTopLeftXArray | 基平面mark点矩形左上角x坐标数组
markTopLeftYArray | 基平面mark点矩形左上角y坐标数组
markTopLeftPointLen | 基平面mark点矩形个数
markWidth | 基平面mark点矩形宽度
markHeight | 基平面mark点矩形高度
markOffsetX | 外部提供的mark点偏移量x
markOffsetY | 外部提供的mark点偏移量y
planeRegionGridSize | 基于mark点划分平面校正网格区域的尺寸
minPlaneMarkDistanceRatio | 平面校正区域使用的mark点间最小距离倍率(planeRegionGridSize的倍数)
minGridMarksDistanceRatio | 网格中心到mark集合的距离倍率(planeRegionGridSize的倍数) float.MaxValue时关闭此功能，设置很大时此功能也会失效
rangeCheckMinZ | 范围检查 zMin
rangeCheckMaxZ | 范围检查 zMax
offsetMode | 校正后数据补偿模式 模式0 kx+b 模式1 k(x/k)^b
solderOffsetParam1 | 校正后数据补偿参数1 k
solderOffsetParam2 | 校正后数据补偿参数2 b

◆ PostProcessPlaneCorrection() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessPlaneCorrection | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | markTopLeftXArray,
 |  | ushort[] | markTopLeftYArray,
 |  | int | markTopLeftPointLen,
 |  | int | markWidth,
 |  | int | markHeight,
 |  | short | markOffsetX = 0,
 |  | short | markOffsetY = 0,
 |  | uint | planeRegionGridSize = 240,
 |  | float | minPlaneMarkDistanceRatio = 1::1f,
 |  | float | minGridMarksDistanceRatio = 1::0f,
 |  | float | rangeCheckMinZ = -5,
 |  | float | rangeCheckMaxZ = 5,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f )
 static

基于mark点对数据进行平面校正

参数
dataFrame | 图像数据
markTopLeftXArray | 基平面mark点矩形左上角x坐标数组
markTopLeftYArray | 基平面mark点矩形左上角y坐标数组
markTopLeftPointLen | 基平面mark点矩形个数
markWidth | 基平面mark点矩形宽度
markHeight | 基平面mark点矩形高度
markOffsetX | 外部提供的mark点偏移量x
markOffsetY | 外部提供的mark点偏移量y
planeRegionGridSize | 基于mark点划分平面校正网格区域的尺寸
minPlaneMarkDistanceRatio | 平面校正区域使用的mark点间最小距离倍率(planeRegionGridSize的倍数)
minGridMarksDistanceRatio | 网格中心到mark集合的距离倍率(planeRegionGridSize的倍数) float.MaxValue时关闭此功能，设置很大时此功能也会失效
rangeCheckMinZ | 范围检查 zMin
rangeCheckMaxZ | 范围检查 zMax
offsetMode | 校正后数据补偿模式 模式0 kx+b 模式1 k(x/k)^b
solderOffsetParam1 | 校正后数据补偿参数1 k
solderOffsetParam2 | 校正后数据补偿参数2 b

◆ PostProcessRangeCheckCircle()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRangeCheckCircle | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | CircleCenterX,
 |  | float | CircleCenterY,
 |  | float | InnerCricleRadius,
 |  | float | OuterCircleRadius,
 |  | float | XMin,
 |  | float | XMax,
 |  | float | YMin,
 |  | float | YMax,
 |  | float | ZMin,
 |  | float | ZMax )
 static

后处理：范围检查。将超出所设置范围的点将视为无效点不做处理。

参数
dataFrame | 三维帧
CircleCenterX | 圆心X
CircleCenterY | 圆心Y
InnerCricleRadius | 内圆半径
OuterCircleRadius | 外圆半径
XMin | 最小X
XMax | 最大X
YMin | 最小Y
YMax | 最大Y
ZMin | 最小Z
ZMax | 最大Z

◆ PostProcessRangeCheckRect()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRangeCheckRect | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | RecCenterX,
 |  | float | RecCenterY,
 |  | float | InnerRecWidth,
 |  | float | InnerRecHeight,
 |  | float | OuterRecWidth,
 |  | float | OuterRecHeight,
 |  | float | XMin,
 |  | float | XMax,
 |  | float | YMin,
 |  | float | YMax,
 |  | float | ZMin,
 |  | float | ZMax )
 static

后处理：范围检查。将超出所设置范围的点将视为无效点不做处理。

参数
dataFrame | 三维帧
RecCenterX | 矩形中心X
RecCenterY | 矩形中心Y
InnerRecWidth | 内矩形宽
InnerRecHeight | 内矩形高
OuterRecWidth | 外矩形宽
OuterRecHeight | 外矩形高
innerRecWidth | 矩形角度
XMin | 最小X
XMax | 最大X
YMin | 最小Y
YMax | 最大Y
ZMin | 最小Z
ZMax | 最大Z

◆ PostProcessRangeCheckRingEndRect()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRangeCheckRingEndRect | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | RingEndRectCenterX,
 |  | float | RingEndRectCenterY,
 |  | float | RingEndRectWidth,
 |  | float | RingEndRectOuterR,
 |  | float | RingEndRectInnerR,
 |  | float | RingEndRectAngle,
 |  | float | XMin,
 |  | float | XMax,
 |  | float | YMin,
 |  | float | YMax,
 |  | float | ZMin,
 |  | float | ZMax )
 static

后处理：范围检查。将超出所设置范围的点将视为无效点不做处理。

参数
dataFrame | 三维帧
RingEndRectCenterX | 胶囊环形中心X
RingEndRectCenterY | 胶囊环形中心Y
RingEndRectWidth | 胶囊环形内矩形宽
RingEndRectOuterR | 胶囊环形外圆半径
RingEndRectInnerR | 胶囊环形内圆半径
RingEndRectAngle | 胶囊环形外圆角度
XMin | 最小X
XMax | 最大X
YMin | 最小Y
YMax | 最大Y
ZMin | 最小Z
ZMax | 最大Z

◆ PostProcessRectangleRangeCheck_ByReferencePlan()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRectangleRangeCheck_ByReferencePlan | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | recCenterX,
 |  | float | recCenterY,
 |  | float | innerRecWidth,
 |  | float | innerRecHeight,
 |  | float | outerRecWidth,
 |  | float | outerRecHeight,
 |  | float | planeNormalX,
 |  | float | planeNormalY,
 |  | float | planeNormalZ,
 |  | float | planeMeanX,
 |  | float | planeMeanY,
 |  | float | planeMeanZ,
 |  | float | distanceMin,
 |  | float | distanceMax )
 static

后处理：通过参考平面进行矩形框范围检查。将超出所设置范围的点将视为无效点不做处理。

参数
dataFrame | 三维帧
recCenterX | 矩形中心点X
recCenterY | 矩形中心点Y
innerRecWidth | 矩形内宽
innerRecHeight | 矩形内高
outerRecWidth | 矩形外宽
outerRecHeight | 矩形外高
innerRecWidth | 矩形角度
planeNormalX | 平面法相量X
planeNormalY | 平面法相量Y
planeNormalZ | 平面法相量Z
planeMeanX | 平面中心点X
planeMeanY | 平面中心点Y
planeMeanZ | 平面中心点Z
distanceMin | 距离下限
distanceMax | 距离上限

◆ PostProcessRegionMend() [1/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRegionMend | ( | HeadPackStructType | frameInfo,
 |  | byte * | dataPtr,
 |  | ushort[] | regionTopLeftPtX,
 |  | ushort[] | regionTopLeftPtY,
 |  | ushort[] | regionWidth,
 |  | ushort[] | regionHeight,
 |  | float[] | lowThreshold,
 |  | float[] | highThreshold,
 |  | uint | validPtCount,
 |  | short | regionOffsetX = 0,
 |  | short | regionOffsetY = 0 )
 static

对输入的深度图像进行区域修复操作。

参数
frameInfo | 深度图像数据头信息
dataPtr | 输入深度图像数据指针
regionTopLeftPtX | 区域左上角点X坐标数组
regionTopLeftPtY | 区域左上角点Y坐标数组
regionWidth | 区域宽度数组
regionHeight | 区域高度数组
lowThreshold | 低阈值数组
highThreshold | 高阈值数组
validPtCount | 有效点数量
regionOffsetX | 区域偏移值X
regionOffsetY | 区域偏移值Y

◆ PostProcessRegionMend() [2/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRegionMend | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | regionTopLeftPtX,
 |  | ushort[] | regionTopLeftPtY,
 |  | ushort[] | regionWidth,
 |  | ushort[] | regionHeight,
 |  | float[] | lowThreshold,
 |  | float[] | highThreshold,
 |  | uint | validPtCount,
 |  | short | regionOffsetX = 0,
 |  | short | regionOffsetY = 0 )
 static

对输入的深度图像进行区域修复操作。

参数
dataFrame | 图像数据
regionTopLeftPtX | 区域左上角点X坐标数组
regionTopLeftPtY | 区域左上角点Y坐标数组
regionWidth | 区域宽度数组
regionHeight | 区域高度数组
lowThreshold | 低阈值数组
highThreshold | 高阈值数组
validPtCount | 有效点数量
regionOffsetX | 区域偏移值X
regionOffsetY | 区域偏移值Y

◆ PostProcessRegionMend() [3/3]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRegionMend | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | ushort[] | regionTopLeftPtX,
 |  | ushort[] | regionTopLeftPtY,
 |  | ushort[] | regionWidth,
 |  | ushort[] | regionHeight,
 |  | float[] | lowThreshold,
 |  | float[] | highThreshold,
 |  | uint | validPtCount,
 |  | short | regionOffsetX = 0,
 |  | short | regionOffsetY = 0 )
 static

对输入的深度图像进行区域修复操作。

参数
dataFrame | 图像数据
regionTopLeftPtX | 区域左上角点X坐标数组
regionTopLeftPtY | 区域左上角点Y坐标数组
regionWidth | 区域宽度数组
regionHeight | 区域高度数组
lowThreshold | 低阈值数组
highThreshold | 高阈值数组
validPtCount | 有效点数量
regionOffsetX | 区域偏移值X
regionOffsetY | 区域偏移值Y

◆ PostProcessRemoveBurrs() [1/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [2/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [3/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [4/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | ManagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [5/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFix3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [6/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [7/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFixZMapStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [8/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameFloat3DStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRemoveBurrs() [9/9]

static unsafe void MPSizectorS_DotNet.Process.PostProcessRemoveBurrs | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | uint | paramWinSize = 5,
 |  | uint | paramWinSize2 = 2,
 |  | uint | paramSlopeLevel = 50,
 |  | uint | paramNeighborCloseLevel = 50,
 |  | uint | paramNeighborNumLevel = 50,
 |  | uint | paramEdgeSuppressLevel = 50,
 |  | bool | useGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 0 )
 static

后处理：去除飞点。根据点与一定范围相邻点的相近数目来判断点是否应该去除。

参数
dataFrame | 三维帧
paramWinSize | 相邻点的范围
paramWinSize2 | 在相邻点基础上找相关点的范围
paramSlopeLevel | 斜率参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborCloseLevel | 相邻点相近判断参数，范围[0, 100]，值越大则将去除越多飞点
paramNeighborNumLevel | 相近相邻点数目参数，范围[0, 100]，值越大则将去除越多飞点
paramEdgeSuppressLevel | 窄边抑制参数，范围[0, 100]，值越大则将去除越多飞点

◆ PostProcessRingEndRectRangeCheck_ByReferencePlan()

static unsafe void MPSizectorS_DotNet.Process.PostProcessRingEndRectRangeCheck_ByReferencePlan | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | float | RingEndRectCenterX,
 |  | float | RingEndRectCenterY,
 |  | float | RingEndRectWidth,
 |  | float | RingEndRectOuterR,
 |  | float | RingEndRectInnerR,
 |  | float | RingEndRectAngle,
 |  | float | planeNormalX,
 |  | float | planeNormalY,
 |  | float | planeNormalZ,
 |  | float | planeMeanX,
 |  | float | planeMeanY,
 |  | float | planeMeanZ,
 |  | float | distanceMin,
 |  | float | distanceMax )
 static

后处理：通过参考平面进行矩形框范围检查。将超出所设置范围的点将视为无效点不做处理。

参数
dataFrame | 三维帧
RingEndRectCenterX | 胶囊环形中心X
RingEndRectCenterY | 胶囊环形中心Y
RingEndRectWidth | 胶囊环形内矩形宽
RingEndRectOuterR | 胶囊环形外圆半径
RingEndRectInnerR | 胶囊环形内圆半径
RingEndRectAngle | 胶囊环形外圆角度
planeNormalX | 平面法相量X
planeNormalY | 平面法相量Y
planeNormalZ | 平面法相量Z
planeMeanX | 平面中心点X
planeMeanY | 平面中心点Y
planeMeanZ | 平面中心点Z
distanceMin | 距离下限
distanceMax | 距离上限

◆ PostProcessSegmentMedianFilter() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSegmentMedianFilter | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float | segmentLowThreshold,
 |  | float | segmentHighThreshold,
 |  | float | minZ,
 |  | float | maxZ,
 |  | uint | filterSize = 10,
 |  | float | filterTargetPercentage = 0::5f,
 |  | float | validPercentage = 0::2f,
 |  | float | histZPrecision = 0::0025f,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

对平面校正后的图像进行高度分割并分开进行中值滤波

参数
dataFrame | 图像数据
segmentlowThreshold | 高度分割低阈值 low-high = 255 其他 = 0， low = high时 = 255
segmentHighThreshold | 高度分割高阈值 low-high = 255 其他 = 0， low = high时 = 255
minZ | 目标值所在范围的最小z值， 低于此值都会被统计到直方图的第一位，目标值应处于minZ和maxZ之间， 否则统计结果有误
maxZ | 目标值所在范围的最大z值， 高于此值都会被统计到直方图的最后一位，目标值应处于minZ和maxZ之间，否则统计结果有误
filterSize | 中值滤波核半径
filterTargetPercentage | 目标值在邻域值中百分比，中值应设置为0.5f
validPercentage | 计算中值时目标mask且有效的点的个数占窗口点数的百分比，validCount = validPercentage * 4 * filterSize * filterSize
histZPrecision | 统计计算过程的z方向精度
UseGpu | 是否使用gpu
gpuGridSize | gpu线程网格尺寸
gpuBlockSize | gpu线程块尺寸

◆ PostProcessSegmentMedianFilter() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSegmentMedianFilter | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float | segmentLowThreshold,
 |  | float | segmentHighThreshold,
 |  | float | minZ,
 |  | float | maxZ,
 |  | uint | filterSize = 10,
 |  | float | filterTargetPercentage = 0::5f,
 |  | float | validPercentage = 0::2f,
 |  | float | histZPrecision = 0::0025f,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

对平面校正后的图像进行高度分割并分开进行中值滤波

参数
dataFrame | 图像数据
segmentlowThreshold | 高度分割低阈值 low-high = 255 其他 = 0， low = high时 = 255
segmentHighThreshold | 高度分割高阈值 low-high = 255 其他 = 0， low = high时 = 255
minZ | 目标值所在范围的最小z值， 低于此值都会被统计到直方图的第一位，目标值应处于minZ和maxZ之间， 否则统计结果有误
maxZ | 目标值所在范围的最大z值， 高于此值都会被统计到直方图的最后一位，目标值应处于minZ和maxZ之间，否则统计结果有误
filterSize | 中值滤波核半径
filterTargetPercentage | 目标值在邻域值中百分比，中值应设置为0.5f
validPercentage | 计算中值时目标mask且有效的点的个数占窗口点数的百分比，validCount = validPercentage * 4 * filterSize * filterSize
histZPrecision | 统计计算过程的z方向精度
UseGpu | 是否使用gpu
gpuGridSize | gpu线程网格尺寸
gpuBlockSize | gpu线程块尺寸

◆ PostProcessSPI() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPI | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | byte[] | hist2DMapHost,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | uint | offsetMode = 0,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | uint | hist2DChannelIndex1 = 0,
 |  | uint | hist2DChannelIndex2 = 2,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

锡膏检查后处理接口

参数
dataFrame | 简化深度数据
hist2DMapHost | 特征区域直方图
op1CloseKernelSize | 闭运算核心尺寸
op2OpenKernelSize | 开运算核心尺寸
op3CloseKernelSize | 闭运算核心尺寸
filterSize | 最终数据平滑窗口尺寸
hist2DChannelIndex1 | 特征区域直方图通道1
hist2DChannelIndex2 | 特征区域直方图通道2
minNeighborCount | 计算当前像素位置焊锡基准高度的邻域像素个数
minMendNeighborCount | 填补无效像素位置焊锡相对高度时属于求均值的焊锡邻域像素个数
neighborSize
UseGpu
gpuGridSize
gpuBlockSize

◆ PostProcessSPI() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPI | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | byte[] | hist2DMapHost,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | uint | offsetMode = 0,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | uint | hist2DChannelIndex1 = 0,
 |  | uint | hist2DChannelIndex2 = 2,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

锡膏检查后处理接口

参数
dataFrame | 简化深度数据
hist2DMapHost | 特征区域直方图
op1CloseKernelSize | 闭运算核心尺寸
op2OpenKernelSize | 开运算核心尺寸
op3CloseKernelSize | 闭运算核心尺寸
filterSize | 最终数据平滑窗口尺寸
hist2DChannelIndex1 | 特征区域直方图通道1
hist2DChannelIndex2 | 特征区域直方图通道2
minNeighborCount | 计算当前像素位置焊锡基准高度的邻域像素个数
minMendNeighborCount | 填补无效像素位置焊锡相对高度时属于求均值的焊锡邻域像素个数
neighborSize
UseGpu
gpuGridSize
gpuBlockSize

◆ PostProcessSPIChannel3() [1/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPIChannel3 | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mode,
 |  | byte * | lowThresholdArray,
 |  | byte * | highThresholdArray,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | float | maxSolderHeightThreshould = 0::2f,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

锡膏检查后处理接口

参数
dataFrame | 简化深度数据
mode | 颜色模式 奇数 rgb 偶数 hsv； 邻域模式 小于等于1 基板搜索-方向优先：计算相对高度时优先在每个方向找到基板高度（根据焊锡多侧基板点计算相对高度） 大于1 基板搜索-个数优先：计算相对高度时优先找到最近的基板高度（仅根据焊锡一侧基板点计算相对高度）
lowThresholdArray | 图像分割低阈值列表
highThresholdArray | 图像分割高阈值列表
op1CloseKernelSize | 图像分割后操作1闭运算核尺寸
op2OpenKernelSize | 图像分割后操作2开运算核尺寸
op3DilateKernelSize | 图像分割后操作3膨胀运算核尺寸
offsetMode | 校正后数据补偿模式 模式0 kx+b 模式1 k(x/k)^b
solderOffsetParam1 | 校正后数据补偿参数1 k
solderOffsetParam2 | 校正后数据补偿参数2 b
boardFilterSize | 基板滤波尺寸 大于0 均值滤波；小于0 当前值会被滤波窗口内低点拉低
solderFilterSize | 焊锡滤波尺寸 大于0 均值滤波；小于0 当前值会被滤波窗口内高点拉高
maxSolderHeightThreshould | 最大焊锡高度阈值，焊锡相对高度超过此值时，焊锡高度正常时，可区分高度异常的板面；焊锡高度异常时，将焊锡高度置为最大焊锡高度阈值
minNeighborCount | 最小邻域点个数，计算基板高度时使用的点个数
minMendNeighborCount | 修补时最小邻域点个数，对颜色属于焊锡的无效点进行填充时邻域焊锡点的最小个数
neighborSize | 计算基板高度时基板点搜索半径
UseGpu | 是否使用Gpu
gpuGridSize | 网格尺寸
gpuBlockSize | 块尺寸

◆ PostProcessSPIChannel3() [2/2]

static unsafe void MPSizectorS_DotNet.Process.PostProcessSPIChannel3 | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | uint | mode,
 |  | byte * | lowThresholdArray,
 |  | byte * | highThresholdArray,
 |  | float | op1CloseKernelSize,
 |  | float | op2OpenKernelSize,
 |  | float | op3DilateKernelSize,
 |  | uint | offsetMode = 0,
 |  | float | solderOffsetParam1 = 1::0f,
 |  | float | solderOffsetParam2 = 0::0f,
 |  | int | boardFilterSize = -10,
 |  | int | solderFilterSize = -3,
 |  | float | maxSolderHeightThreshould = 0::2f,
 |  | uint | minNeighborCount = 10,
 |  | uint | minMendNeighborCount = 5,
 |  | uint | neighborSize = 500,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

锡膏检查后处理接口

参数
dataFrame | 简化深度数据
mode | 颜色模式 奇数 rgb 偶数 hsv； 邻域模式 小于等于1 基板搜索-方向优先：计算相对高度时优先在每个方向找到基板高度（根据焊锡多侧基板点计算相对高度） 大于1 基板搜索-个数优先：计算相对高度时优先找到最近的基板高度（仅根据焊锡一侧基板点计算相对高度）
lowThresholdArray | 图像分割低阈值列表
highThresholdArray | 图像分割高阈值列表
op1CloseKernelSize | 图像分割后操作1闭运算核尺寸
op2OpenKernelSize | 图像分割后操作2开运算核尺寸
op3DilateKernelSize | 图像分割后操作3膨胀运算核尺寸
offsetMode | 校正后数据补偿模式 模式0 kx+b 模式1 k(x/k)^b
solderOffsetParam1 | 校正后数据补偿参数1 k
solderOffsetParam2 | 校正后数据补偿参数2 b
boardFilterSize | 基板滤波尺寸 大于0 均值滤波；小于0 当前值会被滤波窗口内低点拉低
solderFilterSize | 焊锡滤波尺寸 大于0 均值滤波；小于0 当前值会被滤波窗口内高点拉高
maxSolderHeightThreshould | 最大焊锡高度阈值，焊锡相对高度超过此值时，焊锡高度正常时，可区分高度异常的板面；焊锡高度异常时，将焊锡高度置为最大焊锡高度阈值
minNeighborCount | 最小邻域点个数，计算基板高度时使用的点个数
minMendNeighborCount | 修补时最小邻域点个数，对颜色属于焊锡的无效点进行填充时邻域焊锡点的最小个数
neighborSize | 计算基板高度时基板点搜索半径
UseGpu | 是否使用Gpu
gpuGridSize | 网格尺寸
gpuBlockSize | 块尺寸

◆ PostProcessTransformImage() [1/2]

static unsafe bool MPSizectorS_DotNet.Process.PostProcessTransformImage | ( | ManagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float[] | transformMatrix,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

托管FixZMapSimple格式图像几何变换

参数
dataFrame | 托管原图数据
transformArray | 2D变换矩阵参数 float[6]{m11,m12,m21,m22,offsetX,offsetY} 计算方式:dstX = m11 * srcX + m12 * srcY + offsetX; dstY = m21 * srcX + m22 * srcY + offsetY;
UseGpu | 是否启用GPU
gpuGridSize | GPU网格尺寸
gpuBlockSize | GPU块尺寸

◆ PostProcessTransformImage() [2/2]

static unsafe bool MPSizectorS_DotNet.Process.PostProcessTransformImage | ( | UnmanagedDataFrameFixZMapSimpleStruct | dataFrame,
 |  | float[] | transformMatrix,
 |  | bool | UseGpu = false,
 |  | uint | gpuGridSize = 0,
 |  | uint | gpuBlockSize = 128 )
 static

非托管FixZMapSimple格式图像几何变换

参数
dataFrame | 非托管原图数据
transformArray | 2D变换矩阵参数 float[6]{m11,m12,m21,m22,offsetX,offsetY} 计算方式:dstX = m11 * srcX + m12 * srcY + offsetX; dstY = m21 * srcX + m22 * srcY + offsetY;
UseGpu | 是否启用GPU
gpuGridSize | GPU网格尺寸
gpuBlockSize | GPU块尺寸

◆ RgbToHsv_Cpu()

static unsafe void MPSizectorS_DotNet.Process.RgbToHsv_Cpu | ( | byte * | rgbPtr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | hsvPtr )
 static

使用CPU将RGB图像转换为HSV图像。

参数
rgbPtr | 一个byte*类型的指针，指向RGB图像数据。
imageWidth | 图像宽度。
imageHeight | 图像高度。
hsvPtr | 一个byte*类型的指针，指向HSV图像数据。

◆ SavePCD()

static unsafe bool MPSizectorS_DotNet.Process.SavePCD | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName )
 static

保存非托管的Undefined格式数据到PCD格式点云。

参数
DataFrame | 数据结构体。
FileName | 目标文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ SavePLY()

static unsafe bool MPSizectorS_DotNet.Process.SavePLY | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName )
 static

保存非托管的Undefined格式数据到PLY格式点云。

参数
DataFrame | 数据结构体。
FileName | 目标文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud() [1/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data,
 |  | string | FileName )
 static

将非托管的Fix3D格式数据保存为文本格式点云文件。

参数
FrameInfo | 数据帧信息。
Data | Fix3D数据。
FileName | 要保存的文件名。
返回
操作是否成功。成功为true，失败为false。

◆ SaveTextPointCloud() [2/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data,
 |  | string | FileName )
 static

将托管的Fix3D格式数据保存为文本格式点云文件。

参数
FrameInfo | 数据帧信息。
Data | Fix3D数据。
FileName | 要保存的文件名。
返回
操作是否成功。成功为true，失败为false。

◆ SaveTextPointCloud() [3/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data,
 |  | string | FileName )
 static

将非托管的 FixZMap 格式数据保存为文本格式点云文件。

参数
FrameInfo | 数据帧信息。
Data | 非托管的 FixZMap 数据。
FileName | 要保存的文件名。
返回
操作是否成功。成功为true，失败为false。

◆ SaveTextPointCloud() [4/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data,
 |  | string | FileName )
 static

将托管的 FixZMap 格式数据保存为文本格式点云文件。

参数
FrameInfo | 数据帧信息。
Data | FixZMap 数据。
FileName | 要保存的文件名。
返回
操作是否成功。成功为true，失败为false。

◆ SaveTextPointCloud() [5/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data,
 |  | string | FileName )
 static

保存非托管的Float3D格式数据到文本格式点云。

参数
FrameInfo | 数据帧信息。
Data | 数据。
FileName | 目标文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud() [6/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data,
 |  | string | FileName )
 static

保存托管的Float3D格式数据到文本格式点云。

参数
FrameInfo | 数据帧信息。
Data | 数据。
FileName | 目标文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud() [7/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | string | FileName )
 static

保存非托管的定点数Z数据到文本格式点云。

参数
FrameInfo | 数据帧信息。
Z | Z数据。
FileName | 目标文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud() [8/8]

static unsafe bool MPSizectorS_DotNet.Process.SaveTextPointCloud | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | string | FileName )
 static

保存托管的定点数Z数据到文本格式点云。

参数
FrameInfo | 数据帧信息。
Z | Z数据。
FileName | 目标文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTIFF()

static unsafe bool MPSizectorS_DotNet.Process.SaveTIFF | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | bool | ConvertToRangeImage,
 |  | string | FileName,
 |  | bool | EnableSaveFloatTypeData = false )
 static

保存非托管的Undefined格式数据到TIFF格式点云。

参数
DataFrame | 数据结构体。
ConvertToRangeImage | 是否先转化为RangeImage格式。
FileName | 目标文件名。
返回
操作是否成功。成功为true, 失败为false。

◆ Threshold3Channel_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Threshold3Channel_Cpu | ( | byte * | data1Ptr,
 |  | byte * | data2Ptr,
 |  | byte * | data3Ptr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | maskPtr,
 |  | byte * | minThresholdArray,
 |  | byte * | maxThresholdArray )
 static

使用CPU执行三通道阈值操作。

参数
data1Ptr | 一个byte*类型的指针，指向第一通道（红色）的像素数据。
data2Ptr | 一个byte*类型的指针，指向第二通道（绿色）的像素数据。
data3Ptr | 一个byte*类型的指针，指向第三通道（蓝色）的像素数据。
imageWidth | 图像宽度。
imageHeight | 图像高度。
maskPtr | 一个byte*类型的指针，指向一个可选的掩码。
minThresholdArray | 一个byte*类型的指针，指向最小阈值数组。
maxThresholdArray | 一个byte*类型的指针，指向最大阈值数组。

◆ Threshold_Cpu()

static unsafe void MPSizectorS_DotNet.Process.Threshold_Cpu | ( | byte * | dataPtr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | tablePtr,
 |  | byte * | maskPtr )
 static

使用CPU执行阈值操作。

参数
dataPtr | 一个byte*类型的指针，指向原始像素数据。
imageWidth | 图像宽度。
imageHeight | 图像高度。
tablePtr | 一个byte*类型的指针，指向预生成的查找表。
maskPtr | 一个byte*类型的指针，指向一个可选的掩码。

◆ ThresholdUshort_Cpu()

static unsafe void MPSizectorS_DotNet.Process.ThresholdUshort_Cpu | ( | ushort * | dataPtr,
 |  | int | imageWidth,
 |  | int | imageHeight,
 |  | byte * | tablePtr,
 |  | byte * | maskPtr )
 static

根据阈值表对输入图像进行阈值处理

参数
dataPtr | 输入图像数据指针
imageWidth | 图像宽度
imageHeight | 图像高度
tablePtr | 指向阈值表的指针
maskPtr | 指向掩膜数据的指针

◆ Undistort()

static bool MPSizectorS_DotNet.Process.Undistort | ( | UnmanagedDataFrameUndefinedStruct | Frame,
 |  | CalibParamStructType | CalibParam )

将数据去畸变。

参数
Frame | 图像数据。
CalibParam | 标定参数。
返回
操作是否成功。成功为true, 失败为false。

◆ UpSamplingData()

static unsafe UnmanagedDataFrameUndefinedStruct MPSizectorS_DotNet.Process.UpSamplingData ( UnmanagedDataFrameUndefinedStruct dataFrame )
static

上采样非托管Undefined格式数据。

参数
DataFrame 数据结构体。
返回
上采样后的数据结构体。


MPSizector .NET 编程文档: 成员列表

  • Process
MPSizectorS_DotNet.Process 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.Process,包括所有继承而来的类成员

AngleBetween(Point v1, Point v2) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
calculateMarkCoordinates(int imageWidth, int imageHeight, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int arrayLen, int markWidth, int markHeight, int planeRegionGridSize=240) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
Closing_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
ConvertBayerToRGB(UnmanagedDataFrameUndefinedStruct DataFrame, BayerTransferType bayerTransferType, bool btoCEnable, float gainR, float gainG, float gainB, bool btoGEnable, float gainR_forGray, float gainG_forGray, float gainB_forGray) | MPSizectorS_DotNet.Process | static
ConvertFrame2DBayerToGray(UnmanagedDataFrameUndefinedStruct DataFrame, int startIndex, int endIndex, float gainR, float gainG, float gainB) | MPSizectorS_DotNet.Process | static
ConvertToRangeImage(ManagedDataFrameFloat3DStruct src_frame, RangeImageManaged dst_image) | MPSizectorS_DotNet.Process | static
ConvertToRangeImage(ManagedDataFrameFix3DStruct src_frame, RangeImageManaged dst_image) | MPSizectorS_DotNet.Process | static
ConvertZMapFrameToFloat3DFrame(UnmanagedDataFrameUndefinedStruct data, out UnmanagedDataFrameUndefinedStruct float3DData, CalibParamStructType calibParam) | MPSizectorS_DotNet.Process | static
ConvexHull(List< Point > points) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
CrossProduct(Point p1, Point p2, Point p3) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
Dilate_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
Distance(Point p1, Point p2) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
DotProduct(Point v1, Point v2) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
DownSamplingData(ManagedDataFrameFixZMapSimpleStruct DataFrame, int samplingRate, int mode) | MPSizectorS_DotNet.Process | static
DownSamplingData(UnmanagedDataFrameUndefinedStruct DataFrame, int samplingRate, int mode) | MPSizectorS_DotNet.Process | static
Erosion_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
FindMinimumRotatedRectangle(List< Point > points) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
FitPlane(float[] xyzList) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
FreeGpu() | MPSizectorS_DotNet.Process | static
GenCircleKernel_Cpu(byte *kernelPtr, int kernelWidth, int kernelHeight, float radius) | MPSizectorS_DotNet.Process | static
GenThresholdTable_Cpu(byte *tablePtr, byte lowThreshold, byte highThreshold) | MPSizectorS_DotNet.Process | static
GenThresholdTableUshort_Cpu(byte *tablePtr, ushort lowThreshold, ushort highThreshold) | MPSizectorS_DotNet.Process | static
GetDataPtr(HeadPackStructType srcFrameInfo, byte *srcDataPtr, ref ushort *srcUshortZPtr, ref byte *srcWhiteArrayPtr, ref byte *srcRGBArrayPtr) | MPSizectorS_DotNet.Process | static
GetGridNearestMarkList(int imageWidth, int imageHeight, short[][] markCoordinateList, int gridX, int gridY, int planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=float.MaxValue) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
GetROIData(UnmanagedDataFrameUndefinedStruct dataFrame, int StartX, int StartY, int Width, int Height) | MPSizectorS_DotNet.Process | static
InitGpu(int gpuId=0, bool useGlobalBuffer=false) | MPSizectorS_DotNet.Process | static
MergeWRGBData(UnmanagedDataFrameUndefinedStruct dataFrame3D, UnmanagedDataFrameUndefinedStruct dataFrame2D, int WIndex, int RGBIndex) | MPSizectorS_DotNet.Process | static
Opening_Cpu(byte *maskPtr, byte *maskDstPtr, int maskWidth, int maskHeight, byte *kernelPtr, int kernelWidth, int kernelHeight) | MPSizectorS_DotNet.Process | static
PostProcessCircleRangeCheck_ByReferencePlan(UnmanagedDataFrameUndefinedStruct dataFrame, float circleCenterX, float circleCenterY, float innerCricleRadius, float outerCircleRadius, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessFiltrate(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, bool filtrateMendPointOnly=false) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMend(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint method=1, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0, uint paramWinSize2=3) | MPSizectorS_DotNet.Process | static
PostProcessMendByFeatures(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessMendByFeatures(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessMendByFeatures(HeadPackStructType frameInfo, byte *dataPtr, uint mendMode, uint channel1Diff, uint channel2Diff, uint channel3Diff, float validPtRate, float heightLowThreshold=0, float heightHighThreshold=0, uint paramWinSize=10, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessPlaneCorrection(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f) | MPSizectorS_DotNet.Process | static
PostProcessPlaneCorrection(ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] markTopLeftXArray, ushort[] markTopLeftYArray, int markTopLeftPointLen, int markWidth, int markHeight, short markOffsetX=0, short markOffsetY=0, uint planeRegionGridSize=240, float minPlaneMarkDistanceRatio=1.1f, float minGridMarksDistanceRatio=1.0f, float rangeCheckMinZ=-5, float rangeCheckMaxZ=5, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f) | MPSizectorS_DotNet.Process | static
PostProcessRangeCheckCircle(UnmanagedDataFrameUndefinedStruct dataFrame, float CircleCenterX, float CircleCenterY, float InnerCricleRadius, float OuterCircleRadius, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax) | MPSizectorS_DotNet.Process | static
PostProcessRangeCheckRect(UnmanagedDataFrameUndefinedStruct dataFrame, float RecCenterX, float RecCenterY, float InnerRecWidth, float InnerRecHeight, float OuterRecWidth, float OuterRecHeight, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax) | MPSizectorS_DotNet.Process | static
PostProcessRangeCheckRingEndRect(UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float XMin, float XMax, float YMin, float YMax, float ZMin, float ZMax) | MPSizectorS_DotNet.Process | static
PostProcessRectangleRangeCheck_ByReferencePlan(UnmanagedDataFrameUndefinedStruct dataFrame, float recCenterX, float recCenterY, float innerRecWidth, float innerRecHeight, float outerRecWidth, float outerRecHeight, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax) | MPSizectorS_DotNet.Process | static
PostProcessRegionMend(ManagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0) | MPSizectorS_DotNet.Process | static
PostProcessRegionMend(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0) | MPSizectorS_DotNet.Process | static
PostProcessRegionMend(HeadPackStructType frameInfo, byte *dataPtr, ushort[] regionTopLeftPtX, ushort[] regionTopLeftPtY, ushort[] regionWidth, ushort[] regionHeight, float[] lowThreshold, float[] highThreshold, uint validPtCount, short regionOffsetX=0, short regionOffsetY=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameUndefinedStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFloat3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFix3DStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFixZMapStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRemoveBurrs(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint paramWinSize=5, uint paramWinSize2=2, uint paramSlopeLevel=50, uint paramNeighborCloseLevel=50, uint paramNeighborNumLevel=50, uint paramEdgeSuppressLevel=50, bool useGpu=false, uint gpuGridSize=0, uint gpuBlockSize=0) | MPSizectorS_DotNet.Process | static
PostProcessRingEndRectRangeCheck_ByReferencePlan(UnmanagedDataFrameUndefinedStruct dataFrame, float RingEndRectCenterX, float RingEndRectCenterY, float RingEndRectWidth, float RingEndRectOuterR, float RingEndRectInnerR, float RingEndRectAngle, float planeNormalX, float planeNormalY, float planeNormalZ, float planeMeanX, float planeMeanY, float planeMeanZ, float distanceMin, float distanceMax) | MPSizectorS_DotNet.Process | static
PostProcessSegmentMedianFilter(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSegmentMedianFilter(ManagedDataFrameFixZMapSimpleStruct dataFrame, float segmentLowThreshold, float segmentHighThreshold, float minZ, float maxZ, uint filterSize=10, float filterTargetPercentage=0.5f, float validPercentage=0.2f, float histZPrecision=0.0025f, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPI(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPI(ManagedDataFrameFixZMapSimpleStruct dataFrame, byte[] hist2DMapHost, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, uint offsetMode=0, int boardFilterSize=-10, int solderFilterSize=-3, uint hist2DChannelIndex1=0, uint hist2DChannelIndex2=2, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPIChannel3(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessSPIChannel3(ManagedDataFrameFixZMapSimpleStruct dataFrame, uint mode, byte *lowThresholdArray, byte *highThresholdArray, float op1CloseKernelSize, float op2OpenKernelSize, float op3DilateKernelSize, uint offsetMode=0, float solderOffsetParam1=1.0f, float solderOffsetParam2=0.0f, int boardFilterSize=-10, int solderFilterSize=-3, float maxSolderHeightThreshould=0.2f, uint minNeighborCount=10, uint minMendNeighborCount=5, uint neighborSize=500, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessTransformImage(UnmanagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
PostProcessTransformImage(ManagedDataFrameFixZMapSimpleStruct dataFrame, float[] transformMatrix, bool UseGpu=false, uint gpuGridSize=0, uint gpuBlockSize=128) | MPSizectorS_DotNet.Process | static
quickSort(float[] list, int left, int right) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
RgbToHsv_Cpu(byte *rgbPtr, int imageWidth, int imageHeight, byte *hsvPtr) | MPSizectorS_DotNet.Process | static
RotatePoint(Point point, Point center, double radianAngle) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
SavePCD(UnmanagedDataFrameUndefinedStruct DataFrame, string FileName) | MPSizectorS_DotNet.Process | static
SavePLY(UnmanagedDataFrameUndefinedStruct DataFrame, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, ushort[] Z, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, ushort *Z, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTextPointCloud(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, string FileName) | MPSizectorS_DotNet.Process | static
SaveTIFF(UnmanagedDataFrameUndefinedStruct DataFrame, bool ConvertToRangeImage, string FileName, bool EnableSaveFloatTypeData=false) | MPSizectorS_DotNet.Process | static
selectionSort_Gpu(float[] list, int length, int offset) (定义于 MPSizectorS_DotNet.Process) | MPSizectorS_DotNet.Process | static
Threshold3Channel_Cpu(byte *data1Ptr, byte *data2Ptr, byte *data3Ptr, int imageWidth, int imageHeight, byte *maskPtr, byte *minThresholdArray, byte *maxThresholdArray) | MPSizectorS_DotNet.Process | static
Threshold_Cpu(byte *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr) | MPSizectorS_DotNet.Process | static
ThresholdUshort_Cpu(ushort *dataPtr, int imageWidth, int imageHeight, byte *tablePtr, byte *maskPtr) | MPSizectorS_DotNet.Process | static
Undistort(UnmanagedDataFrameUndefinedStruct Frame, CalibParamStructType CalibParam) | MPSizectorS_DotNet.Process |
UpSamplingData(UnmanagedDataFrameUndefinedStruct dataFrame) | MPSizectorS_DotNet.Process | static


MPSizector .NET 编程文档: MPSizectorS_DotNet.Process.RotatedRectangle结构体 参考

  • Process
  • RotatedRectangle
Public 成员函数 | 属性 | 所有成员列表
MPSizectorS_DotNet.Process.RotatedRectangle结构体 参考

Public 成员函数

RotatedRectangle (double x, double y, double width, double height, double angle)

属性

double | X [get, set]
double | Y [get, set]
double | Width [get, set]
double | Height [get, set]
double | Angle [get, set]


MPSizector .NET 编程文档: 成员列表

  • Process
  • RotatedRectangle
MPSizectorS_DotNet.Process.RotatedRectangle 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.Process.RotatedRectangle,包括所有继承而来的类成员

Angle (定义于 MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
Height (定义于 MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
RotatedRectangle(double x, double y, double width, double height, double angle) (定义于 MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
Width (定义于 MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
X (定义于 MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle
Y (定义于 MPSizectorS_DotNet.Process.RotatedRectangle) | MPSizectorS_DotNet.Process.RotatedRectangle


MPSizector .NET 编程文档: MPSizectorS_DotNet.RangeCheckSettingStructType结构体 参考

  • RangeCheckSettingStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.RangeCheckSettingStructType结构体 参考

由用户指定的范围检查设置结构体。包含了X, Y, Z轴的有效范围信息。 更多...

Public 成员函数

override string ToString ()

Public 属性

float | UXmax
X轴最大值。
float | UXmin
X轴最小值。
float | UYmax
Y轴最大值。
float | UYmin
Y轴最小值。
float | UZmax
Z轴最大值。
float | UZmin
Z轴最小值。

属性

float | _UXmax [get]
float | _UXmin [get]
float | _UYmax [get]
float | _UYmin [get]
float | _UZmax [get]
float | _UZmin [get]

详细描述

由用户指定的范围检查设置结构体。包含了X, Y, Z轴的有效范围信息。


MPSizector .NET 编程文档: 成员列表

  • RangeCheckSettingStructType
MPSizectorS_DotNet.RangeCheckSettingStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.RangeCheckSettingStructType,包括所有继承而来的类成员

_UXmax (定义于 MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UXmin (定义于 MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UYmax (定义于 MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UYmin (定义于 MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UZmax (定义于 MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
_UZmin (定义于 MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
ToString() (定义于 MPSizectorS_DotNet.RangeCheckSettingStructType) | MPSizectorS_DotNet.RangeCheckSettingStructType
UXmax | MPSizectorS_DotNet.RangeCheckSettingStructType
UXmin | MPSizectorS_DotNet.RangeCheckSettingStructType
UYmax | MPSizectorS_DotNet.RangeCheckSettingStructType
UYmin | MPSizectorS_DotNet.RangeCheckSettingStructType
UZmax | MPSizectorS_DotNet.RangeCheckSettingStructType
UZmin | MPSizectorS_DotNet.RangeCheckSettingStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.RangeImageManaged结构体 参考

  • RangeImageManaged
Public 属性 | 所有成员列表
MPSizectorS_DotNet.RangeImageManaged结构体 参考

托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
 更多...

Public 属性

float[] | ZRawData
高度数据数组指针(mm)。
ushort[] | RangeData
以unsigned short表示的高度数据数组指针(mm)。
byte[] | Textures
像素灰度值数值指针。
bool[] | Mask
掩码数据指针，指示对应高度数据是否为有效值。
uint | Width
图像的X方向像素长度。
uint | Height
图像的Y方向像素长度。
float | XOffset
图像的X方向偏移(mm)。
float | YOffset
图像的Y方向偏移(mm)。
float | ZOffset
图像的Z方向偏移(mm)。
float | PixelInterval
图像的X和Y方向像素间隔(mm)。
float | ZInterval
图像的Z方向像素间隔(mm)。

详细描述

托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]


MPSizector .NET 编程文档: 成员列表

  • RangeImageManaged
MPSizectorS_DotNet.RangeImageManaged 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.RangeImageManaged,包括所有继承而来的类成员

Height | MPSizectorS_DotNet.RangeImageManaged
Mask | MPSizectorS_DotNet.RangeImageManaged
PixelInterval | MPSizectorS_DotNet.RangeImageManaged
RangeData | MPSizectorS_DotNet.RangeImageManaged
Textures | MPSizectorS_DotNet.RangeImageManaged
Width | MPSizectorS_DotNet.RangeImageManaged
XOffset | MPSizectorS_DotNet.RangeImageManaged
YOffset | MPSizectorS_DotNet.RangeImageManaged
ZInterval | MPSizectorS_DotNet.RangeImageManaged
ZOffset | MPSizectorS_DotNet.RangeImageManaged
ZRawData | MPSizectorS_DotNet.RangeImageManaged


MPSizector .NET 编程文档: MPSizectorS_DotNet.RangeImageUnmanaged结构体 参考

  • RangeImageUnmanaged
Public 属性 | 所有成员列表
MPSizectorS_DotNet.RangeImageUnmanaged结构体 参考

非托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
 更多...

Public 属性

float * | ZRawData
高度数据数组指针(mm)。
ushort * | RangeData
以unsigned short表示的高度数据数组指针(mm)。
byte * | Textures
像素灰度值数值指针。
bool * | Mask
掩码数据指针，指示对应高度数据是否为有效值。
uint | Width
图像的X方向像素长度。
uint | Height
图像的Y方向像素长度。
float | XOffset
图像的X方向偏移(mm)。
float | YOffset
图像的Y方向偏移(mm)。
float | ZOffset
图像的Z方向偏移(mm)。
float | PixelInterval
图像的X和Y方向像素间隔(mm)。
float | ZInterval
图像的Z方向像素间隔(mm)。

详细描述

非托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]


MPSizector .NET 编程文档: 成员列表

  • RangeImageUnmanaged
MPSizectorS_DotNet.RangeImageUnmanaged 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.RangeImageUnmanaged,包括所有继承而来的类成员

Height | MPSizectorS_DotNet.RangeImageUnmanaged
Mask | MPSizectorS_DotNet.RangeImageUnmanaged
PixelInterval | MPSizectorS_DotNet.RangeImageUnmanaged
RangeData | MPSizectorS_DotNet.RangeImageUnmanaged
Textures | MPSizectorS_DotNet.RangeImageUnmanaged
Width | MPSizectorS_DotNet.RangeImageUnmanaged
XOffset | MPSizectorS_DotNet.RangeImageUnmanaged
YOffset | MPSizectorS_DotNet.RangeImageUnmanaged
ZInterval | MPSizectorS_DotNet.RangeImageUnmanaged
ZOffset | MPSizectorS_DotNet.RangeImageUnmanaged
ZRawData | MPSizectorS_DotNet.RangeImageUnmanaged


MPSizector .NET 编程文档: MPSizectorS_DotNet.ReconstructionSettingsStructType结构体 参考

  • ReconstructionSettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.ReconstructionSettingsStructType结构体 参考

重构设置结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | OverExposureFilterThreshold
过曝滤除阈值，有效范围为[0, 16]和254。
值为0时，允许任何程度的过曝，不剔除任何过曝点。
值为16时，不允许任何程度的过曝，剔除所有过曝点。
值为254时，设备根据不同的3D工作模式，自动设置过曝滤除阈值。
byte | ValidPointThreshold0
有效点阈值0。有效范围为[0, 100]。0为最宽松，100为最严格。
byte | ValidPointThreshold1
有效点阈值1。有效范围为[0, 100]。0为最宽松，100为最严格。
byte | BurrFilterThreshold0
飞点剔除阈值0。有效范围为[0, 100]。0为最宽松，100为最严格。
byte | BurrFilterThreshold1
飞点剔除阈值1。有效范围为[0, 100]。0为最宽松，100为最严格。
byte | PreProcessLoopNum
预处理迭代次数。有效范围为[0, 5]。设置为0时，预处理功能关闭。更高的迭代次数将带来更平滑的表面，但损失更多图像细节。
byte | PreProcessThreshold
预处理阈值。有效范围为[0, 100]。更大的值将更大程度地减少预处理对台阶边缘的变形。

属性

byte | _OverExposureFilterThreshold [get]
byte | _ValidPointThreshold0 [get]
byte | _ValidPointThreshold1 [get]
byte | _BurrFilterThreshold0 [get]
byte | _BurrFilterThreshold1 [get]
byte | _PreProcessLoopNum [get]
byte | _PreProcessThreshold [get]

详细描述

重构设置结构体。


MPSizector .NET 编程文档: 成员列表

  • ReconstructionSettingsStructType
MPSizectorS_DotNet.ReconstructionSettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.ReconstructionSettingsStructType,包括所有继承而来的类成员

_BurrFilterThreshold0 (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_BurrFilterThreshold1 (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_OverExposureFilterThreshold (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_PreProcessLoopNum (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_PreProcessThreshold (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_ValidPointThreshold0 (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
_ValidPointThreshold1 (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
BurrFilterThreshold0 | MPSizectorS_DotNet.ReconstructionSettingsStructType
BurrFilterThreshold1 | MPSizectorS_DotNet.ReconstructionSettingsStructType
OverExposureFilterThreshold | MPSizectorS_DotNet.ReconstructionSettingsStructType
PreProcessLoopNum | MPSizectorS_DotNet.ReconstructionSettingsStructType
PreProcessThreshold | MPSizectorS_DotNet.ReconstructionSettingsStructType
ToString() (定义于 MPSizectorS_DotNet.ReconstructionSettingsStructType) | MPSizectorS_DotNet.ReconstructionSettingsStructType
ValidPointThreshold0 | MPSizectorS_DotNet.ReconstructionSettingsStructType
ValidPointThreshold1 | MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.RTMatrixStructType结构体 参考

  • RTMatrixStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.RTMatrixStructType结构体 参考

旋转平移矩阵结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

float | R00
旋转矩阵00。
float | R01
旋转矩阵01。
float | R02
旋转矩阵02。
float | R10
旋转矩阵10。
float | R11
旋转矩阵11。
float | R12
旋转矩阵12。
float | R20
旋转矩阵20。
float | R21
旋转矩阵21。
float | R22
旋转矩阵22。
float | T0
平移矩阵0。
float | T1
平移矩阵1。
float | T2
平移矩阵2。

属性

float | _R00 [get]
float | _R01 [get]
float | _R02 [get]
float | _R10 [get]
float | _R11 [get]
float | _R12 [get]
float | _R20 [get]
float | _R21 [get]
float | _R22 [get]
float | _T0 [get]
float | _T1 [get]
float | _T2 [get]

详细描述

旋转平移矩阵结构体。


MPSizector .NET 编程文档: 成员列表

  • RTMatrixStructType
MPSizectorS_DotNet.RTMatrixStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.RTMatrixStructType,包括所有继承而来的类成员

_R00 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R01 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R02 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R10 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R11 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R12 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R20 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R21 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_R22 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_T0 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_T1 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
_T2 (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType
R00 | MPSizectorS_DotNet.RTMatrixStructType
R01 | MPSizectorS_DotNet.RTMatrixStructType
R02 | MPSizectorS_DotNet.RTMatrixStructType
R10 | MPSizectorS_DotNet.RTMatrixStructType
R11 | MPSizectorS_DotNet.RTMatrixStructType
R12 | MPSizectorS_DotNet.RTMatrixStructType
R20 | MPSizectorS_DotNet.RTMatrixStructType
R21 | MPSizectorS_DotNet.RTMatrixStructType
R22 | MPSizectorS_DotNet.RTMatrixStructType
T0 | MPSizectorS_DotNet.RTMatrixStructType
T1 | MPSizectorS_DotNet.RTMatrixStructType
T2 | MPSizectorS_DotNet.RTMatrixStructType
ToString() (定义于 MPSizectorS_DotNet.RTMatrixStructType) | MPSizectorS_DotNet.RTMatrixStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.SettingsStructType结构体 参考

  • SettingsStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.SettingsStructType结构体 参考

所有设置的结构体。 更多...

Public 成员函数

override string | ToString ()
void | SetAuxiliaryWhite (bool enable)
设置是否使能外部白光光源曝光。
void | SetAuxiliaryRGB (bool enable)
设置是否使能了外部RGB光光源曝光。

Public 属性

BasicSettingsStructType | BasicSetings
基础设置。
ExposureSettingsStructType | ExposureSettings
曝光设置。
ExternalExposureSettingsStructType | ExternalExposureSettings
外部光源的曝光设置。
ReconstructionSettingsStructType | ReconstructionSettings
重构设置。
MultiHeadSettingsStructType | MultiHeadSettings
多头重构设置。
PostProcessSettingsStructType | PostProcessSettings
后处理设置。
IOSettingsStructType | IOSettings
IO设置。
GeneralSettingsStructType | GeneralSettings
通用设置。
byte | CorrectDistortionEnable
畸变矫正使能状态。
ExpertSettingsStructType | ExpertSettings
专业设置。
MPSizectorS_AutoHDRAdvanceSettingsStructType | AutoHDRAdvanceSettings
自动HDR高级设置。
SoftwarePreprocessListRegisters | SoftwarePreprocessList
软件预处理列表。
HardwarePreprocessModeListStructType | HardwarePreprocessModeList
硬件预处理模式列表。
SoftwarePreprocessPresetParamListStructType | SoftwarePreprocessPresetParamList
软件预处理预设参数列表。
CompensationStructType | CompensationParams
补偿参数。

属性

BasicSettingsStructType | _BasicSettings [get]
ExposureSettingsStructType | _ExposureSettings [get]
ExternalExposureSettingsStructType | _ExternalExposureSettings [get]
ReconstructionSettingsStructType | _ReconstructionSettings [get]
MultiHeadSettingsStructType | _MultiHeadSettings [get]
PostProcessSettingsStructType | _PostProcessSettings [get]
IOSettingsStructType | _IOSettings [get]
GeneralSettingsStructType | _GeneralSettings [get]
byte | _CorrectDistortionEnable [get]
ExpertSettingsStructType | _ExpertSettings [get]
bool | HasAuxiliaryWhiteImage [get]
是否使能了外部白光光源曝光。
bool | HasAuxiliaryRGBImage [get]
是否使能了外部RGB光光源曝光。

详细描述

所有设置的结构体。


MPSizector .NET 编程文档: 成员列表

  • SettingsStructType
MPSizectorS_DotNet.SettingsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SettingsStructType,包括所有继承而来的类成员

_BasicSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_CorrectDistortionEnable (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ExpertSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ExposureSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ExternalExposureSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_GeneralSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_IOSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_MultiHeadSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_PostProcessSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
_ReconstructionSettings (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType
AutoHDRAdvanceSettings | MPSizectorS_DotNet.SettingsStructType
BasicSetings | MPSizectorS_DotNet.SettingsStructType
CompensationParams | MPSizectorS_DotNet.SettingsStructType
CorrectDistortionEnable | MPSizectorS_DotNet.SettingsStructType
ExpertSettings | MPSizectorS_DotNet.SettingsStructType
ExposureSettings | MPSizectorS_DotNet.SettingsStructType
ExternalExposureSettings | MPSizectorS_DotNet.SettingsStructType
GeneralSettings | MPSizectorS_DotNet.SettingsStructType
HardwarePreprocessModeList | MPSizectorS_DotNet.SettingsStructType
HasAuxiliaryRGBImage | MPSizectorS_DotNet.SettingsStructType
HasAuxiliaryWhiteImage | MPSizectorS_DotNet.SettingsStructType
IOSettings | MPSizectorS_DotNet.SettingsStructType
MultiHeadSettings | MPSizectorS_DotNet.SettingsStructType
PostProcessSettings | MPSizectorS_DotNet.SettingsStructType
ReconstructionSettings | MPSizectorS_DotNet.SettingsStructType
SetAuxiliaryRGB(bool enable) | MPSizectorS_DotNet.SettingsStructType
SetAuxiliaryWhite(bool enable) | MPSizectorS_DotNet.SettingsStructType
SoftwarePreprocessList | MPSizectorS_DotNet.SettingsStructType
SoftwarePreprocessPresetParamList | MPSizectorS_DotNet.SettingsStructType
ToString() (定义于 MPSizectorS_DotNet.SettingsStructType) | MPSizectorS_DotNet.SettingsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePostProcessSetting结构体 参考

  • SoftwarePostProcessSetting
Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePostProcessSetting结构体 参考

软件后处理结构体。 更多...

Public 属性

SoftwarePostProcessType | Type
float[] | Param

详细描述

软件后处理结构体。


MPSizector .NET 编程文档: 成员列表

  • SoftwarePostProcessSetting
MPSizectorS_DotNet.SoftwarePostProcessSetting 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePostProcessSetting,包括所有继承而来的类成员

Param (定义于 MPSizectorS_DotNet.SoftwarePostProcessSetting) | MPSizectorS_DotNet.SoftwarePostProcessSetting
Type (定义于 MPSizectorS_DotNet.SoftwarePostProcessSetting) | MPSizectorS_DotNet.SoftwarePostProcessSetting


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessListRegisters结构体 参考

  • SoftwarePreprocessListRegisters
类 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessListRegisters结构体 参考

软件预处理列表结构体。 更多...

类

struct PreprocessStructType

Public 属性

byte | Number
byte | Enable
byte[] | Reserved
PreprocessStructType[] | Preprocess
uint[] | Parameters

详细描述

软件预处理列表结构体。


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessListRegisters
MPSizectorS_DotNet.SoftwarePreprocessListRegisters 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters,包括所有继承而来的类成员

Enable (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Number (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Parameters (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Preprocess (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters
Reserved (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType结构体 参考

  • SoftwarePreprocessListRegisters
  • PreprocessStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType结构体 参考

Public 属性

byte | Size
byte | Address
byte | VersionAndMode
byte | Type


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessListRegisters
  • PreprocessStructType
MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType,包括所有继承而来的类成员

Address (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
Size (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
Type (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
VersionAndMode (定义于 MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType) | MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType结构体 参考

  • SoftwarePreprocessPresetParamListStructType
类 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType结构体 参考

软件预处理预设参数列表结构体。 更多...

类

struct | PreprocessPresetFiltrateStructType
struct | PreprocessPresetMedianFilterStructType
struct | PreprocessPresetMendStructType
struct | PreprocessPresetRemoveBurrsStructType
struct | PreprocessPresetStructType

Public 属性

ushort[] | Version
float | MinZ
float | MaxZ
float | ZPrecision
PreprocessPresetStructType[] | PresetParam

详细描述

软件预处理预设参数列表结构体。


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessPresetParamListStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType,包括所有继承而来的类成员

MaxZ (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
MinZ (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
PresetParam (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
Version (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType
ZPrecision (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetRemoveBurrsStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType,包括所有继承而来的类成员

ParamEdgeSuppressLevel (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamNeighborCloseLevel (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamNeighborNumLevel (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamSlopeLevel (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamWinSize (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
ParamWinSize2 (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
Reserved (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType结构体 参考

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetFiltrateStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType结构体 参考

Public 属性

byte | ParamWinSize
byte | ParamNeighborCloseLevel
byte | ParamNeighborNumLevel
byte | filtrateMendPointOnly


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType结构体 参考

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMedianFilterStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType结构体 参考

Public 属性

byte | FilterWinSize
byte[] | Reserved


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType结构体 参考

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMendStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType结构体 参考

Public 属性

byte | ParamWinSize
byte | ParamWinSize2
byte | Method
byte | Reserved


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType结构体 参考

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetRemoveBurrsStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType结构体 参考

Public 属性

byte | ParamWinSize
byte | ParamWinSize2
byte | ParamSlopeLevel
byte | ParamNeighborCloseLevel
byte | ParamNeighborNumLevel
byte | ParamEdgeSuppressLevel
byte[] | Reserved


MPSizector .NET 编程文档: MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType结构体 参考

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetStructType
Public 属性 | 所有成员列表
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType结构体 参考

Public 属性

PreprocessPresetRemoveBurrsStructType | RemoveBurrsPreset
PreprocessPresetMendStructType | MendPreset
PreprocessPresetFiltrateStructType | FiltratePreset
PreprocessPresetMedianFilterStructType | MedianFilterPreset


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType,包括所有继承而来的类成员

FiltratePreset (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
MedianFilterPreset (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
MendPreset (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
RemoveBurrsPreset (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.StatesStructType结构体 参考

  • StatesStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.StatesStructType结构体 参考

所有设备状态信息的结构体 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | EXTIOInput
输入引脚寄存器值，每一个bit表示一个引脚。
TemperatureFeedbackStructType | TempCore
核心温度传感器的反馈信息。
TemperatureFeedbackStructType | Temp0
温度传感器0的反馈信息。
TemperatureFeedbackStructType | Temp1
温度传感器1的反馈信息。
TemperatureFeedbackStructType | Temp2
温度传感器2的反馈信息。
uint | StartUpTimeMS
设备启动时间，单位为ms。
uint | ConnectionTimeMS
设备连接时间，单位为ms。
uint | SnapCnt
设备拍摄计数，包括2D拍摄与3D拍摄。
ushort | TotalTransferRetryNum
传输重试总计数。
ushort | CurrentTransferRetryNum
当前帧的传输重试计数。
ushort | TotalCaptureRetryNum
拍摄重试总计数。
TSNStructType | CurrentTSN
当前正在执行拍摄或传输的TSN。若处于空闲状态，则是最后一次拍摄的TSN。
TSNStructType | SoftwareTSN
最后一次由软件触发的TSN。
TSNStructType | AutoTSN
最后一次连续拍摄时自动触发的TSN。
TSNStructType | HardwareTSN
最后一次硬件触发的TSN。
DebugInfoStruct | DebugRegisters
制造商调试用途的寄存器。

属性

byte | _EXTIOInput [get]
TemperatureFeedbackStructType | _TempCore [get]
TemperatureFeedbackStructType | _Temp0 [get]
TemperatureFeedbackStructType | _Temp1 [get]
TemperatureFeedbackStructType | _Temp2 [get]
uint | _StartUpTimeMS [get]
uint | _ConnectionTimeMS [get]
uint | _SnapCnt [get]
ushort | _TotalTransferRetryNum [get]
ushort | _CurrentTransferRetryNum [get]
ushort | _TotalCaptureRetryNum [get]
TSNStructType | _CurrentTSN [get]
TSNStructType | _SoftwareTSN [get]
TSNStructType | _AutoTSN [get]
TSNStructType | _HardwareTSN [get]
DebugInfoStruct | _DebugRegisters [get]

详细描述

所有设备状态信息的结构体


MPSizector .NET 编程文档: 成员列表

  • StatesStructType
MPSizectorS_DotNet.StatesStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.StatesStructType,包括所有继承而来的类成员

_AutoTSN (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_ConnectionTimeMS (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_CurrentTransferRetryNum (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_CurrentTSN (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_DebugRegisters (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_EXTIOInput (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_HardwareTSN (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_SnapCnt (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_SoftwareTSN (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_StartUpTimeMS (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_Temp0 (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_Temp1 (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_Temp2 (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_TempCore (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_TotalCaptureRetryNum (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
_TotalTransferRetryNum (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
AutoTSN | MPSizectorS_DotNet.StatesStructType
ConnectionTimeMS | MPSizectorS_DotNet.StatesStructType
CurrentTransferRetryNum | MPSizectorS_DotNet.StatesStructType
CurrentTSN | MPSizectorS_DotNet.StatesStructType
DebugRegisters | MPSizectorS_DotNet.StatesStructType
EXTIOInput | MPSizectorS_DotNet.StatesStructType
HardwareTSN | MPSizectorS_DotNet.StatesStructType
SnapCnt | MPSizectorS_DotNet.StatesStructType
SoftwareTSN | MPSizectorS_DotNet.StatesStructType
StartUpTimeMS | MPSizectorS_DotNet.StatesStructType
Temp0 | MPSizectorS_DotNet.StatesStructType
Temp1 | MPSizectorS_DotNet.StatesStructType
Temp2 | MPSizectorS_DotNet.StatesStructType
TempCore | MPSizectorS_DotNet.StatesStructType
ToString() (定义于 MPSizectorS_DotNet.StatesStructType) | MPSizectorS_DotNet.StatesStructType
TotalCaptureRetryNum | MPSizectorS_DotNet.StatesStructType
TotalTransferRetryNum | MPSizectorS_DotNet.StatesStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.SuppressExpParamsEnableStructType结构体 参考

  • SuppressExpParamsEnableStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.SuppressExpParamsEnableStructType结构体 参考

曝光抑制参数。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | SuppressExpParam1Enable
曝光抑制参数1。
byte | SuppressExpParam2Enable
曝光抑制参数2。
byte | SuppressExpParam3Enable
曝光抑制参数3。

属性

byte | _SuppressExpParam1Enable [get]
byte | _SuppressExpParam2Enable [get]
byte | _SuppressExpParam3Enable [get]

详细描述

曝光抑制参数。


MPSizector .NET 编程文档: 成员列表

  • SuppressExpParamsEnableStructType
MPSizectorS_DotNet.SuppressExpParamsEnableStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SuppressExpParamsEnableStructType,包括所有继承而来的类成员

_SuppressExpParam1Enable (定义于 MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
_SuppressExpParam2Enable (定义于 MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
_SuppressExpParam3Enable (定义于 MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
SuppressExpParam1Enable | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
SuppressExpParam2Enable | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
SuppressExpParam3Enable | MPSizectorS_DotNet.SuppressExpParamsEnableStructType
ToString() (定义于 MPSizectorS_DotNet.SuppressExpParamsEnableStructType) | MPSizectorS_DotNet.SuppressExpParamsEnableStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.TemperatureFeedbackStructType结构体 参考

  • TemperatureFeedbackStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.TemperatureFeedbackStructType结构体 参考

温度反馈信息结构体。 更多...

Public 成员函数

override string ToString ()

Public 属性

byte | SensorValid
温度传感器的有效状态。值为true时传感器有效，值为false时传感器无效。
sbyte | TempValueC
温度读数，以摄氏度为单位。
TemperatureFeedBackStateType | State
温度状态判断。指示该传感器的读数是否在范围之内。

属性

byte | _SensorValid [get]
sbyte | _TempValueC [get]
TemperatureFeedBackStateType | _State [get]

详细描述

温度反馈信息结构体。


MPSizector .NET 编程文档: 成员列表

  • TemperatureFeedbackStructType
MPSizectorS_DotNet.TemperatureFeedbackStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.TemperatureFeedbackStructType,包括所有继承而来的类成员

_SensorValid (定义于 MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType
_State (定义于 MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType
_TempValueC (定义于 MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType
SensorValid | MPSizectorS_DotNet.TemperatureFeedbackStructType
State | MPSizectorS_DotNet.TemperatureFeedbackStructType
TempValueC | MPSizectorS_DotNet.TemperatureFeedbackStructType
ToString() (定义于 MPSizectorS_DotNet.TemperatureFeedbackStructType) | MPSizectorS_DotNet.TemperatureFeedbackStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.TSNStructType结构体 参考

  • TSNStructType
Public 成员函数 | Public 属性 | 属性 | 所有成员列表
MPSizectorS_DotNet.TSNStructType结构体 参考

TSN信息结构体。标示了一个有效的触发信号的信号来源，及其序列号。 更多...

Public 成员函数

override string ToString ()

Public 属性

TSNSourceType | Source
触发信号来源。
uint | SN
触发信号的序列号。

属性

TSNSourceType | _Source [get]
uint | _SN [get]

详细描述

TSN信息结构体。标示了一个有效的触发信号的信号来源，及其序列号。


MPSizector .NET 编程文档: 成员列表

  • TSNStructType
MPSizectorS_DotNet.TSNStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.TSNStructType,包括所有继承而来的类成员

_SN (定义于 MPSizectorS_DotNet.TSNStructType) | MPSizectorS_DotNet.TSNStructType
_Source (定义于 MPSizectorS_DotNet.TSNStructType) | MPSizectorS_DotNet.TSNStructType
SN | MPSizectorS_DotNet.TSNStructType
Source | MPSizectorS_DotNet.TSNStructType
ToString() (定义于 MPSizectorS_DotNet.TSNStructType) | MPSizectorS_DotNet.TSNStructType


MPSizector .NET 编程文档: MPSizectorS_DotNet.UnmanagedDataFrame2DStruct结构体 参考

  • UnmanagedDataFrame2DStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.UnmanagedDataFrame2DStruct结构体 参考

非托管的2D数据帧结构体。 更多...

Public 成员函数

Bitmap | GetGrayBitmap (byte PicIndex=0)
获取灰度图像的位图。
Bitmap | GetExposurePredictionBitmap ()
获取曝光预测图像的位图。
bool | SaveDataFrame (string FileName)
将数据帧保存至文件。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
byte * | Data
非托管的2D图像数据。

详细描述

非托管的2D数据帧结构体。

成员函数说明

◆ GetExposurePredictionBitmap()

Bitmap MPSizectorS_DotNet.UnmanagedDataFrame2DStruct.GetExposurePredictionBitmap ( )

获取曝光预测图像的位图。

返回
曝光预测图像的位图。

◆ GetGrayBitmap()

Bitmap MPSizectorS_DotNet.UnmanagedDataFrame2DStruct.GetGrayBitmap ( byte PicIndex = 0 )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrame2DStruct.SaveDataFrame ( string FileName )

将数据帧保存至文件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。


MPSizector .NET 编程文档: 成员列表

  • UnmanagedDataFrame2DStruct
MPSizectorS_DotNet.UnmanagedDataFrame2DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.UnmanagedDataFrame2DStruct,包括所有继承而来的类成员

Data | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
GetExposurePredictionBitmap() | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
GetGrayBitmap(byte PicIndex=0) | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct
SaveDataFrame(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrame2DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct结构体 参考

  • UnmanagedDataFrameFix3DStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct结构体 参考

非托管定点数格式的3D数据帧结构体。 更多...

Public 成员函数

unsafe Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
unsafe Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
unsafe Bitmap | GetHDRMaskBitmap ()
获取HDR掩码位图。
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。
unsafe bool | FreeHGlobalMemory ()
当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。
unsafe void | CopyToManagedFix3D (ManagedDataFrameFix3DStruct ManagedDataFrame)
将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
DataPointFix3DStruct * | Data
非托管的定点数格式的点云数据。
byte * | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte * | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

非托管定点数格式的3D数据帧结构体。

成员函数说明

◆ CopyToManagedFix3D()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.CopyToManagedFix3D ( ManagedDataFrameFix3DStruct ManagedDataFrame )

将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

参数
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.FreeHGlobalMemory ( )

当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。

返回
如果成功返回true。

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetHDRMaskBitmap ( )

获取HDR掩码位图。

返回
HDR掩码位图。

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。


MPSizector .NET 编程文档: 成员列表

  • UnmanagedDataFrameFix3DStruct
MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
CopyToManagedFix3D(ManagedDataFrameFix3DStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
Data | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct结构体 参考

  • UnmanagedDataFrameFixZMapSimpleStruct
Public 成员函数 | 静态 Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct结构体 参考

非托管的简化的定点数深度图的3D数据帧结构体。 更多...

Public 成员函数

unsafe Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
unsafe Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。
unsafe bool | FreeHGlobalMemory ()
当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。
unsafe void | CopyToManagedFixZMapSimple (ManagedDataFrameFixZMapSimpleStruct ManagedDataFrame)
将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

静态 Public 成员函数

static bool | IsValid (ushort point)
判断定点数Z数据的点是否有效。
static byte | GetMaskValue (ushort point)
获取定点数Z数据的点的掩码。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
byte * | Data
包含所有数据的起始指针。
ushort * | Z
转换后的Z值。0和65535代表无效点数据。
byte * | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte * | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

非托管的简化的定点数深度图的3D数据帧结构体。

成员函数说明

◆ CopyToManagedFixZMapSimple()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.CopyToManagedFixZMapSimple ( ManagedDataFrameFixZMapSimpleStruct ManagedDataFrame )

将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

参数
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.FreeHGlobalMemory ( )

当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。

返回
如果成功返回true。

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetMaskValue()

static byte MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetMaskValue ( ushort point )
static

获取定点数Z数据的点的掩码。

参数
point 定点数Z数据点。
返回
掩码。

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ IsValid()

static bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.IsValid ( ushort point )
static

判断定点数Z数据的点是否有效。

参数
point 定点数Z数据点。
返回
如果有效返回true。

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。


MPSizector .NET 编程文档: 成员列表

  • UnmanagedDataFrameFixZMapSimpleStruct
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
CopyToManagedFixZMapSimple(ManagedDataFrameFixZMapSimpleStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
Data | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
GetMaskValue(ushort point) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct | static
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
IsValid(ushort point) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct | static
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |
Z | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct |


MPSizector .NET 编程文档: MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct结构体 参考

  • UnmanagedDataFrameFixZMapStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct结构体 参考

非托管定点数深度图的3D数据帧结构体。 更多...

Public 成员函数

unsafe Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
unsafe Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
unsafe Bitmap | GetHDRMaskBitmap ()
获取HDR掩码位图。
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。
unsafe bool | FreeHGlobalMemory ()
当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。
unsafe void | CopyToManagedFixZMap (ManagedDataFrameFixZMapStruct ManagedDataFrame)
将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
DataPointFixZMapStruct * | Data
定点数深度图格式3D数据点数据。
byte * | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte * | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

非托管定点数深度图的3D数据帧结构体。

成员函数说明

◆ CopyToManagedFixZMap()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.CopyToManagedFixZMap ( ManagedDataFrameFixZMapStruct ManagedDataFrame )

将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

参数
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.FreeHGlobalMemory ( )

当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。

返回
如果成功返回true。

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetHDRMaskBitmap ( )

获取HDR掩码位图。

返回
HDR掩码位图。

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。


MPSizector .NET 编程文档: 成员列表

  • UnmanagedDataFrameFixZMapStruct
MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
CopyToManagedFixZMap(ManagedDataFrameFixZMapStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
Data | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct结构体 参考

  • UnmanagedDataFrameFloat3DStruct
Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct结构体 参考

非托管浮点数格式的3D数据帧结构体。 更多...

Public 成员函数

unsafe Bitmap | GetGrayBitmap ()
获取灰度图像的位图。
unsafe Bitmap | GetAuxiliaryBitmap (Auxiliary2DType type)
获取外部曝光拍摄的2D辅助图像位图。
unsafe Bitmap | GetColorDepthBitmap (float Max, float Min)
获取深度色谱图的位图。
unsafe Bitmap | GetValidMaskBitmap ()
获取有效状态掩码位图。
unsafe Bitmap | GetHDRMaskBitmap ()
获取HDR掩码位图。
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
unsafe bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。
unsafe bool | FreeHGlobalMemory ()
当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。
unsafe void | CopyToManagedFloat3D (ManagedDataFrameFloat3DStruct ManagedDataFrame)
将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
DataPointFloat3DStruct * | Data
非托管的浮点数格式的点云数据。
byte * | AuxiliaryWhite
外部白光曝光时拍摄的2D辅助图像。如果没有启用外部白光曝光，则为null。
byte * | AuxiliaryRGB
外部RGB曝光时拍摄的3张2D辅助图像。如果没有启用外部RGB曝光，则为null。

详细描述

非托管浮点数格式的3D数据帧结构体。

成员函数说明

◆ CopyToManagedFloat3D()

unsafe void MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.CopyToManagedFloat3D ( ManagedDataFrameFloat3DStruct ManagedDataFrame )

将当前UnmanagedDataFrame中数据拷贝到ManagedDataFrame中.

参数
ManagedDataFrame The managed data frame.

◆ FreeHGlobalMemory()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.FreeHGlobalMemory ( )

当该数据为在.NET环境中从Managed转为Unmanaged数据时，需释放该数据。

返回
如果成功返回true。

◆ GetAuxiliaryBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetAuxiliaryBitmap ( Auxiliary2DType type )

获取外部曝光拍摄的2D辅助图像位图。

参数
type 图像类型。
返回
位图。

◆ GetColorDepthBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetColorDepthBitmap | ( | float | Max,
 |  | float | Min )

获取深度色谱图的位图。

参数
Max | 深度色谱图的范围最小值。
Min | 深度色谱图的范围最大值。
返回
深度色谱图的位图。

◆ GetGrayBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetGrayBitmap ( )

获取灰度图像的位图。

返回
灰度图像的位图。

◆ GetHDRMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetHDRMaskBitmap ( )

获取HDR掩码位图。

返回
HDR掩码位图。

◆ GetValidMaskBitmap()

unsafe Bitmap MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.GetValidMaskBitmap ( )

获取有效状态掩码位图。

返回
有效状态掩码位图。

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。


MPSizector .NET 编程文档: 成员列表

  • UnmanagedDataFrameFloat3DStruct
MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct,包括所有继承而来的类成员

AuxiliaryRGB | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
AuxiliaryWhite | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
CopyToManagedFloat3D(ManagedDataFrameFloat3DStruct ManagedDataFrame) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
Data | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
FreeHGlobalMemory() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetAuxiliaryBitmap(Auxiliary2DType type) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetColorDepthBitmap(float Max, float Min) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetGrayBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetHDRMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
GetValidMaskBitmap() | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct


MPSizector .NET 编程文档: MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct结构体 参考

  • UnmanagedDataFrameUndefinedStruct
Public 成员函数 | 静态 Public 成员函数 | Public 属性 | 所有成员列表
MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct结构体 参考

非托管的未定义格式数据帧结构体。该类型为数据回调提供的唯一数据类型，它是一种中间数据格式，用于避免采用多个回调函数传递不同格式的数据。 更多...

Public 成员函数

unsafe UnmanagedDataFrameUndefinedStruct | GetCopy ()
获取该数据帧的独立拷贝。由于驱动程序的BUFFER被循环使用，若回调返回的数据不立刻使用，可能会被后续的数据覆盖。在一些需要缓存大量数据的情况下，请使用该函数以获得独立的数据拷贝。需要注意的是，客户将负责销毁该数据。
unsafe bool | DestroyCopy ()
当该数据为在.NET环境中生成的拷贝时，销毁该拷贝的数据。
UnmanagedDataFrameFloat3DStruct ToUnmanagedFloat3D ()
将当前数据帧转换为UnmanagedFloat3D格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是Float3D。
UnmanagedDataFrameFix3DStruct ToUnmanagedFix3D ()
将当前数据帧转换为UnmanagedFix3D格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是Float3D。
UnmanagedDataFrameFixZMapStruct ToUnmanagedFixZMap ()
将当前数据帧转换为UnmanagedDataFrameFixZMap格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是FixZMap。
UnmanagedDataFrameFixZMapSimpleStruct ToUnmanagedFixZMapSimple ()
将当前数据帧转换为UnmanagedDataFrameFixZMapSimple格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是FixZMapSimple。
UnmanagedDataFrame2DStruct ToUnmanaged2D ()
将当前数据帧转换为Unmanaged2D格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是2D。
unsafe ManagedDataFrameFloat3DStruct | ToManagedFloat3D ()
将当前数据帧转换为ManagedFloat3D格式。当前数据的原生格式可以是Fix3D，也可以是Float3D。程序会根据需要自动进行转换。
unsafe ManagedDataFrameFix3DStruct | ToManagedFix3D ()
将当前数据帧转换为ManagedFix3D格式。当前数据的原生格式可以是Fix3D，也可以是Float3D。程序会根据需要自动进行转换。
unsafe ManagedDataFrameFixZMapStruct | ToManagedFixZMap ()
将当前数据帧转换为ManagedFixZMap格式。当前数据的原生格式可以任意。程序会根据需要自动进行转换。
unsafe ManagedDataFrameFixZMapSimpleStruct | ToManagedFixZMapSimple ()
将当前数据帧转换为ManagedFixZMapSimple格式。当前数据的原生格式可以任意。程序会根据需要自动进行转换。
unsafe ManagedDataFrame2DStruct | ToManaged2D ()
将当前数据帧转换为Managed2D格式。数据的原生格式必须是2D。
bool | SaveDataFrame (string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
将数据帧保存至文件。
bool | SaveTextPointCloud (string FileName)
将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

静态 Public 成员函数

static bool LoadDataFrame (out UnmanagedDataFrameUndefinedStruct Data, string FileName, out float ColorDepthMin, out float ColorDepthMax)
从文件读入数据帧。

Public 属性

HeadPackStructType | FrameInfo
数据帧信息。
byte * | Data
数据。

详细描述

非托管的未定义格式数据帧结构体。该类型为数据回调提供的唯一数据类型，它是一种中间数据格式，用于避免采用多个回调函数传递不同格式的数据。

成员函数说明

◆ DestroyCopy()

unsafe bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.DestroyCopy ( )

当该数据为在.NET环境中生成的拷贝时，销毁该拷贝的数据。

返回
如果成功返回true。

◆ LoadDataFrame()

static bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.LoadDataFrame | ( | out UnmanagedDataFrameUndefinedStruct | Data,
 |  | string | FileName,
 |  | out float | ColorDepthMin,
 |  | out float | ColorDepthMax )
 static

从文件读入数据帧。

参数
Data | 读入的数据帧结果。
FileName | 包含路径的文件名。若不包含路径，则在当前文件夹下查找文件。
ColorDepthMin | 读出的深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 读出的深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveDataFrame()

bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.SaveDataFrame | ( | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )

将数据帧保存至文件。

参数
FileName | 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
ColorDepthMin | 可选参数，深度色谱范围最小值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
ColorDepthMax | 可选参数，深度色谱范围最大值，可在打开3D数据时，应用保存时的深度色谱设置。仅对3D数据帧有效，默认值为0。
返回
操作是否成功。成功为true, 失败为false。

◆ SaveTextPointCloud()

bool MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.SaveTextPointCloud ( string FileName )

将3D数据帧保存为文本格式的点云。该格式通常被用于将数据导入第三方点云处理软件。

参数
FileName 包含路径的文件名。若不包含路径，则保存在当前文件夹下。
返回
操作是否成功。成功为true, 失败为false。

◆ ToManaged2D()

unsafe ManagedDataFrame2DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManaged2D ( )

将当前数据帧转换为Managed2D格式。数据的原生格式必须是2D。

返回
转换后的数据帧。

◆ ToManagedFix3D()

unsafe ManagedDataFrameFix3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFix3D ( )

将当前数据帧转换为ManagedFix3D格式。当前数据的原生格式可以是Fix3D，也可以是Float3D。程序会根据需要自动进行转换。

返回
转换后的数据帧。

◆ ToManagedFixZMap()

unsafe ManagedDataFrameFixZMapStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFixZMap ( )

将当前数据帧转换为ManagedFixZMap格式。当前数据的原生格式可以任意。程序会根据需要自动进行转换。

返回
转换后的数据帧。

◆ ToManagedFixZMapSimple()

unsafe ManagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFixZMapSimple ( )

将当前数据帧转换为ManagedFixZMapSimple格式。当前数据的原生格式可以任意。程序会根据需要自动进行转换。

返回
转换后的数据帧。

◆ ToManagedFloat3D()

unsafe ManagedDataFrameFloat3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToManagedFloat3D ( )

将当前数据帧转换为ManagedFloat3D格式。当前数据的原生格式可以是Fix3D，也可以是Float3D。程序会根据需要自动进行转换。

返回
转换后的数据帧。

◆ ToUnmanaged2D()

UnmanagedDataFrame2DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanaged2D ( )

将当前数据帧转换为Unmanaged2D格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是2D。

返回
转换后的数据帧。

◆ ToUnmanagedFix3D()

UnmanagedDataFrameFix3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFix3D ( )

将当前数据帧转换为UnmanagedFix3D格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是Float3D。

返回
转换后的数据帧。

◆ ToUnmanagedFixZMap()

UnmanagedDataFrameFixZMapStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFixZMap ( )

将当前数据帧转换为UnmanagedDataFrameFixZMap格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是FixZMap。

返回
转换后的数据帧。

◆ ToUnmanagedFixZMapSimple()

UnmanagedDataFrameFixZMapSimpleStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFixZMapSimple ( )

将当前数据帧转换为UnmanagedDataFrameFixZMapSimple格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是FixZMapSimple。

返回
转换后的数据帧。

◆ ToUnmanagedFloat3D()

UnmanagedDataFrameFloat3DStruct MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct.ToUnmanagedFloat3D ( )

将当前数据帧转换为UnmanagedFloat3D格式。该函数只做类型转换而不修改数据，因此数据的原生格式必须是Float3D。

返回
转换后的数据帧。


MPSizector .NET 编程文档: 成员列表

  • UnmanagedDataFrameUndefinedStruct
MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct,包括所有继承而来的类成员

Data | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
DestroyCopy() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
FrameInfo | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
GetCopy() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
LoadDataFrame(out UnmanagedDataFrameUndefinedStruct Data, string FileName, out float ColorDepthMin, out float ColorDepthMax) | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct | static
SaveDataFrame(string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
SaveTextPointCloud(string FileName) | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManaged2D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFix3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFixZMap() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFixZMapSimple() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToManagedFloat3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanaged2D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFix3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFixZMap() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFixZMapSimple() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |
ToUnmanagedFloat3D() | MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct |


MPSizector .NET 编程文档: MPSizectorS_DotNet.Utils类 参考

  • Utils
Public 成员函数 | 静态 Public 成员函数 | 静态 Public 属性 | 所有成员列表
MPSizectorS_DotNet.Utils类 参考

Public 成员函数

static void | CopyMemory (IntPtr dest, IntPtr src, uint count)
非托管内存拷贝，kernel32.dll中CopyMemory函数的映射。
static unsafe void | FreeUnmanagedData (UnmanagedDataFrameUndefinedStruct DataFrame)
释放非托管数据内存。
static unsafe void | TransformROISettingToROIPixel (DeviceInfoStructType DevInfo, byte VSensorX0Ratio, byte VSensorY0Ratio, byte VSensorWRatio, byte VSensorHRatio, out uint OSensorX0, out uint OSensorY0, out uint OSensorXResol, out uint OSensorYResol, bool IsBinningMode=false)
将相机硬件ROI0~255的数值转换为像素坐标的ROI。
static unsafe void | TransformROIPixelToROISetting (DeviceInfoStructType DevInfo, uint IXStartPixel, uint IYStartPixel, uint IWidthPixel, uint IHeightPixel, out byte OROIX0Ratio, out byte OROIY0Ratio, out byte OROIWidthRatio, out byte OROIHeightRatio, out uint OXStartPixel, out uint OYStartPixel, out uint OWidthPixel, out uint OHeightPixel, bool IsBinningMode=false)
将像素坐标的ROI设置转换为相机硬件ROI可接受的参数范围为0~255的数值。
static unsafe uint | Get3DDataLen (HeadPackDataInfoStructType DataInfo)
获取3D数据的长度(仅对非托管数据有效)。
static unsafe uint | GetDataLen (HeadPackStructType FrameInfo)
获取数据的长度(仅对非托管数据有效)。
static unsafe bool | CalculateCorrectDistortionParamFromData (UnmanagedDataFrameUndefinedStruct Data, out CorrectDistortionParamStructType CorrectDistortionMatrix, int Interval=16)
读取实时后处理mppp文件的后处理设置。
static unsafe void | CompensateData (UnmanagedDataFrameUndefinedStruct data, UnmanagedDataFrameUndefinedStruct compensationData)
data 与 compensationData 点对点相减， 用于校正data中的畸变，仅支持UnmanagedDataFrameUndefinedStruct。

静态 Public 成员函数

static bool | SaveUnmanagedDataFrameUndefined (UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, float ColorDepthMin=0, float ColorDepthMax=0)
保存Undefined格式数据到文件。
static unsafe bool | LoadUnmanagedDataFrameUndefined (out UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, out float ColorDepthMin, out float ColorDepthMax)
从文件中读取Undefined格式数据。
static unsafe bool | SaveDataFrame_ManagedFixZMapSimpleDataFrame (FileStream fs, ManagedDataFrameFixZMapSimpleStruct DataFrame, out int Size, float ColorDepthMin=0, float ColorDepthMax=0)
通过文件流保存数据。（针对托管带RGB的简化深度图，3D数据与2D数据不连续）
static unsafe bool | SaveDataFrame_FileStream (FileStream fs, HeadPackStructType FrameInfo, Byte *Data, out int Size, float ColorDepthMin=0, float ColorDepthMax=0)
通过文件流保存数据。
static unsafe Bitmap | ConvertGrayByteArrayToGrayBitmap (byte[] Gray, uint Width, uint Height, byte Index=0)
将灰度指针转换为灰度Bitmap.
static unsafe Bitmap | ConvertGrayByteArrayToGrayBitmap (byte *Gray, uint Width, uint Height, byte Index=0)
将非托管的灰度数据转换为灰度位图。
static unsafe Bitmap | ConvertRGBByteArrayToRGBBitmap (byte[] Red, byte[] Green, byte[] Blue, uint Width, uint Height)
将3个频道(RGB)的颜色数组指针转换为彩色Bitmap.
static unsafe Bitmap | ConvertRGBByteArrayToRGBBitmap (byte *Red, byte *Green, byte *Blue, uint Width, uint Height)
将3个频道(RGB)的颜色数组指针转换为彩色Bitmap.
static unsafe Bitmap | GetAuxiliaryBitmap (byte *data, Auxiliary2DType type, int width, int height)
从非托管灰度数据中获得灰度图或彩图。
static unsafe Bitmap | GetAuxiliaryBitmap (byte[] data, Auxiliary2DType type, int width, int height)
从托管灰度数据中获得灰度图或彩图。
static float | GetExposureValueFromExposurePredictionData (byte Data)
将曝光预测图像灰度值转换为曝光强度值。
static unsafe Bitmap | GetExposurePredictionBitmap (HeadPackStructType FrameInfo, byte *Data)
从非托管数据帧中获取曝光预测位图。数据帧必须是曝光预测图象的采集结果。
static unsafe Bitmap | GetExposurePredictionBitmap (HeadPackStructType FrameInfo, byte[] Data)
从托管数据帧中获取曝光预测位图。数据帧必须是曝光预测图象的采集结果。
static Bitmap | Convert32bppTo8bpp (Bitmap source, int dataIndex=0)
将bitmap格式从32位转为8位.
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data)
从非托管浮点数3D点云格式数据中获得灰度位图。
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data)
从托管浮点数3D点云格式数据中获得灰度位图。
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data)
从非托管定点数3D点云格式数据中获得灰度位图。
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data)
从托管定点数3D点云格式数据中获得灰度位图。
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data)
从非托管定点数深度图格式数据中获得灰度位图。
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data)
从托管定点数深度图格式数据中获得灰度位图。
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, byte *Data)
从非托管灰度数据中获得灰度位图。
static unsafe Bitmap | GetGrayBitmap (HeadPackStructType FrameInfo, byte[] Data)
从托管灰度数据中获得灰度位图。
static Color | GetDepthColor (float Ratio)
从色谱中获得颜色。
static void | PrepareColorArr ()
根据若干个预先定义的色谱颜色，产生细化的色谱数组。在第一次生成深度色谱图时，该函数自动被调用。若调整了色谱颜色，该函数需要被手动调用。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, float Max, float Min)
从非托管浮点数3D数据帧中获取深度色谱图。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, float Max, float Min)
从托管浮点数3D数据帧中获取深度色谱图。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, float Max, float Min)
从非托管定点数3D数据帧中获取深度色谱图。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, float Max, float Min)
从托管定点数3D数据帧中获取深度色谱图。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, float Max, float Min)
从非托管定点数深度图数据帧中获取深度色谱图。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, float Max, float Min)
从托管定点数深度图数据帧中获取深度色谱图。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, ushort *Z, byte *Gray, float Max, float Min)
从非托管定点数Z数据帧和灰度数据帧中获取深度色谱图。
static unsafe Bitmap | GetColorDepthBitmap (HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray, float Max, float Min)
从托管定点数Z数据帧和灰度数据帧中获取深度色谱图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data)
从非托管浮点数3D数据帧中获取有效掩码位图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data)
从托管浮点数3D数据帧中获取有效掩码位图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data)
从非托管定点数3D数据帧中获取有效掩码位图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data)
从托管定点数3D数据帧中获取有效掩码位图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data)
从非托管定点数深度图数据帧中获取有效掩码位图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data)
从托管定点数深度图数据帧中获取有效掩码位图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, ushort *Z, byte *Gray)
从非托管定点数Z数据帧和灰度数据帧中获取有效掩码位图。
static unsafe Bitmap | GetValidMaskBitmap (HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray)
从托管定点数Z数据帧和灰度数据帧中获取有效掩码位图。
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data)
从非托管浮点数3D数据帧中获取HDR掩码位图。
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data)
从托管浮点数3D数据帧中获取HDR掩码位图。
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data)
从非托管定点数3D数据帧中获取HDR掩码位图。
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data)
从托管定点数3D数据帧中获取HDR掩码位图。
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data)
从非托管定点数深度图数据帧中获取HDR掩码位图。
static unsafe Bitmap | GetHDRMaskBitmap (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data)
从托管定点数深度图数据帧中获取HDR掩码位图。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取非托管Float3D格式数据的自动色谱反范围。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取托管Float3D格式数据的自动色谱反范围。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取非托管Fix3D格式数据的自动色谱反范围。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取托管Fix3D格式数据的自动色谱反范围。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取非托管FixZMap格式数据的自动色谱反范围。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取托管FixZMap格式数据的自动色谱反范围。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, ushort *Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取非托管FixZMapSimple格式数据的自动色谱反范围。
static unsafe ColorDepthRangeStruct | GetAutoColorDepthRange (HeadPackStructType FrameInfo, ushort[] Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f)
获取托管FixZMapSimple格式数据的自动色谱反范围。
static List< SoftwarePostProcessSetting > | LoadPostProcessFile (string FileName)
获取实时后处理窗口mppp文件的后处理设置。
static string | FilterLog (string logStr, bool filterDetailLog=true, bool filterOperationLog=false, bool filterSystemLog=false, bool filterInfoLog=false, bool filterNoticeLog=false, bool filterSuccessLog=false, bool filterFailureLog=false)
根据过滤条件筛选SizectorS返回的日志。
static unsafe void | OffsetGrayData (UnmanagedDataFrameUndefinedStruct dataFrame, int xOffset, int yOffset, byte paddingValue=0)
将输入的三维数据的灰度数据进行指定的偏移，并对空位进行填充。
static double | GetStandardDeviation (double[] Data)
获取标准差

静态 Public 属性

static Color[] | DepthColorStops
定义3D数据转换为深度图的色谱。
static Color | TooHighColor = Color.FromArgb(230, 230, 230)
定义3D数据转换的深度图中，值超过Max时所显示的颜色。
static Color | TooLowColor = Color.FromArgb(20, 20, 20)
定义3D数据转换的深度图中，值不足Min时所显示的颜色。
static Color[] | ColorArr = new Color[10001]
细化色谱数组，具有10001种不同的颜色。

成员函数说明

◆ CalculateCorrectDistortionParamFromData()

static unsafe bool MPSizectorS_DotNet.Utils.CalculateCorrectDistortionParamFromData | ( | UnmanagedDataFrameUndefinedStruct | Data,
 |  | out CorrectDistortionParamStructType | CorrectDistortionMatrix,
 |  | int | Interval = 16 )

读取实时后处理mppp文件的后处理设置。

参数
Data | 图像数据。
CorrectDistortionMatrix | 畸变矫正矩阵。
Interval | 像素间隔。
返回
操作是否成功。成功为true, 失败为false。

◆ CompensateData()

static unsafe void MPSizectorS_DotNet.Utils.CompensateData | ( | UnmanagedDataFrameUndefinedStruct | data,
 |  | UnmanagedDataFrameUndefinedStruct | compensationData )

data 与 compensationData 点对点相减， 用于校正data中的畸变，仅支持UnmanagedDataFrameUndefinedStruct。

参数
data | 原数据
compensationData | 补偿数据

Point-to-point subtraction of data and compensationData is used to correct distortion in data, only supports UnmanagedDataFrameUndefinedStruct.

参数
data | The data.
compensationData | The compensation data.

◆ Convert32bppTo8bpp()

static Bitmap MPSizectorS_DotNet.Utils.Convert32bppTo8bpp | ( | Bitmap | source,
 |  | int | dataIndex = 0 )
 static

将bitmap格式从32位转为8位.

参数
source | 原图.
dataIndex | 8位数据来自哪个通道.
返回

◆ ConvertGrayByteArrayToGrayBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertGrayByteArrayToGrayBitmap | ( | byte * | Gray,
 |  | uint | Width,
 |  | uint | Height,
 |  | byte | Index = 0 )
 static

将非托管的灰度数据转换为灰度位图。

参数
Gray | 非托管的灰度数据。
Width | 灰度图像像素宽度。
Height | 灰度图像像素高度。
Index | 灰度图像在数据帧中的Index，默认为0。
返回
转换后得到的位图。

◆ ConvertGrayByteArrayToGrayBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertGrayByteArrayToGrayBitmap | ( | byte[] | Gray,
 |  | uint | Width,
 |  | uint | Height,
 |  | byte | Index = 0 )
 static

将灰度指针转换为灰度Bitmap.

参数
Gray | [输入]:灰度数组。 [INPUT]:Gray intensity array.
Width | [输入]:图像宽度。 [INPUT]:Image Width.
Height | [输入]:图像高度。 [INPUT]:Image Height.
返回
转换后的Bitmap图像。 The target bitmap.

◆ ConvertRGBByteArrayToRGBBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertRGBByteArrayToRGBBitmap | ( | byte * | Red,
 |  | byte * | Green,
 |  | byte * | Blue,
 |  | uint | Width,
 |  | uint | Height )
 static

将3个频道(RGB)的颜色数组指针转换为彩色Bitmap.

参数
Red | [输入]:红色数组。 [INPUT]:Red channel array.
Green | [输入]:绿色数组。 [INPUT]:Green channel array.
Blue | [输入]:蓝色数组。 [INPUT]:Blue channel array.
Width | [输入]:图像宽度。 [INPUT]:Image Width.
Height | [输入]:图像高度。 [INPUT]:Image Height.
返回
转换后的Bitmap图像。 The result bitmap.

◆ ConvertRGBByteArrayToRGBBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.ConvertRGBByteArrayToRGBBitmap | ( | byte[] | Red,
 |  | byte[] | Green,
 |  | byte[] | Blue,
 |  | uint | Width,
 |  | uint | Height )
 static

将3个频道(RGB)的颜色数组指针转换为彩色Bitmap.

参数
Red | [输入]:红色数组。 [INPUT]:Red channel array.
Green | [输入]:绿色数组。 [INPUT]:Green channel array.
Blue | [输入]:蓝色数组。 [INPUT]:Blue channel array.
Width | [输入]:图像宽度。 [INPUT]:Image Width.
Height | [输入]:图像高度。 [INPUT]:Image Height.
返回
转换后的Bitmap图像。 The result bitmap.

◆ CopyMemory()

static void MPSizectorS_DotNet.Utils.CopyMemory | ( | IntPtr | dest,
 |  | IntPtr | src,
 |  | uint | count )

非托管内存拷贝，kernel32.dll中CopyMemory函数的映射。

参数
dest | 目标指针。
src | 源指针。
count | 拷贝字节长度。

◆ FilterLog()

static string MPSizectorS_DotNet.Utils.FilterLog | ( | string | logStr,
 |  | bool | filterDetailLog = true,
 |  | bool | filterOperationLog = false,
 |  | bool | filterSystemLog = false,
 |  | bool | filterInfoLog = false,
 |  | bool | filterNoticeLog = false,
 |  | bool | filterSuccessLog = false,
 |  | bool | filterFailureLog = false )
 static

根据过滤条件筛选SizectorS返回的日志。

参数
logStr | 日志。
filterDetailLog | 是否过滤Detail日志。
filterOperationLog | 是否过滤Operation日志。
filterSystemLog | 是否过滤System日志。
filterInfoLog | 是否过滤Info日志。
filterNoticeLog | 是否过滤Notice日志。
filterSuccessLog | 是否过滤Success日志。
filterFailureLog | 是否过滤Failure日志。
返回
如果日志被过滤，则返回null，否则返回解析后的日志。

◆ FreeUnmanagedData()

static unsafe void MPSizectorS_DotNet.Utils.FreeUnmanagedData ( UnmanagedDataFrameUndefinedStruct DataFrame )

释放非托管数据内存。

参数
DataFrame 非托管数据结构体。

◆ Get3DDataLen()

static unsafe uint MPSizectorS_DotNet.Utils.Get3DDataLen ( HeadPackDataInfoStructType DataInfo )

获取3D数据的长度(仅对非托管数据有效)。

参数
DataInfo 数据信息。
返回
3D数据的长度。

◆ GetAutoColorDepthRange() [1/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取非托管Fix3D格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAutoColorDepthRange() [2/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取托管Fix3D格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAutoColorDepthRange() [3/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取非托管FixZMap格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAutoColorDepthRange() [4/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取托管FixZMap格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAutoColorDepthRange() [5/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取非托管Float3D格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAutoColorDepthRange() [6/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取托管Float3D格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAutoColorDepthRange() [7/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取非托管FixZMapSimple格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAutoColorDepthRange() [8/8]

static unsafe ColorDepthRangeStruct MPSizectorS_DotNet.Utils.GetAutoColorDepthRange | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | int | Stride = 3,
 |  | float | DropRatio = 0::002f,
 |  | float | ReservedRatio = 0::05f )
 static

获取托管FixZMapSimple格式数据的自动色谱反范围。

参数
FrameInfo | 数据帧信息。
Data | 3D数据。
Stride | 相邻采样点的像素跨距。
DropRatio | 统计时丢弃的最大和最小点的数量占所有点的比例。
ReservedRatio | 色谱边缘预留比例。
返回
计算得到的自动色谱范围结果。

◆ GetAuxiliaryBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetAuxiliaryBitmap | ( | byte * | data,
 |  | Auxiliary2DType | type,
 |  | int | width,
 |  | int | height )
 static

从非托管灰度数据中获得灰度图或彩图。

参数
data | 数据。
type | 图像类型。
width | 图像宽。
width | 图像高。
返回
转换后得到的位图。

◆ GetAuxiliaryBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetAuxiliaryBitmap | ( | byte[] | data,
 |  | Auxiliary2DType | type,
 |  | int | width,
 |  | int | height )
 static

从托管灰度数据中获得灰度图或彩图。

参数
data | 数据。
type | 图像类型。
width | 图像宽。
width | 图像高。
返回
转换后得到的位图。

◆ GetColorDepthBitmap() [1/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data,
 |  | float | Max,
 |  | float | Min )
 static

从非托管定点数3D数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetColorDepthBitmap() [2/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data,
 |  | float | Max,
 |  | float | Min )
 static

从托管定点数3D数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetColorDepthBitmap() [3/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data,
 |  | float | Max,
 |  | float | Min )
 static

从非托管定点数深度图数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetColorDepthBitmap() [4/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data,
 |  | float | Max,
 |  | float | Min )
 static

从托管定点数深度图数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetColorDepthBitmap() [5/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data,
 |  | float | Max,
 |  | float | Min )
 static

从非托管浮点数3D数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetColorDepthBitmap() [6/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data,
 |  | float | Max,
 |  | float | Min )
 static

从托管浮点数3D数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetColorDepthBitmap() [7/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | byte * | Gray,
 |  | float | Max,
 |  | float | Min )
 static

从非托管定点数Z数据帧和灰度数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Z | Z数据。
Gray | Gray数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetColorDepthBitmap() [8/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetColorDepthBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | byte[] | Gray,
 |  | float | Max,
 |  | float | Min )
 static

从托管定点数Z数据帧和灰度数据帧中获取深度色谱图。

参数
FrameInfo | 数据帧信息。
Z | Z数据。
Gray | Gray数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的深度色谱位图。

◆ GetDataLen()

static unsafe uint MPSizectorS_DotNet.Utils.GetDataLen ( HeadPackStructType FrameInfo )

获取数据的长度(仅对非托管数据有效)。

参数
FrameInfo 数据帧信息。
返回
数据的长度。

◆ GetDepthColor()

static Color MPSizectorS_DotNet.Utils.GetDepthColor ( float Ratio )
static

从色谱中获得颜色。

参数
Ratio [输入]:色谱的偏置值。[0,1]为色谱中的有效值。 [INPUT]:Offset value in the color spectrum.Ratio lies in [0,1].
返回
获得的颜色。 Acquired color.

◆ GetExposurePredictionBitmap() [1/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetExposurePredictionBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte * | Data )
 static

从非托管数据帧中获取曝光预测位图。数据帧必须是曝光预测图象的采集结果。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetExposurePredictionBitmap() [2/2]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetExposurePredictionBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte[] | Data )
 static

从托管数据帧中获取曝光预测位图。数据帧必须是曝光预测图象的采集结果。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetExposureValueFromExposurePredictionData()

static float MPSizectorS_DotNet.Utils.GetExposureValueFromExposurePredictionData ( byte Data )
static

将曝光预测图像灰度值转换为曝光强度值。

参数
Data 曝光预测图像的单个像素灰度值。
返回
转换后得到的曝光强度值。

◆ GetGrayBitmap() [1/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte * | Data )
 static

从非托管灰度数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetGrayBitmap() [2/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | byte[] | Data )
 static

从托管灰度数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetGrayBitmap() [3/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data )
 static

从非托管定点数3D点云格式数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetGrayBitmap() [4/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data )
 static

从托管定点数3D点云格式数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetGrayBitmap() [5/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data )
 static

从非托管定点数深度图格式数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetGrayBitmap() [6/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data )
 static

从托管定点数深度图格式数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetGrayBitmap() [7/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data )
 static

从非托管浮点数3D点云格式数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetGrayBitmap() [8/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetGrayBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data )
 static

从托管浮点数3D点云格式数据中获得灰度位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的位图。

◆ GetHDRMaskBitmap() [1/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data )
 static

从非托管定点数3D数据帧中获取HDR掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的HDR掩码位图。

◆ GetHDRMaskBitmap() [2/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data )
 static

从托管定点数3D数据帧中获取HDR掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的HDR掩码位图。

◆ GetHDRMaskBitmap() [3/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data )
 static

从非托管定点数深度图数据帧中获取HDR掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的HDR掩码位图。

◆ GetHDRMaskBitmap() [4/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data )
 static

从托管定点数深度图数据帧中获取HDR掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的HDR掩码位图。

◆ GetHDRMaskBitmap() [5/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data )
 static

从非托管浮点数3D数据帧中获取HDR掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的HDR掩码位图。

◆ GetHDRMaskBitmap() [6/6]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetHDRMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data )
 static

从托管浮点数3D数据帧中获取HDR掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。
返回
转换后得到的HDR掩码位图。

◆ GetStandardDeviation()

static double MPSizectorS_DotNet.Utils.GetStandardDeviation ( double[] Data )
static

获取标准差

参数
Data 数据
返回
标准差

Gets the standard deviation.

参数
Data The data.
返回
Standard deviation

◆ GetValidMaskBitmap() [1/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct * | Data )
 static

从非托管定点数3D数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的有效掩码位图。

◆ GetValidMaskBitmap() [2/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFix3DStruct[] | Data )
 static

从托管定点数3D数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的有效掩码位图。

◆ GetValidMaskBitmap() [3/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct * | Data )
 static

从非托管定点数深度图数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的有效掩码位图。

◆ GetValidMaskBitmap() [4/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFixZMapStruct[] | Data )
 static

从托管定点数深度图数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的有效掩码位图。

◆ GetValidMaskBitmap() [5/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct * | Data )
 static

从非托管浮点数3D数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的有效掩码位图。

◆ GetValidMaskBitmap() [6/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | DataPointFloat3DStruct[] | Data )
 static

从托管浮点数3D数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Data | 数据。
返回
转换后得到的有效掩码位图。

◆ GetValidMaskBitmap() [7/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort * | Z,
 |  | byte * | Gray )
 static

从非托管定点数Z数据帧和灰度数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Z | Z数据。
Gray | 灰度数据。
返回
转换后得到的有效掩码位图。

◆ GetValidMaskBitmap() [8/8]

static unsafe Bitmap MPSizectorS_DotNet.Utils.GetValidMaskBitmap | ( | HeadPackStructType | FrameInfo,
 |  | ushort[] | Z,
 |  | byte[] | Gray )
 static

从托管定点数Z数据帧和灰度数据帧中获取有效掩码位图。

参数
FrameInfo | 数据帧信息。
Z | Z数据。
Gray | 灰度数据。
返回
转换后得到的有效掩码位图。

◆ LoadPostProcessFile()

static List< SoftwarePostProcessSetting > MPSizectorS_DotNet.Utils.LoadPostProcessFile ( string FileName )
static

获取实时后处理窗口mppp文件的后处理设置。

参数
FileName 文件名。
返回
得到的后处理设置。

◆ LoadUnmanagedDataFrameUndefined()

static unsafe bool MPSizectorS_DotNet.Utils.LoadUnmanagedDataFrameUndefined | ( | out UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName,
 |  | out float | ColorDepthMin,
 |  | out float | ColorDepthMax )
 static

从文件中读取Undefined格式数据。

参数
DataFrame | 通过参考返回，读取得到的数据。
FileName | 目标文件名。
ColorDepthMin | 深度色谱范围最小值。
ColorDepthMax | 深度色谱范围最大值。
返回
操作是否成功。成功为true, 失败为false。

◆ OffsetGrayData()

static unsafe void MPSizectorS_DotNet.Utils.OffsetGrayData | ( | UnmanagedDataFrameUndefinedStruct | dataFrame,
 |  | int | xOffset,
 |  | int | yOffset,
 |  | byte | paddingValue = 0 )
 static

将输入的三维数据的灰度数据进行指定的偏移，并对空位进行填充。

参数
dataFrame | 三维帧
xOffset | X偏移量
yOffset | Y偏移量
paddingValue | 空位的填充值

◆ PrepareColorArr()

static void MPSizectorS_DotNet.Utils.PrepareColorArr ( )
static

根据若干个预先定义的色谱颜色，产生细化的色谱数组。在第一次生成深度色谱图时，该函数自动被调用。若调整了色谱颜色，该函数需要被手动调用。

参数
Max | 深度色谱范围的最大值。
Min | 深度色谱范围的最小值。

◆ SaveDataFrame_FileStream()

static unsafe bool MPSizectorS_DotNet.Utils.SaveDataFrame_FileStream | ( | FileStream | fs,
 |  | HeadPackStructType | FrameInfo,
 |  | Byte * | Data,
 |  | out int | Size,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )
 static

通过文件流保存数据。

参数
fs | 文件流。
FrameInfo | 数据帧信息。
Data | 数据。
Size | 总长度。
ColorDepthMin | 最小颜色深度。
ColorDepthMax | 最大颜色深度。
返回
保存是否成功。

◆ SaveDataFrame_ManagedFixZMapSimpleDataFrame()

static unsafe bool MPSizectorS_DotNet.Utils.SaveDataFrame_ManagedFixZMapSimpleDataFrame | ( | FileStream | fs,
 |  | ManagedDataFrameFixZMapSimpleStruct | DataFrame,
 |  | out int | Size,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )
 static

通过文件流保存数据。（针对托管带RGB的简化深度图，3D数据与2D数据不连续）

参数
fs | 文件流。
DataFrame | 数据帧。
Size | 总长度。
ColorDepthMin | 最小颜色深度。
ColorDepthMax | 最大颜色深度。
返回
保存是否成功。

◆ SaveUnmanagedDataFrameUndefined()

static bool MPSizectorS_DotNet.Utils.SaveUnmanagedDataFrameUndefined | ( | UnmanagedDataFrameUndefinedStruct | DataFrame,
 |  | string | FileName,
 |  | float | ColorDepthMin = 0,
 |  | float | ColorDepthMax = 0 )
 static

保存Undefined格式数据到文件。

参数
DataFrame | 待保存的数据。
FileName | 目标文件名。
ColorDepthMin | 深度色谱范围最小值。
ColorDepthMax | 深度色谱范围最大值。
返回
操作是否成功。成功为true, 失败为false。

◆ TransformROIPixelToROISetting()

static unsafe void MPSizectorS_DotNet.Utils.TransformROIPixelToROISetting | ( | DeviceInfoStructType | DevInfo,
 |  | uint | IXStartPixel,
 |  | uint | IYStartPixel,
 |  | uint | IWidthPixel,
 |  | uint | IHeightPixel,
 |  | out byte | OROIX0Ratio,
 |  | out byte | OROIY0Ratio,
 |  | out byte | OROIWidthRatio,
 |  | out byte | OROIHeightRatio,
 |  | out uint | OXStartPixel,
 |  | out uint | OYStartPixel,
 |  | out uint | OWidthPixel,
 |  | out uint | OHeightPixel,
 |  | bool | IsBinningMode = false )

将像素坐标的ROI设置转换为相机硬件ROI可接受的参数范围为0~255的数值。

参数
devInfo | 设备信息
iXStartPixel | 期望ROI的X起点，单位像素
iYStartPixel | 期望ROI的Y起点，单位像素
iWidthPixel | 期望ROI的宽度，单位像素
iHeightPixel | 期望ROI的高度，单位像素
oROIX0Ratio | 实际硬件ROI可接受的X起点，范围0~255的数值
oROIY0Ratio | 实际硬件ROI可接受的Y起点，范围0~255的数值
oROIWidthRatio | 实际硬件ROI可接受的宽度，范围0~255的数值
oROIHeightRatio | 实际硬件ROI可接受的高度，范围0~255的数值
oXStartPixel | 实际硬件ROI可接受的X起点，单位像素
oYStartPixel | 实际硬件ROI可接受的Y起点，单位像素
oWidthPixel | 实际硬件ROI可接受的宽度，单位像素
oHeightPixel | 实际硬件ROI可接受的高度，单位像素
isBinningMode | 是否为binning模式

◆ TransformROISettingToROIPixel()

static unsafe void MPSizectorS_DotNet.Utils.TransformROISettingToROIPixel | ( | DeviceInfoStructType | DevInfo,
 |  | byte | VSensorX0Ratio,
 |  | byte | VSensorY0Ratio,
 |  | byte | VSensorWRatio,
 |  | byte | VSensorHRatio,
 |  | out uint | OSensorX0,
 |  | out uint | OSensorY0,
 |  | out uint | OSensorXResol,
 |  | out uint | OSensorYResol,
 |  | bool | IsBinningMode = false )

将相机硬件ROI0~255的数值转换为像素坐标的ROI。

参数
devInfo | 设备信息
vSensorX0Ratio | 硬件ROI的X起点，范围0~255的数值
vSensorY0Ratio | 硬件ROI的Y起点，范围0~255的数值
vSensorWRatio | 硬件ROI的宽度，范围0~255的数值
vSensorHRatio | 硬件ROI的高度，范围0~255的数值
vSensorX0 | 像素ROI的X起点，单位像素
vSensorY0 | 像素ROI的Y起点，单位像素
vSensorXResol | 像素ROI的宽度，单位像素
vSensorYResol | 像素ROI的高度，单位像素
isBinningMode | 是否为binning模式

类成员变量说明

◆ DepthColorStops

Color [] MPSizectorS_DotNet.Utils.DepthColorStops
static
初始值:
= new Color[]
{
Color.FromArgb(0xFF, 0xA0, 0x00, 0xA0),
Color.FromArgb(0xFF, 0x00, 0x00, 0xFF),
Color.FromArgb(0xFF, 0x00, 0x90, 0x90),
Color.FromArgb(0xFF, 0x00, 0xC0, 0x00),
Color.FromArgb(0xFF, 0xB0, 0xB0, 0x00),
Color.FromArgb(0xFF, 0xFF, 0x00, 0x00),
}

定义3D数据转换为深度图的色谱。


MPSizector .NET 编程文档: 成员列表

  • Utils
MPSizectorS_DotNet.Utils 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.Utils,包括所有继承而来的类成员

CalculateCorrectDistortionParamFromData(UnmanagedDataFrameUndefinedStruct Data, out CorrectDistortionParamStructType CorrectDistortionMatrix, int Interval=16) | MPSizectorS_DotNet.Utils |
ColorArr | MPSizectorS_DotNet.Utils | static
CompensateData(UnmanagedDataFrameUndefinedStruct data, UnmanagedDataFrameUndefinedStruct compensationData) | MPSizectorS_DotNet.Utils |
Convert32bppTo8bpp(Bitmap source, int dataIndex=0) | MPSizectorS_DotNet.Utils | static
ConvertGrayByteArrayToGrayBitmap(byte[] Gray, uint Width, uint Height, byte Index=0) | MPSizectorS_DotNet.Utils | static
ConvertGrayByteArrayToGrayBitmap(byte *Gray, uint Width, uint Height, byte Index=0) | MPSizectorS_DotNet.Utils | static
ConvertRGBByteArrayToRGBBitmap(byte[] Red, byte[] Green, byte[] Blue, uint Width, uint Height) | MPSizectorS_DotNet.Utils | static
ConvertRGBByteArrayToRGBBitmap(byte *Red, byte *Green, byte *Blue, uint Width, uint Height) | MPSizectorS_DotNet.Utils | static
CopyMemory(IntPtr dest, IntPtr src, uint count) | MPSizectorS_DotNet.Utils |
DepthColorStops | MPSizectorS_DotNet.Utils | static
FilterLog(string logStr, bool filterDetailLog=true, bool filterOperationLog=false, bool filterSystemLog=false, bool filterInfoLog=false, bool filterNoticeLog=false, bool filterSuccessLog=false, bool filterFailureLog=false) | MPSizectorS_DotNet.Utils | static
FreeUnmanagedData(UnmanagedDataFrameUndefinedStruct DataFrame) | MPSizectorS_DotNet.Utils |
Get3DDataLen(HeadPackDataInfoStructType DataInfo) | MPSizectorS_DotNet.Utils |
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, ushort *Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAutoColorDepthRange(HeadPackStructType FrameInfo, ushort[] Z, int Stride=3, float DropRatio=0.002f, float ReservedRatio=0.05f) | MPSizectorS_DotNet.Utils | static
GetAuxiliaryBitmap(byte *data, Auxiliary2DType type, int width, int height) | MPSizectorS_DotNet.Utils | static
GetAuxiliaryBitmap(byte[] data, Auxiliary2DType type, int width, int height) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, ushort *Z, byte *Gray, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetColorDepthBitmap(HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray, float Max, float Min) | MPSizectorS_DotNet.Utils | static
GetDataLen(HeadPackStructType FrameInfo) | MPSizectorS_DotNet.Utils |
GetDepthColor(float Ratio) | MPSizectorS_DotNet.Utils | static
GetExposurePredictionBitmap(HeadPackStructType FrameInfo, byte *Data) | MPSizectorS_DotNet.Utils | static
GetExposurePredictionBitmap(HeadPackStructType FrameInfo, byte[] Data) | MPSizectorS_DotNet.Utils | static
GetExposureValueFromExposurePredictionData(byte Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, byte *Data) | MPSizectorS_DotNet.Utils | static
GetGrayBitmap(HeadPackStructType FrameInfo, byte[] Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data) | MPSizectorS_DotNet.Utils | static
GetHDRMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetStandardDeviation(double[] Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFloat3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct *Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFix3DStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct *Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, DataPointFixZMapStruct[] Data) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, ushort *Z, byte *Gray) | MPSizectorS_DotNet.Utils | static
GetValidMaskBitmap(HeadPackStructType FrameInfo, ushort[] Z, byte[] Gray) | MPSizectorS_DotNet.Utils | static
LoadPostProcessFile(string FileName) | MPSizectorS_DotNet.Utils | static
LoadUnmanagedDataFrameUndefined(out UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, out float ColorDepthMin, out float ColorDepthMax) | MPSizectorS_DotNet.Utils | static
OffsetGrayData(UnmanagedDataFrameUndefinedStruct dataFrame, int xOffset, int yOffset, byte paddingValue=0) | MPSizectorS_DotNet.Utils | static
PrepareColorArr() | MPSizectorS_DotNet.Utils | static
SaveDataFrame_FileStream(FileStream fs, HeadPackStructType FrameInfo, Byte *Data, out int Size, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.Utils | static
SaveDataFrame_ManagedFixZMapSimpleDataFrame(FileStream fs, ManagedDataFrameFixZMapSimpleStruct DataFrame, out int Size, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.Utils | static
SaveUnmanagedDataFrameUndefined(UnmanagedDataFrameUndefinedStruct DataFrame, string FileName, float ColorDepthMin=0, float ColorDepthMax=0) | MPSizectorS_DotNet.Utils | static
TooHighColor | MPSizectorS_DotNet.Utils | static
TooLowColor | MPSizectorS_DotNet.Utils | static
TransformROIPixelToROISetting(DeviceInfoStructType DevInfo, uint IXStartPixel, uint IYStartPixel, uint IWidthPixel, uint IHeightPixel, out byte OROIX0Ratio, out byte OROIY0Ratio, out byte OROIWidthRatio, out byte OROIHeightRatio, out uint OXStartPixel, out uint OYStartPixel, out uint OWidthPixel, out uint OHeightPixel, bool IsBinningMode=false) | MPSizectorS_DotNet.Utils |
TransformROISettingToROIPixel(DeviceInfoStructType DevInfo, byte VSensorX0Ratio, byte VSensorY0Ratio, byte VSensorWRatio, byte VSensorHRatio, out uint OSensorX0, out uint OSensorY0, out uint OSensorXResol, out uint OSensorYResol, bool IsBinningMode=false) | MPSizectorS_DotNet.Utils |


MPSizector .NET 编程文档: 类索引

  • 类成员
类索引
A | B | C | D | E | F | G | H | I | L | M | O | P | R | S | T | U | V
A
AutoHDRResultStructType (MPSizectorS_DotNet)
B
BasicSettingsStructType (MPSizectorS_DotNet)
C
CalibParamStructType (MPSizectorS_DotNet)
ColorDepthRangeStruct (MPSizectorS_DotNet)
CompensationStructType (MPSizectorS_DotNet)
CorrectDistortionParamStructType (MPSizectorS_DotNet)
D
DataPointFix3DStruct (MPSizectorS_DotNet)
DataPointFixZMapStruct (MPSizectorS_DotNet)
DataPointFloat3DStruct (MPSizectorS_DotNet)
DebugInfoStruct (MPSizectorS_DotNet)
DeviceInfoStructType (MPSizectorS_DotNet)
E
ExpertSettingsStructType (MPSizectorS_DotNet)
ExposureBasicSettingStructType (MPSizectorS_DotNet)
ExposureSettingsStructType (MPSizectorS_DotNet)
ExpROIStructType (MPSizectorS_DotNet)
Extension (MPSizectorS_DotNet)
ExternalExposureSettingsStructType (MPSizectorS_DotNet)
F
FlipEnableStructType (MPSizectorS_DotNet)
G
GeneralSettingsStructType (MPSizectorS_DotNet)
H
HardwarePreprocessModeListStructType (MPSizectorS_DotNet)
HardwareTimeStampsStructType (MPSizectorS_DotNet)
HeadDebugInfoStructType (MPSizectorS_DotNet)
HeadPackDataInfoStructType (MPSizectorS_DotNet)
HeadPackStructType (MPSizectorS_DotNet)
HWTriggerSettingStructType (MPSizectorS_DotNet)
I
IOSettingsStructType (MPSizectorS_DotNet)
L
LinearTemperatureDriftCompensationStructType (MPSizectorS_DotNet)
M
ManagedDataFrame2DStruct (MPSizectorS_DotNet)
ManagedDataFrameFix3DStruct (MPSizectorS_DotNet)
ManagedDataFrameFixZMapSimpleStruct (MPSizectorS_DotNet)
ManagedDataFrameFixZMapStruct (MPSizectorS_DotNet)
ManagedDataFrameFloat3DStruct (MPSizectorS_DotNet)
MonitorPositionStructType (MPSizectorS_DotNet)
MonitorZStructType (MPSizectorS_DotNet)
MPDisplayer2D (MPSizectorS_DotNet)
MPDisplayer3D (MPSizectorS_DotNet)
MPSizectorS (MPSizectorS_DotNet)
MPSizectorS_AutoHDRAdvanceSettingsStructType (MPSizectorS_DotNet)
MPSizectorS_ExpICoefSettingsStructType (MPSizectorS_DotNet)
MultiHeadSettingsStructType (MPSizectorS_DotNet)
O
OutputPinSettingStructType (MPSizectorS_DotNet)
P
PartialFactorySettingsStructType (MPSizectorS_DotNet)
PointScaleSettingStructType (MPSizectorS_DotNet)
PostProcessSettingsStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType (MPSizectorS_DotNet)
SoftwarePreprocessListRegisters.PreprocessStructType (MPSizectorS_DotNet)
Process (MPSizectorS_DotNet)
R
RangeCheckSettingStructType (MPSizectorS_DotNet)
RangeImageManaged (MPSizectorS_DotNet)
RangeImageUnmanaged (MPSizectorS_DotNet)
ReconstructionSettingsStructType (MPSizectorS_DotNet)
Process.RotatedRectangle (MPSizectorS_DotNet)
RTMatrixStructType (MPSizectorS_DotNet)
S
SettingsStructType (MPSizectorS_DotNet)
SoftwarePostProcessSetting (MPSizectorS_DotNet)
SoftwarePreprocessListRegisters (MPSizectorS_DotNet)
SoftwarePreprocessPresetParamListStructType (MPSizectorS_DotNet)
StatesStructType (MPSizectorS_DotNet)
SuppressExpParamsEnableStructType (MPSizectorS_DotNet)
T
TemperatureFeedbackStructType (MPSizectorS_DotNet)
TSNStructType (MPSizectorS_DotNet)
U
UnmanagedDataFrame2DStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFix3DStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFixZMapSimpleStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFixZMapStruct (MPSizectorS_DotNet)
UnmanagedDataFrameFloat3DStruct (MPSizectorS_DotNet)
UnmanagedDataFrameUndefinedStruct (MPSizectorS_DotNet)
Utils (MPSizectorS_DotNet)
V
MPDisplayer3D.ViewMatrixStruct (MPSizectorS_DotNet)


MPSizector .NET 编程文档: 类继承关系

  • 类成员
类继承关系
此继承关系列表按字典顺序粗略的排序:
[详情级别 12]
C MPSizectorS_DotNet.AutoHDRResultStructType | 自动HDR的计算结果反馈结构体。该结构体的信息由设备产生，并通过head pack发回至用户端。
C MPSizectorS_DotNet.BasicSettingsStructType | 基础设置结构体。
C MPSizectorS_DotNet.CalibParamStructType | 标定参数结构体。
C MPSizectorS_DotNet.ColorDepthRangeStruct | 深度色谱范围设置结构体。
C MPSizectorS_DotNet.CompensationStructType | 补偿结构体。
C MPSizectorS_DotNet.CorrectDistortionParamStructType
C MPSizectorS_DotNet.DataPointFix3DStruct | 定点数格式3D数据点结构体。
C MPSizectorS_DotNet.DataPointFixZMapStruct | 定点数深度图格式3D数据点结构体。
C MPSizectorS_DotNet.DataPointFloat3DStruct | 浮点数格式3D数据点结构体。
C MPSizectorS_DotNet.DebugInfoStruct | 调试寄存器数组信息结构体。厂商调试用途。
C MPSizectorS_DotNet.DeviceInfoStructType | 用于存储设备信息的结构体。
C MPSizectorS_DotNet.ExpertSettingsStructType | 专业设置的结构体。
C MPSizectorS_DotNet.ExposureBasicSettingStructType | 基础曝光设置。
C MPSizectorS_DotNet.ExposureSettingsStructType | 曝光设置结构体。
C MPSizectorS_DotNet.ExpROIStructType | 曝光区域的结构体。
C MPSizectorS_DotNet.Extension
C MPSizectorS_DotNet.ExternalExposureSettingsStructType | 外部光源的曝光设置结构体。
C MPSizectorS_DotNet.FlipEnableStructType | 翻转参数。
C MPSizectorS_DotNet.GeneralSettingsStructType | 通用设置结构体。
C MPSizectorS_DotNet.HardwarePreprocessModeListStructType | 硬件预处理模式列表结构体。
C MPSizectorS_DotNet.HardwareTimeStampsStructType | 硬件时间戳的结构体。
C MPSizectorS_DotNet.HeadDebugInfoStructType | 调试信息结构体，由设备产生并通过head pack发送至PC。该结构体是StatesStructType的简略版本。
C MPSizectorS_DotNet.HeadPackDataInfoStructType | 数据信息结构体，在head pack中使用。
C MPSizectorS_DotNet.HeadPackStructType | Head pack结构体。它被频繁且规律地发送回PC，并且被包含在每一个数据帧之中。
C MPSizectorS_DotNet.HWTriggerSettingStructType | 硬件触发设置结构体。
C MPSizectorS_DotNet.IOSettingsStructType | IO设置结构个体
C MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType | 线性温漂补偿参数结构体。
C MPSizectorS_DotNet.ManagedDataFrame2DStruct | 托管的2D数据帧结构体。
C MPSizectorS_DotNet.ManagedDataFrameFix3DStruct | 托管定点数格式的3D数据帧结构体。
C MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct | 托管的简化的定点数深度图的3D数据帧结构体。
C MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct | 托管定点数深度图的3D数据帧结构体。
C MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct | 托管浮点数格式的3D数据帧结构体。
C MPSizectorS_DotNet.MonitorPositionStructType | 监视位置。
C MPSizectorS_DotNet.MonitorZStructType | 监视高度。
C MPSizectorS_DotNet.MPSizectorS
C MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType | 自动HDR高级设置结构体。
C MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType | 曝光系数设置结构体。
C MPSizectorS_DotNet.MultiHeadSettingsStructType | 多头重构设置结构体。
C MPSizectorS_DotNet.OutputPinSettingStructType | 输出引脚设置结构体（单个PIN脚的设置）。
C MPSizectorS_DotNet.PartialFactorySettingsStructType | 部分工厂设置结构体。
C MPSizectorS_DotNet.PointScaleSettingStructType 定点数映射设置结构体。用于在浮点数和定点数点云之间转换。
例：浮点数和定点数格式的X值关系如下：XFloat = XIncrement * XFixedPoint + X0Pos
C MPSizectorS_DotNet.PostProcessSettingsStructType | 后处理设置结构体。
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetRemoveBurrsStructType
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetStructType
C MPSizectorS_DotNet.SoftwarePreprocessListRegisters.PreprocessStructType
C MPSizectorS_DotNet.Process
C MPSizectorS_DotNet.RangeCheckSettingStructType | 由用户指定的范围检查设置结构体。包含了X, Y, Z轴的有效范围信息。
C MPSizectorS_DotNet.RangeImageManaged 托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C MPSizectorS_DotNet.RangeImageUnmanaged 非托管深度图像结构体, 数据以一维数组存储。任意像素点(i, j)对应三维坐标为：
X = XOffset + i * PixelInterval
Y = YOffset + j * PixelInterval
Z = ZOffset + RangeData[i + j * Width] * ZInterval = ZRawData[i + j * Width]
C MPSizectorS_DotNet.ReconstructionSettingsStructType | 重构设置结构体。
C MPSizectorS_DotNet.Process.RotatedRectangle
C MPSizectorS_DotNet.RTMatrixStructType | 旋转平移矩阵结构体。
C MPSizectorS_DotNet.SettingsStructType | 所有设置的结构体。
C MPSizectorS_DotNet.SoftwarePostProcessSetting | 软件后处理结构体。
C MPSizectorS_DotNet.SoftwarePreprocessListRegisters | 软件预处理列表结构体。
C MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType | 软件预处理预设参数列表结构体。
C MPSizectorS_DotNet.StatesStructType | 所有设备状态信息的结构体
C MPSizectorS_DotNet.SuppressExpParamsEnableStructType | 曝光抑制参数。
C MPSizectorS_DotNet.TemperatureFeedbackStructType | 温度反馈信息结构体。
C MPSizectorS_DotNet.TSNStructType | TSN信息结构体。标示了一个有效的触发信号的信号来源，及其序列号。
C MPSizectorS_DotNet.UnmanagedDataFrame2DStruct | 非托管的2D数据帧结构体。
C MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct | 非托管定点数格式的3D数据帧结构体。
C MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct | 非托管的简化的定点数深度图的3D数据帧结构体。
C MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct | 非托管定点数深度图的3D数据帧结构体。
C MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct | 非托管浮点数格式的3D数据帧结构体。
C MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct | 非托管的未定义格式数据帧结构体。该类型为数据回调提供的唯一数据类型，它是一种中间数据格式，用于避免采用多个回调函数传递不同格式的数据。
▼C UserControl
C MPSizectorS_DotNet.MPDisplayer2D | 2D图像显示控件。
C MPSizectorS_DotNet.MPDisplayer3D | 3D模型显示控件
C MPSizectorS_DotNet.Utils
C MPSizectorS_DotNet.MPDisplayer3D.ViewMatrixStruct | 视角及物体姿态矩阵结构。


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- a -

  • AntiLampFlickerMode : MPSizectorS_DotNet.ExpertSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • AntiNoiseLevel : MPSizectorS_DotNet.MPSizectorS
  • AutoHDR_ExposureIntensity3D_1st : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_2nd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_3rd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDRAdvanceSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • AutoHDRAdvanceSettingsEnable : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • AutoHDRPriority : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoHDRResult : MPSizectorS_DotNet.HeadPackStructType
  • AutoPHDRQuality : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoSetExpertModeParam() : MPSizectorS_DotNet.MPSizectorS
  • AutoSleepDelayMS : MPSizectorS_DotNet.GeneralSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • AutoSleepEnableState : MPSizectorS_DotNet.GeneralSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • AutoTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • AuxiliaryRGB : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • AuxiliaryWhite : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- b -

  • BasicSetings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • BasicSettings : MPSizectorS_DotNet.MPSizectorS
  • Binning : MPSizectorS_DotNet.MPDisplayer2D
  • BinningPossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • BinningState : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • Bitmap : MPSizectorS_DotNet.MPDisplayer2D
  • BurrFilter_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • BurrFilterThreshold0 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • BurrFilterThreshold1 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- c -

  • CalculateCorrectDistortionParamFromData() : MPSizectorS_DotNet.Utils
  • CalibDate : MPSizectorS_DotNet.CalibParamStructType
  • CalibParam : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS
  • CC1 : MPSizectorS_DotNet.CalibParamStructType
  • CC2 : MPSizectorS_DotNet.CalibParamStructType
  • CF1 : MPSizectorS_DotNet.CalibParamStructType
  • CF2 : MPSizectorS_DotNet.CalibParamStructType
  • CKappa : MPSizectorS_DotNet.CalibParamStructType
  • Close() : MPSizectorS_DotNet.MPSizectorS
  • Closing_Cpu() : MPSizectorS_DotNet.Process
  • ColorArr : MPSizectorS_DotNet.Utils
  • ColorDepthImageMax : MPSizectorS_DotNet.MPDisplayer3D
  • ColorDepthImageMin : MPSizectorS_DotNet.MPDisplayer3D
  • CompensateData() : MPSizectorS_DotNet.Utils
  • CompensationParams : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ConnectionTimeMS : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Convert32bppTo8bpp() : MPSizectorS_DotNet.Utils
  • ConvertBayerToRGB() : MPSizectorS_DotNet.Process
  • ConvertFrame2DBayerToGray() : MPSizectorS_DotNet.Process
  • ConvertGrayByteArrayToGrayBitmap() : MPSizectorS_DotNet.Utils
  • ConvertRGBByteArrayToRGBBitmap() : MPSizectorS_DotNet.Utils
  • ConvertToRangeImage() : MPSizectorS_DotNet.Process
  • ConvertZMapFrameToFloat3DFrame() : MPSizectorS_DotNet.Process
  • CopyMemory() : MPSizectorS_DotNet.Utils
  • CopyToManagedFix3D() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
  • CopyToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
  • CopyToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • CopyToManagedFloat3D() : MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • CoreHardReset() : MPSizectorS_DotNet.MPSizectorS
  • CoreSoftReset() : MPSizectorS_DotNet.MPSizectorS
  • CorrectDistortion() : MPSizectorS_DotNet.MPSizectorS
  • CorrectDistortionEnable : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • CorrectionMode : MPSizectorS_DotNet.MPSizectorS
  • CR00 : MPSizectorS_DotNet.CalibParamStructType
  • CR01 : MPSizectorS_DotNet.CalibParamStructType
  • CR02 : MPSizectorS_DotNet.CalibParamStructType
  • CR10 : MPSizectorS_DotNet.CalibParamStructType
  • CR11 : MPSizectorS_DotNet.CalibParamStructType
  • CR12 : MPSizectorS_DotNet.CalibParamStructType
  • CR20 : MPSizectorS_DotNet.CalibParamStructType
  • CR21 : MPSizectorS_DotNet.CalibParamStructType
  • CR22 : MPSizectorS_DotNet.CalibParamStructType
  • CSx : MPSizectorS_DotNet.CalibParamStructType
  • CSy : MPSizectorS_DotNet.CalibParamStructType
  • CT0 : MPSizectorS_DotNet.CalibParamStructType
  • CT1 : MPSizectorS_DotNet.CalibParamStructType
  • CT2 : MPSizectorS_DotNet.CalibParamStructType
  • CurPixelCord : MPSizectorS_DotNet.MPDisplayer2D
  • CurrentDeviceInfo : MPSizectorS_DotNet.MPSizectorS
  • CurrentTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • CurrentTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- d -

  • Data : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DataCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • DataFormat : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataInfo : MPSizectorS_DotNet.HeadPackStructType
  • DataNumber : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataOutMode : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • DataTag : MPSizectorS_DotNet.HeadPackDataInfoStructType, MPSizectorS_DotNet.MPSizectorS
  • DebugInfo : MPSizectorS_DotNet.HeadPackStructType
  • DebugRegisters : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • DefaultSettings : MPSizectorS_DotNet.MPSizectorS
  • DelayIn100us : MPSizectorS_DotNet.HWTriggerSettingStructType
  • DepthColorStops : MPSizectorS_DotNet.Utils
  • DestroyCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DeviceInfo : MPSizectorS_DotNet.HeadPackStructType
  • DeviceName : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceSerialNumber : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceState : MPSizectorS_DotNet.MPSizectorS
  • DeviceStateChangeCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • DeviceTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DiffPrejudgePatternEnable : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • Dilate_Cpu() : MPSizectorS_DotNet.Process
  • Display() : MPSizectorS_DotNet.MPDisplayer3D
  • Dispose() : MPSizectorS_DotNet.MPDisplayer2D, MPSizectorS_DotNet.MPDisplayer3D
  • DownSamplingData() : MPSizectorS_DotNet.Process
  • Dump() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- e -

  • Enable : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
  • EnableDisplayFilter : MPSizectorS_DotNet.MPDisplayer3D
  • Erosion_Cpu() : MPSizectorS_DotNet.Process
  • ExpertSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • ExpICoef : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefMax : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefSettings : MPSizectorS_DotNet.HeadPackStructType
  • ExposureBasicSetting : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity2D : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_1st : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_2nd : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_3rd : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExposureMode : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureNum : MPSizectorS_DotNet.AutoHDRResultStructType
  • ExposureNumber : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • ExpROIHeight : MPSizectorS_DotNet.ExpROIStructType
  • ExpROINum : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIs : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIWidth : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIXCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIYCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExternalExposureEnable : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureGain : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposurePossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • ExternalExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • ExternalExposureTimeBlue_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeGreen_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeRed_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeWhite_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • EXTIO0Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIO1Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIOInput : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • EXTIOO0Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOO1Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOOutput : MPSizectorS_DotNet.IOSettingsStructType, MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- f -

  • FilterLog() : MPSizectorS_DotNet.Utils
  • FireSoftwareTrigger() : MPSizectorS_DotNet.MPSizectorS
  • FlipEnable : MPSizectorS_DotNet.ExpertSettingsStructType
  • FlipNextBinningStateEnable : MPSizectorS_DotNet.MPSizectorS
  • FlipXEnable : MPSizectorS_DotNet.FlipEnableStructType, MPSizectorS_DotNet.MPSizectorS
  • FlipYEnable : MPSizectorS_DotNet.FlipEnableStructType, MPSizectorS_DotNet.MPSizectorS
  • FrameInfo : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • FreeGpu() : MPSizectorS_DotNet.Process
  • FreeHGlobalMemory() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • FreeUnmanagedData() : MPSizectorS_DotNet.Utils
  • FWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- g -

  • GenCircleKernel_Cpu() : MPSizectorS_DotNet.Process
  • GeneralSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • GenThresholdTable_Cpu() : MPSizectorS_DotNet.Process
  • GenThresholdTableUshort_Cpu() : MPSizectorS_DotNet.Process
  • Get3DDataLen() : MPSizectorS_DotNet.Utils
  • GetAutoColorDepthRange() : MPSizectorS_DotNet.Utils
  • GetAuxiliaryBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetColorDepthBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • GetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • GetDataLen() : MPSizectorS_DotNet.Utils
  • GetDataPtr() : MPSizectorS_DotNet.Process
  • GetDepthColor() : MPSizectorS_DotNet.Utils
  • GetDeviceCount() : MPSizectorS_DotNet.MPSizectorS
  • GetDeviceInfo() : MPSizectorS_DotNet.MPSizectorS
  • GetExpIByTargetGray() : MPSizectorS_DotNet.MPSizectorS
  • GetExposurePredictionBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.Utils
  • GetExposureValueFromExposurePredictionData() : MPSizectorS_DotNet.Utils
  • GetGrayBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetHardwareTimeStamps() : MPSizectorS_DotNet.MPSizectorS
  • GetHDRMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetLastZAt() : MPSizectorS_DotNet.MPSizectorS
  • GetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetMaskValue() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • GetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyFWVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyInstanceID() : MPSizectorS_DotNet.MPSizectorS
  • GetProjectorExpRegionInfoFromCamExpRegion() : MPSizectorS_DotNet.MPSizectorS
  • GetROIData() : MPSizectorS_DotNet.Process
  • GetSDKVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetStandardDeviation() : MPSizectorS_DotNet.Utils
  • GetValidMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • Gray : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- h -

  • HardwarePreprocessModeList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HardwareTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • HasAuxiliaryRGBImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HasAuxiliaryWhiteImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HeadPackCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • Height : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • HoldState : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • HWTriggerSeting : MPSizectorS_DotNet.IOSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • HWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- i -

  • ImageOrigin : MPSizectorS_DotNet.MPDisplayer2D
  • InitGpu() : MPSizectorS_DotNet.Process
  • InitStates : MPSizectorS_DotNet.HeadDebugInfoStructType
  • InterfaceType : MPSizectorS_DotNet.DeviceInfoStructType
  • IOSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • IsActivated : MPSizectorS_DotNet.DeviceInfoStructType
  • IsBase : MPSizectorS_DotNet.ExpROIStructType
  • IsLoaded : MPSizectorS_DotNet.MPDisplayer3D
  • IsReversed : MPSizectorS_DotNet.HWTriggerSettingStructType
  • IsReversedForSpecialFunction : MPSizectorS_DotNet.OutputPinSettingStructType
  • IsUsingAutoHDRResult : MPSizectorS_DotNet.AutoHDRResultStructType
  • IsValid : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- k -

  • K : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- l -

  • LinearTemperatureDriftCompensationParam : MPSizectorS_DotNet.CompensationStructType
  • LoadCorrectionParamFromXML() : MPSizectorS_DotNet.MPSizectorS
  • LoadDataFrame() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • LoadDefaultSettings() : MPSizectorS_DotNet.MPSizectorS
  • LoadDll() : MPSizectorS_DotNet.MPSizectorS
  • LoadPostProcessFile() : MPSizectorS_DotNet.Utils
  • LoadSettingFromXML() : MPSizectorS_DotNet.Extension
  • LoadUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • LoadUnmanagedDataFrameUndefined_FileStream() : MPSizectorS_DotNet.Extension
  • LogCallBackType() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- m -

  • m_SizectorS_Instance : MPSizectorS_DotNet.MPSizectorS
  • Mask : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Max : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MergeNumber : MPSizectorS_DotNet.MPSizectorS
  • MergeParam0 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam1 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam2 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam3 : MPSizectorS_DotNet.MPSizectorS
  • MergeThreshold : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeWRGBData() : MPSizectorS_DotNet.Process
  • Min : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MinimumSDKVersion : MPSizectorS_DotNet.DeviceInfoStructType
  • ModelPolygon : MPSizectorS_DotNet.MPDisplayer3D
  • ModelTexture : MPSizectorS_DotNet.MPDisplayer3D
  • MonitorPositions : MPSizectorS_DotNet.ExpertSettingsStructType
  • MonitorPositionX : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorPositionY : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorZArr : MPSizectorS_DotNet.ExpertSettingsStructType
  • MPDisplayer2D() : MPSizectorS_DotNet.MPDisplayer2D
  • MPDisplayer3D() : MPSizectorS_DotNet.MPDisplayer3D
  • MPModelPolygonType : MPSizectorS_DotNet.MPDisplayer3D
  • MPModelTextureType : MPSizectorS_DotNet.MPDisplayer3D
  • MPSizectorS() : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadConfig : MPSizectorS_DotNet.DeviceInfoStructType, MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarMode : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarRatio : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • MultiHeadSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- o -

  • OffsetGrayData() : MPSizectorS_DotNet.Utils
  • Open() : MPSizectorS_DotNet.MPSizectorS
  • Opening_Cpu() : MPSizectorS_DotNet.Process
  • OverExposureFilterThreshold : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- p -

  • PartialFactorySettings : MPSizectorS_DotNet.HeadPackStructType
  • PatternPeriod1 : MPSizectorS_DotNet.MPSizectorS
  • PatternPeriod2 : MPSizectorS_DotNet.MPSizectorS
  • PC1 : MPSizectorS_DotNet.CalibParamStructType
  • PC2 : MPSizectorS_DotNet.CalibParamStructType
  • PCTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • PF1 : MPSizectorS_DotNet.CalibParamStructType
  • PF2 : MPSizectorS_DotNet.CalibParamStructType
  • PhyDisconnect() : MPSizectorS_DotNet.MPSizectorS
  • PhyRecconect() : MPSizectorS_DotNet.MPSizectorS
  • PhyReset() : MPSizectorS_DotNet.MPSizectorS
  • PinMode : MPSizectorS_DotNet.OutputPinSettingStructType
  • PixelCordChange : MPSizectorS_DotNet.MPDisplayer2D
  • PixelInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • PKappa : MPSizectorS_DotNet.CalibParamStructType
  • PointScaleSetting : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • Polarity : MPSizectorS_DotNet.ExpROIStructType
  • PostProcessCircleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessFiltrate() : MPSizectorS_DotNet.Process
  • PostProcessMend() : MPSizectorS_DotNet.Process
  • PostProcessMendByFeatures() : MPSizectorS_DotNet.Process
  • PostProcessPlaneCorrection() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckCircle() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRect() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRingEndRect() : MPSizectorS_DotNet.Process
  • PostProcessRectangleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessRegionMend() : MPSizectorS_DotNet.Process
  • PostProcessRemoveBurrs() : MPSizectorS_DotNet.Process
  • PostProcessRingEndRectRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessSegmentMedianFilter() : MPSizectorS_DotNet.Process
  • PostProcessSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • PostProcessSPI() : MPSizectorS_DotNet.Process
  • PostProcessSPIChannel3() : MPSizectorS_DotNet.Process
  • PostProcessTransformImage() : MPSizectorS_DotNet.Process
  • PR00 : MPSizectorS_DotNet.CalibParamStructType
  • PR01 : MPSizectorS_DotNet.CalibParamStructType
  • PR02 : MPSizectorS_DotNet.CalibParamStructType
  • PR10 : MPSizectorS_DotNet.CalibParamStructType
  • PR11 : MPSizectorS_DotNet.CalibParamStructType
  • PR12 : MPSizectorS_DotNet.CalibParamStructType
  • PR20 : MPSizectorS_DotNet.CalibParamStructType
  • PR21 : MPSizectorS_DotNet.CalibParamStructType
  • PR22 : MPSizectorS_DotNet.CalibParamStructType
  • PrejudgePatternGain : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • PrepareColorArr() : MPSizectorS_DotNet.Utils
  • PreProcess_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • PreProcessLoopNum : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • PreProcessThreshold : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ProjectionMode : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.MultiHeadSettingsStructType
  • ProjectionNumber : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • PSx : MPSizectorS_DotNet.CalibParamStructType
  • PSy : MPSizectorS_DotNet.CalibParamStructType
  • PT0 : MPSizectorS_DotNet.CalibParamStructType
  • PT1 : MPSizectorS_DotNet.CalibParamStructType
  • PT2 : MPSizectorS_DotNet.CalibParamStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- r -

  • R00 : MPSizectorS_DotNet.RTMatrixStructType
  • R01 : MPSizectorS_DotNet.RTMatrixStructType
  • R02 : MPSizectorS_DotNet.RTMatrixStructType
  • R10 : MPSizectorS_DotNet.RTMatrixStructType
  • R11 : MPSizectorS_DotNet.RTMatrixStructType
  • R12 : MPSizectorS_DotNet.RTMatrixStructType
  • R20 : MPSizectorS_DotNet.RTMatrixStructType
  • R21 : MPSizectorS_DotNet.RTMatrixStructType
  • R22 : MPSizectorS_DotNet.RTMatrixStructType
  • RangeCheckEnableState : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeCheckSetting : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ReadSettingsFromFile() : MPSizectorS_DotNet.MPSizectorS
  • Reconnect() : MPSizectorS_DotNet.MPSizectorS
  • ReconstructionSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.SettingsStructType
  • Reserved : MPSizectorS_DotNet.ExpertSettingsStructType
  • RgbToHsv_Cpu() : MPSizectorS_DotNet.Process
  • ROIHeightRatio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ROIWidthRatio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ROIX0Ratio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • ROIY0Ratio : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • RotateAmplitude : MPSizectorS_DotNet.MPDisplayer3D
  • RotateMode : MPSizectorS_DotNet.MPDisplayer3D
  • RotateModeEnumType : MPSizectorS_DotNet.MPDisplayer3D
  • RotatePhase : MPSizectorS_DotNet.MPDisplayer3D
  • RotateSpeed : MPSizectorS_DotNet.MPDisplayer3D


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- s -

  • SaveCorrectionParams() : MPSizectorS_DotNet.MPSizectorS
  • SaveCorrectionParamToXML() : MPSizectorS_DotNet.MPSizectorS
  • SaveDataFrame() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveDataFrame_FileStream() : MPSizectorS_DotNet.Utils
  • SaveDataFrame_ManagedFixZMapSimpleDataFrame() : MPSizectorS_DotNet.Utils
  • SavePCD() : MPSizectorS_DotNet.Process
  • SavePLY() : MPSizectorS_DotNet.Process
  • SaveSettingsAsDefault() : MPSizectorS_DotNet.MPSizectorS
  • SaveSettingToXML() : MPSizectorS_DotNet.Extension
  • SaveTextPointCloud() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Process, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveTIFF() : MPSizectorS_DotNet.Process
  • SaveUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • Score : MPSizectorS_DotNet.AutoHDRResultStructType
  • Screenshot : MPSizectorS_DotNet.MPDisplayer3D
  • SensorBinningHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorExpBaseTime : MPSizectorS_DotNet.MPSizectorS
  • SensorHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorValid : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • SensorWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SetAutoReconnect() : MPSizectorS_DotNet.MPSizectorS
  • SetAuxiliaryRGB() : MPSizectorS_DotNet.SettingsStructType
  • SetAuxiliaryWhite() : MPSizectorS_DotNet.SettingsStructType
  • SetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • SetDataCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDeviceStateChangeCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDrawLines() : MPSizectorS_DotNet.MPDisplayer3D
  • SetHeadPackCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • Settings : MPSizectorS_DotNet.MPSizectorS
  • SettingsVersion : MPSizectorS_DotNet.HeadPackStructType
  • SettingValidation : MPSizectorS_DotNet.HeadDebugInfoStructType
  • shapeType : MPSizectorS_DotNet.ExpROIStructType
  • SN : MPSizectorS_DotNet.TSNStructType
  • SnapCnt : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • SnapUnmanaged() : MPSizectorS_DotNet.MPSizectorS
  • SoftwarePreprocessList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwarePreprocessPresetParamList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwareTSN : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Source : MPSizectorS_DotNet.TSNStructType
  • SpecularReflection : MPSizectorS_DotNet.MPDisplayer3D
  • StartUpTimeMS : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • State : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • States : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo1Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo2Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo3Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpParam1Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam2Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam3Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParamsEnable : MPSizectorS_DotNet.ExpertSettingsStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- t -

  • T0 : MPSizectorS_DotNet.RTMatrixStructType
  • T1 : MPSizectorS_DotNet.RTMatrixStructType
  • T2 : MPSizectorS_DotNet.RTMatrixStructType
  • Temp0 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Temp1 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • Temp2 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • TempCore : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • TempValueC : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • TestMultiHeadError() : MPSizectorS_DotNet.MPSizectorS
  • Textures : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Threshold3Channel_Cpu() : MPSizectorS_DotNet.Process
  • Threshold_Cpu() : MPSizectorS_DotNet.Process
  • ThresholdUshort_Cpu() : MPSizectorS_DotNet.Process
  • ToManaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • TooHighColor : MPSizectorS_DotNet.Utils
  • TooLowColor : MPSizectorS_DotNet.Utils
  • TotalCaptureRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • TotalTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.StatesStructType
  • ToUnmanaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMap() : MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMapSimple() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • TransferExpoIntensityToExpoTime() : MPSizectorS_DotNet.MPSizectorS
  • TransferExpoTimeToExpoIntensity() : MPSizectorS_DotNet.MPSizectorS
  • TransformROIPixelToROISetting() : MPSizectorS_DotNet.Utils
  • TransformROISettingToROIPixel() : MPSizectorS_DotNet.Utils
  • TransparentBackGroundSnapshot : MPSizectorS_DotNet.MPDisplayer3D
  • TriggerSource : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • TSN : MPSizectorS_DotNet.HeadPackDataInfoStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- u -

  • Undistort() : MPSizectorS_DotNet.Process
  • UpdateDeviceList() : MPSizectorS_DotNet.MPSizectorS
  • UpSamplingData() : MPSizectorS_DotNet.Process
  • UseNormVector : MPSizectorS_DotNet.MPDisplayer3D
  • UserGain : MPSizectorS_DotNet.ExposureSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • UserRTMatrix : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • UserRTMatrixEnableState : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.PostProcessSettingsStructType
  • UXmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UXmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmin : MPSizectorS_DotNet.RangeCheckSettingStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- v -

  • ValidPointThreshold0 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ValidPointThreshold1 : MPSizectorS_DotNet.MPSizectorS, MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ValidPointThreshold_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • ViewMatrix : MPSizectorS_DotNet.MPDisplayer3D


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- w -

  • Width : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • WorkingMode : MPSizectorS_DotNet.BasicSettingsStructType, MPSizectorS_DotNet.MPSizectorS
  • WriteSettingsToFile() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- x -

  • X : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • X0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • XIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • XMax : MPSizectorS_DotNet.DeviceInfoStructType
  • XOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • XPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • XReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- y -

  • Y : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • Y0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • YIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • YMax : MPSizectorS_DotNet.DeviceInfoStructType
  • YOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • YPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • YReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET 编程文档: 类成员

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
这里列出了所有文档化的类成员，并附带类所属的文件:

- z -

  • Z : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • Z0 : MPSizectorS_DotNet.MonitorZStructType
  • Z0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • Z1 : MPSizectorS_DotNet.MonitorZStructType
  • Z2 : MPSizectorS_DotNet.MonitorZStructType
  • Z3 : MPSizectorS_DotNet.MonitorZStructType
  • ZIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • ZInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ZMax : MPSizectorS_DotNet.DeviceInfoStructType, MPSizectorS_DotNet.MPSizectorS
  • ZMin : MPSizectorS_DotNet.MPSizectorS
  • ZOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Zoom : MPSizectorS_DotNet.MPDisplayer2D
  • ZRawData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- a -

  • AutoSetExpertModeParam() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- c -

  • CalculateCorrectDistortionParamFromData() : MPSizectorS_DotNet.Utils
  • Close() : MPSizectorS_DotNet.MPSizectorS
  • Closing_Cpu() : MPSizectorS_DotNet.Process
  • CompensateData() : MPSizectorS_DotNet.Utils
  • Convert32bppTo8bpp() : MPSizectorS_DotNet.Utils
  • ConvertBayerToRGB() : MPSizectorS_DotNet.Process
  • ConvertFrame2DBayerToGray() : MPSizectorS_DotNet.Process
  • ConvertGrayByteArrayToGrayBitmap() : MPSizectorS_DotNet.Utils
  • ConvertRGBByteArrayToRGBBitmap() : MPSizectorS_DotNet.Utils
  • ConvertToRangeImage() : MPSizectorS_DotNet.Process
  • ConvertZMapFrameToFloat3DFrame() : MPSizectorS_DotNet.Process
  • CopyMemory() : MPSizectorS_DotNet.Utils
  • CopyToManagedFix3D() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct
  • CopyToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct
  • CopyToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • CopyToManagedFloat3D() : MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • CoreHardReset() : MPSizectorS_DotNet.MPSizectorS
  • CoreSoftReset() : MPSizectorS_DotNet.MPSizectorS
  • CorrectDistortion() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- d -

  • DataCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • DestroyCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DeviceStateChangeCallBackType() : MPSizectorS_DotNet.MPSizectorS
  • Dilate_Cpu() : MPSizectorS_DotNet.Process
  • Display() : MPSizectorS_DotNet.MPDisplayer3D
  • Dispose() : MPSizectorS_DotNet.MPDisplayer2D, MPSizectorS_DotNet.MPDisplayer3D
  • DownSamplingData() : MPSizectorS_DotNet.Process
  • Dump() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- e -

  • Erosion_Cpu() : MPSizectorS_DotNet.Process


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- f -

  • FilterLog() : MPSizectorS_DotNet.Utils
  • FireSoftwareTrigger() : MPSizectorS_DotNet.MPSizectorS
  • FreeGpu() : MPSizectorS_DotNet.Process
  • FreeHGlobalMemory() : MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • FreeUnmanagedData() : MPSizectorS_DotNet.Utils


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- g -

  • GenCircleKernel_Cpu() : MPSizectorS_DotNet.Process
  • GenThresholdTable_Cpu() : MPSizectorS_DotNet.Process
  • GenThresholdTableUshort_Cpu() : MPSizectorS_DotNet.Process
  • Get3DDataLen() : MPSizectorS_DotNet.Utils
  • GetAutoColorDepthRange() : MPSizectorS_DotNet.Utils
  • GetAuxiliaryBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetColorDepthBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetCopy() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • GetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • GetDataLen() : MPSizectorS_DotNet.Utils
  • GetDataPtr() : MPSizectorS_DotNet.Process
  • GetDepthColor() : MPSizectorS_DotNet.Utils
  • GetDeviceCount() : MPSizectorS_DotNet.MPSizectorS
  • GetDeviceInfo() : MPSizectorS_DotNet.MPSizectorS
  • GetExpIByTargetGray() : MPSizectorS_DotNet.MPSizectorS
  • GetExposurePredictionBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.Utils
  • GetExposureValueFromExposurePredictionData() : MPSizectorS_DotNet.Utils
  • GetGrayBitmap() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetHardwareTimeStamps() : MPSizectorS_DotNet.MPSizectorS
  • GetHDRMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils
  • GetLastZAt() : MPSizectorS_DotNet.MPSizectorS
  • GetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • GetMaskValue() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • GetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyFWVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetPhyInstanceID() : MPSizectorS_DotNet.MPSizectorS
  • GetProjectorExpRegionInfoFromCamExpRegion() : MPSizectorS_DotNet.MPSizectorS
  • GetROIData() : MPSizectorS_DotNet.Process
  • GetSDKVersion() : MPSizectorS_DotNet.MPSizectorS
  • GetStandardDeviation() : MPSizectorS_DotNet.Utils
  • GetValidMaskBitmap() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Utils


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- h -

  • HeadPackCallBackType() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- i -

  • InitGpu() : MPSizectorS_DotNet.Process
  • IsValid() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- l -

  • LoadCorrectionParamFromXML() : MPSizectorS_DotNet.MPSizectorS
  • LoadDataFrame() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • LoadDefaultSettings() : MPSizectorS_DotNet.MPSizectorS
  • LoadDll() : MPSizectorS_DotNet.MPSizectorS
  • LoadPostProcessFile() : MPSizectorS_DotNet.Utils
  • LoadSettingFromXML() : MPSizectorS_DotNet.Extension
  • LoadUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • LoadUnmanagedDataFrameUndefined_FileStream() : MPSizectorS_DotNet.Extension
  • LogCallBackType() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- m -

  • MergeWRGBData() : MPSizectorS_DotNet.Process
  • MPDisplayer2D() : MPSizectorS_DotNet.MPDisplayer2D
  • MPDisplayer3D() : MPSizectorS_DotNet.MPDisplayer3D
  • MPSizectorS() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- o -

  • OffsetGrayData() : MPSizectorS_DotNet.Utils
  • Open() : MPSizectorS_DotNet.MPSizectorS
  • Opening_Cpu() : MPSizectorS_DotNet.Process


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- p -

  • PhyDisconnect() : MPSizectorS_DotNet.MPSizectorS
  • PhyRecconect() : MPSizectorS_DotNet.MPSizectorS
  • PhyReset() : MPSizectorS_DotNet.MPSizectorS
  • PostProcessCircleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessFiltrate() : MPSizectorS_DotNet.Process
  • PostProcessMend() : MPSizectorS_DotNet.Process
  • PostProcessMendByFeatures() : MPSizectorS_DotNet.Process
  • PostProcessPlaneCorrection() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckCircle() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRect() : MPSizectorS_DotNet.Process
  • PostProcessRangeCheckRingEndRect() : MPSizectorS_DotNet.Process
  • PostProcessRectangleRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessRegionMend() : MPSizectorS_DotNet.Process
  • PostProcessRemoveBurrs() : MPSizectorS_DotNet.Process
  • PostProcessRingEndRectRangeCheck_ByReferencePlan() : MPSizectorS_DotNet.Process
  • PostProcessSegmentMedianFilter() : MPSizectorS_DotNet.Process
  • PostProcessSPI() : MPSizectorS_DotNet.Process
  • PostProcessSPIChannel3() : MPSizectorS_DotNet.Process
  • PostProcessTransformImage() : MPSizectorS_DotNet.Process
  • PrepareColorArr() : MPSizectorS_DotNet.Utils


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- r -

  • ReadSettingsFromFile() : MPSizectorS_DotNet.MPSizectorS
  • Reconnect() : MPSizectorS_DotNet.MPSizectorS
  • RgbToHsv_Cpu() : MPSizectorS_DotNet.Process


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- s -

  • SaveCorrectionParams() : MPSizectorS_DotNet.MPSizectorS
  • SaveCorrectionParamToXML() : MPSizectorS_DotNet.MPSizectorS
  • SaveDataFrame() : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveDataFrame_FileStream() : MPSizectorS_DotNet.Utils
  • SaveDataFrame_ManagedFixZMapSimpleDataFrame() : MPSizectorS_DotNet.Utils
  • SavePCD() : MPSizectorS_DotNet.Process
  • SavePLY() : MPSizectorS_DotNet.Process
  • SaveSettingsAsDefault() : MPSizectorS_DotNet.MPSizectorS
  • SaveSettingToXML() : MPSizectorS_DotNet.Extension
  • SaveTextPointCloud() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.Process, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • SaveTIFF() : MPSizectorS_DotNet.Process
  • SaveUnmanagedDataFrameUndefined() : MPSizectorS_DotNet.Utils
  • SetAutoReconnect() : MPSizectorS_DotNet.MPSizectorS
  • SetAuxiliaryRGB() : MPSizectorS_DotNet.SettingsStructType
  • SetAuxiliaryWhite() : MPSizectorS_DotNet.SettingsStructType
  • SetCorrectionParam() : MPSizectorS_DotNet.MPSizectorS
  • SetDataCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDeviceStateChangeCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetDrawLines() : MPSizectorS_DotNet.MPDisplayer3D
  • SetHeadPackCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogCallBack() : MPSizectorS_DotNet.MPSizectorS
  • SetLogImportanceLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetLogTypeLevel() : MPSizectorS_DotNet.MPSizectorS
  • SetMonitorPosition() : MPSizectorS_DotNet.MPSizectorS
  • SnapUnmanaged() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- t -

  • TestMultiHeadError() : MPSizectorS_DotNet.MPSizectorS
  • Threshold3Channel_Cpu() : MPSizectorS_DotNet.Process
  • Threshold_Cpu() : MPSizectorS_DotNet.Process
  • ThresholdUshort_Cpu() : MPSizectorS_DotNet.Process
  • ToManaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMap() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFixZMapSimple() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToManagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanaged2D() : MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFix3D() : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMap() : MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFixZMapSimple() : MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • ToUnmanagedFloat3D() : MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • TransferExpoIntensityToExpoTime() : MPSizectorS_DotNet.MPSizectorS
  • TransferExpoTimeToExpoIntensity() : MPSizectorS_DotNet.MPSizectorS
  • TransformROIPixelToROISetting() : MPSizectorS_DotNet.Utils
  • TransformROISettingToROIPixel() : MPSizectorS_DotNet.Utils


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- u -

  • Undistort() : MPSizectorS_DotNet.Process
  • UpdateDeviceList() : MPSizectorS_DotNet.MPSizectorS
  • UpSamplingData() : MPSizectorS_DotNet.Process


MPSizector .NET 编程文档: 类成员 - 函数

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- w -

  • WriteSettingsToFile() : MPSizectorS_DotNet.MPSizectorS


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • AntiLampFlickerMode : MPSizectorS_DotNet.ExpertSettingsStructType
  • AutoHDR_ExposureIntensity3D_1st : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_2nd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDR_ExposureIntensity3D_3rd : MPSizectorS_DotNet.AutoHDRResultStructType
  • AutoHDRAdvanceSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • AutoHDRAdvanceSettingsEnable : MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • AutoHDRPriority : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoHDRResult : MPSizectorS_DotNet.HeadPackStructType
  • AutoPHDRQuality : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • AutoSleepDelayMS : MPSizectorS_DotNet.GeneralSettingsStructType
  • AutoSleepEnableState : MPSizectorS_DotNet.GeneralSettingsStructType
  • AutoTSN : MPSizectorS_DotNet.StatesStructType
  • AuxiliaryRGB : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct
  • AuxiliaryWhite : MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • BasicSetings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • BinningPossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • BinningState : MPSizectorS_DotNet.BasicSettingsStructType
  • BurrFilterThreshold0 : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • BurrFilterThreshold1 : MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • CalibDate : MPSizectorS_DotNet.CalibParamStructType
  • CalibParam : MPSizectorS_DotNet.HeadPackStructType
  • CC1 : MPSizectorS_DotNet.CalibParamStructType
  • CC2 : MPSizectorS_DotNet.CalibParamStructType
  • CF1 : MPSizectorS_DotNet.CalibParamStructType
  • CF2 : MPSizectorS_DotNet.CalibParamStructType
  • CKappa : MPSizectorS_DotNet.CalibParamStructType
  • ColorArr : MPSizectorS_DotNet.Utils
  • CompensationParams : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ConnectionTimeMS : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • CorrectDistortionEnable : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • CR00 : MPSizectorS_DotNet.CalibParamStructType
  • CR01 : MPSizectorS_DotNet.CalibParamStructType
  • CR02 : MPSizectorS_DotNet.CalibParamStructType
  • CR10 : MPSizectorS_DotNet.CalibParamStructType
  • CR11 : MPSizectorS_DotNet.CalibParamStructType
  • CR12 : MPSizectorS_DotNet.CalibParamStructType
  • CR20 : MPSizectorS_DotNet.CalibParamStructType
  • CR21 : MPSizectorS_DotNet.CalibParamStructType
  • CR22 : MPSizectorS_DotNet.CalibParamStructType
  • CSx : MPSizectorS_DotNet.CalibParamStructType
  • CSy : MPSizectorS_DotNet.CalibParamStructType
  • CT0 : MPSizectorS_DotNet.CalibParamStructType
  • CT1 : MPSizectorS_DotNet.CalibParamStructType
  • CT2 : MPSizectorS_DotNet.CalibParamStructType
  • CurrentTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • CurrentTSN : MPSizectorS_DotNet.StatesStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • Data : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • DataFormat : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataInfo : MPSizectorS_DotNet.HeadPackStructType
  • DataNumber : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DataOutMode : MPSizectorS_DotNet.PostProcessSettingsStructType
  • DataTag : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DebugInfo : MPSizectorS_DotNet.HeadPackStructType
  • DebugRegisters : MPSizectorS_DotNet.StatesStructType
  • DelayIn100us : MPSizectorS_DotNet.HWTriggerSettingStructType
  • DepthColorStops : MPSizectorS_DotNet.Utils
  • DeviceInfo : MPSizectorS_DotNet.HeadPackStructType
  • DeviceName : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceSerialNumber : MPSizectorS_DotNet.DeviceInfoStructType
  • DeviceTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • DiffPrejudgePatternEnable : MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • Enable : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType
  • ExpertSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ExpICoef : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefMax : MPSizectorS_DotNet.MPSizectorS_ExpICoefSettingsStructType
  • ExpICoefSettings : MPSizectorS_DotNet.HeadPackStructType
  • ExposureBasicSetting : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity2D : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity3D_1st : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity3D_2nd : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureIntensity3D_3rd : MPSizectorS_DotNet.ExposureSettingsStructType
  • ExposureMode : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureNum : MPSizectorS_DotNet.AutoHDRResultStructType
  • ExposureNumber : MPSizectorS_DotNet.ExposureBasicSettingStructType
  • ExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ExpROIHeight : MPSizectorS_DotNet.ExpROIStructType
  • ExpROINum : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIs : MPSizectorS_DotNet.ExpertSettingsStructType
  • ExpROIWidth : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIXCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExpROIYCenter : MPSizectorS_DotNet.ExpROIStructType
  • ExternalExposureEnable : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureGain : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposurePossibility : MPSizectorS_DotNet.DeviceInfoStructType
  • ExternalExposureSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • ExternalExposureTimeBlue_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureTimeGreen_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureTimeRed_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • ExternalExposureTimeWhite_us : MPSizectorS_DotNet.ExternalExposureSettingsStructType
  • EXTIOInput : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • EXTIOO0Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOO1Setting : MPSizectorS_DotNet.IOSettingsStructType
  • EXTIOOutput : MPSizectorS_DotNet.IOSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • FlipEnable : MPSizectorS_DotNet.ExpertSettingsStructType
  • FlipXEnable : MPSizectorS_DotNet.FlipEnableStructType
  • FlipYEnable : MPSizectorS_DotNet.FlipEnableStructType
  • FrameInfo : MPSizectorS_DotNet.ManagedDataFrame2DStruct, MPSizectorS_DotNet.ManagedDataFrameFix3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapStruct, MPSizectorS_DotNet.ManagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrame2DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFix3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapStruct, MPSizectorS_DotNet.UnmanagedDataFrameFloat3DStruct, MPSizectorS_DotNet.UnmanagedDataFrameUndefinedStruct
  • FWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • GeneralSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • Gray : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • HardwarePreprocessModeList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HardwareTSN : MPSizectorS_DotNet.StatesStructType
  • Height : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • HoldState : MPSizectorS_DotNet.BasicSettingsStructType
  • HWTriggerSeting : MPSizectorS_DotNet.IOSettingsStructType
  • HWVersion : MPSizectorS_DotNet.DeviceInfoStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • InitStates : MPSizectorS_DotNet.HeadDebugInfoStructType
  • InterfaceType : MPSizectorS_DotNet.DeviceInfoStructType
  • IOSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • IsActivated : MPSizectorS_DotNet.DeviceInfoStructType
  • IsBase : MPSizectorS_DotNet.ExpROIStructType
  • IsReversed : MPSizectorS_DotNet.HWTriggerSettingStructType
  • IsReversedForSpecialFunction : MPSizectorS_DotNet.OutputPinSettingStructType
  • IsUsingAutoHDRResult : MPSizectorS_DotNet.AutoHDRResultStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- k -

  • K : MPSizectorS_DotNet.LinearTemperatureDriftCompensationStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • LinearTemperatureDriftCompensationParam : MPSizectorS_DotNet.CompensationStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • m_SizectorS_Instance : MPSizectorS_DotNet.MPSizectorS
  • Mask : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • Max : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MergeParam0 : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam1 : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeParam2 : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • MergeThreshold : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • Min : MPSizectorS_DotNet.ColorDepthRangeStruct
  • MinimumSDKVersion : MPSizectorS_DotNet.DeviceInfoStructType
  • MonitorPositions : MPSizectorS_DotNet.ExpertSettingsStructType
  • MonitorPositionX : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorPositionY : MPSizectorS_DotNet.MonitorPositionStructType
  • MonitorZArr : MPSizectorS_DotNet.ExpertSettingsStructType
  • MultiHeadConfig : MPSizectorS_DotNet.DeviceInfoStructType
  • MultiHeadExpoVarMode : MPSizectorS_DotNet.ExposureSettingsStructType
  • MultiHeadExpoVarRatio : MPSizectorS_DotNet.ExposureSettingsStructType
  • MultiHeadSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • OverExposureFilterThreshold : MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • PartialFactorySettings : MPSizectorS_DotNet.HeadPackStructType
  • PC1 : MPSizectorS_DotNet.CalibParamStructType
  • PC2 : MPSizectorS_DotNet.CalibParamStructType
  • PCTimeStamp : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • PF1 : MPSizectorS_DotNet.CalibParamStructType
  • PF2 : MPSizectorS_DotNet.CalibParamStructType
  • PinMode : MPSizectorS_DotNet.OutputPinSettingStructType
  • PixelInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • PKappa : MPSizectorS_DotNet.CalibParamStructType
  • PointScaleSetting : MPSizectorS_DotNet.PostProcessSettingsStructType
  • Polarity : MPSizectorS_DotNet.ExpROIStructType
  • PostProcessSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • PR00 : MPSizectorS_DotNet.CalibParamStructType
  • PR01 : MPSizectorS_DotNet.CalibParamStructType
  • PR02 : MPSizectorS_DotNet.CalibParamStructType
  • PR10 : MPSizectorS_DotNet.CalibParamStructType
  • PR11 : MPSizectorS_DotNet.CalibParamStructType
  • PR12 : MPSizectorS_DotNet.CalibParamStructType
  • PR20 : MPSizectorS_DotNet.CalibParamStructType
  • PR21 : MPSizectorS_DotNet.CalibParamStructType
  • PR22 : MPSizectorS_DotNet.CalibParamStructType
  • PrejudgePatternGain : MPSizectorS_DotNet.MPSizectorS_AutoHDRAdvanceSettingsStructType
  • PreProcessLoopNum : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • PreProcessThreshold : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ProjectionMode : MPSizectorS_DotNet.MultiHeadSettingsStructType
  • PSx : MPSizectorS_DotNet.CalibParamStructType
  • PSy : MPSizectorS_DotNet.CalibParamStructType
  • PT0 : MPSizectorS_DotNet.CalibParamStructType
  • PT1 : MPSizectorS_DotNet.CalibParamStructType
  • PT2 : MPSizectorS_DotNet.CalibParamStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • R00 : MPSizectorS_DotNet.RTMatrixStructType
  • R01 : MPSizectorS_DotNet.RTMatrixStructType
  • R02 : MPSizectorS_DotNet.RTMatrixStructType
  • R10 : MPSizectorS_DotNet.RTMatrixStructType
  • R11 : MPSizectorS_DotNet.RTMatrixStructType
  • R12 : MPSizectorS_DotNet.RTMatrixStructType
  • R20 : MPSizectorS_DotNet.RTMatrixStructType
  • R21 : MPSizectorS_DotNet.RTMatrixStructType
  • R22 : MPSizectorS_DotNet.RTMatrixStructType
  • RangeCheckEnableState : MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeCheckSetting : MPSizectorS_DotNet.PostProcessSettingsStructType
  • RangeData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ReconstructionSettings : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • Reserved : MPSizectorS_DotNet.ExpertSettingsStructType
  • ROIHeightRatio : MPSizectorS_DotNet.BasicSettingsStructType
  • ROIWidthRatio : MPSizectorS_DotNet.BasicSettingsStructType
  • ROIX0Ratio : MPSizectorS_DotNet.BasicSettingsStructType
  • ROIY0Ratio : MPSizectorS_DotNet.BasicSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • Score : MPSizectorS_DotNet.AutoHDRResultStructType
  • SensorBinningHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorBinningWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorHeight : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorResolution : MPSizectorS_DotNet.DeviceInfoStructType
  • SensorValid : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • SensorWidth : MPSizectorS_DotNet.DeviceInfoStructType
  • SettingsVersion : MPSizectorS_DotNet.HeadPackStructType
  • SettingValidation : MPSizectorS_DotNet.HeadDebugInfoStructType
  • shapeType : MPSizectorS_DotNet.ExpROIStructType
  • SN : MPSizectorS_DotNet.TSNStructType
  • SnapCnt : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • SoftwarePreprocessList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwarePreprocessPresetParamList : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • SoftwareTSN : MPSizectorS_DotNet.StatesStructType
  • Source : MPSizectorS_DotNet.TSNStructType
  • StartUpTimeMS : MPSizectorS_DotNet.StatesStructType
  • State : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • SuppressExpParam1Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam2Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParam3Enable : MPSizectorS_DotNet.SuppressExpParamsEnableStructType
  • SuppressExpParamsEnable : MPSizectorS_DotNet.ExpertSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • T0 : MPSizectorS_DotNet.RTMatrixStructType
  • T1 : MPSizectorS_DotNet.RTMatrixStructType
  • T2 : MPSizectorS_DotNet.RTMatrixStructType
  • Temp0 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • Temp1 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • Temp2 : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TempCore : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TempValueC : MPSizectorS_DotNet.TemperatureFeedbackStructType
  • Textures : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • TooHighColor : MPSizectorS_DotNet.Utils
  • TooLowColor : MPSizectorS_DotNet.Utils
  • TotalCaptureRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TotalTransferRetryNum : MPSizectorS_DotNet.HeadDebugInfoStructType, MPSizectorS_DotNet.StatesStructType
  • TriggerSource : MPSizectorS_DotNet.BasicSettingsStructType
  • TSN : MPSizectorS_DotNet.HeadPackDataInfoStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • UserGain : MPSizectorS_DotNet.ExposureSettingsStructType
  • UserRTMatrix : MPSizectorS_DotNet.PostProcessSettingsStructType
  • UserRTMatrixEnableState : MPSizectorS_DotNet.PostProcessSettingsStructType
  • UXmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UXmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UYmin : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmax : MPSizectorS_DotNet.RangeCheckSettingStructType
  • UZmin : MPSizectorS_DotNet.RangeCheckSettingStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • ValidPointThreshold0 : MPSizectorS_DotNet.ReconstructionSettingsStructType
  • ValidPointThreshold1 : MPSizectorS_DotNet.ReconstructionSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • Width : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • WorkingMode : MPSizectorS_DotNet.BasicSettingsStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • X : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • X0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • XIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • XMax : MPSizectorS_DotNet.DeviceInfoStructType
  • XOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • XPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • XReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • Y : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFloat3DStruct
  • Y0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • YIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • YMax : MPSizectorS_DotNet.DeviceInfoStructType
  • YOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • YPixResolution : MPSizectorS_DotNet.HeadPackDataInfoStructType
  • YReserved : MPSizectorS_DotNet.PointScaleSettingStructType


MPSizector .NET 编程文档: 类成员 - 变量

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • Z : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct, MPSizectorS_DotNet.ManagedDataFrameFixZMapSimpleStruct, MPSizectorS_DotNet.UnmanagedDataFrameFixZMapSimpleStruct
  • Z0 : MPSizectorS_DotNet.MonitorZStructType
  • Z0Pos : MPSizectorS_DotNet.PointScaleSettingStructType
  • Z1 : MPSizectorS_DotNet.MonitorZStructType
  • Z2 : MPSizectorS_DotNet.MonitorZStructType
  • Z3 : MPSizectorS_DotNet.MonitorZStructType
  • ZIncrement : MPSizectorS_DotNet.PointScaleSettingStructType
  • ZInterval : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ZMax : MPSizectorS_DotNet.DeviceInfoStructType
  • ZOffset : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged
  • ZRawData : MPSizectorS_DotNet.RangeImageManaged, MPSizectorS_DotNet.RangeImageUnmanaged


MPSizector .NET 编程文档: 类成员 - 枚举

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • MPModelPolygonType : MPSizectorS_DotNet.MPDisplayer3D
  • MPModelTextureType : MPSizectorS_DotNet.MPDisplayer3D
  • RotateModeEnumType : MPSizectorS_DotNet.MPDisplayer3D


MPSizector .NET 编程文档: 类成员 - 属性

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- a -

  • AntiLampFlickerMode : MPSizectorS_DotNet.MPSizectorS
  • AntiNoiseLevel : MPSizectorS_DotNet.MPSizectorS
  • AutoHDRAdvanceSettingsEnable : MPSizectorS_DotNet.MPSizectorS
  • AutoSleepDelayMS : MPSizectorS_DotNet.MPSizectorS
  • AutoSleepEnableState : MPSizectorS_DotNet.MPSizectorS
  • AutoTSN : MPSizectorS_DotNet.MPSizectorS

- b -

  • BasicSettings : MPSizectorS_DotNet.MPSizectorS
  • Binning : MPSizectorS_DotNet.MPDisplayer2D
  • BinningState : MPSizectorS_DotNet.MPSizectorS
  • Bitmap : MPSizectorS_DotNet.MPDisplayer2D
  • BurrFilter_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • BurrFilterThreshold0 : MPSizectorS_DotNet.MPSizectorS
  • BurrFilterThreshold1 : MPSizectorS_DotNet.MPSizectorS

- c -

  • CalibParam : MPSizectorS_DotNet.MPSizectorS
  • ColorDepthImageMax : MPSizectorS_DotNet.MPDisplayer3D
  • ColorDepthImageMin : MPSizectorS_DotNet.MPDisplayer3D
  • ConnectionTimeMS : MPSizectorS_DotNet.MPSizectorS
  • CorrectionMode : MPSizectorS_DotNet.MPSizectorS
  • CurPixelCord : MPSizectorS_DotNet.MPDisplayer2D
  • CurrentDeviceInfo : MPSizectorS_DotNet.MPSizectorS
  • CurrentTransferRetryNum : MPSizectorS_DotNet.MPSizectorS
  • CurrentTSN : MPSizectorS_DotNet.MPSizectorS

- d -

  • DataOutMode : MPSizectorS_DotNet.MPSizectorS
  • DataTag : MPSizectorS_DotNet.MPSizectorS
  • DebugRegisters : MPSizectorS_DotNet.MPSizectorS
  • DefaultSettings : MPSizectorS_DotNet.MPSizectorS
  • DeviceState : MPSizectorS_DotNet.MPSizectorS
  • DiffPrejudgePatternEnable : MPSizectorS_DotNet.MPSizectorS

- e -

  • EnableDisplayFilter : MPSizectorS_DotNet.MPDisplayer3D
  • ExpertSettings : MPSizectorS_DotNet.MPSizectorS
  • ExposureBasicSetting : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity2D : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_1st : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_2nd : MPSizectorS_DotNet.MPSizectorS
  • ExposureIntensity3D_3rd : MPSizectorS_DotNet.MPSizectorS
  • ExposureSettings : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureEnable : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureGain : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureSettings : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeBlue_us : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeGreen_us : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeRed_us : MPSizectorS_DotNet.MPSizectorS
  • ExternalExposureTimeWhite_us : MPSizectorS_DotNet.MPSizectorS
  • EXTIO0Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIO1Setting : MPSizectorS_DotNet.MPSizectorS
  • EXTIOInput : MPSizectorS_DotNet.MPSizectorS
  • EXTIOOutput : MPSizectorS_DotNet.MPSizectorS

- f -

  • FlipNextBinningStateEnable : MPSizectorS_DotNet.MPSizectorS
  • FlipXEnable : MPSizectorS_DotNet.MPSizectorS
  • FlipYEnable : MPSizectorS_DotNet.MPSizectorS

- g -

  • GeneralSettings : MPSizectorS_DotNet.MPSizectorS

- h -

  • HardwareTSN : MPSizectorS_DotNet.MPSizectorS
  • HasAuxiliaryRGBImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HasAuxiliaryWhiteImage : MPSizectorS_DotNet.HeadPackStructType, MPSizectorS_DotNet.SettingsStructType
  • HoldState : MPSizectorS_DotNet.MPSizectorS
  • HWTriggerSeting : MPSizectorS_DotNet.MPSizectorS

- i -

  • ImageOrigin : MPSizectorS_DotNet.MPDisplayer2D
  • IOSettings : MPSizectorS_DotNet.MPSizectorS
  • IsLoaded : MPSizectorS_DotNet.MPDisplayer3D
  • IsValid : MPSizectorS_DotNet.DataPointFix3DStruct, MPSizectorS_DotNet.DataPointFixZMapStruct, MPSizectorS_DotNet.DataPointFloat3DStruct

- m -

  • MergeNumber : MPSizectorS_DotNet.MPSizectorS
  • MergeParam0 : MPSizectorS_DotNet.MPSizectorS
  • MergeParam1 : MPSizectorS_DotNet.MPSizectorS
  • MergeParam2 : MPSizectorS_DotNet.MPSizectorS
  • MergeParam3 : MPSizectorS_DotNet.MPSizectorS
  • MergeThreshold : MPSizectorS_DotNet.MPSizectorS
  • ModelPolygon : MPSizectorS_DotNet.MPDisplayer3D
  • ModelTexture : MPSizectorS_DotNet.MPDisplayer3D
  • MultiHeadConfig : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarMode : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadExpoVarRatio : MPSizectorS_DotNet.MPSizectorS
  • MultiHeadSettings : MPSizectorS_DotNet.MPSizectorS

- o -

  • OverExposureFilterThreshold : MPSizectorS_DotNet.MPSizectorS

- p -

  • PatternPeriod1 : MPSizectorS_DotNet.MPSizectorS
  • PatternPeriod2 : MPSizectorS_DotNet.MPSizectorS
  • PointScaleSetting : MPSizectorS_DotNet.MPSizectorS
  • PostProcessSettings : MPSizectorS_DotNet.MPSizectorS
  • PrejudgePatternGain : MPSizectorS_DotNet.MPSizectorS
  • PreProcess_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • PreProcessLoopNum : MPSizectorS_DotNet.MPSizectorS
  • PreProcessThreshold : MPSizectorS_DotNet.MPSizectorS
  • ProjectionMode : MPSizectorS_DotNet.MPSizectorS
  • ProjectionNumber : MPSizectorS_DotNet.MultiHeadSettingsStructType

- r -

  • RangeCheckEnableState : MPSizectorS_DotNet.MPSizectorS
  • RangeCheckSetting : MPSizectorS_DotNet.MPSizectorS
  • ReconstructionSettings : MPSizectorS_DotNet.MPSizectorS
  • ROIHeightRatio : MPSizectorS_DotNet.MPSizectorS
  • ROIWidthRatio : MPSizectorS_DotNet.MPSizectorS
  • ROIX0Ratio : MPSizectorS_DotNet.MPSizectorS
  • ROIY0Ratio : MPSizectorS_DotNet.MPSizectorS
  • RotateAmplitude : MPSizectorS_DotNet.MPDisplayer3D
  • RotateMode : MPSizectorS_DotNet.MPDisplayer3D
  • RotatePhase : MPSizectorS_DotNet.MPDisplayer3D
  • RotateSpeed : MPSizectorS_DotNet.MPDisplayer3D

- s -

  • Screenshot : MPSizectorS_DotNet.MPDisplayer3D
  • SensorExpBaseTime : MPSizectorS_DotNet.MPSizectorS
  • Settings : MPSizectorS_DotNet.MPSizectorS
  • SnapCnt : MPSizectorS_DotNet.MPSizectorS
  • SoftwareTSN : MPSizectorS_DotNet.MPSizectorS
  • SpecularReflection : MPSizectorS_DotNet.MPDisplayer3D
  • StartUpTimeMS : MPSizectorS_DotNet.MPSizectorS
  • States : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo1Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo2Enable : MPSizectorS_DotNet.MPSizectorS
  • SuppressExpo3Enable : MPSizectorS_DotNet.MPSizectorS

- t -

  • Temp0 : MPSizectorS_DotNet.MPSizectorS
  • Temp1 : MPSizectorS_DotNet.MPSizectorS
  • Temp2 : MPSizectorS_DotNet.MPSizectorS
  • TempCore : MPSizectorS_DotNet.MPSizectorS
  • TotalCaptureRetryNum : MPSizectorS_DotNet.MPSizectorS
  • TotalTransferRetryNum : MPSizectorS_DotNet.MPSizectorS
  • TransparentBackGroundSnapshot : MPSizectorS_DotNet.MPDisplayer3D
  • TriggerSource : MPSizectorS_DotNet.MPSizectorS

- u -

  • UseNormVector : MPSizectorS_DotNet.MPDisplayer3D
  • UserGain : MPSizectorS_DotNet.MPSizectorS
  • UserRTMatrix : MPSizectorS_DotNet.MPSizectorS
  • UserRTMatrixEnableState : MPSizectorS_DotNet.MPSizectorS

- v -

  • ValidPointThreshold0 : MPSizectorS_DotNet.MPSizectorS
  • ValidPointThreshold1 : MPSizectorS_DotNet.MPSizectorS
  • ValidPointThreshold_PresetMode : MPSizectorS_DotNet.MPSizectorS
  • ViewMatrix : MPSizectorS_DotNet.MPDisplayer3D

- w -

  • WorkingMode : MPSizectorS_DotNet.MPSizectorS

- z -

  • ZMax : MPSizectorS_DotNet.MPSizectorS
  • ZMin : MPSizectorS_DotNet.MPSizectorS
  • Zoom : MPSizectorS_DotNet.MPDisplayer2D


MPSizector .NET 编程文档: 类成员 - 事件

  • 全部
  • 函数
  • 变量
  • 枚举
  • 属性
  • 事件
  • PixelCordChange : MPSizectorS_DotNet.MPDisplayer2D


MPSizector .NET 编程文档: D:/gitlab-runner/builds/k3GARMtj/0/megaphase/mp3dscontrol/SizectorS_SDK/MPSizectorS_DotNet/obj/Release 目录参考

  • obj
  • Release
Release 目录参考


MPSizector .NET 编程文档: D:/gitlab-runner/builds/k3GARMtj/0/megaphase/mp3dscontrol/SizectorS_SDK/MPSizectorS_DotNet/obj 目录参考

  • obj
obj 目录参考

目录

Release


MPSizector .NET 编程文档: D:/gitlab-runner/builds/k3GARMtj/0/megaphase/mp3dscontrol/SizectorS_SDK/MPSizectorS_DotNet/Properties 目录参考

  • Properties
Properties 目录参考


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMedianFilterStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType,包括所有继承而来的类成员

FilterWinSize (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType
Reserved (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMedianFilterStructType


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetFiltrateStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType,包括所有继承而来的类成员

filtrateMendPointOnly (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
ParamNeighborCloseLevel (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
ParamNeighborNumLevel (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType
ParamWinSize (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetFiltrateStructType


MPSizector .NET 编程文档: 成员列表

  • SoftwarePreprocessPresetParamListStructType
  • PreprocessPresetMendStructType
MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType 成员列表

成员的完整列表，这些成员属于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType,包括所有继承而来的类成员

Method (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
ParamWinSize (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
ParamWinSize2 (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType
Reserved (定义于 MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType) | MPSizectorS_DotNet.SoftwarePreprocessPresetParamListStructType.PreprocessPresetMendStructType